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Chapter 1

Introducing Mellel

1. What is Mellel?
Mellel is a word processor. Similarly to other word processors, it allows you to write text, edit it,

style it, format it as lists or tables, lay it out, and later on print or export it to other applications.
But Mellel goes far beyond this. It was developed specifically to handle long and complex
documents. It oﬀers a set of advanced features that enable you to take full control of the
document structure and style. Using Mellel you can consistently and eﬃciently create
documents exactly the way they want to, while minimizing the manual labor and frustration
commonly experienced with competing word processors.
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2. Who is Mellel For?
Mellel is a useful tool for anyone looking for a robust, reliable, and friendly word processor for

the macOS operating system. The following groups will find it particularly beneficial:
• Writers and Publishers: Mellel separates structure and style, which is ideal for writers and
publishers who must change one without aﬀecting the other throughout the writing and
editing process. Powerful reviewing and editing tools enable you to get your desired results
with minimal eﬀort.
• Scholars and Academics: Mellel oﬀers two features that are crucial to academic and
scientific writing: Note Streams and Live Bibliography. Note Streams allow complete
configuration and customization of document notes. Be it end notes, footnotes, or any kind
of custom notes, Mellel supports it. In addition, the Live Bibliography feature (supported when
Mellel is combined with Bookends) allows you to seamlessly manage your citations and
bibliography as the document is created, with no detrimental eﬀect on performance.
• Technical Writers: The Cross References and Auto-Titles features in Mellel are perfect tools for
technical writers. They enable you to generate structured and dynamic documents that
allow quick and customizable referencing from any section of the document to another. As
Mellel's cross references are dynamically managed by the application, any changes to the
document are immediately and automatically reflected in the references as well, negating
the need for any manual intervention to validate and correct the references throughout the
document.
• Legal Documentation Teams: The consistency and accuracy of legal documents are of the
utmost importance to their creators and consumers, as each character and sentence might
have profound implications. Mellel provides the required toolbox for achieving this
consistency--using Style Sets, a revolutionary Find and Replace feature, and the ability to
apply and enforce any desired style and structure to meet legal requirements. Furthermore,
the section styling tools enable meeting the line-numbering requirements in legal
documents, and the Auto-Indent feature makes creating the document structure a breeze.
• Non-English Writer: Mellel is the only word processor that was built from the ground up to
support multilingual capabilities. This includes controlling text direction on diﬀerent level
(character, paragraph, pages and the entire document), supporting diﬀerent scripts and
unique ligatures and providing a localized user interface for multiple languages.
• Anyone creating long and complex documents: Mellel was built to be robust and resilient,
as noted immediately by anyone working with long documents with numerous automatic
fields and cross references. Mellel's performance is impeccable even as pages pile up; it
enables you to focus on creating the document without worrying about whether or not the
system will crash and all progress will be lost.
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3. How does Mellel Work?
Mellel is a true What You See Is What You Get (WYSIWYG) word processor. The document's view

in the application mirrors the final result, be it a printed version or an exported file in a
diﬀerent format (such as a PDF document). This allows you to apply style and structural
changes that immediately appear on the screen.
Unlike other word processors, Mellel separates the concepts of document structure from
document style. This requires a certain mind-shift for users accustomed to other word
processors in which the two go hand in hand.
For an example, Mellel separates between setting text to be a chapter title and setting how a
chapter titles is styled.
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4. How do I Use Mellel?
Mellel's User Interface (UI) was designed and developed to be accessible and intuitive. The
following figure details Mellel's UI elements:

Figure 1-1: Mellel User Interface Elements
1. Menu Bar: Includes several menus that allow you to access diﬀerent functionalities and
configuration options. Refer to Menu Bar on page 294 for a complete description of all the
menu items.
2. Toolbar: Includes shortcuts to Mellel functionalities. The toolbar is customizable and allows
you to add your frequently used functions for easy and quick access. Refer to Customizing
the Toolbar on page 268 for more information on configuring the toolbar and to Toolbar
on page 328 for a complete description of its UI elements.
3. Ruler: Used to change the paragraph start margin, end margin and indent level, as well as
adding and configuring tabs. Refer to Managing Tab Stops and Tabs on page 166 and
Paragraph Formatting on page 164.
4. Side Pane: Includes three diﬀerent tabs:
a. Outline: Displays the document structure and allows quickly navigating between
diﬀerent sections of the document, as well as making easy changes to the document
structure. Refer to Outline on page 139 for more information.
b. Story: Used to display story points, and to add and sort characters and locations. Refer
to Story on page 147 for more information.
c. Index: Used to create and manage the document Index Records and to configure and
insert the actual index into the document. Refer to Indexing on page 242 for more
information.
5. Document Area: Used to edit the document, enter and style diﬀerent elements. Refer to
Writing your Document on page 34 and Styling your Document on page 154 for more
information.
5 | Introducing Mellel

6. Annotations Pane: Displays diﬀerent annotations that were added on top of the
document, such as comments or changes (when the Track Changes feature is active). Refer
to Track Changes on page 220 and Comments on page 225 for more information.
7. Bottom Bar: Used to adjust the display layout and to navigate the document. Refer to View
Settings on page 263 and Navigation on page 35 for more information on adjusting your
display and navigation.
8. Palettes: The palettes are your main toolbox for editing the document, including up to 11
pre-defined palettes comprising diﬀerent functions and features. The palettes are
customizable. You can select which palettes to display, and even split them into several
diﬀerent stacks. Refer to Configuring the Palette Layout on page 266 for more information
on customizing the palettes, and to Palettes on page 337 for a complete description of the
diﬀerent palettes and their components.
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5. How do I Use This Manual?
This Manual serves as a reference guide for Mellel's various functionalities and functions. While
you can learn how to use Mellel by reading this manual from cover to cover, we recommend
you to use our on-line training materials to get started. Once viewed, you can use this manual
as a reference for specific functions and questions.
The manual structure is based on tasks which are grouped into distinct sections. This enables
you to locate the information you need quickly and eﬃciently:
1. Administration and Maintenance: Includes all the administrative and maintenance tasks
required to use Mellel. This includes downloading, installing, registering and updating the
software.
2. Managing your Document Files: Includes task descriptions for managing files. This
includes loading, saving, importing and exporting files and documents.
3. Writing your Document: Includes task descriptions for inserting text and diﬀerent objects
into your document.
4. Styling your Document: Includes task descriptions for styling diﬀerent objects in your
document.
5. Reviewing and Editing your Document: Includes task descriptions for using the diﬀerent
tools available in Mellel to review and edit your document throughout the writing process
and prior to publishing.
6. Configuring Mellel: Includes diﬀerent configuration options that allow you to customize
the way Mellel works to your own needs and preferences.
7. Appendix: Includes information that is useful for some users but is not directly associated
with any specific task. This includes:
a. Help & Support: Includes a complete description of the diﬀerent ways to get help and
support when using Mellel.
b. Common Functionalities: Includes a complete description of various functionalities
that are repeatedly used in Mellel but are not a purposeful task on their own. This
includes, for example, selecting a colour for an element or using diﬀerent
measurement units to adjust elements' size.
c. Find and Replace Expression Elements: Includes a complete description of the
elements that can be added to Find and Replace expressions.
d. Screen Descriptions: Includes a complete description of the diﬀerent UI elements in
Mellel. While it is not task-oriented, this section can assist users who wish to know what
a specific button does or what would be the eﬀect of selecting a certain option from a
given menu.
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Chapter 2

Administration and Maintenance

1. Downloading and Installing Mellel
To download and install Mellel:
1. Open a web browser and navigate to http://www.mellel.com/download/.
2. Click the Download button at the top of the page.
3. Select a location on your computer to save the installation file (optional).
4. Once the download is completed, the following window is displayed:
Tip: If the window does not appear automatically, locate the downloaded .dmg file on your
computer and double click it.

Figure 2-1: Installation Window
5. Drag the Mellel application icon over the Applications folder icon.
6. If you already have an existing copy of Mellel, you will be asked whether you want to
replace it:

Figure 2-2: Replacing an Existing Mellel Version
6. Click Replace to overwrite the existing copy or Stop to keep the current one.
Tip: Once the installation is complete, the virtual Mellel hard disk icon that was created as part
of the installation process can be removed by dragging it into the trash.
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2. Running Mellel
1. To run Mellel, locate its icon in your Applications folder and double click it.
2. If you are using the Trial Version click Use Demo to launch the application. Refer to Trial
Version Limitations below for more information regarding the trial version.
Tip: Add Mellel to your Dock if you use it regularly. Drag the Mellel icon from your Applications
folder onto the Dock area. You can move Mellel's icon within the Dock by dragging and
dropping it in a new location, or remove it by dragging it outside of the dock.

1. Trial Version Limitations
Anyone can download the latest Mellel version for a 30-day trial before buying it. The trial
version will run with the following limitations:
• When you launch Mellel, a Please Register window is displayed.
• When printing from Mellel to an output device (including exporting to a PDF document) a
large Unregistered watermark will be stamped across each printed page.
Once the 30-day trial period is over, a third limitation is added:
• Exporting or copying content from Mellel to a file or to other applications is disabled.

2. System Requirements
The following list details system requirements for installing and running Mellel:
• Mac OS X 10.6 or later versions.
• Intel processor.
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3. Updating Mellel
Updates are frequently released to introduce new features and fix any rare bugs that are
discovered. Once Mellel is installed, you can either manually or automatically check for updates
and install them.

1. Manually Updating Mellel
To manually check for updates:
1. Choose Mellel > Check for Updates from the menu bar.
2. Do one of the following:
• If you have the most recent version, the following dialogue-box is displayed as no
updates are required. Click OK to continue.

Figure 2-3: Current Version Up to Date

•

If a newer version exists, the Install Update dialogue-box is displayed. Click Install
Update to install the new version or Cancel to continue using the existing version.
This is the latest
version

And this is the version
you have

Here you'll find
information
about the latest
version

Read this carefully:
The information here
will tell you if the
update is free for you
or not!

Don't want to
update? press here

Want to update?
Press Here

Figure 2-4: Install Update dialogue-box
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2. Automatically Updating Mellel
Perform the following instructions to set Mellel to automatically check and install updates
when they are available:
1. Choose Mellel > Preferences from the menu bar.
2. Click the General tab.
3. Use the Automatically Check for Updates popup menu to select the desired option:
• Never.
• Every Day.
• Every Week.
• Every Month.
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4. Buying Mellel
Mellel is a shareware product. This means that anyone can download the latest version and try

it for 30 days, with limitations detailed under Trial Version Limitations on page 10.
When the trial version has expired and you decide to purchase Mellel, perform the following
instructions:
1. Launch Mellel.
2. Click Buy Now in the Registration Prompt window:

Figure 2-5: Buy Now Button
3. Select the desired option from the Mellel Store dialogue-box:

Figure 2-6: Mellel Store dialogue-box
a. Buy Regular License: Purchase a regular license from within the application.
b. Buy Education License: Purchase an education license from within the application.
c. Mellel Upgrade: Purchase a Mellel upgrade from within the application. This option is
used if there is a new update available but your license has expired and does not entitle
you to any more free updates.
d. Go to Web Store: Open the Mellel web store in a new browser window to complete the
purchase outside the application.
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4. Once you complete the purchase process you will receive your user name and registration
code via e-mail. Refer to Registering Mellel on page 15 to complete the registration
process.
Note: If you buy Mellel on Apple's App Store the application is automatically registered.
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5. Registering Mellel
Once you have your user name and registration code (refer to Buying Mellel on page 13 for
more information), perform the following instructions to register Mellel:
1. Launch Mellel.
2. Choose Mellel > Registration Code from the menu bar.
3. Enter your User Name and Registration code (received in your confirmation e-mail) into the
corresponding text boxes in the Registration Code dialogue-box:

Figure 2-7: Registration Code dialogue-box
4. Click Register.
Note: Manual registration is not required when Mellel is bought from Apple's App Store.

15 | Administration and Maintenance

6. Uninstalling Mellel
If you no longer wish to use Mellel and would like to uninstall it, perform the following
instructions:
1. Quit Mellel (if it is running).
2. Open your Applications folder.
3. Drag Mellel's application icon to the trash.
Note: You will not be able to empty the trash if Mellel is still running.
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7. Migrating from Other Word Processors
Replacing your previous word processor with Mellel can bring some challenges, such as the
technical aspect of migrating your documents from the other word processor into Mellel. The
following tips can assist in smoothing the migration process:
• Using Replace Styles: The Replace Styles feature is a powerful tool when migrating a large
set of files from your old word processor to Mellel. This option, accessible from the File menu,
allows you to replace a document style with a global style. In other words, it helps you
replace the temporary paragraph and character styles created in files with the styles you
regularly use (refer to Replacing Styles on page 193 for more information). If you intend to
migrate a large set of your old files to Mellel, doing it in an orderly fashion will allow you to
use the Replace Styles feature to the full and save yourself a lot of time in the process.
Following are some handy rules to keep in mind while migrating:
• Create a set of styles: The most important part of a good migration path is creating a
good set of styles in Mellel that will match the styles you commonly used in your old word
processor.
• Minimize your font set: You probably experimented with diﬀerent fonts and font faces
with your previous word processor. This can be a problem when using Replace Styles
because you will have to replace a lot of temporary styles every time you want to migrate a
file to Mellel. To prevent this, you should utilize the RTF Font Matching panel to limit the
number of fonts in your imported files. For example, you can match similar fonts such as
Times, Times New Roman, New York, Gramond, Georgia, Gentium, and Palatino with a font
such as Hoefler Text; or replace Helvetica, Arial, and Tahoma with Helvetica Neue, for
example.
• Migrating from MS Word: Importing Word files can be done fairly easily and quickly. You
should divide your existing Word files into two groups:
• Simple: Files that do not contain footnotes and/or endnotes. Simply open these files in
Mellel and save them as Mellel files. Refer to Importing Word Documents on page 30 for
more information.
• Complex: Use Word to save them as an RTF document, and then open them in Mellel. Refer
to Importing RTF Documents on page 29 for more information.
• Migrating from TextEdit and other editors: Many word processors save their files in RTF
format or oﬀer this option as an equivalent (native) format. Open such files as you would any
RTF file (refer to Importing RTF Documents on page 29 for more information).
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Chapter 3

Managing your Document Files

1. Opening a Document
1. Creating a New Document
Any new Mellel document is created based on a template. Either you select one manually, or
Mellel uses the default template for new documents.
To create a new document:
1. Do one of the following:
• Launch Mellel and click New Document in the Welcome to Mellel window.
Or
• Choose File > New from the menu bar (if Mellel is already running).
Or
• Press Cmd + N (if Mellel is already running).
The Template Browser is displayed:

Figure 3-1: Template Browser
2. Choose the desired category from the templates category list. Templates that are included
in the selected category are displayed in the templates preview area.
3. Choose the desired template from the templates preview area.
4. Click Open.
Templates save time by using ready-made structure and style for your document (refer to
Templates on page 198 for more information).
Tip: You can also choose File > Open Template from the menu bar and choose your desired
template to create a new document based on it.
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2. Creating a new Document from the Default Template
You can create a new document based on the default template without using the Template
Browser (refer to Setting the Default Template on page 198 for step-by-step instructions for
setting the default template).
To create a new document from the default template:
• Choose File > New with Default from the menu bar.
Or
• Press Shift + Cmd + N.

3. Opening an Existing Document
To open an existing document:
1. Do one of the following:
a. Choose File > Open from the menu bar.
Or
b. Press Cmd + O.
2. Locate and select the desired file in the Open File window.
3. Click Open to open the selected file.
Note: You can open multiple files by holding down the Cmd key while selecting files.

4. Opening a Recent Document
Mellel keeps track of the documents you recently opened. This enables easy access to

frequently used documents.
To open a recently used document:
• Using the Welcome to Mellel window:
1. Launch Mellel, or choose Window > Welcome to Mellel from the menu bar if Mellel is
already running.
2. Choose the desired file from the Recent Documents area.
• Using the menu bar:
1. Choose File > Open Recent from the menu bar.
2. Choose the desired file from the list to open it.
Note: The number of recent documents displayed depends on your macOS preferences.

5. Reverting to a Previous Version of the Document
Mellel can be configured to automatically create backups of the document while you are

working on it (refer to Activating Automatic Backup on page 24 for more information).
To open a previous version of a document:
1. Choose File > Revert To from the menu bar.
2. Perform any of the following:
a. Choose Last Saved to revert to the most recent backup version.
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b. Choose Last Opened to revert to version of the document when you last opened it.
c. Choose Browse All Versions to see all backed up versions and revert to a specific one.
Note: Reverting to a previous version of the document will discard all changes made since that
version was created.

6. File Opening Preferences
1. Setting the Number of Pages Available in QuickLook
With Mellel you can utilize the macOS Finder QuickLook feature to preview Mellel documents.
This allows you to view the content of Mellel documents in the Finder without having to open
them. Mellel supports accurate display of the content (e.g., tables, notes, columns, images,
pagination), resembling what would have been displayed in a PDF.
To configure how many pages are available in the Quickview preview:
1. Choose Mellel > Preferences from the menu bar.
2. Click the General tab.
3. Under QuickLook, check the Limit previews to checkbox.
4. Enter a value in the adjacent pages text box to determine the allowed preview size.

2. Setting the Default Text Encoding for Plain Text Files
When you open plain text files without using the File > Import option from the menu bar
(refer to Importing Plain Text Files on page 28 for more information), the default text encoding
is applied.
To set the default text encoding:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Open & Save tab.
3. Use the Default Plain Text Encoding popup menu to set the default encoding.

3. Setting the Default Behavior for Displaying the Font Matching Panel
When you import RTF documents without using the File > Import option from the menu bar
(refer to Importing RTF Documents on page 29 for more information), the default behavior for
displaying the Font Matching panel is applied.
To set the default behavior:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Open & Save tab.
3. Use the RTF Font Matching panel popup menu to set the default behavior:
• Don't show: The panel will never be displayed and any required font matching are
handled automatically by Mellel.
• Show if needed: The panel will only be displayed if there are font matching that
cannot be handled automatically by Mellel and must be manually resolved.
• Always show: The panel will always be displayed and all font matching must be
performed manually.
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Note: These settings can be overridden for individual files when you import a document using
the menu bar, as detailed in Importing RTF Documents on page 29.

4. Setting Mellel as the Default Application for Opening Diﬀerent File Types
Mellel can be used to open file types other than .mellel files:

• Plain text files (files with a .txt extension): Refer to Importing Plain Text Files on page 28 for
more information.
• RTF documents (files with a .rtf extension): Refer to Importing RTF Documents on page 29
for more information.
• Word Documents (files with a .doc extension): Refer to Importing Word Documents on page
30 for more information.
• OPML files (files with an .opml extension): Refer to Importing OPML Files on page 31 for
more information.
To set Mellel as the default application for opening any of these files types (i.e. Mellel will be
launched when they are double-clicked from the Finder):
1. Locate and select a file of the desired type in Finder.
2. Choose File > Get Info from the Finder menu bar.
3. Under Open With use the popup menu to choose Mellel.
4. Click Change All.
5. Click Continue.
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2. Saving a Document
1. Saving a Document
To save your document Do one of the following:
• Choose File > Save from the menu bar.
Or
• Press Cmd + S.
Note: If this is the first time you are saving the document, you will be prompted to select a
location and a name for the saved file.

2. Duplicating a Document
Do one of the following instructions sets to duplicate the active document:
• Choose File > Duplicate from the menu bar.
Or
• Press Cmd + Shift + S.
A new window with an unsaved copy of your document is opened, and you can now save it as
a new file.

3. Saving a Document as a Template
You can create templates to save time and improve consistency across diﬀerent documents
(refer to Templates on page 198 for more information).
To save a file as a template:
1. Choose File > Save As Template from the menu bar.
2. Enter a name for your template in the Template Name text box.
Tip: You can make this template the new default template by checking the Make Default
checkbox.
3. Under Location use the Category popup menu to select a location for the new template, or
use the Save Elsewhere button to select a location outside Mellel's templates folder.
4. Under Template Preview use the radio button to choose a preview for this template (the
preview images is displayed in the template browser):
a. None: No preview will be displayed.
b. Use Page: Enter a page number in the adjacent text box to set that page as the
template preview.
c. Custom Image: Click the Choose button to locate and select an image that will be
used as the template preview.
5. Under Template Description you may use the Description text box to enter a general
description for the template.
6. Click Save.
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Note: Refer to Creating a New Document on page 19 for instructions on how to create a new
document based on your new template.

4. Saving Preferences
1. Activating Automatic Saving
Mellel automatically saves your documents while they are open in accordance with Apple's

automatic save preferences.
To configure automatic saving:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Open & Save tab.
3. Use the Automatic Save radio button to choose the desired option:
a. Oﬀ: Mellel will not save files automatically.
b. System Standard: Mellel will use the system standard for automatic saving. This option
is only available for Mac Lion OS and later versions.
c. Save Every: Choose this option and enter a value in the adjacent Minutes text box to
set the time interval for auto-saving your open files.
Note: It is recommended to use the System Standard default option. When any other option is
chosen, reverting to previous versions of the document is disabled.

2. Activating Automatic Backup
Mellel is configured to backup your files by default, so that copies of any open file are

periodically copied into a backup folder.
To disable or configure automatic backup:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Open & Save tab.
3. Under Automatic backup, use the checkbox to determine whether or not backups are
being performed.
4. If the checkbox is checked, enter a value in the adjacent Minutes text box to set the time
interval for backing up your open files.
Note: Only one backup copy per given document is maintained, so newly created backups
overwrite existing ones.
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3. Managing iCloud Documents
If you purchased Mellel from Apple's App Store, you can manage your files on iCloud, as
described in the following sub-sections.

1. Opening a Document from iCloud
To open a file saved on iCloud:
1. Choose File > iCloud from the menu bar.
2. Locate and select the desired file.
3. Click Open to open the selected file.

2. Saving a Document to iCloud
To save a file to iCloud:
1. Choose File > Move to iCloud from the menu bar.
2. Select an iCloud location to save the file.

3. Removing a Document from iCloud
To remove a file from iCloud:
1. Choose File > iCloud from the menu bar.
2. Locate and select the desired file.
3. Choose File > Remove from iCloud from the menu bar.
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4. Exporting and Importing Files
1. Exporting Files
1. Exporting as Plain Text
To export a Mellel document as a plain text file:
1. Choose File > Export > Plain Text from the menu bar.
2. Select a name and a location for the exported file.
3. Under Plain Text Export Options, configure the desired exporting preferences:
a. Use the Encoding popup menu to select the plain text encoding.
Note: When selecting any option other than Unicode or UTF-8, use the Default replacement
character popup menu to set the character that will be used to replace characters that cannot
be exported into the selected encoding option.
b. Use the Export notes checkbox to determine whether notes will be exported into the
text file.
Note: When notes are exported into a plain text document, Mellel inserts an asterisk both
before and after a note reference for the first stream and will do the same for the note symbol
at the end of the document. The second stream will get two asterisks before and after the note
reference and the note symbol, and so on. Refer to Notes on page 60 for more information
regarding note streams.
c. Use the Include URL with hyperlinks checkbox to determine whether the URL is included
in the exported document when hyperlinks are included in the original text.
4. Click Save.

2. Exporting as RTF
Mellel supports exporting documents as a Rich Text Format (RTF) document, including a wide

range of RTF tags that cover essential features such as character, paragraph and page
attributes, tables, headers and footers, footnotes and endnotes, images, columns and sections.
Perform the following instructions to export a Mellel document as an RTF document:
1. Choose File > Export > RTF from the menu bar.
2. Select a location and a name for the exported file.
3. Configure the desired exporting preferences:
a. Use the Export Markers checkbox to determine whether markers from the Mellel
document will appear in the exported document.
b. Use the Export Text Language tags checkbox to determine whether the languages
applied to the text are exported with the document. The default is No as it commonly
leads to styling issues in the exported document.
c. Use the Vector Images Resolution text box to set the resolution for exported vector
images.
Note: The default value is 300 DPI. This value is suﬃcient for most use cases.
4. Click Save.
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3. Exporting as Word Documents
Mellel supports exporting documents in an RTF standard using a .doc extension, which means

that other systems will handle them as Word documents.
To export a Mellel document as a Word (.doc) document:
1. Choose File > Export > Word Format from the menu bar.
2. Select a location and a name for the exported file.
3. Configure your desired exporting preferences:
a. Use the Export Markers checkbox to determine whether markers from the Mellel
document will appear in the exported document.
b. Use the Export Text Language tags checkbox to determine whether the languages
applied to the text are exported with the document. The default is No as it commonly
leads to styling issues in the exported document.
c. Use the Vector Images Resolution text box to set the resolution for exported vector
images.
Note: The default value is 300 DPI. This value is suﬃcient for most use cases.
4. Click Save.

4. Exporting as OPML Files
Mellel supports exporting documents as OPML files, resulting in an XML document that is
readable by all outliners. Mellel's Auto-Titles serve as items in the outliner application.

Note: OPML stands for Outline Processor Markup Language. It is an XML format used by
outliners, which are a specialized type of word processors used to display, organize, and edit
text hierarchically in an outline tree structure.
To export a Mellel document as an OPML file:
1. Choose File > Export > OPML from the menu bar.
2. Select a name and a location for the exported file.
3. Configure your desired exporting preferences:
a. Use the Export Content as Notes checkbox to determine whether text located under the
various Auto-titles will be included as notes in the OPML file.
b. Use the Include URL with hyperlinks checkbox to determine whether the URL is included
in the exported document when hyperlinks are included in the original text.
4. Click Save.

5. Exporting as PDF
The Portable Document Format (PDF) is a standard file format which preserves the original
text's structure and style.
To export a Mellel document as a PDF document:
1. Choose File > Export > PDF from the menu bar.
2. Select a location and a name for the exported file.
3. Configure your desired exporting preferences:
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a. Use the Outline checkbox to determine whether Auto-Titles (both structural and tags,
refer to Auto-Titles on page 44 for more information) will be exported as the table of
contents for the PDF document. When this checkbox is checked, two additional
checkboxes beneath it become available:
1) Include Bookmarks: Use this checkbox to determine whether bookmarks are
included in the exported outline.
2) List Tag flows separately: Use this checkbox to determine whether tag flows (user
defined Auto-titles) will appear separately from the structural Auto-titles in the PDF
table of contents. Refer to Flow Types on page 46 for more information on the
diﬀerent flow types.
b. Use the Markers checkbox to determine whether markers from the Mellel document will
be included in the exported document.
c. Use the Annotations checkbox to determine whether comments and tracked changes
from the Mellel document will be included in the exported document.
4. Click Save.
Note: When printing a document, macOS includes a built in function for saving documents as
a PDF file. However, it is recommended to use Mellel's exporting tool rather than the macOS'
built in feature.

6. Exporting to a Spreadsheet
Perform the following instructions to export any text found within a table in Mellel to a
spreadsheet application:
1. Select the text within the table in Mellel.
2. Choose Edit > Copy from the menu bar.
3. Switch to the spreadsheet application and paste the text.

7. Exporting Text into Graphic or Layout Applications
Perform the following instructions to export a Mellel document into graphic or layout
applications:
1. Export the document as a plain text file with the suitable encoding (refer to Exporting as
Plain Text on page 26).
2. Import the text file into the graphic or layout application.
Tip: When exporting into Unicode compliant layout applications, you can simply copy the text
from Mellel and paste it directly into the layout application.

2. Importing Files
1. Importing Plain Text Files
To import a plain text file into Mellel:
1. Choose File > Import > Plain Text from the menu bar, or press Cmd + Shift + R.
2. Locate and select the file you wish to import.
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3. Note: You can click the Options button and use the Encoding popup menu to manually
select the text encoding.
4. Click Open to complete the importing process.
5. Tip: There are three alternative ways to import a plain text file:
6. Selecting it in Finder and dragging it onto the Mellel application icon in the Finder or in the
Dock.
7. Using File > Open from the menu bar, as described in Opening a Document on page 19.
8. Double clicking the file in Finder (if Mellel is set as the default application for opening .txt
files, as detailed in Setting Mellel as the Default Application for Opening Diﬀerent File
Types on page 22).
When importing plain text files in any of these alternative ways, the default plain text
encoding and the default import template are used (refer to Setting the Default Text Encoding
for Plain Text Files on page 21 and Setting a Default Template for Importing Documents on
page 33 for more information).

2. Importing RTF Documents
Mellel supports exporting documents as a Rich Text Format (RTF) document, including a wide

range of RTF tags that cover essential features such as character, paragraph and page
attributes, tables, headers and footers, footnotes and endnotes, images, columns and sections.
To import an RTF document into Mellel:
1. Choose File > Import > RTF from the menu bar.
2. Locate and select the file you wish to import.
3. Click the Options button to display and configure the following importing preferences:
a. Use the Source encoding popup menu to select the text encoding to use when
importing the RTF document into a Mellel document.
b. Use the Font Matching panel popup menu to determine whether or not the panel will
be displayed (Refer to Matching Fonts from Imported Documents on page 31 for more
information):
1) Don't show: The panel will not be displayed and any required font matching will be
handled automatically by Mellel.
2) Show if needed: The panel will only be displayed if there are required font
matching that cannot be handled automatically by Mellel and must be manually
resolved.
3) Always show: The panel will be displayed and any required font matching will be
handled manually.
4. Click Open.
5. If the Font Matching panel is displayed, perform the required font matching (refer to
Matching Fonts from Imported Documents on page 31 for more information).
6. Click OK to complete the import process.
Tip: There are three alternative ways to import a RTF document:
• Selecting it in Finder and dragging it onto the Mellel application icon in the Finder or in the
Dock.
• Using File > Open from the menu bar, as described in Opening a Document on page 19.
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• Double Clicking the file in Finder (if Mellel is set as the default application for opening .rtf

files, as detailed in Setting Mellel as the Default Application for Opening Diﬀerent File Types
on page 22).
When importing RTF documents in any of these alternative ways, the default plain text
encoding and the default import template are used (refer to Setting the Default Text Encoding
for Plain Text Files on page 21 and Setting a Default Template for Importing Documents on
page 33 for more information).

3. Importing Word Documents
Mellel oﬀers an option to import Word files in .doc and docx format, including a wide range of

options that cover essential features such as character, paragraph and page attributes, tables,
headers and footers, footnotes and endnotes, images, columns and sections.
To import a Word document in .doc or docx format into Mellel:
1. Choose File > Import > Word Document (.doc, docx)... from the menu bar.
2. Locate and select the file you wish to import.
Tip: There are three alternative ways to import a Word document:
• Selecting it in Finder and dragging it onto the Mellel application icon in the Finder or in the
Dock.
• Using File > Open from the menu bar, as described in Opening a Document on page 19.
• Double Clicking the file in Finder (if Mellel is set as the default application for opening .doc
files, as detailed in Setting Mellel as the Default Application for Opening Diﬀerent File Types
on page 22).
When importing Word documents in any of these alternative ways, the default plain text
encoding and the default import template are used (refer to Setting the Default Text Encoding
for Plain Text Files on page 21 and Setting a Default Template for Importing Documents on
page 33 for more information).
The following Word features are supported when documents are imported into Mellel and will
be preserved in the new document:
• Standard text encoding.
• Text Style:
• Font family.
• Font size.
• Font colour.
• Bold face.
• Subscript and superscript.
• Paragraph Style:
• First-line indent.
• Left indent.
• Text alignment - center, left, right.
• New paragraph, set to default (import only).
• Paragraph style (import only).
• Page Style:
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• Background colour.
• Page width.
• Right and left margins.
• Tabs placement.

4. Importing OPML Files
Mellel supports importing OPML files, converting the outliner's titles into Mellel Auto-titles,

while the outliner's notes are converted into text which is placed below the corresponding
Auto-title in Mellel.
Note: When importing an OPML file, Auto-title setup from the default document template is
used (refer to Templates on page 198 and Managing Auto-Title Flows Setup on page 51 for
more information).
Note: OPML stands for Outline Processor Markup Language. It is an XML format used by
Outliners, which are a specialized type of word processors used to display, organize, and edit
text hierarchically in an outline tree structure.
To import an OPML document into Mellel:
1. Choose File > Import > OPML from the menu bar.
2. Locate and select the file you wish to import.
3. Click Open to complete the import process.
Tip: There are three alternative ways to import an OPML file:
• Selecting it in Finder and dragging it onto the Mellel application icon in the Finder or in the
Dock.
• Using File > Open from the menu bar, as described in Opening a Document on page 19.
• Double clicking the file in Finder (if Mellel is set as the default application for opening .opml
files, as detailed in Setting Mellel as the Default Application for Opening Diﬀerent File Types
on page 22).

5. Importing Spreadsheets
Perform the following instructions to import a spreadsheet into Mellel:
1. Open the spreadsheet application and save the file as a Tab-Delimited text file.
2. Open the text file in Mellel (refer to Importing Plain Text Files on page 28).
3. Press Cmd + A to select all the text in the document.
4. Choose Edit > Convert Text to Table from the menu bar.

6. Matching Fonts from Imported Documents
Imported RTF documents might include fonts that are not available on your local machine.
The Font Matching panel enables conversion of original fonts into the best possible alternative
supported by Mellel.
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Figure 3-2: Font Matching Panel
The panel might be displayed when importing RTF and Word documents, depending on your
selected import method. Refer to Importing RTF Documents on page 29 and Importing Word
Documents on page 30 for more information.
To select the best alternatives for replacing original fonts from the RTF document:
1. Choose a font pairing from the list.
2. Use the Font popup menu to select the replacing font.
3. Use the Face popup menu to select the replacing font face.
4. Check the Make default checkbox to set your selection as the default replacement for the
original font. Uncheck it to remove its status as a default replacement.
5. When you are done matching fonts, click OK to complete the matching process.
Refer to Font Matching Panel on page 383 for a complete description of the panel.
Best Practices:
The following tips are useful for improving the font matching process:
• Cover the Basics: Most documents use a relatively limited set of Windows-based fonts such
as Arial, Tahoma, Courier, and Times New Roman. If you can create good default matches for
this basic set of fonts, you will eliminate most of the font matching issues. There are three
main types of fonts you have to match:
• Roman (serif ) fonts such as Times.
• Sans serif fonts such as Helvetica, Tahoma, and Arial.
• Slab serif fonts such as Courier.
• If you Can't Match Them, Use Them: If you don’t like matching fonts, use the original ones.
You can download and install the core set of fonts used in Windows and use them without
being forced to make any matches or compromise. Click this link to download Microsoft’s
core fonts.
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• Big Fonts have High Coverage: If you don’t like Mellel replacing missing characters with
•

•

characters from another font, try using one of the inclusive Unicode fonts that cover most of
the Unicode range (e.g. Times New Roman, Helvetica, Lucida Grande, Arial).
Localization: Localized versions of Word use special versions of core fonts such as Courier
New CY or Tahoma Greek. Although all the language versions of a font are listed, usually only
one of them is actually used in the document. If you know what language version is actually
used in the imported file, you can match only that version, leaving the others unmatched.
Trust Mellel: It is advisable to let Mellel sort encoding issues on its own. That is, accept Mellel's
suggestions for font replacements when importing files. Many of the problems that appear
to be font matching problems are usually encoding problems.

7. Setting a Default Template for Importing Documents
When documents are imported into Mellel, a default template is used for the generated Mellel
document.
To set the default template for importing documents:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Open & Save tab.
3. Click the Browse button next to the Default Template for Import title.
4. Click the desired template.
5. Click Choose.
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Chapter 4

Writing your Document

1. Writing Essentials
To write your document, you would usually navigate to a specific location, and then either
enter a new element or select an existing one and edit it. This section describes the navigation,
selection and editing tools available in Mellel.

1. Navigation
Mellel oﬀers several tools for navigating the document:

• Using the keyboard: Refer to Keyboard Navigation below.
• Using the navigation buttons: Refer to Navigation Panel on page 37.
• Using the Outline: Refer to Outline on page 139.

1. Keyboard Navigation
Mellel’s keyboard navigation options allow you to navigate through the document using

simple keyboard shortcuts and combinations, which are aligned with Apple’s guidelines. These
shortcuts are separated into commands that change the document view, and commands that
change the position of the insertion point.
The following table details the diﬀerent keyboard navigation options that only move the
document view, without moving the insertion point:
Table 4-1: Keyboard Commands for Navigating the Document View
If you want to navigate...
To the top of the previous page or one screen
length up (based on the preferences

described under Configuring Scrolling
Preferences on page 37)
To the top of the previous page or one screen
length up (based on the preferences

described under Configuring Scrolling
Preferences on page 37)
To the top of the next page or one screen
length down (based on the preferences

described under Configuring Scrolling
Preferences on page 37)
To the top of the next page or one screen
length down (based on the preferences

described under Configuring Scrolling
Preferences on page 37)

Press...
Fn + Up Arrow

Option + Fn + Up Arrow

Fn + Down Arrow

Option + Fn + Down Arrow

To the top of the document

Fn + Left Arrow

To the bottom of the document

Fn + Right Arrow

To the currently selected text within the
document (if no text is selected, this option Cmd + J
navigates to the insertion point location)
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The following table details the diﬀerent keyboard navigation options that move the insertion
point:
Table 4-2: Keyboard Commands for Moving the Insertion Point
If you want to navigate...

Press...

One character to the right

Right Arrow

One character to the left

Left Arrow

To the line above, to the nearest character
Up Arrow
boundary at the same horizontal location
To the line below, to the nearest character
Down Arrow
boundary at the same horizontal location
To the end of the current word, then to the end
Option + Right Arrow
of the next word
To the beginning of the current word, then to
Option + Left Arrow
the beginning of the previous word
To the beginning of the current paragraph,
then to the beginning of the preceding Option + Up Arrow
paragraph
To the end of the current paragraph, then to
Option + Down Arrow
the end of the next paragraph
To the end of the current line

Cmd + Right Arrow

To the beginning of the current line

Cmd + Left Arrow

Upward to the beginning of the document

Cmd + Up Arrow

Downward to the end of the document

Cmd + Down Arrow

To the currently selected text within the
document (if no text is selected, this option Cmd + J
navigates to the insertion point location)
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2. Navigation Panel
The navigation panel is located at the bottom right corner of the screen. The following figure
depicts the panel and its functionalities:

Figure 4-1: Navigation Panel
1. Go to page: Clicking this button opens the Go to page dialogue-box. Enter a page number
and click OK to scroll to the top of that page.
2. Go to start: Clicking this button scrolls to the top of the document.
3. Page up: Clicking this button scrolls either one page or one screen length up, based on the
preferences described under Configuring Scrolling Preferences below.
4. Page down: Clicking this button scrolls either one page or one screen length down, based
on the preferences described under Configuring Scrolling Preferences below.
5. Go to end: Clicking this button scrolls to the end of the document.

3. Configuring Scrolling Preferences
You can configure the page scrolling behavior when using the page up and/or page down
functionalities. To set your preferred configuration:
1. Choose Mellel > Preferences from the menu bar.
2. Click the General tab.
3. Under Page up/down choose your preferred configuration:
a. Top of page: Using the page up/down functionalities would result in scrolling to the
top of the previous/next page, respectively.
b. Screen length: Using the page up/down functionalities would result in scrolling one
screen length up/down, respectively.

2. Selection
Almost every action in Mellel involves selecting the element before you can apply any changes
to it. Mellel enables diﬀerent functionalities for selecting elements using either the mouse or
the keyboard.
Tip: Press Cmd + J to navigate to the currently selected element from anywhere in the
document.

1. Mouse Selection

The following functionalities are available for selecting
elements using the mouse:
Table 4-3: Mouse Selection
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If you want to...

Do this...

Select a an element

Click the element.

Edit an element

Double-click the element.

Select a word

Double-click the word.

Select a paragraph

Triple-click anywhere inside the paragraph.

Select a section of the text

Click where you want the selection to start, hold down the mouse
button and drag to the desired end of the selection.

Select a wide range of the text

Click where you want the selection to start, then scroll down and
click where you want the selection to end while holding down the
Shift key.

2. Keyboard Selection
The following functionalities are available for selecting elements using the keyboard:
Table 4-4: Keyboard Selection
If you want to select...

Press this...

One character to the right.

Shift + Right Arrow

One character to the left.

Shift + Left Arrow

Text from the current insertion point to the line above, to
the nearest character boundary at the same horizontal Shift + Up Arrow
location.
Text from the current insertion point to the line below, to
the nearest character boundary at the same horizontal Shift + Down Arrow
location.
Text from the current insertion point to the end of the
Shift + Option + Right Arrow
current word, then to the end of the next word.
Text from the current insertion point to the beginning of
the current word, then to the beginning of the previous Shift + Option + Left Arrow
word.
Text from the current insertion point to the beginning of
the current paragraph, then to the beginning of the Shift + Option + Up Arrow
paragraph before it.
Text from the current insertion point to the end of the
current paragraph, then to the end of the next paragraph
Shift + Option + Down Arrow
(including the blank line between paragraphs in Cut,
Copy, and Paste operations).
Text from the current insertion point to the end of the
Shift + Cmd + Right Arrow
current line.
Text from the current insertion point to the beginning of
Shift + Cmd + Left Arrow
the current line.
Text from the current insertion point upward to the
Shift + Cmd + Up Arrow
beginning of the document.
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Text from the current insertion point downward to the
Shift + Cmd + Down Arrow
end of the document.
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3. Editing
The following functionalities are available for basic editing of selected elements in the
document:
Table 4-5: Basic Editing Tools
If you want to...

Do this...

Cut an element from the document onto Select the element and then either choose Edit > Cut
the clipboard.
from the menu bar or press Cmd + X.
Copy an element from the document Select the element and then either choose Edit > Copy
onto the clipboard.
from the menu bar or press Cmd + C.
Place the insertion point where you want to paste the
Paste the content of the clipboard into
content and then either choose Edit > Paste from the
the document.
menu bar or press Cmd + V.
Clear an element from the document.

Select the element and then either choose Edit > Cut
from the menu bar or press Cmd + X, Backspace or
Delete.

1. Copying and Pasting as Plain Text
You can copy and paste elements as plain text. This enables pasting diﬀerent content while
preserving existing formatting in the paste location.
To copy an element as plain text:
1. Select the desired element.
2. Choose Edit > Copy Special > Copy Plain Text from the menu bar, or press Cmd + Option
+ Shift + C.
To paste the clipboard content as plain text:
1. Place the insertion point where you want the content to be pasted.
2. Choose Edit > Paste Special > Paste Plain Text from the menu bar, or press Cmd +
Option + Shift + V.
Note: It is not required to copy an element as plain text to paste it as plain text.

2. Copying and Pasting Attributes
You can copy and paste just the style attributes for a given element. This enables applying
diﬀerent style attributes while preserving the original content. As Mellel has separate attribute
sets for diﬀerent elements, you must explicitly define what attribute set are you copying/
pasting.
To copy the style attributes of a given element:
1. Select the desired element.
2. Choose Edit > Copy Special from the menu bar, followed by the option that corresponds
to the attributes you wish to copy:
• Copy Character Attributes.
• Copy Paragraph Attributes.
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•

Copy List Attributes.
To apply the style attributes of the clipboard content to a diﬀerent element:
1. Copy any element to the clipboard.
2. Select the element you wish to apply the attributes to.
3. Choose Edit > Paste Special from the menu bar, followed by the option that corresponds
to the attributes you wish to apply:
• Paste Character Attributes.
• Paste Paragraph Attributes.
• Paste List Attributes.
Note: Mellel enables you to paste the style attributes of any element from the clipboard, even if
it wasn't copied using the Copy Special functionality.
Note: If you copy a certain type of attribute set but try and paste a diﬀerent type, nothing will
happen (for example, choosing Copy Character Attributes followed by Paste List Attributes
will have no eﬀect on the selected text).

3. Dragging and Dropping Text
Dragging and dropping text in Mellel is a useful way to edit content. From a functional point of
view drag & drop is similar to the cut, copy, and paste operations (depending on the type of
drag and drop you perform), the diﬀerence being that the dragged content is never placed in
the clipboard.
To drag and drop text:
1. Select the text you wish to drag.
2. Click the mouse button inside the selection area.
3. While holding the mouse button, drag it to its new location. The dragged text will become
partly transparent, and an insertion point will appear where the next is to be placed.
4. Release the mouse button to paste the text in the desired location.
Tip: This action is similar to cutting and pasting text. If you press and hold the Option key
when releasing the mouse button, the text will be copied and pasted rather than cut and
pasted.
Tip: You can drag and drop text between Mellel and other applications. When dragging text
from Mellel into other applications, it is always copied and never cut from the original text.
Note: When dragging text in/from a header/footer, it is always copied and never cut from the
original text.
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4. Special Characters
Mellel enables you to enter special characters such as unique types of hyphens, currency

symbols, mathematical operators, and so on.
To enter a special character:
1. Place the insertion point where you want to add the special character.
2. Do one of the following:
• Using the Insert Special Characters menu:
1) Choose Insert > Special Characters from the menu bar.
2) Choose the desired character from the categorized groups:

Figure 4-2: Special Characters Categories

•

Using the macOS built-in Emoji & Symbols panel:
1) Choose Edit > Emoji & Symbols from the menu bar, or press Ctrl + Cmd + Space.
The Emoji panel is displayed:

Figure 4-3: Characters Panel
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2) Choose the desired category from the category list.
3) Double click the desired symbol to add it to the text.
Note: You can only enter characters with a Unicode encoding.

5. Deleting Elements
The following functionalities are available for deleting elements from the document:
Table 4-6: Deleting Elements
If you want to...

Do this...

Delete the previous character

Press Backspace.

Delete the next character

Press Delete.

Delete the previous word

Press Option + Backspace.

Delete the next word

Press Option + Delete.

6. Undo and Redo
Undo and Redo are useful operations, through which you can cancel or repeat recent changes
made to document elements.
To cancel your recent action, choose Edit > Undo from the menu bar or press Cmd + Z.
To repeat the most recently canceled action, choose Edit > Redo from the menu bar or press
Cmd + Shift + Z.

A. Configuring the Undo Cache
To support the Undo and Redo functionalities, Mellel maintains a cache of your recent actions.
Perform the following instructions to configure the cache size:
1. Choose Mellel > Preferences from the menu bar.
2. Click the General tab.
3. Do one of the following:
• To set a hard size limit on the cache size: Use the Undo Cache radio button to choose
Remember last and then use the adjacent text box to enter the maximum number of
actions that will be saved.
• To have the cache reset whenever the document is saved without limiting its size: Use
the Undo Cache radio button to choose Clear with Save.
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2. Auto-Titles
1. What are Auto-Titles?
Auto-titles are structural elements you can insert into your document to serve as headings or
as captions for chapters, tables, images, graphs and more. Auto-titles form the basis for many
other Mellel features:
• Outline: The Outline is built from all the Auto-titles in the document, as they are the
foundation for the document structure. Refer to Outline on page 139 for more information.
• Table of Contents: When generating a table of contents, it can include all the Auto-titles in
the document. Refer to Table of Contents on page 121 for more information.
• Cross-References: Auto-titles can serve as targets for cross-references added to the
document. Refer to Cross References on page 112 for more information.
• Mentions: Auto-titles can be used to generate Mentions, which are contextual headings (for
example including the title of a chapter in the page header).

1. Auto-Title Flows
Every Auto-title belongs to a single flow—a sequence of Auto-titles of a certain type, like titles,
headings, small headings, figures, tables and so on. All the Auto-titles in a given flow share the
same format and contain the same elements.
All Auto-titles that belong to the same flow are numbered according to their position in the
sequence of Auto-titles of that flow in the document. A simple sequence of Chapters flow may
look something like the following:
C1

C2

C3

C4

Figure 4-4: Chapters Flow
When a new Chapter Auto-title is added, Mellel enumerates all the existing Auto-titles in the
document's Chapter flow, and number or renumber them according to their position in the
sequence. For example, if you add a new Chapter Auto-title between the existing first and
second ones, the new Auto-title will be numbered two (2) and the original second Auto-title
(now the third in the sequence) will be numbered three (3).
Auto-title flows comprise a single hierarchy in the document. For example, the Chapter flow
may be the top flow, Heading might come next, then Sub-heading and so on. A simple flows
hierarchy is depicted in the following figure:
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Figure 4-5: Simple Auto-Titles Flow Hierarchy
Three flows are shown in this figure: Blue is the top level, Yellow is the second, and Green is the
third. Whenever a Blue flow Auto-title is added, the numbering of the Yellow flow is reset, and
the same is true for the Green flow, whenever a Yellow flow item is entered.
Note: This is the default behavior. Lower level flows can be configured so that they are not
reset with higher level flows.
Mellel manages all the flows, at every level, and numbers them according to their position in
their flow, as well as in relation to flows that are higher in the hierarchy.

2. Auto-Titles Format
You can configure any Auto-title to include several elements, both dynamic and static. Refer to
the following image as an example:

Figure 4-6: Auto-Title Example
This is an example of an Auto-title which is the heading for a chapter. It includes three
elements:
• The word Chapter: This is a static element. It will appear exactly the same in all the Autotitles that belong to the this flow.
• The number 1: This is a dynamic element. It will automatically be updated based on the
position of the current Auto-title within its flow sequence.
• The word Introduction: This is a user-set element. It must be manually inserted whenever
an Auto-title element of this flow is added.
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3. Flow Types
Mellel includes two types of flows:

• Structural Flows:

Structural flows are used to create and maintain the structure of the
document. Each document includes a hierarchy of ten structural flows. For example: chapter
titles, headings, sub-headings and so on. You cannot add or delete structural flows, or to
move them within the flows hierarchy. You can, however, edit their format and style.
• Tag Flows: Tag flows are used to tag diﬀerent elements in the document. By default, new
documents include two tag flows - Table and Figure. You can create up to 99 new tag flows
and place them under any structural flows, to enable inserting captions or unnumbered
headings. For example: captions for figures, tables, equations and so on. You can delete tag
flows, and move them within the flows hierarchy.
The following image depicts structural flows in black numbered 1-10, and tag flows in blue
(Equation, Figure, Picture, Table):

Figure 4-7: Auto-Titles Flow Hierarchy
Tag flow are reset when the structural flow they are located under is reset. For example, in the
figure above the Table tag flow is located under the Flow 4 structural flow. As a result, the Table
flow numbering will be reset after each Flow 4 Auto-Title.

2. Auto-Titles Tasks
1. Managing Individual Auto-Titles
A. Inserting an Auto-Title
To insert a new Auto-title:
1. Place the insertion point where you want to insert the Auto-title.
2. Do one of the following:
• Using the menu bar:
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1) Choose Insert > Auto-Title from the menu bar.
2) Choose the flow you wish to add an Auto-title to.
Using the Auto-Title palette:
1) Click the Auto-Title palette.
2) Choose the flow you wish to add an Auto-title to.
3) Click the Insert Auto-title button (

).

Or
• Using the Auto-Title palette:
1) Click the Auto-Title palette:
2) Double click the flow you wish to add an Auto-title to.
Or
• Using the Outline:
1) Click the Outline tab in the side-panel.
2) Right-click anywhere in the Outline.
3) Click Insert.
4) Select the flow you wish to add an Auto-title to.
3. Edit the default untitled text with your desired title.
Tip: You can create an Auto-title from existing text by selecting it in the document area and
performing the steps described above.

B. Renaming an Auto-Title
To rename an existing Auto-Title:
1. Do one of the following:
• Click on the Auto-title while holding the Option key.
Or
• Select the Auto-title, then click anywhere within it.
2. Enter a new name for the Auto-Title.

C. Editing an Auto-Title
To open the Auto-Title popover and edit an existing Auto-title:
• Double-click on the Auto-title in the document area.
Or
• Double-click on the Auto-title in the Outline pane.
The Auto-title popover is displayed:
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Figure 4-8: Auto-Title Popover
1. Enter a new title for the edited Auto-title (optional).
2. Enter a Cross Reference Target ID in the corresponding text box (optional). Refer to Cross
References on page 112 for more information.
3. Use the Assign Virtual Target popup menu to assign this Auto-title to an existing Virtual
Target (optional). Refer to Assigning a Virtual Target on page 117 for more information.
4. Enter a comment regarding this Auto-title in the Comment text box (optional). These
comments can be displayed in the Outline pane. Refer to Changing the Outline Pane
Layout on page 145
5. Add tags to this Auto-title by typing them into the Tags text box and pressing the Return
key (optional). Auto-titles can be filtered by their tags in the Outline pane. Refer to Filtering
Outline Items on page 144 for more information.
Note: You can add multiple tags to a single Auto-title.
6. Select a Marker to highlight this Auto-title in the Outline pane (optional). Auto-titles can be
filtered by their markets in the Outline pane. Refer to Filtering Outline Items on page 144
for more information.

D. Deleting an Auto-Title
To delete an existing Auto-title Do one of the following:
• Place the insertion point at the end of the Auto-title and press the Backspace key.
Or
• Place the insertion point at the start of the Auto-title and press the Delete key.
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Or
Select the Auto-title and press Cmd + Backspace.
Or
Select the Auto-title in the Outline pane and press either the Backspace or Delete keys.
Or

• Click the Delete button (

) in the Auto-title popover.

Tip: When deleting an Auto-title from the Outline pane, all the document elements between
the deleted Auto-title and the next Auto-title of the same flow is deleted as well.
Note: When you delete an Auto-title, the numbering of all the Auto-titles coming after this
Auto-title may change, depending on its hierarchical location.

E. Copying and Moving Auto-Titles
Auto-titles can be copied and moved just like any other object in your document, as detailed
in Basic Editing Tools on page 40.
Additionally, you may use the Outline panel to easily move Auto-titles by selecting and
dragging them to the desired location.
Tip: When moving an Auto-title using the Outline pane, all the document elements between
the moved Auto-title and the next Auto-title of the same flow are moved as well. It is a very
powerful tool that allows you to quickly and easily reorganize your document.
Note: When you copy or move an Auto-title, the numbering of all the Auto-titles coming after
this Auto-title may change, depending on its hierarchical location.

F. Auto-Indent
Auto-indent is a feature which allows you to easily and quickly structure your document by
automatically applying diﬀerent Auto-title levels, without the need to enter them via the Autotitle palette. Document with Auto-indent active are especially suited for writing structured
documents such as legal documents.
To enable Auto-indent:
1. Open the Auto-Titles Flow Setup (refer to Editing Auto-Title Flows Setup on page 53 for
step-by-step instructions).
2. Check the Auto-Indent checkbox.
3. Click OK.
New buttons will be added to the Auto-Title palette, as shown in the following figure:
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Figure 4-9: Auto-Title Palette with Auto-Indent Active
Note: For best results using Auto-indent you need to configure your Auto-title flow setup
correctly. Mellel is shipped with a template that is configured correctly by default, so you can
either use this template or create your own.

G. Using Auto-Indent
Once Auto-Indent is active (refer to Auto-Indent on page 49 for step-by-step instructions), you
can perform the following:

• Indent or Outdent Paragraph: Clicking the Indent Level (

) or Outdent Level (

)

buttons will result the following behavior:
• If the current paragraph includes an Auto-title, it is indented/outdented to the next/
previous level based on your selection.
• If the current paragraph does not include an Auto-title, it is indented to the next level, if
Indent Level is pressed.
• If the selected Auto-title is at the top title flows level, clicking Outdent Level will change it
to regular text.
Note: Selecting regular text and clicking the Indent Level button will change it into the top
level in the title flow.

• Continue on Same Level: Clicking the Continue Same Level (

) button will result in the

following behavior:
• If the current paragraph includes an Auto-title, the Auto-title is removed. The Next
Paragraph style set for this paragraph style is applied to the Auto-title text.
• If the current paragraph is already a continuing paragraph (and thus, does not include an
Auto-title) it is indented to the level of its preceding Auto-title.
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• If the current paragraph does not have a preceding Auto-title, nothing will happen.

• Clearing Auto-Titles: Position the insertion point within any paragraph and then click the
Clear Level (

) button to convert the Auto-title into regular text and clear any indentions

associated with this Auto-title.
• Press the Return key at the end of a paragraph with an Auto-title to insert a new Auto-title at
the same level as the current Auto-title.
Note: The same functionalities are also available in the Edit > Auto-Indent sub-menu, which
is only displayed when Auto-Indent is enabled.
Note: When Auto-Indent is enabled, its keyboard shortcuts overwrite the same shortcuts that
are usually reserved for managing lists (changing list level and reseting a list):
• Cmd + ]: Indent level.
• Cmd + [: Outdent level.
• Cmd + |: Clear level.
• Cmd + `: Continue same level.

1. Continuing Paragraph
Edit Title flows drop-sheet (refer to Editing Auto-Title Flows Setup on page 53 for step-by-step
instructions) allows you to set the indentation of continuing paragraphs. Under Continuing
Paragraph you can:
• Set the Indent level for a continuing paragraph.
• Set the Start Margin for a continuing paragraph.

2. Managing Auto-Title Flows Setup
Auto-Title flows preferences are configured per document. This configuration is referred to as
Auto-Titles Flows Setup, and can be loaded and saved to your work environment. This allows
using the same setup across diﬀerent documents.

A. Selecting an Auto-Titles Flows Setup
To select the Auto-Titles Flows Setup currently being used in the document, Do one of the
following:
• Using the Auto-Title palette:
1. Click the Auto-Title palette.
2. Use the Setup popup menu to select the desired setup.
Or
• Using the Edit title flows window:
1. Choose Insert > Auto-Title > Edit title flows from the menu bar, or click the Edit title
flows (

) button in the Auto-Title palette.

2. Use the Selected setup popup menu to select the desired setup.
Note: When you change the selected Auto-Titles Flows Setup, the format of all the Auto-titles in
the document will change to fit the new setup.
Tip: To set any Auto-Titles Flows Setup as your default setup, perform the following instructions:
1. Open your default document template.
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2. Select the desired Auto-Titles Flows Setup.
3. Save the template.
The selected setup will now be used whenever a new document is created from this template.

B. Creating a New Auto-Titles Flows Setup
You may duplicate an existing Auto-Titles Flows Setup to create new setups in your document.
To create a new Auto-Titles Flows Setup:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Use the Selected setup popup menu to select the setup you wish to base your new setup
on.
3. Click Save setup.
4. Enter a name for your new setup.
5. Click OK to create your new setup.

C. Renaming an Auto-Titles Flows Setup
To rename an existing Auto-Titles Flows Setup:
1. Open Finder.
2. Choose Go > Library from the menu bar while pressing the Option key.
3. Navigate to Application Support > Mellel > AutoTitles Setups.
4. Select the desired setup.
5. Rename it while keeping the .asup extension.

D. Deleting an Auto-Titles Flow Setup
To delete an existing Auto-Titles Flow Setup:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Use the Selected setup popup menu to select the setup you wish to delete.
3. Click Delete setup.
Note: Deleting an Auto-Title Flows Setup removes it from Mellel's work environment. However,
when you delete a setup that is being used in the current document, it will still be available
even after deleting it, as all the configuration is still available in the document itself. The style
will appear as <style name> (from document) in the setup list. If you later apply a diﬀerent
setup, the previously deleted setup will no longer be available.
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E. Editing Auto-Title Flows Setup
1. Changing Flow Names
To rename an existing Auto-title flow:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Double-click the desired flow. The Title flow name dialogue-box is displayed.
3. Enter a new name for the flow.
4. Click OK.

2. Managing Tag Flows
You can add up to 99 tag flows in each Auto-Titles Flows Setup and edit, move and delete them
as you wish. The following sections detail the diﬀerent Tag flows management functionalities.
Note: While Tag flows are editable, structural flows are fixed, and you can only change their
name and formatting. Refer to Flow Types on page 46 for more information regarding flow
types.

A. Adding a Tag Flow
To add a new tag flow:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Click the Add button.
A new untitled flow is added to the Auto-titles flows hierarchy.

B. Deleting a Tag Flow
To delete an existing tag flow:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Select the tag flow you wish to delete.
3. Click the Delete button.
The selected tag flow is removed from the flows hierarchy.
Note: You can only delete tag flows (as opposed to structural flows). Tag flows appear in Blue
in the flows hierarchy.

C. Moving a Tag Flow
To move an existing tag flow:
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1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Select the tag flow you wish to move and drag it to the new location.
The selected tag flow is moved to the new location.
Note: Moving tag flows may aﬀect when and if their numbering is reset. Refer to Flow Types
on page 46 for more information.

3. Managing Flow Numbering
One of the most useful and important features of Auto-titles is their automatic numbering.
Mellel enables you to control several preferences of this feature, as detailed in the following
subsections.

A. Setting the Numbering Unit
The default numbering unit for an Auto-title is Arabic numbering (i.e. 1,2,3...). You can set a
diﬀerent numbering unit by doing the following:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Select the flow you wish to edit.
3. Use the Numbering Unit popup menu to select the desired numbering unit.

B. Setting the Initial Number
By default any Auto-title flow begins with the first number in its numbering unit sequence. You
can set a diﬀerent initial number by doing the following:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Select the flow you wish to edit.
3. Use the Start text box to enter the desired initial number.

C. Setting the Numbering Increment
By default any Auto-title flow increments by a single number between two subsequent Autotitles. (e.g. 1 > 2 > 3...). You can set a diﬀerent increment unit by doing the following:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Select the flow you wish to edit.
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3. Use the Increment text box to enter the desired increment value.

4. Formatting the Flow Auto-Titles
Mellel enables you to fully customise the format and style of your Auto-titles. Furthermore,

Auto-titles can be configured to have a diﬀerent format and/or style for diﬀerent usages such
as the document area, the Outline pane, in cross-references or in the table of contents.
All format and style options are performed from the formatting area, which is located at the
bottom of the Auto-Titles Flows Setup window:

Figure 4-10: Auto-Titles Flow Setup Window
Auto-titles can comprise diﬀerent elements. Some elements are static (i.e. they will appear the
same in all the Auto-titles in this flow, for example the word Chapter in Figure 4-10 above),
while others are dynamic (i.e. their appearance will change based on the location of the
specific Auto-title within the flow, for example the chapter number in Figure 4-10 above).
The following sub-sections detail the diﬀerent options for configuring the Auto-titles format
and style.

A. Inserting an Element
To insert an element into the Auto-Title format:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Select the flow you wish to edit.
3. In the format field, Place the insertion point where you want to enter the element.
4. Use the Elements popup menu to select the element you wish to enter (Refer to Auto-Titles
Flows Setup Window on page 370 for details regarding the diﬀerent elements).
55 | Writing your Document

B. Removing an Element
To remove an existing element from the Auto-title format:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Select the flow you wish to edit.
3. Select the element you wish to remove.
4. Use any of the methods described in Deleting Elements on page 43 to remove the
element.

C. Move an Element in the Format Area
To move an existing element within the format area:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Select the flow you wish to edit.
3. Select the element you wish to move.
4. Use any of the methods described in Basic Editing Tools on page 40 to move the element.

D. Inserting and Editing Text in the Format Area
Text added to the format area is a static element. This means that it will appear the same in all
the Auto-titles created in this flow. To insert and edit text to the format area:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Select the flow you wish to edit.
3. Place the insertion point in the format area.
4. Enter the desired text and use any of the methods described in Basic Editing Tools on page
40 to edit it.

E. Styling the Flow Auto-Titles
To change the character and/or paragraph attributes of auto-titles in a flow::
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Select the flow you wish to style.
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3. Use the Character and Paragraph palettes to change the attributes of Auto-titles in this flow.
Tip: You can set the Auto-title to use its surrounding paragraph and/or character attributes by
applying the <use surrounding> style from the relevant palette, as shown in the following
figure:

Figure 4-11: Use Surrounding Style
Tip: It is recommended to use styles rather than attributes to style your Auto-titles flows, as this
ensures consistency throughout the document.

F. Use a Diﬀerent Format for Diﬀerent Auto-Titles Usages
Auto-titles are often used and displayed in diﬀerent components within Mellel. This includes
the Outline, cross-references, table of contents and Mentions. You can create diﬀerent
combinations of format and style for Auto-titles based on where they are being used. For
example, you may not want the title number to appear in the Outline, but you would like it to
appear in the table of contents.
To use a diﬀerent format and style for diﬀerent usages:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Select the flow you wish to adjust a format for.
3. Click any of the following format tabs:
• TOC format: Determines how the Auto-title is displayed in the table of contents. Refer
to Table of Contents on page 121 for more information.
• Mention format: Determines how the Auto-title is displayed in a Mention. Refer to
Inserting Mentions on page 183 for more information.
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•

Outline format: Determines how the Auto-title is displayed in the Outline. Refer to
Outline on page 139 for more information.
• Ref format: Determines how the Auto-title is displayed in a cross-reference. Refer to
Cross References on page 112 for more information.
4. Check the Use a diﬀerent format for <element name> checkbox.
5. Change the format and style as required, as detailed in Inserting an Element on page 55 and
Styling the Flow Auto-Titles on page 56.
6. Click OK to apply changes.

5. Additional Preferences
A. Include/Exclude a Flow from the Table of Contents
You can set whether specific Auto-title flows will appear in the document's table of contents by
doing the following:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Select the flow you wish to configure.
3. Check the Include in TOC checkbox to include the flow in the table of contents, or uncheck
it to exclude it.
4. If the edited flow is a tag flow, you may use the List as separate section in TOC to have Autotitles from this flow appear as a separate section in the table of contents.
5. Click OK to apply changes.

B. Selecting the Title When Inserting Auto-Titles
You can configure whether or not the title is automatically selected for editing when an Autotitle of a specific flow is inserted into the document.
To configure whether or not the title is selected automatically:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Select the flow you wish to configure.
3. Check the Select Title after inserting checkbox to select the title when an Auto-title of this
flow is inserted into the document.
4. Click OK to apply changes.

C. Separate the Auto-Title from Previous Content
You can configure Auto-titles flows so that Mellel automatically separates them from the
previous content by adding a line break, a page break or a section break, among other
options. Perform the following instructions to configure this feature:
1. Do one of the following to open the Auto-Title Flows Setup window:
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•

Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Select the flow you wish to configure.
3. Use the Insert Before popup menu to select the desired option (refer to Auto-Titles Flows
Setup Window on page 370 for a complete description of the diﬀerent options.
4. Click OK to apply changes.

D. Configuring Flow Numbering Reset
You can configure an Auto-title flow to determine whether or not its numbering is reset when a
flow higher in the hierarchy is reset. Perform the following instructions to configure this
feature:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Select the flow you wish to configure.
3. Check the Reset numbering with higher level flow checkbox to reset the flow whenever a
flow from a higher level is reached.
4. Click OK to apply changes.
Note: The checkbox is not available for the top level flow.

F. Saving Changes to an Auto-Titles Flows Setup
To save changes to an Auto-Titles Flows Setup:
1. Do one of the following to open the Auto-Title Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Perform your required changes, as detailed in Editing Auto-Title Flows Setup on page 53.
3. Click OK to save your changes.
Tip: To discard your changes, use the Selected setup popup menu to choose the setup you've
changed. All made changes will be discarded and the setup will revert to its original
configuration.
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3. Notes
1. What are Notes?
Notes are special types of comments that can be added to the document. Notes can appear at
the bottom of each page or at the end of the document, and are referenced by a symbol
inserted into the document text.
The following figure provides an example for a footnote, and details the diﬀerent elements of
any note:
Reference
symbol

Separator
Note
symbol

Note text

Figure 4-12: Example Footnote

• Reference Symbol: This symbol references and links from the document text to the actual
•
•
•

note with the corresponding symbol. The reference symbol is usually numbered in sequence
(e.g. 1, 2, 3... or A, B, C...) for diﬀerent notes.
Separator: This line separates the main document text from the notes list.
Note Symbol: This symbol appears at the beginning of the note. The numbering of the note
symbol usually corresponds to that of the reference symbol.
Note text: This is the actual text comprising the note.

1. Note Streams
Typically, documents include two types of notes: Footnotes that appear at the bottom of each
page, and Endnotes that appear at the end of the document.
Mellel includes a unique feature that enables you to add additional types of notes and
customise them to match your specific requirements. This feature is referred to as Note
Streams.
The following figure illustrates how note streams work in Mellel:
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Figure 4-13: Note Streams Example
This example includes three diﬀerent streams of footnotes: One with Arabic numbering, a
second stream with Greek numbering, and a third with symbols. The ability to enter
concurrent note streams is very useful in cases where notes to the text come from more than
one source. One such use-case is with translator notes and author notes, or adding personal
notes to the text while writing, without interfering with the regular notes stream.

2. Notes Tasks
1. Managing Notes
A. Inserting a Note
To insert a new note:
1. Place the insertion point where you want to enter the note reference in the text.
2. Choose Insert > Note from the menu bar.
3. Choose the desired note stream from the list.

B. Deleting a Note
To delete an existing note:
1. Select the reference symbol of the note you wish to delete.
2. Press the Delete key.
Both the reference symbol and the corresponding note are removed from the document.

C. Moving a Note to a Diﬀerent Location
To move an existing note to a new location in the document:
1. Select the reference symbol of the note you wish to move.
2. Use any of the methods described in Basic Editing Tools on page 40 to cut the reference.
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3. Use any of the methods described in Basic Editing Tools on page 40 to paste the reference
in its new location.
Both the reference symbol and the corresponding note are moved to the new location.

D. Moving a Note to a Diﬀerent Stream
To move an existing note to a diﬀerent stream (for example, moving a footnote to the
endnotes stream):
1. Select the reference symbol of the note you wish to move.
2. Do one of the following:
• Choose Insert > Note from the menu bar and choose the new stream.
• Right click on the reference symbol and then click Note and the new stream.

E. Navigating Notes
There are several tools available for navigating notes in your document:
• To jump from a reference to its note, double-click the reference symbol.
• To jump from the note to its reference, either double-click the note symbol or click on the
note and press the ESC key.

F. Highlighting Notes
Mellel enables you to highlight notes, which makes them easier to spot, particularly if your
notes appear in superscript. To highlight notes in the text:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Check the Highlight notes on screen checkbox to highlight notes in the document area.
3. Check the Highlight notes in print checkbox to highlight notes when the document is
printed.
4. Click OK to apply changes.

2. Managing Note Streams
A. Creating a New Stream
To create a new note stream:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Click the Add button (

).

3. A new untitled stream is added to the document.
4. Change the stream attributes as required.
5. Click OK to apply changes.
Note: Refer to Edit Note Attributes Window on page 376 for a complete description of the Edit
Note Attributes window and its functionalities.

B. Deleting a Stream
To delete an existing note stream:
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1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Choose the stream you wish to delete from the streams list in the upper left corner.
3. Click the Delete button (

).

4. If there are any note associated with this stream, the following dialogue-box is displayed:

Figure 4-14: Deleting a Stream with Existing Notes
5. Do one of the following:
• Choose Delete associated notes to remove all the notes associated with the deleted
stream.
Or
• Choose Move notes to another stream and use the popup menu to choose the note
stream to move them to.
5. Click OK to confirm.
Note: Streams are document-specific, so deleting a stream only applies to the current
document.

C. Editing a Stream
Perform the following instructions to edit an existing note stream:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Choose the stream you wish to edit from the streams list in the upper left corner.
3. Perform any required changes.
4. Click OK to apply changes.
The following sub-sections detail the diﬀerent attributes you can change to configure your
note streams.

1. Renaming a Stream
Perform the following instructions to rename a stream:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Double-click the stream you wish to rename.
3. Enter a new name.
4. Press the Enter key or click anywhere outside the stream name to apply the name change.
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5. Click OK to apply changes.

2. Repositioning a Stream in the Streams List
To reposition a stream within the streams list:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Select the stream you wish to reposition and drag it to its new location.
3. Click OK to apply changes.
Note: When multiple streams reside in the same location (e.g. two footnotes streams), Mellel
will order the streams at the bottom of the page based on their position in the streams list.

3. Changing Note Text Styles
To change the character and paragraph styles of the notes text:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Choose the stream you wish to edit.
3. Under Note text style in the bottom right corner, use the Character (
(

) and Paragraph

) attributes buttons to apply character and paragraph styles to the note text.

4. Click OK to apply changes.

4. Setting Reference Symbol Attributes
To change the reference symbol attributes:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Choose the stream you wish to edit.
3. Under Reference symbol, use the Type and Format popup menus, the Character attributes
button (
) as well as the Superscript checkbox to set the desired attributes. Refer to Edit
Note Attributes Window on page 376 for a complete description of the diﬀerent options.
4. Click OK to apply changes.

5. Setting Note Symbol Attributes
To set the note symbol attributes:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Choose the stream you wish to edit.
3. Under Note symbol, use the Type and Format popup menus, the Character attributes button
(
) as well as the Superscript checkbox to set the desired attributes. Refer to Edit Note
Attributes Window on page 376 for a complete description of the diﬀerent options.
4. Click OK to apply changes.

6. Setting the Stream Start Number
You can configure a note stream to begin at any desired value by doing the following:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
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2. Choose the stream you wish to edit.
3. Enter the desired initial value in the Start at number text box at the bottom left corner.
4. Click OK to apply changes.
Note: If you choose Restart Every Page in the numbering popup menu, the Start At number
will be used as the start number on every page.

7. Styling the Separator
You can style the separator between the text and the notes by performing the following
procedure:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Choose the stream you wish to edit.
3. Use the diﬀerent tools under Separator to style its appearance. Refer to Edit Note Attributes
Window on page 376 for a complete description of the diﬀerent options.
4. Click OK to apply changes.

8. Setting Notes Height Limit
To prevent notes from taking over the entire page, you can set the maximum height allowed
for a notes area in any given page by doing the following:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Choose the stream you wish to edit.
3. Enter a numerical value in the Height Limit text-box to set the maximal percentage of the
page height that can be used by the notes area.
4. Click OK to apply changes.
Tip: The following figure illustrates diﬀerent heigh limit settings and the eﬀect they have on
the document layout:

Figure 4-15: Diﬀerent Height Limit Layout

65 | Writing your Document

When the height limit is set to be very low, some of the text linked to notes may flow to the
next page. This is useful when you want to avoid long notes covering the bulk of a page, or
when you have very few notes. If your document contains many notes but they are relatively
short, it is recommended to set the height limit to around 50 or 60 percent. In all other
situations, use the default setting (100 percent).

9. Setting Notes Position
You can set the placement of notes for any given stream by doing the following:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Choose the stream you wish to edit.
3. Under Placement use the Position popup menu to set the notes placement. Refer to Edit
Note Attributes Window on page 376 for a complete description of the diﬀerent options.
4. Click OK to apply changes.
Note: Changing the notes placement essentially changes them from footnotes to endnotes.

10. Setting Reseting Option
You can configure when and if will the note stream numbering be reset, by doing the
following:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Choose the stream you wish to edit.
3. Under Placement use the Numbering popup menu to set the reset behavior. Refer to Edit
Note Attributes Window on page 376 for a complete description of the diﬀerent options.
4. Click OK to apply changes.

11. Configuring Note and Reference Same Page Limitation
You can configure whether Mellel will allow notes and their corresponding references to be on
diﬀerent pages, by doing the following:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Choose the stream you wish to edit.
3. Under Placement use the May separate from reference checkbox to allow the reference and
the actual note to be on diﬀerent pages.
4. Click OK to apply changes.
Note: The May separate from reference checkbox is only available for notes placed on the same
page as the reference (such as footnotes).

12. Configuring Splitting Rules
You can configure the rules that govern whether the note text can be split across diﬀerent
pages, by performing the following procedure:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Choose the stream you wish to edit.
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3. Under Placement use the May Split popup menu to choose he desired option. Refer to Edit
Note Attributes Window on page 376 for a complete description of the diﬀerent options.
4. Click OK to apply changes.

13. Assigning a Shortcut to a Stream
You can assign a shortcut to a note stream to allow simple and quick entry, by doing the
following:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Click to the right of the stream you wish to add the shortcut to.
3. Choose the desired shortcut from the popup menu:

Figure 4-16: Assigning a Shortcut to a Note Stream
4. Click OK to apply changes.

14. Managing Note Stream Styles
You can use styles as templates for sets of attributes applied to note streams. A Note Stream
Style includes all the attributes defined in the Edit Note Attributes window, and enables
achieving consistency between diﬀerent documents and users. The following sub-sections
detail how you can use note stream styles.

A. Creating a Note Stream Style
To create a new note stream style:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Click the New Style button (

).

3. Enter a name for your new style.
4. Click OK to complete the creation process.
Tip: You can create a note stream style using the Style Sets window as well. Refer to Managing
Style Sets on page 194 for more information.

B. Editing a Note Stream Style
To edit an existing note stream style:
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1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Use the Note popup menu to choose the style you wish to edit.
3. Perform any required changes.
4. Click the Save Changes To Style button (

) to save your changes.

5. Click OK to apply changes.
Note: The Save Changes To Style button is only enabled after you perform any changes to
the style.
Tip: You can edit a note stream style using the Style Sets window as well. This option oﬀers the
same functionalities as editing from the Edit Note Attributes window. Refer to Managing Style
Sets on page 194 for more information.

C. Renaming a Note Stream Style
To rename an existing note stream style:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Use the Note popup menu to choose the style you wish to edit.
3. Enter a new name in the Note Style text box.
4. Click the Save Changes To Style button (

) to save your changes.

5. Click OK to apply changes.

D. Applying a Note Stream Style
To apply a note style to an existing note stream:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Choose the note stream you wish to apply the style to.
3. Use the Note popup menu to choose the style you wish to apply.
4. Click OK to apply changes.
Note: You can apply the same style to several note streams.

E. Deleting a Note Stream Style
To delete an existing note stream style:
1. Choose Insert > Note > Edit note attributes from the menu bar. The Edit Note Attributes
window is displayed.
2. Use the Note popup menu to choose the style you wish to delete.
3. Click the Delete Style (

) button.

4. Click OK to apply changes.
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4. Lists
1. What are Lists?
Lists are document elements that allow creating a sequenced series of paragraphs preceded
by a number or a bullet. You can create an unlimited number of lists in a document, and
completely customize their format and style to meet your requirements.
Each list in Mellel comprises a hierarchy of nine (9) levels , as shown in the following figure:

Figure 4-17: Example List
Lists can be ordered (e.g. sequences of incrementing characters/numbers such as 1,2,3 or I,II,III)
or unordered (e.g. sequences of identical icons such as bullets, asterisks and squares). Ordered
lists are reset whenever a new item from a higher level in the hierarchy is entered.
You can format each level independently of the others to meet your requirements. This
includes determining the symbol preceding the text, the distance between the text and the
symbol, the character style and more.
Note: The lists feature purpose is to create simple lists in side the document. For more
complex numbering and indention patterns, refer to Auto-Titles on page 44.

2. Lists Tasks
1. Managing Lists
A. Starting a List
To start a list Place the insertion point in the desired location and Do one of the following
instructions:
• Press Cmd + ].
Or
• Choose Edit > List > Increase One Level from the menu bar.
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Or

• Click the Increase button (

) in the List palette.

Tip: If you select a text prior to performing the above instructions, it is converted to a list.

B. Adding a New List Item
To add a new item to an existing list, Place the insertion point inside the list and press the
Return key.

C. Changing a List Item to Next Level
Lists comprise nine levels, and each level can have unique formatting and style. To change a
list item to the next level:
1. Place the insertion point inside the desired item.
2. Do one of the following:
• Press Cmd + ].
Or
• Choose Edit > List > Increase One Level from the menu bar.
Or

•

Click the Increase button (

) from the List palette.

Tip: You can change multiple list items together by selecting them before applying any of the
methods described above.

D. Changing a List Item to the Previous Level
Lists comprise nine levels, and each level can have unique formatting and style. To change a
list item to the previous level:
1. Place the insertion point inside the desired item.
2. Do one of the following:
• Press Cmd + [.
Or
• Choose Edit > List > Decrease One Level from the menu bar.
Or

•

Click the Decrease button (

) from the List palette.

Tip: You can change multiple list items together by selecting them before applying any of the
methods described above.

E. Resetting a List
Resetting a list means the list style no longer applies from the reset point and onwards. To
reset a list:
1. Place the insertion point where you wish you reset the list:
2. Do one of the following:
• Press Cmd + \ on the keyboard.
Or

Lists | 70

•

Choose Edit > List > Reset list from the menu bar.
Or

•

Click the Reset (

) button from the List palette.

F. Changing the List Initial Number
You can create lists that do not start in the initial value of their numbering sequence (e.g. a
numbered list that will start from three (3) instead of one (1). To change the list initial number:
1. Select an existing list.
2. In the List palette, insert the desired value in the Start at text box.
Tip: If you've had to reset a list but wish you resume it from the same numbering sequence,
start a new list and change the Start At value to the number the original list stopped at plus
one. For example, if you broke the previous list after the third item, create a new list and
change the Start At value to four (4).

G. Copying List Items
You can copy any individual item from a list, or the entire list altogether. Perform any of the
methods described in Basic Editing Tools on page 40 to copy and paste list items.
Note: When copying and pasting list items, they are copied with their original list attributes. To
copy the items without their attributes, refer to Copying and Pasting as Plain Text on page 40.

H. Copying List Attributes
List style attributes can be copied and pasted without the list content. Refer to Copying and
Pasting Attributes on page 40 for step-by-step instructions.

2. Styling a List
Like any other document element in Mellel, lists can be styled using either attributes or styles
(refer to Styling Essentials on page 155 for more information).

A. Styling a List using Attributes
You can style any list in the document using the Attributes tab in the List palette. To style a list
using the attributes tab:
1. Select the list you wish to style, or Place the insertion point within it.
2. In the List palette, click the Attributes tab.
3. Use the diﬀerent tools in the palette and the ruler to style your list (refer to Ruler on page
330 and List Palette Description on page 346 for a complete description of styling options).
Note: Changes made using the attributes tab will only aﬀect the specific list being edited. If
document consistency is of any importance, it is recommended to style lists (and any other
document element) using styles rather than attributes.

B. Styling a List using Styles
Using styles to change list attributes is similar to using styles with any other document
element. Refer to Working with Styles on page 186 for step-by-step instructions.
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5. Tables
1. What are Tables?
Tables allow you to organize your content in rows and columns. Each row or column contains
one cell or more. Tables are commonly used to make it easier for readers to browse large
amounts of information, or when it is required to compare diﬀerent types of data.

2. Table Tasks
1. Managing Tables
A. Inserting a Table
To insert a table:
1. Place the insertion point where you want to insert the table.
2. Do one of the following:
• Choose Insert > Table... from the menu bar.

•

Click the Table icon (

) in the toolbar.

The Insert Table dropping-sheet is displayed:

Figure 4-18: Insert Table dropping-sheet
2. Browse the table style using the arrow buttons and select the desired table style and
template.
3. Use the Rows text box to change the number of rows.
4. Use the Columns text box to change the number of columns.
5. Use the Direction icon menu to set the table direction.
6. Click Insert Table.
Tip: A shortcut to insert a table using a certain table style is to open the Table palette and
under the Styles tab double click a table style.
Tip: You can also insert a table in headers, footers and notes.
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Note: The Table icon appears in the toolbar by default, but you can remove it. Refer to
Customizing the Toolbar on page 268 for more information.

B. Selection in Tables
Like most elements in Mellel, you must first need to select something in order to edit it. There
are various ways to make a selection.
To select the entire table:
• Click a table. If you’ve already selected the table or editing it, click outside the table and then
click it again.
To select a single cell:
• Do one of the following:
• Click to select a table, then click again within any cell to select, and start editing that cell.
To select a range of cells:
• Use any of the following methods:
1. Using the cursor: Click inside the first cell you wish to select and drag the cursor all
over the desired cell range.
2. Using the Table palette: Place the insertion point in a cell and from the Commands
popup menu select one of the following options:
1. Select Row (

): Select all the cells in the current cell's row.

2. Select Column (

): Select all the cells in the current cell's column.

3. Select All Cells ( ): Select all the cells in the table.
3. Using the keyboard:
• Place the insertion point inside the table and press Shift + Up/Down/Right/Left
Arrow Key to select the cell in the corresponding direction.

C. Editing Tables
When editing tables, you must be able to diﬀerentiate between editing the table structure,
and formatting the content in cells. As a rule of thumb: you can always edit a table structure,
when a table or any part of it is selected. You can edit the content of cells if the insertion point
is visible in a cell or if several cells are selected.

D. Editing Table Content
To start editing the content of a cell:
• Click the table, then click within a table cell you wish to edit, or simply double click the cell.
To edit the table content, use the methods described in Basic Editing Tools on page 40.
When pasting text into a table, Mellel applies the following logic:
• If you copy text from another table and paste it into another cell , Mellel will try to paste the
content as it appeared in the original table. For example, if you copied the content of three
cells in a row, as shown in the following figure:
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Figure 4-19: Copying from a Table Example
Mellel will try to paste the content of those cells horizontally, starting with the cell where the

insertion point is located, as shown in the following figure:

Figure 4-20: Pasting in a Table Example

• When pasting cells’ content into a range of selected cells, only the selected cells are aﬀected.
If the pasted cells outnumber the selected range, the extra cells are ignored. If the selected
cells outnumber the pasted cells, the extra cells are not aﬀected. For example, when copying
three horizontal cells but selecting only two cells for pasting, the following result is achieved:

Figure 4-21: Pasting Three Cells’ content into Two

• If

you copy text from another document or application, Mellel will treat it diﬀerently
depending on the pasting target:
• If you place the insertion point in a single cell, Mellel will paste the entire copied content
into that cell. For example, this copied text:

Figure 4-22: Copied Text from TextEdit
When pasted into a cell, will produce the following result:

Tables | 74

Figure 4-23: Text Pasted into a Cell

• If

you select a range of cells, Mellel will try and organize the copied content into the
selected range using the standard delimit characters (tab = next column, return = next
row). For example, the same text above will produce the following result when pasted into
a range of cells:

Figure 4-24: Text Pasted into Range of Cells
Note: Mellel never changes the structure of a table following a paste operation.

E. Navigating Cells in a Table
The following navigation options are available within tables:
Table 4-7: Table Navigation Options
To...

Press...

Skip to the next cell in the row (or to
the first cell in the next row if at the last
cell in a row) and select the text in that
cell. Pressing tab when your in the last
cell at the last row will add a row to the
table

Tab
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Skip to the previous cell in the row (or
to the last cell in the previous line if at
the first cell in a row) and select the
text in that cell.

Shift + Tab

Inserts a tab character to the text.

Option + Tab

Skip one cell to the right (or to the first
cell in the next row if at the last cell in a
row).

Right Arrow
(when at the end of the text in a cell)

Skip one cell to the right and select its
content.

Cmd + Right Arrow

Skip one cell to the left (or to the last
cell in the previous row if at the first
cell in a row).

Left Arrow
(when at the beginning of the text in a
cell)

Skip one cell to the left and select its
content.

Cmd + Left Arrow

Skip one cell downwards. If at the
bottom row in the table, skips to the
line below the table.

Down Arrow

Skip one cell downwards and select its
content.

Cmd + Down Arrow

Enter the table cell below that best
corresponds to the insertion point
position.

Down Arrow
(when above a table)

Skip one cell upwards. If at the top cell
in a table, skips to the line above the
table.

Up Arrow

Skip one cell upwards and select its
content.

Cmd + Up Arrow

Enter the table cell above that best
corresponds to the insertion point
position.

Up Arrow
(when below a table)

F. Moving, Copying and deleting Tables
To move a table do the following:
1. Click and hold over a table.
2. Drag it to the desired destination.
To duplicate a table:
1. Click and hold over a table with the Option key pressed.
2. Drag the duplicate to the desired destination.
To cut, copy or paste a table:
1. Click a table to select it.
2. Use any of the methods described in Basic Editing Tools on page 40 to copy, cut and/or
paste the table.
To Delete a table, do any of the following:
• Place the insertion point right after a table and press the Backspace key.
Tables | 76

•

Click a table to select it, then click the Delete action button that will appear below the
table.

G. Converting Text to a Table
You can convert any tab-delimited text (i.e. Tab = New column; Return = New row) into a table
by doing the following:
1. Select the text you wish to convert.
2. Choose Edit > Convert Text to Table from the menu bar. Mellel will use the last chosen
style/template with the inserted table.

2. Structuring Tables
A. Resizing a table
To resize the entire table width:
1. Click the table. The table resize handles will appear at the table end (i.e. at the border of the
last column), bottom-right (or bottom left, if the table runs from Right to left).
2. Drag any of the resize handles right, left, up or down.
Note: Mellel Will change row and column height or width proportionally. For example, let’s say
you’ve resizes your table to by dragging a handle down and to the left.

Figure 4-25: Dragging the bottom-right border down and to the left
The end result will look like this:

Figure 4-26: After the drag
All the rows and columns were resized proportionally based on their size before you’ve resized
the table.
Note: You can also set the width of a table by setting a numerical value. For details, see Setting
Row and Column Width and Height on page 80.
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B. Setting the Table’s Position
To set the table’s position:
1. Click the table to select it
2. From the Table palette or the Edit Table Attributes popover choose any of the options
available from the Position drop-menu, or set the position (in percent point) manually.
Note: You can also centre a table by choosing Centre Table Horizontally from the Context
menu > Table Commands, or from the Table Commands menu in the Table palette.

C. Changing the Table’s Direction
Tables in Mellel are directional. They can run from left to right or from right to left.
Note: Changing the table direction does not change the text direction within the table.
To change an existing table's direction:
1. Click the table direction button at the Table palette or the the Edit Table Attributes popover.
Clicking this button will toggle the table’s direction from left-to-right to right-to-left.
Note: You can also select the table direction when creating a new table. Refer to Inserting a
Table on page 72.
Note: Changing the table's direction aﬀects the way new columns are added to the table.
Refer to Adding and Subtracting Rows and Columns below for more information.

D. Adding and Subtracting Rows and Columns
You can add rows and columns to a table in several ways.
To add a column to a table, do any of the following:
• Click a table to select it or position the insertion point within a table.
• From the Table palette or from the Edit Table attributes popover use the steppers for setting
the Table size to set number of columns and rows.
Note: Using this method, will add or remove (as much as possible) normal cell rows or
columns.
To add a column or a row before or after a certain cell, row or column:
1. Click within a cell, or select a range of cells.
2. From the Table palette or from the Edit Table attributes popover use the Table Command
menu to:
• Add a row above
• Add a row below
• Add a column Before
• Add a column After
Refer to Table Commands menu on page 361 for a description of these options.
Note: The meaning Before and After as they relate to columns depend on the table’s direction.

E. Adjusting Rows and Columns Size
There are several ways to adjust the size of rows and columns.
To adjust a column’s width:
1. Hover above the column border you wish to adjust.
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The cursor will change to a two-headed arrow.
2. Drag the border to the right or to the left to adjust the column size.
Here, only the edge will move, so that the column on one one side of the border will grow
larger and the column on the other side will be smaller.

Figure 4-27: Dragging a column border to resize it...

Figure 4-28: ... Will make one wider and the other narrower
To adjust a row’s height:
1. Hover above the row border you wish to adjust.
The cursor will change to a two-headed arrow.
2. Drag the border up or down to adjust the row heigh.
Note: Shrinking rows is limited to the minimal height required for text in any cell in that row.
To adjust column without aﬀecting other columns:
1. Hover above the row border you wish to adjust.
The cursor will change to a two-headed arrow.
2. Press the Shift key and drag the border to the right or to the left to adjust the column size.
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Figure 4-29: Shift + Drag a column border....

Figure 4-30: ... Will only aﬀect the dragged column

F. Setting Row and Column Width and Height
You can set the width and heights of rows and columns by manually entering the width or
height of column(s) or row(s). You can also set the relative width of columns.
To set the width of a column using exact measurements, do any of the following:
• Click within a cell or select a range of cells, and from the Table palette enter the desired
width in the Width field for that range of cells. The Width label will change to indicate the
selected range of cells.
• Click within a cell or select a range of cells, and from the context menu choose Edit Table
Attributes and from the Edit Table Attributes popover enter the desired width in the Width
field for the column(s).
• Hover above the column border you wish to adjust, and double click it. An editable field
will appear, allowing you to set the width value. Enter the desired value and click Return.
To set the width of a column relative to the entire table width, do any of the following:
• Click within a cell or select a range of cells, and from the Table palette enter the desired
width in the Width field for that range of cells, adding % character after the desired width
to set the width of a column or columns relative to the entire table width.
• Click within a cell or select a range of cells, and from the context menu choose Edit Table
Attributes and from the Edit Table Attributes popover enter the desired width in the Width
field for that range of cells, adding % character after the desired width to set the width of a
column or columns relative to the entire table width.
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Note: If you select the entire table (see Resizing a table on page 77), the changes you make will
apply to the entire table.
To set the height of a row using exact measurements, do the following:
1. Hover above the row border you wish to adjust, and double click it. An editable field will
appear, allowing you to set the height value. Enter the desired value and click Return.

G. Equalising Row and Column size
To equalise the width of selected columns in a table:
1. Select the columns you wish to equalise.
2. From the Table palette Commands popup menu or from the Table Commands menu in the
Context menu choose Equalise Column Widths ( ).
To equalise the height of selected rows in a table:
1. Select the rows you wish to equalise.
2. From the Table palette open the Commands popup menu or from the Table Commands
menu in the Context menu choose Equalise Row Heights ( ).
To equalise the width of all the columns in a table:
1. Hover above a column border.
The cursor will change to a two-headed arrow.
2. Press the Option key and drag the border to the right or to the left equalise column widths
for the entire table.
To equalise the height of all the rows in a table:
1. Hover above a row border.
The cursor will change to a two-headed arrow.
2. Press the Option key and drag the border up or down to equalise row heights for the entire
table.

H. Merging Cells
To merge adjacent cells:
1. Select the table cells you wish to merge.
2. Choose Merge Cells ( ) from the Context menu or from the Table Commands menu in
the Table palette.
Note: Merging cells also merges their content.

I. Splitting Cells
To split existing cells either horizontally or vertically:
1. Select the table cells you wish to split.
2. Choose Split Horizontally ( ) or Split Vertically ( ) from the Context menu or from the
Table Commands menu in the Table palette. The selected cell will be split in two.

J. Deleting Cells
To delete existing rows or columns:
1. Select the entire row or column you wish to delete.
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2. Choose Delete Cells ( ) from the Context menu or from the Table Commands menu in
the Table palette.
Note: The Delete Cells option is disabled unless an entire row or column are selected.

3. Styling Tables
You can style your tables using the Table palette or the Edit Table Attributes popover menu. You
can also create, edit and save table styles (see Table Styles below).

A. Headers, Footers, Leading and Trailing Columns
You can set headers, footers, and leading and trailing columns for a table.
To add a Header to a table:
1. Click to select a table.
2. Open the Table palette or with the Edit Table Attributes popover, and under the Header &
Footer section set the number of header rows ( ) by entering a value into the text field or
by using the stepper next to it.
To add a Footer to a table:
1. Click to select a table.
2. Open the Table palette or with the Edit Table Attributes popover, and under the Header &
Footer section set the number of footer rows ( ) by entering a value into the text field or
by using the stepper next to it.
To add a Leading column to a table:
1. Click to select a table.
2. Open the Table palette or with the Edit Table Attributes popover, and under the Header &
Footer section set the number of leading columns ( ) by entering a value into the text
field or by using the stepper next to it. The Leading column will be added on the left or
right of the table, based on the table’s direction.
To add a Trailing column to a table:
1. Click to select a table.
2. Open the Table palette or with the Edit Table Attributes popover, and under the Header &
Footer section set the number of trailing columns ( ) by entering a value into the text
field or by using the stepper next to it. The trailing column will be added on the left or right
of the table, based on the table’s direction.

1. Repeating header
You can set a repeating header for your table. A repeating header is a table header that
appears again and again at the top of the page in a table spanning over multiple pages.
To set a Repeating header:
1. Click to select a table.
2. Open the Table palette or with the Edit Table Attributes popover, and press the Rep. Header
popup menu. You can select to repeat any header row or all of them.
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B. Setting Colour Alternation
Setting the colour alternation allows you to set the background colour for alternating rows. To
set the background colour for a table:
1. Click to select a table.
2. Open the Table palette or with the Edit Table Attributes popover and set the line count for
the alternation (every other line, every 2 lines, etc.). Setting the value to 0 will turn Colour
Alternation oﬀ.
3. Click the Colour well to open the Colour window and determine the fill colour. Refer to
Colour Window on page 281 for a complete description. Refer to Table Palette Description
on page 357 and Edit Table Attributes popover on page 413 for a complete description of
the styling options.

C. Styling Table Borders
You can change the border line type, colour and weight (width). To change any border
property, you must first determine which of the borders you wish to adjust. The Border Selector
in the Table palette or the Edit Table Attributes popover is used to set which borders will be
aﬀected by the changes.
To adjust table borders:
1. Select the table cells you wish to edit.
2. Use the Border Selector in the Table palette (under the Options popover) or the Edit Table
Attributes popover Border Selector to selects the border that will be aﬀected by the
changes. Those borders, depending on your selection, will be wither the outer borders,
inner borders, horizontal or vertical borders. Refer to the section about Boarder Selector on
page 358 for more details about the selection context in the border selector.
Selected borders appear in blue. Unselected borders appear in grey and will not be aﬀected by any changes made in the attributes area.
3. Use the Line type, Weight and colour tools to style the selected borders. Refer to Table
Palette Description on page 357 and Edit Table Attributes popover on page 413 for a
complete description of the styling options.
Tip: Click on any crossing point to select/unselect all the borders that cross it.
Tip: Hold the Option key while clicking a border to deselect all borders except for the one
you‘ve clicked.
Note: By default, all borders are selected.

1. Inserting a Diagonal Line
To insert a diagonal line in a table cell:
1. Click inside the cell where you wish to insert the diagonal line.
2. Hold down the Option key and click one of the diagonal lines of the Border Selector in the
Table palette or the Edit Table Attributes popover.
3. Set the Line type, Weight and colour for the diagonal line.
Note: You must manually format the text so that it fits around the diagonal line. Refer to
Paragraph Formatting on page 164 for details about formatting options.
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D. Configuring Outer Padding
To adjust Outer Padding:
1. Select the table cells you wish to edit.
2. Use the Outer padding Selector in the Table palette (under the Options popover) or the Edit
Table Attributes popover to select the borders to apply outer padding.
3. Change the value using the field or stepper.
Selected padding sides appear in blue. Unselected padding sides appear in grey and will
not be aﬀected by changes you make. Refer to Table Palette Description on page 357 and
Edit Table Attributes popover on page 413 for a complete description of the styling
options.
Note: Only the outer borders of the selection will be aﬀected by changes in the outer
padding.

E. Configuring Corner Radius
To adjust corner radius:
1. Select the table cells you wish to edit.
2. Use the Corner Radius selector and field combo in the Table palette (under the Options
popover) or the Edit Table Attributes popover to select the corners to which you wish to
apply a corner radius.
3. Using the field or stepper set the corner radius value.
Selected corners appear in blue. Unselected corners appear in grey and will not be aﬀected by changes you make. Refer to Table Palette Description on page 357 and Edit Table
Attributes popover on page 413 for a complete description of the styling options.
Note: Only the outer corners of the selection will be aﬀected by changes in the corner
radius.

F. Configuring Vertical Alignment
To configure the vertical alignment of the text within the table cells:
1. Select the table cells you wish to edit.
2. Use the Alignment popup menu in the Table palette (under the Options popover) or the
Edit Table Attributes popover to select the desired alignment. Refer to Table Palette
Description on page 357 and Edit Table Attributes popover on page 413 for a complete
description of the diﬀerent options.

G. Configuring Inner padding
Inner padding is the distance between the cell’s content and its borders. To configure the Inner
padding:
1. Select the table cells you wish to edit.
2. Use the Inner Padding popup menu in the Table palette (under the Options popover) or the
Edit Table Attributes popover to select the desired padding. Available options include 1 to 5
points or None (no padding); the default value is 2 points. Refer to Table Palette
Description on page 357 and Edit Table Attributes popover on page 413 for a complete
description of the styling options.
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Note: The inner padding is maintained even when the border weight is changed (i.e., the
borders would never overlap the text).

H. Changing Cell Background Colour
To change the background colour of selected cells:
1. Select the table cells you wish to edit.
2. Use the Background popup menu in the Table palette or the Edit Table Attributes popover to
choose the option Solid.
3. Click the Colour well to open the Colour window and determine the fill colour. Refer to
Colour Window on page 281 for a complete description. Refer to Table Palette Description
on page 357 and Edit Table Attributes popover on page 413 for a complete description of
the styling options.

I. Styling Table Text
Styling text within a table is identical to styling text outside a table. Refer to Character
Formatting on page 157, and Paragraph Formatting on page 164 for a complete description.
The text in a table cell is set by default using the style applied to the table style and template.
When you make changes to this style, you can always discard those and go back to the original
styles applied by removing the text formatting of a table or of a range of cells.
To remove text formatting from text in a table:
1. Select cells in a table.
2. Choose Remove Text Formatting from the Table Commands menu in the Table palette or via
the Table Commands sub-menu available from the Context menu.

J. Manipulating Images within Cells
Manipulating images within cells is identical to manipulating them anywhere else in your
document. Refer to Images on page 92 for a complete description.
Note: When you paste an image into a cell, it is automatically scaled to fit into the cell.

4. Table Styles
Table styles are a collection of cell attributes for various types of cells. The various possible
types appear in the following table:
Leading Column Header cell Header cell Header cell Header cell Trailing column header cell
Leading column cell

normal cell

normal cell

normal cell

Trailing column

Leading column cell

normal cell

normal cell

normal cell

Trailing column

Leading column cell

normal cell

normal cell

normal cell

Trailing column

Leading column cell

normal cell

normal cell

normal cell

Trailing column

Leading column cell

normal cell

normal cell

normal cell

Trailing column

Leading Column Footer cell

footer cell

footer cell

footer cell

trailing column footer cell
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Table 4-8: Cell types
When displaying cells, Mellel needs to determine their attributes (e.g, background colour, text
font, inner padding etc.). To do that Mellel does two things. First, it determines the type of the
cell, and then it refers to the table style to look for the attributes defined for that cell type.
Mellel uses this logic to determine the cell type: If the cell is in a table header, it is a header cell;
if the cell is in the footer, it is a footer cell. Similarly, if a cell is in a leading column it is a leading
column cell, and if it is the trailing columns it is a trailing column cell. If a cell is on the
intersection of these special rows or columns, it is considered a corner cell (for example, if a cell
is in the intersection of a header row and a leading column it is considered a leading column
header cell). Cells that don't belong to any any of these categories are considered "normal"
cells.
The table can define attributes for any of the cell types, and when looking up the attributes in
the style it follows a hierarchy (or ancestry): Mellel first looks at the attributes defined for that
specific cell type, if the attribute is defined for that type, it uses the attribute; otherwise, if an
attribute is not defined for that cell type, Mellel continues down the hierarchy until it finds a
cell type for which this attribute is defined — and uses that attribute.
For example, lets consider a 4 by 4 table that has 1 header row and 1 leading column. When
trying to determine the background colour for the top left cell Mellel does the following. First
it determines the type. The cell is in the header but it is also in the leading column, this makes
this cell a leading column header cell. Once the type is figured out, Mellel looks at the table
style to figure out its attributes, first it will look for the attributes defined for leading column
header cells, if a background colour is defined for that cell type, Mellel will use it; if not, Mellel
will try the attributes for the next type down the hierarchy — the header cells. If the attribute
is not defined for header cells, Mellel will look at the attributes defined for leading column
cells. If the attribute is not defined for that type, Mellel will look in the attributes defined for "all
cells" (or common). A table style will always contain all the attributes for "all cells" as this type
is the last resort for cell attributes.
Most cell attributes, such as height, width, background colour, and so on, can be set for each
cell type, without any conflict with other cell types. This, however, is not always true for cell
border attributes, which may be common with with cells of diﬀerent types. Borders may be
horizontal or vertical, and are divided into three groups:
• Inner – borders between cells of the same type.
• Outer – borders at the outer edges of a table or edges that have an outer padding.
• Inter-Type – borders between cells of diﬀerent types.
Inter-type

Inner
Outer
Table 4-9: Border types
Note: Refer to Table Style Window on page 409 for a description of table style options.
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A. Table style templates
Every table style contains at least one template, and you can create multiple templates per
table style. Templates are used to store pre-fabricated tables, defining several attributes that
are not part of the style. This is especially useful when you need to enter tables that are
basically the same, in terms of design, but diﬀer in some details, such as the header content,
length of the table, and so on.
The following types of attributes are stored within a template:
• Table dimensions: Row and column count, size, and so on.
• Header, Footer, Leading, and Trailing count: For example, If a table has a header, footer
or a two-row header.
• Repeating header setting (refer to Repeating header on page 82 for a description of
Repeating headers).
• Content in cells: you may enter text, formulas, and so on into table cells.
Note that when you style your tables “by example” from within a table, you cannot save the
types of content detailed above into a specific template. This can only be done via the Edit
Table Style window.
Refer to Table Palette Description on page 357 and Edit Table Attributes popover on page 413
for a a description of styling options. Refer to Table Style Window on page 409 for a description
of table style options.
Note: Refer to Table Style Window on page 409 for a description of table style options.

B. Using Styles and templates
To Add, delete, edit, apply or save changes to a style:
• With the Table palette:
1. In the the Table palette, under the Styles tab, select one of the styles.
2. Click Create New Style, Delete Style, Edit Style (i.e., open the Edit Table Style window),
Apply style or Save Changes to Style buttons to perform those types of actions.
• With the Edit Table Attributes popover:
1. Do one of the following:
• Click a table to select it or select cells in a table and from the context menu choose
Edit Table Attributes.
• Click the Edit button at the bottom of the table to open the Edit Table Attributes
popover.
2. Click the Create New Style, Delete Style, and Save Changes to style (available if there are
changes to the style) buttons to perform those actions. Use the Styles popup menu to
apply a diﬀerent style to the selected table.
Note: Refer to Table Style Window on page 409 for a description of table style options.
To apply a style to an existing table:
1. Select a table or any part of a table.
2. Do any of the following:
a. With the Table palette, under the Styles tab, select a style and click the Apply button
(Alternately, you can simply double-click the style).
b. With the Edit Table Attributes popover, select a style from the Style popup menu.
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To Edit a style via the Table Style Window:
1. Select a table or any part of a table.
2. With the Table palette, under the Styles tab, select a style and click the Edit button .
3. Edit the style and then click Save to save the changes or Cancel to discard.
To Edit a style “by example”:
1. Select a table and edit it via the Table palette or the Edit Table Attributes popover.
2. When done editing, do any of the following:
a. With the Table palette, under the Styles tab, select the edited style (marked by a + next
to its name) and press the Save Changes to Style button.
b. With the Edit Table Attributes popover, click the Save Changes to Style button.
Important: you should be aware that every table has a style and a template applied to by
default. That means that the changes you’ll make to the table’s attributes will be overrides to
the table style. When you save the changes to the style, Mellel will try to interpret the overrides
as changes to the style, by looking to see if the overrides are consistent.
For example, if the background colour of all Header cells was modified, this can be interpreted
as setting the background colour for header cells, but if the background colour is changed
only with some of the header cells, the change is considered inconsistant. After modifying the
style, all overrides are discarded, including inconsistant overrides.

3. Formulas
A Formula object consists of a formula expression, which defines how the formula value
should be calculated. Formulas can only be used in tables.
Mellel come with several pre-defined formulas:
• Sum of Column: The sum of a column’s quantities.
• Average of Column: The Average of a column’s quantities.
• Standard Deviation of Column: The Standard Deviation of the column’s quantities.
• Product of Column: the multiplication of quantities in a column.
• Sum of Row: The sum of a row’s quantities.
• Average of Row: The Average of a row’s quantities.
• Standard Deviation of Row: The Standard Deviation of the row’s quantities.
• Product of Row: the multiplication of quantities in a row.
You can edit a formula expression to perform any calculation you like. If the calculation is not
provided as one of the built-in formulas, you can insert any formula and then edit its code to
suit your needs. Refer to Formula Expressions on page 89 to learn more about how to write
formula expressions.
To insert a formula:
1. Click within a cell in the table.
2. Choose Insert > Formula > <any formula> or choose Formula > <any formula> from the
Context menu.
To edit the formula expression:
1. Double-click the inserted formula in a cell.
2. The Formula Code popover will open, allowing you to edit the Formula’s expression.
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3. Click Set to save the edit, or click outside the Formula Code popover to discard it. Click the
Help button to learn about the options available to you when creating formulas.
Tip: You can cut, copy and paste formulas, which will help you quickly duplicate them into
additional cells.

1. Formula Expressions
Formula expressions are mathematical expressions which are evaluated to produce a numeric
result. A formula can contain literals (that is, numbers), functions and operators. You can enclose parts of a formula with parenthesis, for clarity or to override the default operator
precedence.
Every time you make a change to the contents of cells in a table containing a formula, the formula is re-evaluated, and the value changes, if needed.
For Example, let’s examine the following formula: sum(col_all)*1.5. This formula includes several parts: sum() is a function that sums up the value of the cells indicated by the argument.
col_all is the function argument indicating that all the cells above the cell containing the formula in the same column are to be evaluated and *1.5 means that we need to multiply the result
of the sum function by 1.5.

A. Functions
A function takes an input — a series of values — to produce an output which can then be used
as the formula value (in a typical case of a formula expression containing only a function) or as
part of a longer expression. The input is indicated by the function argument which
determines which cell values are included.
There are two types of cells: plain cells — cells that do not contain formulas — and formula
cells — cells that contain a formula. Plain cells are evaluated by taking the value of the first
sequence of digits in the cell (or zero, if the cell text contains no digits), formula cells are
evaluated by evaluating the formula and taking the result as the cell’s value.

1. Function names
The following functions are available in Mellel’s formula expressions:
SUM — adds up the values of all the cells in the input.
AVERAGE — adds up the values of all the cells in the input and divides it by the number of
cells.
STDEV — Standard deviation: Adds up the square of the diﬀerence between cell values in the
input and the average of all the cell values and divides it by the number of cells minus one.
PRODUCT — Multiplies all the values of the cells in the input.

2. Function Argument
The function argument indicates how to compose the input for the function. It is made of two
parts, the first indicates whether the function input is taken from the column or from the row.
The second indicates what type of cells will be used (plain, formula, or both).

A. Column/Row
There are two options for the first part of the function argument.
col — indicates using the cells above the formula cell in the same column.
row — indicates using the cells before the formula cell in the same row.
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B. Cell Type
There are four options for the second part of the function argument
all — uses any cell.
form — uses only cells with a formula.
plain — uses only cells that don’t contain a formula.
segment — uses only plain cells between the last cell containing a formula and the formula
cell.

B. Operators
The following operators are allowed in formula expressions:
* — multiplication.
/ — division.
+ — addition.
- — Subtraction.
^ — Power of (Exponent).

2. Useful tips
The formula feature in Mellel is very flexible. Usually, when table cells contain formulas, they
are formula cells, and thus cannot contain any additional text. Also, regular cells are defined as
number cells, and do not allow you to have a mix of text and numbers in them. Mellel takes a
diﬀerent approach.
For example, let’s say you want to have a cell with the following content: “Average:
<AVERAGE(col_all)>”. Problem? No problem. Just write what you need to, and add the formula
you need.
The same applies to cells. For example, let’s say you wish to enter in a cell “40.1 Pounds”. No
problem here. If there is a formula calculating this cell, it’ll ‘pick’ the “40.1” and ignore “Pounds”.
It’ll work the same way with any additional content.
Note: If there are two numbers in a cell, Mellel will automatically pick the first one.
Another flexible option is the ability to combine calculations applying to diﬀerent scope. Fore
example, the following content in a cell: “AVERAGE(col_all)+SUM(row_all)” will calculate the
average of a column plus the sum of the row!
A final note will touch upon cell types. Usually, when performing calculations, the apply to a
range of cells (e.g., a column). This is good as long as that’s the calculation you wish to perform.
But let’s say you have this table:
Item A

1

Item A

1

Sum A

2

Item B

1

Item C

1
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Sum All

6

The result at the Sum All row is clearly faulty: 1+1+1+1=4 and not 6. The calculation should not
have included the Sum A result row. Here, setting the cell type for Sum All Cell right will do the

trick:
Item A

1

Item A

1

Sum A

2

Item B

1

Item C

1

Sum All

4

What did the trick was changing the Sum All formula from “SUM(col_all)” to “SUM(col_plain)”.
That is, only plain cells (i.e., without a formula) were summed.
You can use the cell type options to achieve even more sophisticated results.
Janurary

20

February

40

March

92

First Quarter

152

April

90

May

94

June

113

Second Quarter

297

1st Half

449

Here, the First Quarter cell uses the code “SUM(col_segment)”, which results in only summing
up cells without a formula, but not for the entire column, but just to the last cell with a
formula. The 1st Half cell contains the code “SUM(col_form)” — that is, it only sums up cells
with a formula. The end result is that each formula is used to sum up just the cells that are
relevant to the calculation at hand.
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6. Images
1. What are Images?
You can insert diﬀerent types of graphic files into your Mellel documents. These include
pictures, graphs or equations which are all referred to as Images in Mellel. You can use various
tools to insert, move and edit images, as described in the following sub-sections.
Images in Mellel can be placed into a document as either an inline or a floating object, which
determines how they are laid out in relation to other document elements. An inline image is
positioned relative to the text, while a floating image is positioned relative to the page. The
following figure depicts the diﬀerence between an inline and a floating image:

Figure 4-31: Inline (Top) versus Floating (Bottom) Image
Both inline and floating images can be set so that surrounding text is wrapped around them,
as depicted in the following image:

Figure 4-32: Text Wrapping

2. Supported Graphic Formats
Mellel supports any graphic format supported by the macOS, preserving both pixel and vector

data (where applicable). This includes BMP, EPS, GIF, JPEG, PDF, PICT, PNG, PSD (Photoshop),
TARGA, TIFF, and more.
In most cases, even unsupported formats can be inserted into Mellel and converted to a
supported format. For example, graphics can be copied from applications such as Adobe
Illustrator®, OmniGraﬄe®, Sketch, and others, and Mellel will preserve both pixel and vector
data while converting the graphics to a supported format.
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3. Images Tasks
1. Inserting an Image
To insert a new image into your document:
1. Place the insertion point where you want to insert the image.
2. Do one of the following:
• Choose Insert > Image from the menu bar.
Or

•

Click the Insert Image button (

) in the toolbar

Note: The Insert Image button is not included in the toolbar by default. Refer to Customizing
the Toolbar on page 268 for more information.
2. Locate and select the graphic file you wish to insert into your document.
3. Click Open.

2. Inserting an Equation as an Image
Elements from almost any equation editor can be inserted into Mellel using either drag and
drop or copy and paste. Once inserted into the Mellel document, equations are manipulated
just like any other image. The main diﬀerence between other graphic elements and equations
is that when equations are pasted, they usually come with the proper vertical positioning shift
so that you can position them inline properly.
Note: Equations pasted from the MathMagic equation editor can be edited in MathMagic if
they are copied from Mellel and pasted back into MathMagic.

3. Moving an Image
To move an image within your document, click it and drag it to its new location.
Note: Dragging behavior would vary depending on whether the image is set to be inline or
floating. Inline images will be dragged in relation to other document elements and cannot be
placed on top of them. Floating images can be dragged freely across the page regardless of
any other elements. Refer to What are Images? on page 92 for a comparison between the two.
Tip: When moving a floating image, snapping lines are displayed in the following cases:
• Image is at the top/bottom/left/right edge of the document area.
• Image is at the top/bottom/left/right edge of the page.
• Image is aligned with another object (diﬀerent image/text box).

A. Moving an Image Within its Frame
To move an image within its frame while keeping its frame in the same position within the
document:
1. Double-click the image you wish to move.
The Edit Image popover is displayed.
2. Use the Fitting Method popup menu to choose Float in frame.
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3. Press and hold the Option key while clicking on the image and dragging it within its
frame.

4. Replacing an Image
To replace an existing image:
1. Select the image you wish to replace.
2. Do one of the following:
• Insert a new image using any of the methods described in Inserting an Image on page
93.
Or
• Copy/cut and paste an image from a diﬀerent location by using any of the methods
described in Basic Editing Tools on page 40.
The new image will replace the existing one.
Note: When replacing an image, the original image attributes are applied to the new image.

5. Resizing an Image
To resize an existing image:
1. Select the image you wish to resize.
2. Do one of the following:
• Click and drag any of the eight squares surrounding the image.
Or
• Double click the image to open the Edit Image popover and use the Resize
(Percentage) or Resize (Dimensions) buttons to resize it (refer to Edit Image Popover
on page 384 for a complete description).
Tip: When manually resizing a floating image, snap bars appear in the same cases described in
Moving an Image on page 93.
Tip: When resizing an image using the Edit Image popover, click the Lock icon so that it
appears closed ( ) to maintain original image proportions (e.g. when you change either the
height or width, the other is automatically changed to maintain the same ratio).
Note: When hovering over any of the eight clickable squares, the cursor changes to a bidirectional black arrow.

6. Editing Image Attributes
Image attributes are edited using the Edit Image popover. Do one of the following to open the
popover:
• Double-click on the image you wish to edit.
Or

• Select the image you wish to edit and click the Edit Image icon (

).

The Edit Image popover is displayed.
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A. Setting Image Fill
To change the image fill:
1. Select and edit the desired image (refer to Editing Image Attributes on page 94).
2. In the Fill area, use the Type popup menu to choose Solid.
3. In the Fill area, use the Colour well (
) to open the Colour window and choose the fill
colour. Refer to Colour Window on page 281 for step-by-step instructions.

B. Setting Image Transparency
To change the transparency of an image:
1. Select and edit the desired image (refer to Editing Image Attributes on page 94).
2. In the Fill area either use the Alpha text-box or drag the slider to achieve the desired
transparency.

C. Setting Image Frame
By default, images are inserted without a frame. To add and style a frame:
1. Select and edit the desired image (refer to Editing Image Attributes on page 94).
2. In the Frame area use the Type and Weight popup menus and the Colour well (
) to
style the frame. Refer to Edit Image Popover on page 384 for a complete description of the
diﬀerent options.

D. Setting Image Corner Radius
To edit images so that they are displayed with rounded edges:
1. Select and edit the desired image (refer to Editing Image Attributes on page 94).
2. In the Frame area use the Radius text-box to set the desired corner radius.

E. Setting Image Vertical Position
When images are set to appear inline with the surrounding text, you can set their vertical
position, so that they appear above/below the text. To set an image vertical position:
1. Select and edit the desired image (refer to Editing Image Attributes on page 94).
2. Use the Vertical Position text-box to enter the desired value.
Note: Positive values will position the image above the text baseline level, while negative
values will position it below the baseline.

F. Adjusting Fixed Line Spacing for Images
When images are set to appear inline with the surrounding text, Mellel can automatically fit the
image size to multiplications of the surrounding text spacing. This enables maintaining the
same spacing in pages that include and do not include images. For example, if the line spacing
is 14 points, and the image height is 53 points, it will occupy 56 points (14 x 4) so that the page
spacing remain visually consistent.
To enable adjusting fixed line spacing for images:
1. Select and edit the desired image (refer to Editing Image Attributes on page 94).
2. Check the Adjust fixed line spacing checkbox.
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Note: The Adjust fixed line spacing checkbox is only available if the image is set to be inline with
no text wrapping.

G. Setting the Image as Inline or Floating
Images in Mellel can be positioned as either inline or floating by doing the following (refer to
What are Images? on page 92 for a comparison of inline and floating images):
1. Select and edit the desired image (refer to Editing Image Attributes on page 94).
2. Use the Placement radio button to choose Inline or Floating.

H. Setting Image Text Wrapping
To determine whether text is wrapped around images and how:
1. Select and edit the desired image (refer to Editing Image Attributes on page 94).
2. Check the Image causes wrap checkbox.
3. Click one of the wrapping layout buttons to select the desired layout (refer to Edit Image
Popover on page 384 for a complete description of the diﬀerent options).
4. Use the Extra space text-box to enter the desired space between the image and the
wrapping text.
Note: Diﬀerent buttons are available, and their behavior is diﬀerent, when an image is set to
be inline or floating. Refer to Edit Image Popover on page 384 for a complete description of
the diﬀerent options

I. Setting Image Title
Each image can be set with a title that enables using it as a reference target (refer to Cross
References on page 112 for more information).
To set an image title:
1. Select and edit the desired image (refer to Editing Image Attributes on page 94).
2. Enter the desired title in the Image Title text-box.

J. Setting Image Cross-Reference Target ID
You can assign an image with a cross-reference target ID. This enables to use the image as a
target for references from other parts of the document (refer to Cross References on page 112
for more information).
To set a cross-reference target ID for an image:
1. Select and edit the desired image (refer to Editing Image Attributes on page 94).
2. Do one of the following:
• Enter the desired ID in the Cross Reference Target ID text-box and click Set.
Or
• Use the Assign Virtual Target popup menu to assign a virtual target to the image (refer
to Managing Virtual Targets on page 116 to learn more about virtual targets).

7. Deleting an Image
To delete an existing image:
1. Click on the desired image.
Images | 96

2. Do one of the following:

•
•

Click the Delete button (

).

Use any of the methods described in Deleting Elements on page 43 to delete the
image.
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7. Text Boxes
1. What are Text Boxes?
Text boxes are document elements that allow you to enter text inside a rectangle box. The box
can be styled and positioned in various options to allow greater flexibility for creating unique
headings, emphasized paragraphs, and so on.
Text boxes in Mellel can be placed as either an inline or a floating object, which dictates how
they are laid out in relation to other document elements. An inline text box is tied to a certain
position in the text, while a floating text box is positioned relative to the page. The following
figure depicts the diﬀerence between an inline and a floating text box:

Figure 4-33: Inline (Top) versus Floating (Bottom) Text Box
Both inline and floating text boxes can be set so that surrounding text is wrapped around
them, as depicted in the following figure:

Figure 4-34: Text Box with Text Wrapping

2. Text Boxes Tasks
1. Inserting a Text Box
To insert a new text box:
1. Place the insertion point where you want to insert the text box.
2. Do one of the following:
• Choose Insert > Text box from the menu bar.
Or

•

Click the Insert Text Box button (

) in the toolbar.
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Note: The Insert Text Box button is not included in the toolbar by default. Refer to
Customizing the Toolbar on page 268 for more information.

2. Replacing a Text Box
To replace an existing text box:
1. Select the text box you wish to replace.
2. Do one of the following:
• Insert a new text box using any of the methods described in Inserting a Text Box on
page 98.
Or
• Copy/cut and paste a text box from a diﬀerent location by using any of the methods
described in Basic Editing Tools on page 40.
The new/copied text box will replace the existing one.

3. Moving a Text Box
To move an text box within your document, click and drag it to its new location.
Note: Dragging behavior would vary depending on whether the text box is set to be inline or
floating. Inline text boxes will be dragged in relation to other document elements and cannot
be placed on top of them. Floating text boxes can be dragged freely across the page
regardless of any other elements. Refer to What are Text Boxes? on page 98 for a comparison
between the two.
Tip: When moving a floating text box, snapping lines appear in the following cases:
• Text box is at the top/bottom/left/right edge of the document area.
• Text box is at the top/bottom/left/right edge of the page.
• Text box is aligned with another object (diﬀerent image/text box).

4. Resizing a Text Box
To resize an existing text box:
1. Select the text box you wish to resize.
2. Do one of the following:
• Click and drag any of the eight squares surrounding the text box.
• Double click the text box to open the Edit Text Box popover and enter the desired
dimensions in the Width and Height text boxes.

•

Click either the Fit Width (

) or Fit Height (

) buttons to auto-size the text box

width/height so that its fits the text exactly.
Tip: If the entire text cannot be displayed within the Text box, an overflow indicator will
appear at the bottom right corner of the Text box, as depicted in the following figure:
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Figure 4-35: Text Box Overflow Indicator
Tip: When resizing a floating text box, snap bars appear in the same cases described in Moving
a Text Box on page 99.
Note: When hovering over any of the eight clickable squares, the cursor changes to a bidirectional black arrow.

5. Editing Text Box Content
When you first enter a Text box, it appears with a dummy text and ready for text editing. To
edit the content, use the same tools you would for editing text anywhere else in the
document. When you are done with editing, click anywhere outside the text box.
To enter content edit mode again, double-click on the text box you wish to edit.

6. Editing Text Box Attributes
Text box attributes are edited using the Edit Text Box popover. To open the popover, select the
text box you wish to edit and click the Edit Text Box icon (
).

A. Setting Text Box Dimensions
To change the text box width and height:
1. Select and edit the desired text box (refer to Editing Text Box Attributes above).
2. Under Text Box use the Height and Width text boxes to enter the desired value.

B. Setting Text Box Padding
Padding is the distance between the text box content and its border. To change the text box
padding:
1. Select and edit the desired text box (refer to Editing Text Box Attributes above).
2. Under Text Box use the Padding text box to enter the desired value.

C. Setting Text Box Fill
To change the text box fill:
1. Select and edit the desired text box (refer to Editing Text Box Attributes above).
2. In the Fill area, use the Type popup menu to choose Solid.
3. In the Fill area, use the Colour well (
) to open the Colour window and choose fill
colour. Refer to Colour Window on page 281 for step-by-step instructions.
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D. Setting Text Box Transparency
To change the text box transparency:
1. Select and edit the desired text box (refer to Editing Text Box Attributes on page 100).
2. In the Fill area either use the Alpha text-box or drag the slider to achieve the desired
transparency.

E. Setting Text Box Frame
By default text boxes are added with a solid one (1) point wide black frame. Perform the
following instructions to change the text box frame:
1. Select and edit the desired text box (refer to Editing Text Box Attributes on page 100).
2. In the Frame area use the Type and Weight popup menus and the Colour well (
) to
style the frame. Refer to Edit Text Box Popover on page 389 for a complete description of
the diﬀerent options.

F. Setting Text Box Corner Radius
To style text boxes so that they are displayed with rounded edges:
1. Select and edit the desired text box (refer to Editing Text Box Attributes on page 100).
2. In the Frame area use the Radius text-box to set the desired rounded edge radius.

G. Setting Text Box Vertical Position
When text boxes are set to appear inline with the surrounding text, you can set their vertical
position, so that they appear above/below the text, to achieve optimal layout. To set a text box
vertical position:
1. Select and edit the desired text box (refer to Editing Text Box Attributes on page 100).
2. Use the Vertical Position text-box to enter the desired value.
Note: Positive values will position the image above the text baseline level, while negative
values will position it below the baseline.

H. Adjusting Fixed Line Spacing for Text Box
When text boxes are set to appear inline with the surrounding text, Mellel can automatically fit
the text box size to multiplications of the surrounding text spacing. This enables maintaining
the same spacing in pages that include and do not include text boxes. For example, if the line
spacing is 14 points, and the text box height is 53 points, it will occupy 56 points (14 x 4) so
that the page spacing remain visually consistent.
Perform the following instructions to enable adjusting fixed line spacing for text boxes:
1. Select and edit the desired text box (refer to Editing Text Box Attributes on page 100).
2. Check the Adjust fixed line spacing checkbox to enable this feature.
Note: The Adjust fixed line spacing checkbox is only available if the text box is set to be inline
with no text wrapping.

I. Setting Text Box as Inline or Floating
To set text boxes to be positioned inline or floating (refer to What are Text Boxes? on page 98
for a comparison of inline and floating text boxes):
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1. Select and edit the desired text box (refer to Editing Text Box Attributes on page 100).
2. Use the Placement radio button to choose Inline or Floating.

J. Setting Text Box Text Wrapping
To determine whether text is wrapped around text boxes and how:
1. Select and edit the desired text box (refer to Editing Text Box Attributes on page 100).
2. Check the Text Box causes wrap checkbox.
3. Click one of the wrapping layout buttons to set the desired layout (refer to Edit Text Box
Popover on page 389 for a complete description of the diﬀerent options).
4. Use the Extra space text box to enter the desired space between the text box and the
wrapping text.
Note: Diﬀerent buttons are available, and their behavior is diﬀerent, when a text box is set to
be inline or floating.

7. Deleting a Text Box
To delete an existing text box:
1. Click on the desired text box.
2. Do one of the following:

•

Click the Delete button (

•

Or
Use any of the methods described in Deleting Elements on page 43 to delete the text
box.

).
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8. Hyperlinks
1. What are Hyperlinks?
Hyperlinks in Mellel are textual objects within your document that can be linked to external
web sites, e-mail addresses or files.
Each link comprises two components:
• Display Text: This is the text that will appear in the document and which you can click to
navigate to the hyperlink.
• Target: This is the target of the hyperlink, e.g. this is where you are directed when you click
the hyperlink (either a web site, e-mail address or file).

2. Hyperlinks Tasks
1. Inserting a Hyperlink
A. Inserting a Hyperlink to a Web Address
To insert a hyperlink to a web address:
1. Place the insertion point where you want to insert the hyperlink.
2. Do one of the following:
• Choose Insert > Hyperlink from the menu bar.
Or

•

Click the Hyperlink button (

) in the toolbar.

The Edit Hyperlink window is displayed.
3. Use the Hyperlink Type popup menu to choose Web.
4. Insert a Display Text, URL and Anchor (Anchor is optional). Refer to Edit Hyperlink Window
on page 392 for a complete description of the diﬀerent fields.
5. Click OK.
Tip: If you select any text before inserting a hyperlink, it is automatically used as the display
text.
Note: The Hyperlink button is not included in the toolbar by default. Refer to Customizing the
Toolbar on page 268 for more information.

B. Inserting a Hyperlink to an E-Mail address
To insert a hyperlink to an e-mail address:
1. Place the insertion point where you want to insert the hyperlink.
2. Do one of the following:
• Choose Insert > Hyperlink from the menu bar.
Or

•

Click the Hyperlink icon (
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) from the toolbar.

The Edit Hyperlink window is displayed.
3. Use the Hyperlink Type popup menu to choose Email.
4. Insert a Display Text, Address and Subject (Subject is optional). Refer to Edit Hyperlink
Window on page 392 for a complete description of the diﬀerent fields.
5. Click OK.
Tip: If you select any text before inserting a hyperlink, it is automatically used as the display
text.
Note: The Hyperlink icon is not included in the toolbar by default. Refer to Customizing the
Toolbar on page 268 for more information.

C. Inserting a Hyperlink to a File
To insert a hyperlink to a file:
1. Place the insertion point where you want to insert the hyperlink.
2. Do one of the following:
• Choose Insert > Hyperlink from the menu bar.
Or

•

Click the Hyperlink icon (

) from the toolbar.

The Edit Hyperlink window is displayed.
3. Use the Hyperlink Type popup menu to choose File.
4. Insert a Display Text.
5. Click the Browse button.
6. Locate and select the file you wish to link to.
7. Click Open.
8. Click OK.
Tip: If you select any text before inserting a hyperlink, it is automatically used as the display
text.
Note: The Hyperlink icon is not included in the toolbar by default. Refer to Customizing the
Toolbar on page 268 for more information.

2. Editing a Hyperlink
To edit a hyperlink, Do one of the following:
• Double click the hyperlink you wish to edit.
Or

• Right click the hyperlink you wish to edit and choose Edit hyperlink.
The Edit Hyperlink window is displayed.

A. Editing the Display Text for a Hyperlink
If you wish to edit the display text, hold down the Option key and click the hyperlink you wish
to edit.
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3. Using Hyperlinks
A. Navigating to a Hyperlink
To navigate to an existing hyperlink, click it.

B. Viewing a Hyperlink Path
To display the path for any type of hyperlink, hover with the cursor over it until a tooltip
appears, showing the hyperlink path.

4. Adjusting Hyperlinks Display
A. Displaying Hyperlinks as Regular Text
By default, hyperlinks are displayed in blue and underlined. The colour is customizable, as
detailed in Changing Hyperlinks Colour below.
However, you can set individual hyperlinks to be displayed as regular text in your document by
doing the following:
1. Edit the hyperlink you wish to display as re gular text as detailed in Editing a Hyperlink on
page 104.
2. Uncheck the Display as link checkbox.

B. Changing Hyperlinks Colour
By default, hyperlinks are displayed in blue and underlined. To change the display colour:
1. Choose Mellel > Preferences from the menu bar.
2. Click the General tab.
3. Use the Hyperlink colour popup menu to choose Custom.
4. Use the Colour well (

) to open the Colour window and set the desired colour (refer

to Colour Window on page 281 for step-by-step instructions).

5. Importing Hyperlinks
When pasting text with hyperlinks from an external source, Mellel automatically maintains the
hyperlinks functionality.
Note: Plain text that includes elements that look like links (e.g. mailto:frome@to.yuo) is not
treated as hyperlinks but rather imported as plain text.

6. Exporting Hyperlinks
When exporting Mellel documents to PDF, RTF or Word format, hyperlinks are exported with
the text and will maintain their functionality in the exported document. Refer to Exporting
Files on page 26 for step-by-step instructions.
When exporting text with links to plain text files, you can determine how will hyperlinks be
handled, as detailed in Exporting as Plain Text on page 26.
Note: Links in exported PDF documents will work in Acrobat Viewer, but not in the macOS
Preview application.
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9. Line Numbering
1. What is Line Numbering?
Line numbering is a Mellel feature that automatically numbers document elements (either
lines or paragraphs). It is used in specific types of documents such as legal papers, transcripts,
interviews and others. Various line numbering styling and structural preferences can be
adjusted to meet the diﬀerent use cases. Line numbers are displayed outside of the page
margin without aﬀecting the document layout.
Line numbers are part of the section style, which means that diﬀerent sections in the
document can have diﬀerent preferences regarding the format and style of their line
numbering.

2. Line Numbering Tasks
1. Activating Line Numbering
Perform any of the following to activate line numbering in the current section:
• Using the Section palette:
1. Place the insertion point within the section for which you want to activate line
numbering.
2. In the Section palette click the Attributes tab.
3. Use the Line Numbering popup menu to choose either Restart with Page, Restart
with Section or Continuous. Refer to Line Numbers Window on page 394 for a
complete description of the diﬀerent options.
• Using the Style Sets window:
1. Choose Styles > Edit style sets from the menu bar.
2. Click the Section tab.
3. Select the section style for which you want to activate line numbering.
4. Click the Edit Style button (

•

).

5. Use the Line Numbering popup menu to choose either Restart with Page, Restart
with Section or Continuous. Refer to Line Numbers Window on page 394 for a
complete description of the diﬀerent options.
6. Click Save to save changes to the edited style.
7. Click Save to save changes to the edited style set.
Using the Line Numbers window:
1. Place the insertion point within the section for which you want to edit line numbering.
2. In the Section palette click the Attributes tab.
3. Use the Line Numbering popup menu to choose Edit Attributes.
4. Use the Line Numbers popup menu to choose either Restart with Page, Restart with
Section or Continuous. Refer to Line Numbers Window on page 394 for a complete
description of the diﬀerent options.
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Note: Repeat any of the methods described above to deactivate line numbering.

2. Editing Line Numbering Attributes
Line Numbering attributes are edited using the Line Numbers window (refer to Line Numbers
Window on page 394 for a complete description of the window and its functionalities). Do one
of the following to open the Line Numbers window:
• Using the Section palette:
1. Place the insertion point within the section for which you want to edit line numbering.
2. In the Section palette click the Attributes tab.
3. Use the Line Numbering popup menu to choose Edit Attributes.
• Using the Style Sets window:
1. Choose Styles > Edit style sets from the menu bar.
2. Click the Section tab.
3. Select the section style for which you want to activate line numbering.
4. Click the Edit Style button (

).

5. Use the Line Numbering popup menu to choose Edit Attributes.

A. Configuring Numbering Options
After activating line numbering, you can configure various numbering options, including the
initial number, the increment and the type of numbers sequence to use. To configure these
options:
1. Activate line numbering using any of the methods described in Activating Line Numbering
on page 106.
2. Open the Line Numbers window using any of the methods described in Editing Line
Numbering Attributes above.
3. Use the Start at and Increment text boxes and the Type popup menu to configure the
desired options. Refer to Line Numbers Window on page 394 for a complete description of
the diﬀerent options.

B. Setting Character Attributes
To set the line numbers character attributes:
1. Activate line numbering using any of the methods described in Activating Line Numbering
on page 106.
2. Open the Line Numbers window using any of the methods described in Editing Line
Numbering Attributes above.
3. Use the Character Attributes button (

) to apply any desired character attributes to the

line numbers. Refer to Character Formatting on page 157 for a complete description of the
diﬀerent attributes.
The Character attributes area displays the current attributes and a preview of the line numbers, as shown in the following figure:
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Figure 4-36: Line Numbers Character Attributes

C. Selecting What to Count
By default Mellel counts lines when the line numbering feature is activated. To select the
counted element:
1. Activate line numbering using any of the methods described in Activating Line Numbering
on page 106.
2. Open the Line Numbers window using any of the methods described in Editing Line
Numbering Attributes on page 107.
3. Use the Count popup menu to choose either Lines or Paragraphs.

D. Changing Display Frequency
By default Mellel displays numbers for every counted line/paragraph. To change the display
frequency:
1. Activate line numbering using any of the methods described in Activating Line Numbering
on page 106.
2. Open the Line Numbers window using any of the methods described in Editing Line
Numbering Attributes on page 107.
3. Use the Display every text box to enter the desired value for display frequency.

E. Numbering First and Last Lines
When a display frequency diﬀerent than every one line/paragraph is selected, you can
configure Mellel to always number the first and/or last lines, regardless of the frequency
setting. To always number first and/or last lines:
1. Activate line numbering using any of the methods described in Activating Line Numbering
on page 106.
2. Open the Line Numbers window using any of the methods described in Editing Line
Numbering Attributes on page 107.
3. Enter the desired value (diﬀerent than one) in the Display every text box.
4. Check the Always display for first line and/or Always display for last line checkboxes to enable
the desired configuration.

F. Only Counting Numbered Lines
When a display frequency diﬀerent than every one line/paragraph is selected, you can
configure Mellel to only count the numbered Lines/Paragraphs by doing the following:
1. Activate line numbering using any of the methods described in Activating Line Numbering
on page 106.
2. Open the Line Numbers window using any of the methods described in Editing Line
Numbering Attributes on page 107.
3. Enter the desired value (diﬀerent than one) in the Display every text box.
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4. Check the Only count numbered lines checkbox.

G. Ignoring Empty Lines
By default, Mellel ignores empty lines when numbering lines. To change this setting:
1. Activate line numbering using any of the methods described in Activating Line Numbering
on page 106.
2. Open the Line Numbers window using any of the methods described in Editing Line
Numbering Attributes on page 107.
3. Uncheck the Ignore empty lines checkbox.

H. Setting Numbers Position
To set the line numbers position:
1. Activate line numbering using any of the methods described in Activating Line Numbering
on page 106.
2. Open the Line Numbers window using any of the methods described in Editing Line
Numbering Attributes on page 107.
3. Under the Position area configure the desired position using any of the following tools
(refer to Line Numbers Window on page 394 for a complete description of the diﬀerent
options):
• Use the Relative to Text popup menu to determine the line numbers position relative to
the document text.
• Use the Distance from text text box to determine the distance between the line
numbers and the document text.
• Use the Alignment popup menu to determine the alignment of line numbers within the
page margins.
Note: The line numbers position settings are independent of the separator position settings,
and the two can overlap.

I. Formatting the Separating Line
By default line numbers appear next to the text without a separating line. To add and format a
separating line:
1. Activate line numbering using any of the methods described in Activating Line Numbering
on page 106.
2. Open the Line Numbers window using any of the methods described in Editing Line
Numbering Attributes on page 107.
3. Under the Separator area configure the separating line using any of the following tools
(refer to Line Numbers Window on page 394 for a complete description of the diﬀerent
options):
• Use the Line type popup menu to set the separator line type.
• Use the Weight popup menu to set the separator line weight (width).

•

Use the Colour well (

•

colour.
Use the Distance from line text box to set the distance between the separator line and
the document text.
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) to open the Colour window and set the separator line

Note: The separator position settings are independent of the line numbers position settings,
and the two can overlap.

J. Setting the Numbering Channel
Mellel can be configured to use up to ten (10) diﬀerent numbering channels, which enable

managing several numbering streams in the same document. This is useful when users need
to number lines in diﬀerent parts of the document separately. For example, numbering the
main body text in one stream while numbering quotes in another. Diﬀerent numbering
streams can be formatted diﬀerently.
To associate a line numbering with a specific numbering channel:
1. Activate line numbering using any of the methods described in Activating Line Numbering
on page 106.
2. Open the Line Numbers window using any of the methods described in Editing Line
Numbering Attributes on page 107.
3. Use the Numbering channel popup menu to choose the desired channel.
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10. Breaks
1. What are Breaks?
Breaks are structural document elements that separate between other elements in the
document. These include paragraph breaks (return), section breaks, page breaks and more.
While the most common break is the paragraph break (inserted using the Return key), other
types of breaks are used to delimiting style and attribute application, enabling you to apply
diﬀerent attributes to diﬀerent parts of the documents that are separated by breaks.

2. Inserting a Break
To insert a break into your document:
1. Place the insertion point where you want to insert the break.
2. Choose Insert > Breaks from the menu bar.
3. Choose the desired break from the Breaks submenu (refer to Breaks Sub-Menu on page
319 for a complete description of the diﬀerent options):

Figure 4-37: Breaks Submenu
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11. Cross References
1. What are Cross References?
Cross references are document elements that point to a diﬀerent element in the same
document. For example, a cross reference can point to a diﬀerent page in the document (e.g.
“see page 13”), to a footnote (e.g. “see note 2 on page 13”) or to a specific heading (e.g. “see
heading 3.1: The Hobbit”), among others.
In Mellel, every cross reference is dynamically linked to its target. This means that if anything
changes in the target, the cross reference is automatically and immediately updated. For
example, if a reference points to a heading on page 13 (i.e. “see Heading 3.1: The Hobbit on
page 13”), and some text is added so that the heading is now on page 17, Mellel automatically
updates the reference accordingly (“see Heading 3.1: The Hobbit on page 17”).
This automatic and dynamic management of references enables you to add a reference once
without worrying about having to update it whenever something changes in the document.
There are three types of document elements that can be used as cross reference targets:
• Bookmarks: Invisible markers added to the text so that cross references can use them as
targets.
• Potential Targets: Elements that are automatically marked as potential targets when they
are created. This includes Auto-titles and images.
• Virtual Targets: Targets that do not exist in the text when the reference is created. For
example, you can create a reference to a chapter that hasn't been written yet, and point it to
a virtual target. When that chapter is eventually written, you link it to the virtual target and
the reference will be updated automatically. Refer to Managing Virtual Targets on page 116
for more information.
You can format references using dynamic context-sensitive fields, using diﬀerent elements of
the reference target in the reference itself. For example, you can include the target title, title
number, page, page range and more. These options tools are detailed in the following subsections.

2. Cross References Tasks
1. Managing Bookmarks
Bookmarks are invisible markers added to the text so that cross references can use them as
targets. They are also displayed in the outline and can be used as bookmarks for organizing
and locating content in the document.

A. Inserting a Bookmark
To insert a new bookmark:
1. Place the insertion point where you want to enter the bookmark.
2. Do one of the following:
• Choose Insert > Cross Reference > Insert Bookmark from the menu bar.
Or
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•

Click the Insert Bookmark button (

) in the Reference palette.

The Edit Bookmark popover is displayed:

Figure 4-38: The Edit Bookmark Popover
3. Use the Target ID text box to enter an ID for your bookmark.
4. Use the Assign Virtual Target popup menu to assign this bookmark to an existing Virtual
Target (optional). Refer to Assigning a Virtual Target on page 117 for more information.
5. Enter a remark regarding this bookmark in the Remarks text box (optional). These remarks
can be displayed in the Outline pane. Refer to Changing the Outline Pane Layout on page
145
6. Add tags to this bookmark by typing them into the Tags text box and pressing the Return
key (optional). Bookmarks can be filtered by their tags in the Outline pane and in the
reference dialogue-box when creating a new reference. Refer to Filtering Outline Items on
page 144 for more information.
Note: You can add multiple tags to a single bookmark.
8. Choose a Marker to highlight this bookmark in the Outline pane (optional). Bookmarks can
be filtered by their markers in the Outline pane and in the reference dialogue-box when
creating a new reference. Refer to Filtering Outline Items on page 144 for more
information.
9. Click anywhere outside the popover to complete the creation process.
The new bookmarks is added, and a blue marker is added to indicate its exact location in the
text, as shown in the following figure:
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Figure 4-39: Bookmark Marker
Note: The marker is only visible when you edit your document in Mellel. It will not appear in
any printed or exported versions.

B. Editing a Bookmark

To edit an existing bookmark:
• Right-click its blue marker (see Figure 4-39 above) and

choose Edit Bookmark.
Or

• Double-click its blue marker (see Figure 4-39 above).
•

Or
Double-click it in the Outline pane.

C. Deleting a Bookmark
To delete an existing bookmark, click the Delete button (

) in the Edit Bookmark popover.

D. Navigating form a Bookmark to its Reference
To navigate from a bookmark to its reference:
• Right-click the target and choose Jump to Reference.
Or
• Double-click the target while pressing the Option key.
Note: After choosing Jump to Reference, Mellel navigates to the first reference to the selected
bookmark. When there are multiple references pointing to the same bookmark, you can cycle
between them by performing one of the following:
• Holding down the Cmd key while double-clicking one of the references.
Or
• Right-clicking one of the references and choosing Jump to next Reference to this Target.

2. Inserting a Cross Reference
To insert a new cross reference:
1. Place the insertion point where you want to enter the cross reference.
2. Do one of the following:
• Choose Insert > Cross Reference > Insert Reference from the menu bar.
Cross References | 114

Or

•

Click the Insert Reference button (

) in the Reference palette.

The Edit Reference window is displayed:

Figure 4-40: Edit Reference Window
2. Choose the type of reference from the Reference type list (refer to Edit Reference Window
on page 400 for a complete description of the diﬀerent types).
3. Choose the target from the list in the center of the window (the list title changes based on
the selected reference type. Refer to Edit Reference Window on page 400 for a complete
description of the diﬀerent options).
Tip: You can use the filter toolbar to filter the displayed targets. Refer to Edit Reference
Window on page 400 for a complete description of the diﬀerent filtering options.
4. Use the format area to format the reference (refer to Edit Reference Window on page 400
for a complete description of the diﬀerent formatting options).
5. Click OK.

3. Highlighting References
By default, references are highlighted by a yellow background to distinguish them from other
document elements. This background is only displayed in the document area and will not
appear in print or when exporting the document.
To change this setting Do one of the following:
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•

Using the toolbar:
1. Click the Show button (

•

) in the toolbar.

2. Uncheck References.
Using the menu bar:
1. Choose View > Show Hidden > References from the menu bar.

4. Managing Virtual Targets
Often when writing long and complex documents, it is required to insert a reference to a
target that hadn't been created yet. To meet this requirement, Mellel implements the concept
of Virtual Targets. A virtual target is a target that does not exist in the document but can be
used as a target for cross references. When a virtual target is later assigned to an existing
document element, all the references that were pointing at the virtual target will now point at
that document element.
For example, consider an operation manual with a safety regulations appendix, which is the
last part to be written. You may need to create references to this appendix while writing all the
other chapters, but it does not exist yet. To solve this, create a virtual target and point all those
cross references to it. When you complete writing the safety appendix, assign its heading to
the virtual target you used. All the cross references that were pointing at the virtual target will
now point to the linked heading.

A. Creating a Reference to a New Virtual Target
Creating a reference to a new virtual target is similar to creating a regular reference. The only
diﬀerence is that instead of pointing to an existing target in the document, the reference is
configured to point to a virtual target that is created as part of the reference creation process.
To create a reference to a new virtual target:
1. Do one of the following:
• Choose Insert > Cross Reference > Insert Reference from the menu bar.
Or

•

Click the Insert Reference button (

) in the Reference palette.

2. Choose Virtual Target from the Reference type list.
3. Enter an ID for your virtual target in the Virtual target ID text box.
4. Use the format area to format the reference (refer to Edit Reference Window on page 400
for a complete description of the diﬀerent formatting options).
5. Click OK.

B. Creating a Reference to an Existing Virtual Target
To create a reference to an existing virtual target:
1. Do one of the following:
• Choose Insert > Cross Reference > Insert Reference from the menu bar.
Or

•

Click the Insert Reference button (

) from the Reference palette.

2. Choose Existing Targets from the Reference type list.
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3. Choose the desired virtual target from the Existing targets list.
4. Use the format area to format the reference (refer to Edit Reference Window on page 400
for a complete description of the diﬀerent formatting options).
5. Click OK.
Note: Virtual targets are indicated by a unique icon (

).

C. Assigning a Virtual Target
Virtual targets are used to enable creating references to document elements that do not exist
yet. When those elements are eventually created, you must assign the correct virtual target to
them, so that all the references that were pointing to the virtual target are updated and point
to the correct document element.
To assign a virtual target to diﬀerent elements:
• Auto-Title:
1. Edit the Auto-title (refer to Editing an Auto-Title on page 47 for step-by-step
instructions).
2. Use the Assign Virtual Target popup menu to choose the virtual target you wish to
assign to this Auto-title.
3. Click OK.
All the references that were pointing to the selected virtual target will now point to
the edited Auto-title.
• Image:
1. Edit the Image (refer to Editing Image Attributes on page 94 for step-by-step
instructions).
2. Use the Assign Virtual Target popup menu to choose the virtual target you wish to
assign to this image.
3. Click OK.
All the references that were pointing to the selected virtual target will now point to
the edited image.
• Bookmark:
1. Edit the bookmark (refer to Editing a Bookmark on page 114 for step-by-step
instructions).
2. Use the Assign Virtual Target popup menu to choose the virtual target you wish to
assign to this bookmark.
3. Click OK.
All the references that were pointing to the selected virtual target will now point to
the edited bookmark.

D. Navigating between References to Virtual Targets
You can navigate between all the references to virtual targets in your document by doing the
following:
1. Open the Reference palette.
2. Choose Virtual targets using the Browse References radio button.
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3. Use the Previous Reference (

) and Next Reference (

) buttons to navigate

between all the virtual targets in the document.

5. Editing a Reference
Double-click any reference to open the Edit Reference window and edit it.

6. Formatting a Reference
The bottom part of the Edit Reference window is used to format the appearance of the
reference. You can freely manipulate the references appearance in the document by adding
static text elements or dynamic context based elements, and apply diﬀerent character styles
to the reference.
To format and style the reference:
1. Double-click the reference you wish to edit.
The Edit Reference window is displayed.
2. Use the Elements popup menu to enter dynamic elements into the reference. These
elements are automatically updated based on the reference target. Refer to Edit Reference
Window on page 400 for a complete description of the diﬀerent elements available.
3. Use the text box to add static text elements to the reference.
4. Use the Character palette to style the reference appearance. Refer to Character Formatting
on page 157 for more information on available character attributes.
5. Click OK to apply changes.
Note: In addition to the regular document styles, you can choose the <use surrounding>
option from the Character palette Styles tab to automatically match the reference character
style to its surrounding text.
Tip: You can use the Direction button (

) to change the format area direction. The button's

purpose is to assist you when editing the reference appearance. It does not aﬀect the direction
of the reference in the actual document.

A. Using an Existing Reference Format
Frequently used reference formats can be saved to avoid creating them from scratch every
time you enter a reference. In addition, Mellel is shipped with several common reference
formats. This can save you time by using existing formats instead of creating new ones.
To use an existing reference format:
1. Double-click the reference you wish to format to edit it.
2. Use the Reference formats popup menu to choose the desired saved format.
3. Click OK to apply changes.

B. Saving a Reference Format
Frequently used reference formats can be saved to avoid creating them from scratch every
time you enter a reference. To save a reference format:
1. Double-click a reference to edit it.
2. Perform any required changes to the format, as detailed in Formatting a Reference above.
Cross References | 118

3. Choose Save Format from the Reference formats popup menu.
4. Enter a name for the format.
5. Click OK.
The new format is now available for selection in the Reference formats popup menu.

C. Setting the Default Reference Format
To set the default format for new references:
1. Choose Mellel > Preferences from the menu bar.
2. Click the General tab.
3. Use the Default reference format popup menu to set the default format.
The selected format will be applied to all new references added to the document.

7. Navigating References
A. Navigating between References
You can navigate between all the references in your document by doing the following:
1. Open the Reference palette.
2. Choose All using the Browse References radio button.
3. Use the Previous Reference (

) and Next Reference (

) buttons to navigate

between all the references in the document.

B. Navigating from a Reference to its Target
To navigate from a reference to its target, Do one of the following instructions:
• Right-click on the reference and choose Jump to Target.
Or
• Hold the Option key while double-clicking a reference.

C. Navigating from a Target to its Reference
To navigate from a target to its reference, right-click the target and choose Jump to
Reference.
Note: After choosing Jump to Reference, Mellel navigates to the first reference to the selected
target. If there are multiple references pointing to the same target, you can cycle between
them by performing one of the following:
• Holding down the Cmd key while double-clicking one of the references.
Or
• Right-clicking one of the references and choosing Jump to next Reference to this Target.

8. Broken References
References can break if the document element they are pointing to is removed from the
document. Mellel treats broken references as a virtual target, and they must be manually fixed.
Refer to Navigating between References to Virtual Targets on page 117 for step-by-step
instructions for locating virtual targets.
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9. Locating Ambiguous References
Ambiguous references are created in very rare cases when rendering the reference in one way
would change the document layout in a way that makes the rendering invalid, which creates
an infinite loop that must be resolved manually (for example by adding lines to the document
or moving the location of the reference in relation to its target).
To assist in locating and fixing ambiguous references, you can navigate between them by
doing the following:
1. Open the Reference palette.
2. Choose Ambiguous using the Browse References radio button.
3. Use the Previous Reference (

) and Next Reference (

) buttons to navigate

between all the ambiguous references in the document.

10. Exporting Cross References
When exporting a Mellel document with cross references to a diﬀerent application, references
to images, Auto-titles, notes or segments of the text will be exported correctly, pointing to the
correct document location. However, references to page numbers must be manually
inspected after the export is completed to assure their behavior is consistent.
Cross references are exported as hot links when documents are exported to PDF files. Clicking
the references in the exported PDF will scroll to the reference target.
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12. Table of Contents
1. What is a Table of Contents?
A Table of Contents (TOC) is a list of the chapters, sub-chapters, headings, images, tables and
any other document element that was configured to be included in the TOC. TOC items are
sorted by their order of appearance in the document, and they may be categorized and
include the page number in which they appear.
In Mellel, the TOC is based on Auto-titles that were added to the document and configured to
appear in the TOC. The Auto-Titles Flows Setup window (refer to Auto-Titles Flows Setup
Window on page 370 for a complete description of the window and its functionalities) is used
to determine what Auto-titles would appear in the TOC, and how will they be formatted and
styled.

2. Table of Contents Tasks
1. Inserting a Table of Contents

To insert a TOC into your document, Place the insertion point
where you want to insert the TOC and choose Insert > Table of
Contents from the menu bar.
The table of content is added based on the settings in the
Auto-Titles Flows Setup window. In addition, a Page
Style Break is automatically added after the table of
contents (refer to Breaks on page 111 for more information
about break types).
The table of contents is added as plain text to the document. Once it has been inserted, you
can edit it just like any other text element in your document.
Note: When a Mellel document with a TOC is exported as a PDF, all the TOC items are exported
as live links, i.e. clicking them would navigate to the corresponding element.
Note: As the TOC is inserted as a regular text element to the document, any changes made
after it had been inserted are not reflected (for example new Auto-titles will not be added and
any changes in page numbers will not be applied in the TOC). You must regenerate the TOC to
reflect any changes.
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2. Updating a Table of Contents
Since adding a TOC in Mellel is simple and quick, there is no need to update the existing table
of contents. Rather, you need only to remove the existing TOC and insert a new one.

3. Configuring an Auto-Title Flow to be Included in the TOC
The Auto-Titles Flows Setup window is used to determine what flows are included in the TOC. To
include/exclude a flow from the TOC:
1. Do one of the following to open the Auto-Titles Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Choose the desired Auto-title level from the Title Flows list.
3. Use the Include in TOC checkbox to determine whether the selected level will be included
in generated TOCs.
4. Click OK to apply changes.
Note: TOCs in Mellel are not dynamic. Thus, changes made will only apply to TOCs created after
the changes are made.

4. Configuring the Format of Auto-Titles in the TOC
While diﬀerent Auto-title flows are usually formatted diﬀerently in the document, in the TOC it
is usually preferred to have a consistent format and style. To apply a specific format for an
Auto-titles flow in the TOC:
1. Do one of the following to open the Auto-Titles Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2.
3.
4.
5.

Choose the desired Auto-title level from the Title Flows list.
Click the TOC format tab.
Check the Use a diﬀerent format for table of contents checkbox.
Use the format area to format how will Auto-titles from the selected flow be displayed in
the TOC. Refer to Auto-Titles Flow Setup Window on page 55 for step-by-step instructions.
6. Click OK to apply changes.
Tip: A commonly used format for a TOC is to have leading dots between the title name and the
page number. To create this format in Mellel:
1. Do one of the following to open the Auto-Titles Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•

In the Auto-Title palette, click the Edit title flows (

) button.

2. Perform the following for each Auto-title level that appears in the TOC:
• Click the TOC format tab.
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•
•
•
•
•
•
•

Check the Use a diﬀerent format for table of contents checkbox.
Choose Tab from the Elements popup menu.
Drag a tab from the Tab Well into the Ruler.
Click the dragged tab.
Open the Paragraph palette.
Click the Attributes tab.
Choose Dot from the Lead popup menu.

5. Using Separate TOC Sections for Tag Flows
Tag flows are customized flows that you can add to your document (refer to Flow Types on
page 46 for more information). These tag flows can appear as separate sections in the TOC.
This enables, for example, to have a separate TOC for the chapters (structural flow) and the
figures (tag flow) in your document.
Perform the following instructions to use separate TOC sections for tag flows:
1. Do one of the following to open the Auto-Titles Flows Setup window:
• Choose Insert > Auto-Title > Edit title flows from the menu bar.
Or

•
2.
3.
4.
5.

In the Auto-Title palette, click the Edit title flows (

) button.

Choose the desired tag flow from the Title Flows list (tag flows appear in blue).
Check the Include in TOC checkbox.
Check the List as separate section in TOC checkbox.
Click OK to apply changes.
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13. Variables
1. What are Variables?
Variables are dynamic document elements that change their content based on document
characteristics and/or set preferences. There are two types of variables in Mellel:
• Page Variables: These include the current page number and the total number of pages in
the document. These dynamic elements are updated based on the document layout, and are
commonly used in headers and footers to indicate the current page and the total number of
pages (e.g. page 94 out of 370).
• Document Variables: These are a set of 20 label-value pairs that can be inserted into the
document. Variables are dynamic. That is, you can update their value in one place, and by
doing so update them wherever they are being used in the document.
For example, you can have a variable titled Author. This variable will be used to enter the
name of the author in diﬀerent places in the document, possibly as part of a document template. Whenever a new document is created out of this template, all you have to do is
change the value of the variable, and all of its appearances will be automatically updated to
the new value.
As mentioned above, each variable comprises two parts:

• Label: This it the name of the variable, e.g. how it is being referred to by Mellel. In our
•

example, the variable label is Author.
Value: This is the content of the variable. Values are defined per document. In our example,
the value of the Author variable can be John Smith, Rotem Sella, or any other author name.
When a variable is inserted into the document, it is its value that appears in the text.

2. Variables Tasks
1. Inserting a Page Variable
To insert a page variable into your document:
1. Place the insertion point where you want to insert the variable.
2. Choose Insert > Page Variables from the menu bar.
3. Choose the desired variable from the variables list:
• Page Number: Dynamically displays the page where the variable is located.
• Total Number of Pages: Dynamically displays the total number of pages in the
document.

2. Inserting a Document Variable
To insert a document variable into your document:
1. Place the insertion point where you want to enter the variable.
2. Choose Insert > Document Variables from the menu bar.
3. Choose the desired variable from the variables list.
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The variable is inserted into the document. You can now apply it with any character and
paragraph attributes, just like any other text. The only diﬀerence is that if the variable's value is
ever changed, the text would be automatically updated accordingly.

3. Renaming Document Variables
Variable Labels are the names of the diﬀerent variables and are shared across all documents. To
rename document variables by changing their labels:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Document Setup tab.
3. In the Document Variables area, double click on the variable label you wish to change.
4. Enter a new label for the variable.
5. Click anywhere outside the label name to apply the change.

4. Changing Document Variables Values
Variable values are the content of the variable, and the part that appears in the document
when you insert a document variable. Values are document-specific. To change the value of
document variables in the current document:
1. Choose Mellel > File > Document Setup from the menu bar.
2. In the Document Variables area, double-click on the value you wish to change.
3. Enter a new value for the variable.
4. Click anywhere outside the value name to apply the change.
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14. Date and Time Stamps
1. What are Date and Time Stamps?
Date and time stamps are dynamic document elements that are entered into the document
and are dynamically updated to insert one of three possible date and time stamps:
• Document Creation Date: Inserts the date or time when the document was first created.
This text is static and will never be updated.
• Document Opening Date: Inserts the date or time when the document was last opened.
This stamp will automatically update whenever the document is opened.
• Current Date: Inserts a text string with the date or time of entry. This text is static and will
never be updated.
You can configure the date and time stamps to appear in one of three possible formats:
• Long Date.
• Short Date.
• Time.
Note: The specific layout of the diﬀerent formats depend on your macOS formats settings
under System Preferences > Language and Text > Formats.

2. Date and Time Stamp Tasks
1. Inserting a Date and Time Stamp
To enter a date and time stamp:
1. Place the insertion point where you want to insert the stamp.
2. Choose Insert > Date from the menu bar.
The Insert Date and Time Stamp dialogue-box is displayed:
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Figure 4-41: Insert Date and Time Stamp dialogue-box
3. Use the Type radio button to choose the stamp type (refer to What are Date and Time
Stamps? on page 126 for a complete description of the diﬀerent options).
4. Use the Format popup menu to choose the stamp format (refer to What are Date and Time
Stamps? on page 126 for a complete description of the diﬀerent options).
5. Click Insert.
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15. Bibliography
1. What is a Bibliography?
The bibliography feature in Mellel enables you to incorporate references (citations) to books,
articles, essays, etc. stored in a reference database application. You can manage your citations,
create a bibliography of cited references, search for references, style the citations and the
bibliography, and more.
Mellel can work with any reference application, but integrates best with two prominent
reference managers: Bookends from Sonny Software (http://www.sonnysoftware.com) and
Sente from Third Street Software (http://www.thirdstreetsoftware.com/). It is highly
recommended to work with Bookends, as it is the only application that supports the powerful
Live Bibliography feature (refer to Live Bibliography on page 129 for more information).
Creating a bibliography involves three steps:
1. Creating the references in your reference manager. This step is performed externally to
Mellel and is not described in this manual.
2. Inserting citations into the document (either as a temporary citation or in its final format),.
3. Converting the citations to their final format and generating the bibliography. This step is
referred to as Scanning the document.

1. Inserting Citations
Citations in Mellel are Dynamic Objects. That is, they change dynamically—both in content and
appearance—depending on their status (temporary or final), and their verification (verified
versus unverified).
The following tables detail the appearance of citations in the text depending on their status,
verification and reference manager:
Table 4-10: Bookends Citation Appearance
Citation

Status
Temporary citation
Final-form citation
Temporary citation, unverified
Final-form citation, unverified

Table 4-11: Sente Citations Appearance
Citation

Status
Temporary citation
Final-form citation
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Final-form citation, unverified

From a styling point of view, citations in Mellel behave like normal text in a document, and you
can style them by either using attributes or applying styles.
You may choose to verify your citations. When you enter a citation via a reference manager, it is
automatically verified. However, when you change the content of a citation, or when you enter
a citation manually, the reference manager cannot tell if the citation is still valid—that is, if it
can still be mapped to a reference in the reference database. This is when verification is
needed.

2. Scanning the Document
Once all the citations are right where they should be, you can convert them into their final
format and generate the bibliography by scanning the document. This includes the following
steps:
• Setting Citations Format: In this step you determine the format the citations will be
converted to, usually by selecting a specific set of formatting guidelines (e.g. Chicago, APA 6,
etc.) in your reference manager.
• Producing Final Manuscript: Now that you have verified and set the formatting for your
manuscript, it’s time to scan it. That is, to produce the final manuscript with the bibliography.
The result of the scan process will be a document with citations in their final format, and a
bibliography located at the end of the document.
Note: Scanning is not required if Live Bibliography is turned on.

Figure 4-42: Example Bibliography
Note: The bibliography section has a grey gradient line to its left (or to its right, with text that
runs from right to left). This line will not be printed or displayed in a PDF. Its sole purpose is to
mark where the bibliography is.

3. Live Bibliography
The Live Bibliography feature automatically updates your citations and bibliography in realtime as you add and edit citations in your document. Whenever you enter a citation, Mellel will
automatically verify it, update the citation to its final format and add the appropriate item to
the bibliography.
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When Live Bibliography is enabled, the reference manager will prompt you to select a reference
format and resolve any ambiguous citations.
Note: Live Bibliography is only available when using Bookends as a reference manager.

2. Bibliography Tasks
1. Bibliography Preferences
A. Selecting a Bibliography Application
To select the Bibliography application:
1. Choose Mellel > Preferences from the menu bar.
2. Click the General tab.
3. Use the Bibliography Application popup menu to choose either Bookends or Sente.

B. Activating Live Bibliography
To enable Live Bibliography:
1. Click the Bibliography palette.
2. Check the Live Bibliography checkbox.
Note: Live Bibliography is only available when using Bookends as a reference manager.

C. Synchronizing the Database
The Synchronize Database feature loads all the citations from the document into the selected
reference manager database, checks if they already exist there, and removes any ambiguities.
This is useful, for example, when you receive a document containing citations that do not exist
in your reference database. Synchronization will add those missing references to your
reference database. This option is also handy for moving citations and references around with
the document, serving as a mobile library of sorts.
To synchronize the document with the reference database, choose Edit > Bibliography >
Synchronize Database from the menu bar.
Note: Synchronizing the database is only available when using Bookends as a reference
manager.

2. Managing Citations
A. Inserting Citations Using a Reference Manager
To enter a citation from a reference manager:
1. Launch your reference manager.
2. Switch to Mellel.
3. Place the insertion point where you want to insert the reference.
4. Do one of the following to switch to the reference manager:

•

Click the Switch to reference database button (

) in the Bibliography palette.

Or
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•

Choose Edit > Bibliography > Switch to Reference Data Base from the menu bar.
Or
• Press Cmd + Y.
Or
• Manually switch to the reference manager.
3. Do one of the following to insert a citation:
• Select the citation you wish to insert and click Cite (in Sente) or Copy Selected
Citations (in Bookends).
Or
• Select the citation you wish to insert and drag it into your Mellel document.
Or
• Copy the citation you wish to insert, switch to your Mellel document and paste it.
The citation will appear in Mellel in its temporary format, as shown in the following figure:

Figure 4-43: Citation Temporary Format
Tip: You can select multiple citations to insert them together.
Tip: If you select an existing citation prior to inserting a new one, the new citation would
replace the selected one.
Note: When you drag and drop or paste a citation from Bookends or Sente, it is automatically
converted into a Mellel citation object. When you drag and drop or copy a citation from any
other reference manager, it will be pasted as it was formatted in the reference manager.

B. Inserting Citations Manually
To manually insert a new citation:
1. Do one of the following to open the Edit Citation window:

•

Click the Enter citation manually button (

) from the Bibliography palette.

Or
• Choose Edit > Bibliography > Enter Citation Manually from the menu bar.
Or
• Press Cmd + Shift + M.
2. Enter the citation text in the Citation text box.
3. Click OK to insert the citation.
Tip: To insert multiple citations, enter them in sequence into the Citation text box separated
by semi-colons (;).
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C. Inserting a Non-Object Citation
Mellel’s citation object may not fit all your requirements, and you may need to manually enter a
citation that is not a citation object. Doing this is as simple as adding any text in Mellel. Mellel
can automatically convert manually entered citations delimited by specific characters to Mellel

citation objects (refer to Converting Text to Citations below for step-by-step instructions). The
one thing you will need to know is how to frame the citation—that is, what delimiting
characters you wish to have before and after the citation (e.g., curly ({ }) or square ([ ]) brackets
or tilde (~).

D. Converting Text to Citations
To convert text to citation objects:
1. Choose Edit > Bibliography > Convert Text to Citations from the menu bar.
2. Use the Citation Delimiter popup menu to choose the delimiter character used to frame the
citations in the text. The following options are available:

Figure 4-44: Available Citation Delimiter Options
Note: Converting text to citation objects does not remove the possibility of unmatched or
ambiguous citations. You may have to resolve such issues using your reference manager.

E. Reusing an Existing Citation
Citations that were inserted into the document appear in the citations list in the Bibliography
palette. To reuse an existing citation in a diﬀerent place in your document, Do one of the
following:
• Place the insertion point where you want to insert the citation, and double-click it in the
citations list in the Bibliography panel.
• Select the citation from the citations list in the Bibliography panel and drag and drop it into
the desired location in the document.
• Copy and paste the citation just like you would any other text.

F. Finding Citations in Your Document
To browse citations in the document perform a Find and Replace action (refer to Performing a
Find and Replace Action on page 211 for step-by-step instructions) and insert the Citation
element (
) using the Insert popup menu.

G. Finding all Occurrences of a Selected Citation
To find all the occurrences of an existing citation:
1. Place the insertion point where you want to start searching for the citation.
2. Double-click the desired citation in the Bibliography panel while holding the Cmd button.
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H. Opening the Reference Manager Search Window
To open the reference manager search window Do one of the following:

• Click the Find in reference database button (

) in the Bibliography palette.

Or
• Choose Edit > Bibliography > Find in Reference Database from the menu bar.
Or
• Press Cmd + Shift + Option + F.
Tip: Select any text in your document prior to opening the reference manager search window
to use it as the search string.

I. Editing a Citation
To edit a citation Do one of the following:
• Double-click it to edit it in the Edit Citation window.
Or
• Click it while holding the Option key to edit it in the document area.

J. Editing a Citation Reference in the Reference Manager
To edit a citation reference in the reference manager, double-click the citation while holding
the Option key.

K. Verifying Citations
To verify citations Do one of the following:

• Click the Verify citations button (

) in the Bibliography palette.

Or
• Choose Edit > Bibliography > Verify Citations from the menu bar.
Tip: When Live Bibliography is turned on, references verification status is indicated on the Verify
Citations button by either a black tick (
) when all references are verified or a red question
mark (

) when there are any unverified references in the document.

Note: Mellel will switch to the reference manager if it cannot verify a reference so that you can
resolve the issue.

L. Refreshing the Citation List
To refresh and update the citations list, click the Refresh citation list button (

) in the

Bibliography palette.

M. Formatting Citations Using Styles
By default, citations style matches their surrounding text. However, Mellel can be configured to
automatically map styles in the formatted citation into Mellel character styles. For example, you
can select a certain style that will be applied to all bold text in inserted references. This enables
consistent and automatic styling of your inserted citations.
To map citation styles:
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1. Click the Edit style mapping for Bibliography & Citations button (

) in the

Bibliography palette.
2. Click the Citations tab.
3. Check the Map Citation Styles checkbox.
4. Choose the desired Text in... element to map.
5. Use the Use Style... and Variation popup menu to choose the character style and variation
the selected Text in... element will be mapped into.
6. Click Save.
Note: These settings only aﬀect citations when they are converted to their final format, not
when they appear as temporary citations in the document.

N. Formatting Citations Using Attributes
By default, citations style matches to their surrounding text. To change the citations format
using attributes:
1. Edit the citation (refer to Editing a Citation on page 133 for step-by-step instructions).
2. Select the text you wish to format.
3. Apply any desired character attributes (refer to Styling Characters Using Attributes on
page 157 for step-by-step instructions).
Note: Formatting changes applied using attributes will be overwritten the next time the text
is scanned. When Live Bibliography is active, they will be overwritten immediately.

O. Highlighting Citations
To enable/disable highlighting citations in the text, choose View > Show Hidden > Citations
from the menu bar.
Note: Citations are only highlighted on screen, not in printed or exported versions of the
document.

P. Excluding a Citation form the Final Bibliography
To exclude a citation from appearing in the final bibliography, edit it (refer to Editing a Citation
on page 133 for step-by-step instructions) and Do one of the following:
• Check the Exclude from final document checkbox.
Or
• Enter an exclamation mark (!) at the beginning of the citation.
Note: When you enter an exclamation mark at the beginning of the citation, the next time you
open the Edit Citation window Mellel will automatically delete the exclamation mark and select
the Exclude from final document checkbox.

Q. Removing Enclosing Characters from Citations
To remove enclosing characters from the final format of citations, edit it (refer to Editing a
Citation on page 133 for step-by-step instructions) and Do one of the following:
• Check the Don't enclose formatted citation checkbox.
Or
• Enter a star (*) at the beginning of the citation.
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Note: When you enter a star at the beginning of the citation, the next time you open the Edit
Citation window Mellel will automatically delete the star and check the Don't enclose formatted
citation checkbox.

R. Suppressing Superscript in Citations
To prevent citation text from being superscripted, edit the citation (refer to Editing a Citation
on page 133 for step-by-step instructions) and Do one of the following:
• Check the Suppress Superscript checkbox.
Or
• Enter an underline (_) at the beginning of the citation.
Note: When you enter an underline at the beginning of the citation, the next time you open
the Edit Citation window Mellel will automatically delete the underline and check the Suppress
Superscript checkbox.

S. Removing Author Name from Citations
In some cases it is required to remove the author name and only use the date in a citation. For
example:

will look very cumbersome after scanning:

But if you add a percent character before the citation:

the text will look exactly right:

To remove the author name from a citation:
1. Edit the citation (refer to Editing a Citation on page 133 for step-by-step instructions).
2. Enter a percentage character (%) at the beginning of the citation.

T. Adding Page Numbers to a Citation
To manually add pages numbers to a citation:
1. Edit the citation (refer to Editing a Citation on page 133 for step-by-step instructions).
2. Enter an @ character at the end of the citation, followed by a page number or page range
(e.g. @30 or @30-38).
For example, the following addition to a citation:
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will produce the following output:

U. Adding Additional Information to a Citation
To manually add information to a citation:
1. Edit the citation (refer to Editing a Citation on page 133 for step-by-step instructions).
2. Enter the information anywhere within the citation, enclosed by slash characters (\).
For example, the following addition to a citation:

will produce the following output:

3. Generating the Final Manuscript
A. Scanning the Document
When scanning the document, Mellel collects all the temporary citations and sends them to
the reference manager. The latter then formats the citations and bibliography based on the
chosen format, and sends them back to Mellel which integrates them into the document.
To scan the document, convert citations to their final format and create a bibliography:

• Click the Scan Documents button (

) in the Bibliography palette.

Or
• Choose Edit > Bibliography > Scan Document from the menu bar.
The reference manager will now let you choose a format for the bibliography and citations for
the final manuscript.
Note: If Live Bibliography is turned on (only available with Mellel and Bookends) Scan and
Unscan will not be available, as they are not required.
Note: If you’ve added citations or changed citations, you will need to scan the document
again, so that the changes will be reflected in the generated bibliography.

B. Rescanning the Document
To add citations to the document after it has been scanned, insert citations following the
instructions described in Inserting Citations Using a Reference Manager on page 130. The
citations will be added as temporary citations and you will have to scan the document again
(as detailed in Scanning the Document above) to generate an updated bibliography.
Note: If Live Bibliography is turned on (only available with Mellel and Bookends) citations will
be inserted in their final format and bibliography items will be added automatically.

Bibliography | 136

C. Unscanning the Document
Unscanning a document reverts all the citations from their final format to temporary citations
and removes the bibliography. This is required, for example, if you need to scan a document
using a diﬀerent bibliography formatting (e.g., to conform with the style guide of diﬀerent
journals).

To unscan citations Do one of the following:
• Click the Unscan Document button (

) in the Bibliography palette.

Or
• Choose Edit > Bibliography > Unscan Document from the menu bar.
The bibliography is removed and all the citations are reverted to their temporary format.
Tip: To unscan a single citation, double-click it to open the Edit Citation window, then use the
Display popup menu to choose Temporary Citation.
Note: If Live Bibliography is turned on (only available with Mellel and Bookends) Scan and
Unscan will not be available, as they are not required.

D. Formatting the Bibliography Using Styles
Mellel can be configured to automatically map styles from the inserted bibliography into Mellel

character styles. For example, you can select a certain style that will be applied to all bold text
in the inserted bibliography. This enables consistent and automatic styling of your
bibliography, while matching the styles used in your document.
To map bibliography styles:
1. Click the Edit style mapping for Bibliography & Citations button (

) in the

Bibliography palette.
2. Click the Bibliography tab.
3. Do one of the following:
• Use the Paragraph Style and Character Style popup menus to choose the styles to be
used in the bibliography.
Or
• Choose the desired Text in... element to map, then use the Use Style... and Variation
popup menu to choose the character style and variation the selected Text in... element
will be mapped into.
4. Click Save.

E. Moving the Bibliography
The bibliography section can be moved like any other section. It is positioned at the end of the
document by default, but it doesn’t have to stay there. You can move it around and position it
anywhere you want.
To move the bibliography Do one of the following:
• If the bibliography has an Auto-title above it, you can use the outline to move it to its new
location (refer to Moving Outline Items on page 143 for more information).
Or
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• Select the entire bibliography, cut and paste it into its new location.
Note: If you cut and paste the bibliography you may have to manually terminate it by inserting
a section break at the end of the bibliography (choose Insert > Breaks > Section Break from
the menu bar, or press Cmd + Option + L).
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16. Outline
1. What is the Outline?
The Outline provides an overview of the document structure by displaying an hierarchical list
of all the Auto-titles and bookmarks in the document, as shown in the following figure:

Figure 4-45: Outline Example
The Outline can be used to review the document structure and to navigate it, while applying
diﬀerent filters to the displayed headings. Furthermore, the outline can be a powerful tool for
editing the document structure. By using simple drag and drop actions, you can move entire
sections and chapters from one place to the other, change the position of items in the
document hierarchy, add and delete items, and more.
For example, suppose you create a document with chapters and sub-chapters, but later decide
that all the sub-chapters should really be chapters as well. Instead of sipping through the
headings and changing them, you can simply ‘promote’ the sub-chapters to the same level as
the chapters, without changing anything else in the document.

139 | Writing your Document

2. Outline Tasks
1. Inserting Outline Items
Whenever an Auto-title is inserted into the document (refer to Inserting an Auto-Title on page
46 for step-by-step instructions), it is automatically added as an outline item as well. However,
you can use the outline to manually structure the entire document by creating structural
Auto-titles without leaving the outline pane.
To insert outline items:
• Using the Outline pane:
• Click the Add Outline Element button ( ) in the outline pane. The new item will be
added where your cursor is currently positioned, be it in the document area or in the
Outline pane.
Or
• Right-click an existing item from the outline pane and choose Insert followed by the
desired item.
• Using the menu bar:
• Select an item from the Outline pane.
• Choose Edit > Outline from the menu bar.
• Choose any of the following:
• Add Sibling: Adds a new sibling to the selected Outline item (a sibling is an item on the
same level as the selected item in the hierarchy, with both located under the same
parent).
• Add Child: Adds a new child to the selected Outline item (a child is an item one level
lower then the selected item in the hierarchy, which is located directly beneath it).
• Add Aunt: Adds a new aunt for the selected Outline item (an aunt is an item one level
higher then the selected item in the hierarchy, but it is not its direct parent).

2. Renaming Outline Items
To rename an existing outline item:
1. Select the item.
2. Do one of the following:
• Press Return.
• Click the item again.
3. Enter a new name for the item.

3. Editing Outline Items
To edit an outline item, double-click it in to open the drop-down edit panel, shown in the
following figure:
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Figure 4-46: Outline Item Edit Panel
The options in this panel are similar to those described in Inserting an Auto-Title on page 46.
Note: To hide the edit panel,click the collapse button at the bottom of the panel, or doubleclick the panel itself.

4. Promoting and Demoting Outline Items
You can use the Outline pane to demote or promote outline items. When you change an item in
the document area, only that item will change. However, when you demote or promote an item
using the outline, you will change the hierarchy position of all the items u it as well, down to
the next heading of the same level.
For example, consider the following outline:
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Figure 4-47: Outline Demotion Example
If we change the selected item to a Level 2 item using the Auto-titles palette in the document
area, no other heading is aﬀected:

Figure 4-48: Outline Demotion Example - Regular Change
If, on the other hand, we demote the item using the Outline pane, the result will be completely
diﬀerent, as all the items beneath it are demoted as well:
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Figure 4-49: Outline Demotion Example - Demotion
Select the items from the outline and perform any of the following to:
• Bring the selected item (and all of its children items) one level higher in the Auto-title
hierarchy:
• Click the Promote ( ) button.

•

Or
• Press Cmd + [.
Or
• Choose Edit > Outline > Decrease Level from the menu bar.
Bring the selected item (and all of its children items) one level lower in the Auto-title
hierarchy:
• Click the Demote ( ) button.

Or
• Press Cmd + ].
Or
• Choose Edit > Outline > Increase Level from the menu bar.
Note: You cannot use the outline to promote or demote a tag flow item, as its is not part of the
hierarchy. Refer to Flow Types on page 46 for more information.

5. Moving Outline Items
To move an outline item, click and drag it to its new position.
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Note: The headings displayed in the Outline are connected not only to the corresponding
Auto-titles in the text, but also to the content following those Auto-titles. Thus, when you
move an outline item, the content following the corresponding Auto-title up to the next Autotitle of that level will also be moved.
Note: You cannot move a tag flow item on its own in the hierarchy (only as part of the
structural flow item it is part of ). Refer to Flow Types on page 46 for more information.

6. Deleting Outline Items
To delete an outline item, select it and press Cmd + Backspace.
Note: The headings displayed in the Outline are connected not only to the corresponding
Auto-titles in the text, but also to the content following those Auto-titles. Thus, when you
delete an outline item, the content following the corresponding Auto-title up to the next
Auto-title at that level will also be deleted.

7. Using the Outline to Navigate the Document
One of the main outline functions is to allow you to view the document as a whole and to
navigate it with ease. You can navigate the document via the Outline pane using any of the
following methods:
• To navigate to a certain auto-title in the document, select it from the outline pane.
• Select any outline item and use the arrow keys to navigate to previous/next item.

8. Filtering Outline Items
You can filter outline items that are displayed in the outline pane to assist in locating specific
document elements.
There are three available methods for filtering the displayed outline items:
• Text: To only show outline items that include a specific text string, type the string into the
Filter text box. The outline items are filtered in real time as you type (the title, comment and
x-ref target are searched for the inserted text string).
• Marker: To only show outline items that were marked with a specific marker, click the Filter
Markers button (
) and choose the desired marker. You can choose more than one
marker. Any items that are marked with either of the selected markers will be displayed.
Note: Markers are indicated in the outline pane by an underlying line in the corresponding
colour, as shown in the following example, showing the green marker indication:

Figure 4-50: Outline Marker Indication

• Tags: To only show outline items that include a specific tag, click the Filter Tags button (

)

and choose the desired tag. Only tags that are applied to outline items in the current
document are included in the shown list. You can choose more than one tag, and any items
that include either tag will be displayed.
Note: Tagged Outline items are indicated by a corresponding icon in the Outline pane, as
shown in the following example, showing an Outline item tagged with the boom tag:
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Figure 4-51: Outline Chemistry Tag

9. Changing the Outline Pane Layout
You can change the layout of the outline pane using any of the following methods:
• Show/Hide the Outline Pane:
• Choose View > Outline from the menu bar.
Or
• Press Cmd + Shift + O.
Or

•

Click the Show/Hide side panel button (

).

• Resize the Outline Pane: Click and drag either the pane border or the Resize side pane
button (

• Determine
button (

•
•

•

).
Tag Flow Items View Layout: Click the Toggle Combined/Separate View
) to determine whether Tag Flow items are displayed separately from Structural

Flow items. When they are displayed separately, the button is highlighted in blue.
Show Auto-Title Remarks: Click the Toggle showing remarks ( ) button to show Autotitle and bookmarks remarks in the Outline pane. When remarks are displayed, the button is
highlighted in blue.
Change the Outline Font Size: Choose Mellel > Preferences... from the menu bar, click the
Document Setup tab and use the Outline Font Size popup menu to choose a font size.
Alternatively, check the Edit Outline with Actual Font and Size checkbox to use the same font
family and font size used in the document area when editing.
Truncate lines: Choose Mellel > Preferences... from the menu bar, click the Document
Setup tab and check the Check Truncate lines (...) to display outline items that cannot be
displayed fully in one line truncated.

10. Changing the Appearance of Outline Items
Mellel allows you to change the appearance of items in the Outline pane, so that their format is

diﬀerent in the document area compared to the outline. For example, you can shorten some
words, eliminate item numbering or eliminate the titles from the outline display.
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Figures section
of the outline

Document text

Table section of
the outline

Figure 4-52: Diﬀerent Appearance of Outline Items
To change the appearance of Auto-titles in the outline, refer to Use a Diﬀerent Format for
Diﬀerent Auto-Titles Usages on page 57.
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17. Story
1. What is Story?
The story feature was developed to assist you in writing manuscripts, novels and stories. This is
achieved by inserting elements called Story Points into the document. These story points can
include references to characters and locations that appear in that part of the story, and thus
aid you in keeping track of the plot and its progress. Characters and/or locations can appear in
more than one story point, and a single story point can include more than one character and/
or location. You can then navigate between story points to get a better understanding of the
story structure and progress.
Story Points are displayed in the Story pane, where you can browse, edit, filter and sort them in
various ways.

2. Story Tasks
1. Inserting Story Points
To insert a story point:
1. Place your insertion marker in the document area where you want to enter the story point.
2. Do one of the following:
• Using the Story pane:
1) Click the Story pane.
2) Click the Insert Story Point button ( ).

•

Using the menu bar:
1) Choose Insert > Story Point from the menu bar.
3. The Story Point popover is displayed, as shown in the following figure:
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Figure 4-53: Story Point Popover
3. Enter a title for the story point.
Tip: If you select text in the document area before inserting a story point, it will be
automatically used as your story point title.
4. Insert characters that are relevant to this story point by typing their name in the Characters
text box and pressing the Return key.
If it is the first time you are using this character, you will be prompt to create it, as shown
in the following figure:

Figure 4-54: Create Character Prompt
If you've previously used this character, its name will appear in a popup menu as you begin typing, as shown in the following figure:
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Figure 4-55: Using an Existing Character
Tip: Press the down arrow to select the previously created character and then press Return to
enter it to the selected story point.
5. Insert locations that are relevant to this story point by typing their name in the Locations
text box and pressing the Return key (optional).
If it is the first time you are using this location, you will be prompt to create it, as shown in
the following figure:

Figure 4-56: Create Location Prompt
If you've previously used this location, its name will appear in a popup menu as you begin
typing, as shown in the following figure:

Figure 4-57: Using an Existing Location
6. Use the Date & Time area to type in the absolute date and time for this story point
(optional). Story points can later be sorted by their date and time.
7. Use the Importance slider to change the default importance for this story point (optional).
Story points can later be sorted by their importance.
8. Use the Remarks text box to add any remarks (optional).
9. Use the Tags text box to add tags to the story point by typing their name and pressing the
Return key (optional). Story points can later by filtered by their tags.
10. Mark the story point by choosing a colour from the Marker area (optional). Story points can
later by sorted and filtered by the markers applied to them.
Note: To close the story point popover, double-click it.

2. Changing the Appearance of Story Points in the Document Area
By default, story points are displayed in the document area where they were inserted as
shown in the following figure:
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Figure 4-58: Story Point in Text
However, you can toggle the display of story points in the document area by clicking the
Toggle expanding story points inline button (
) in the Story pane. When this button is
active it is highlighted in blue, and sets Mellel to indicate the story point by a small circle next
to the text, as shown in the following figure:

Figure 4-59: Story Point Indication
Hovering over the indication circle would reveal its name, as shown in the following figure:

Figure 4-60: Story Point Indication Name
Note: If there are two story points in the same line, both will be displayed when hovering over
the indication.
Note: If story points are displayed in-line, they will also be printed as part of the document.

3. Editing Story Points
To edit a story point, double click it in the Story pane or in the document area. The Story Point
popover is displayed, with the same functionalities described in Inserting Story Points on
page 147.
Note: If story points are set not to be displayed inline in the text (refer to Changing the
Appearance of Story Points in the Document Area on page 149 for more information), you
must hover over the story point indication circle and click on the story point name in the tool
tip to edit it.

4. Editing Characters and Locations
While characters and locations can be added using the Story Point popover (refer to Inserting
Story Points on page 147 for more information), they are edited separately, enabling you to
add additional details to them.
To edit characters and locations:
1. Open the Story pane.
2. Click the Characters or Locations tab.
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3. Double-click the desired character/location.
4. Perform any of the following changes:
• Renaming the Character/Location: Type the new name.
• Adding a Character/Location Image: Click the Drag Image Here button, locate and
select the desired image, then click Open. Alternatively, drag an image from a diﬀerent
application and drop it onto the button to use it.
• Setting Character/Location Importance: Use the Importance slider to set the
importance level. Note that this property is independent of the similar property of any
story point that includes the character/location. Characters/Locations can later be
sorted by importance.
• Adding Character/Location Remarks: Use the Remarks text box to type in your
remarks.
• Adding Character/Location Tags: Use the Tags text box to type in the tag name and
press the Return key. Characters/locations can later be filtered by tags.
• Adding Character/Location Markers: Choose the desired colour from the Marker
area. Characters/locations can later be filtered and sorted by markers.

5. Moving Story Points
To move an existing story point to a diﬀerent location:
1. Set the Story Points in the document to be expanded inline (refer to Changing the
Appearance of Story Points in the Document Area on page 149 for step-by-step
instructions).
2. Select the story point you wish to move.
3. Cut the story point and paste it into its new location in the document using any of the tools
described in Basic Editing Tools on page 40.

6. Deleting Story Points
To delete a story point, select it either in the document area or in the Story pane and press the
Delete key, or click the Delete button (

) in the Story Point panel.

Note: Deleting a story point does not delete the characters and locations that are included in
it, even if they do not appear in any other story point.

7. Filtering Story Points, Characters and Locations
Story points, characters and locations can be filtered to allow you to easily locate specific
items.
To filter the displayed Story Points, Characters and/or Locations:
1. Open the Story pane.
2. Click the Story Points, Characters or Locations tab.
3. Use one of the following filtering tools:
• Text: To only show items that include a specific text string, type the string into the Filter
text box. The items are filtered in real time as you type.
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•

Marker: To only show items that were marked with a specific colour, click the Filter
Markers button (
) and then choose the desired colour. You can choose more than

one colour. Any items that are marked with either of the selected colours will be
displayed.
Note: Marked items are indicated by an underlying line in the corresponding colour, as shown
in the following example, showing the green marker indication:

Figure 4-61: Marker Indication

•

Tags: To only show items that include a specific tag, click the Filter Tags button (

)

and choose the desired tag. Only tags that are applied to items in the current
document are included in the shown list. You can choose more than one tag, and any
items that include either tag will be displayed.
Note: Tagged items are indicated by a corresponding icon in the Story pane,, as shown in the
following example, showing an item tagged with the incomplete tag:

Figure 4-62: Story Point Tagged with the Happy Tag

8. Sorting Story Points, Characters and Locations
Story points, characters and locations can be sorted to allow you to easily track the progress of
diﬀerent elements in the plot.
To sort the displayed Story Points, Characters and/or Locations:
1. Open the Story pane.
2. Click the Story Points, Characters or Locations tab.
3. Click the Sort button (

) and choose one of the following available options:

•
•
•
•
•
•
•

Sort alphabetically.
Sort by first appearance.
Sort chronologically.
Sort by importance.
Sort by marker.
Sort by character (only available for sorting Story Points).
Sort by location (only available for sorting Story Points).
Note: The active sorting order is indicated on the button.

9. Changing the Story Pane Layout
You can change the layout of the story pane using any of the following methods:
• Show/Hide the Story Pane:
• Choose View > Story from the menu bar.
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Or

• Click the Show/Hide side panel button (

).

• Resize the Story Pane: Click and drag either the pane border or the Resize side pane
button (

).

• Show Story Point Details: Click the Toggle showing details button (
•

) to determine

whether the story point details (importance, locations, characters and time & date) are
shown in the story pane. When the details are shown, the button is highlighted in blue.
Set Story Point Font Size: Choose Mellel > Preferences... from the menu bar, click the
Document Setup tab and use the Story Point Font Size popup menu to set the font size for
story points.
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Chapter 5

Styling your Document

1. Styling Essentials
Document style and appearance can be just as important as its content. That is why Mellel
includes a variety of tools that allow you to change exactly what you want and make it look
exactly how you want it to.
There are several concepts at the foundation of how to style documents in Mellel:
• Separation between Style and Structure: In Mellel, style and structure are not related. Thus,
elements are not forced into a particular style just because they serve a specific structural
function. For example, diﬀerent Auto-titles can have diﬀerent styles applied to them. You are
free to apply whatever attributes you want to diﬀerent elements, and not worry about the
eﬀect it may have on the structure of the document. The two concepts are completely
independent of each other.
• Granularity: In Mellel, you can define exactly what part of the document you want to apply
styling attributes to. This includes several diﬀerent levels of elements that can be styled,
without aﬀecting one another:
• Character Styling: Used to adjust all the attributes that aﬀect the appearance of the single
character. This includes font, font colour, font size, font position and more. Refer to
Character Formatting on page 157 for more information.
• Paragraph Styling: Adjusts all the attributes that aﬀect the appearance of the paragraph.
This includes alignment, spacing, margins, tabs and more. Refer to Paragraph Formatting
on page 164 for more information.
• List Styling: Adjusts all the attributes that aﬀect the appearance of text arranged in lists.
This includes the list indention, symbol and more. Refer to Styling a List on page 71 for
more information.
• Section Styling: Adjusts all the attributes that aﬀect how paragraphs are grouped and laid
out together. This includes number of columns, their style, line numbers and more. Refer to
Section Formatting on page 175 for more information.
• Page Styling: Adjusts all the attributes that aﬀect the appearance of a page. This includes
headers and footers, page numbers, page margins and page orientation. Refer to Page
Formatting on page 178 for more information.
Every type of style in Mellel has diﬀerent, non-converging, attributes. That is, attributes set
for one type of style are never set by another type of style. Every style is managed individually, and they are all independent of each other. For example, one paragraph can have several diﬀerent character attributes in it, while diﬀerent paragraphs can have the same character attributes.

• Ad Hoc vs. Styles: Each of these elements can be styled in two diﬀerent ways:
• Ad Hoc Changes: You can manually apply diﬀerent attributes to selected elements in the

•

document, and the changes would only aﬀect the selected element. For example,
selecting a paragraph and aligning it to the centre of the page. Attributes are
recommended for small singular changes that shouldn't be reflected anywhere else in the
document.
Using Styles: Styles are sets of pre-configured attributes, that can be applied together to
certain parts of the document. For example, applying a specific paragraph style might
align it to the center of the page, change its line spacing to double and change its below
spacing to 6 points all at once. When styles are changed, the changes are immediately
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•

applied to all the document elements that use the changed style. Styles are recommended
for ensuring consistency within and between documents. You can use the predefined
styles that are shipped with Mellel, or create new styles of your own. Refer to Working with
Styles on page 186 for more information.
Selection before Editing: The basic principle of operation in Mellel is that you first select the
text you want to style, and then apply attributes and/or styles to the selected text.
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2. Character Formatting
1. What are Characters?
A Character is the most basic unit in any document. That is, a single letter, number, space, and
so on. Every character has certain attributes like the font family and font face applied to it, its
size, fill colour, and more.
There are three main UI elements that can be used to style characters:
• The Character palette Attributes tab: Applies diﬀerent character attributes to the currently
selected text or to text entered following the insertion point. These attributes include
underlines, colour, background colour, superscript, upper and lower case and more. Changes
made using the Attributes tab are only applied to the currently selected text, or to text
entered following the insertion point. Refer to Styling Essentials on page 155 for more
information.
• The Character palette Styles tab: Applies diﬀerent character styles to the currently selected
text. Additionally, the Styles tab can be used to manage existing styles or add new ones.
Changes made to styles would aﬀect all the text that is using that style. Refer to Styling
Essentials on page 155 for more information.
• The Character menu (Styles > Character Style): Includes similar functionalities to the
Character palette Styles tab.

2. Character Styling Tasks
1. Styling Characters Using Attributes
To style characters using attributes:
1. Select the text you wish to style.
2. Click the Attributes tab in the Character palette.
3. Use the diﬀerent options to style the characters in the selected text. Refer to Character
Palette Description on page 337 for a complete description of the diﬀerent options.

A. Setting Character Font Family
To set the character font type (e.g. Arial, Times New Roman, Helvetica, etc.):
1. Select the text you wish to style.
2. Click the Attributes tab in the Character palette.
3. Use the Font popup menu to choose the desired font.
Note: The availability of items in the Font popup menu is determined by the fonts installed on
your computer.

B. Setting Character Font Face
To set the character font face (e.g. Italic, Bold, etc.):
1. Select the text you wish to style.
2. Click the Attributes tab in the Character palette.
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3. Use the Face popup menu to choose the desired font face.
Tip: Press Cmd + I to apply Italic face and/or Cmd + B to apply Bold face to the selected text.
Note: The availability of items in the Face popup menu is determined by the selected font
type. Diﬀerent fonts have diﬀerent faces that can be applied to them. Some fonts have many
faces, but other fonts may have but a single, regular face.

C. Setting Character Font Size
To set the character font size (in points):
1. Select the text you wish to style.
2. Click the Attributes tab in the Character palette.
3. Use the Size popup menu to choose the desired font size.
Tip: Choose Other from the Size popup menu to manually enter the desired font size.

D. Setting Character Fill colour
To set the character fill colour:
1. Select the text you wish to style.
2. Click the Attributes tab in the Character palette.
3. Choose Solid from the Fill popup menu.
4. Click the Colour well (

) to open the Colour window and set a fill colour. Refer to

Colour Window on page 281 for step-by-step instructions.
Note: Choosing None will make the selected text invisible.

E. Setting Character Stroke
To style the character stroke:
1. Select the text you wish to style.
2. Click the Attributes tab in the Character palette.
3. Click the Stroke button to open the Stroke popover.
4. Use the Type popup menu under the Stroke title to choose the desired option. Refer to
Character Palette Description on page 337 for a complete description of the diﬀerent
options.
5. Use the Stroke Size popup menu under the Stroke title to set the stroke size. Refer to
Character Palette Description on page 337 for a complete description of the diﬀerent
options.
6. Click the Colour well (

) under the Stroke title to open the Colour window and set a

stroke colour. Refer to Colour Window on page 281 for step-by-step instructions.

F. Setting Character Background Fill
To set the character background fill colour:
1. Select the text you wish to style.
2. Click the Attributes tab in the Character palette.
3. Choose Solid from the Background popup menu.
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4. Click the Colour well (

) to open the Colour window and set a background fill colour.

Refer to Colour Window on page 281 for step-by-step instructions for using the Colour
window to choose colour.

G. Adding Lines to the Character
To add lines to the character:
1. Select the text you wish to add lines to.
2. Click the Attributes tab in the Character palette.
3. Use the Line popup menu to choose the desired line. Refer to Character Palette Description
on page 337 for a complete description of the diﬀerent options.
Tip: Press Cmd + U to add a single underline to the selected text.
Note: Once any line has been added to the character, it can be styled using the various Stroke
functionalities. Refer to Setting Character Stroke on page 158 for step-by-step instructions.

H. Setting Lines Stroke
To style the stroke of added lines:
1. Select the text you wish to style.
2. Click the Attributes tab in the Character palette.
3. Click the Stroke button to open the Stroke popover.
4. Use the Type popup menu under the Line Stroke title to choose the desired option. Refer to
Character Palette Description on page 337 for a complete description of the diﬀerent
options.
5. Use the Stroke Size popup menu under the Line Stroke title to set the stroke size. Refer to
Character Palette Description on page 337 for a complete description of the diﬀerent
options.
6. Click the Colour well (

) under the Line Stroke title to open the Colour window and set

a stroke colour. Refer to Colour Window on page 281 for step-by-step instructions.

I. Setting Character Vertical Position
Characters can be styled so that their vertical position is either normal, superscript or
subscript. When a character is set to be superscript or subscript the font size is also reduced.
To adjust the character vertical position:
1. Select the text you wish to position vertically.
2. Click the Attributes tab in the Character palette.
3. Use the Position popup menu to choose a preset vertical position. Refer to Character
Palette Description on page 337 for a complete description of the diﬀerent options.

J. Setting Character Baseline Shift
Characters can be styled so that they are shifted up or down from the surrounding text
baseline level. To set the character baseline shift:
1. Select the text you wish to shift from the baseline.
2. Click the Attributes tab in the Character palette.
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3. Use the Baseline shift text box to manually enter the desired distance from the baseline text
level. Positive values will move the selected text above the baseline level, while negative
values will move it under.
Note: Unlike setting the vertical position, applying a baseline shift does not aﬀect the font size
of the shifted text.

K. Setting Tracking
Tracking allows you to set the spacing between letters, beyond the spacing set within a font.
Tracking is set by default to 0.
You can set tracking by doing the following:
1. Select the text to which you wish to apply tracking.
2. Click the Attributes tab in the Character palette.
3. Click the Options button.
4. Type or use the stepper to set the tracking value in 1/1000th of an Em Space.

L. Using OpenType Features
OpenType is a font standard that enables adding extra typographic attributes to certain
characters. Refer to Advanced Typography on page 200 for a complete description of available
features.
To enable OpenType features in Mellel:
1. Select the text you wish to enable OpenType features for.
2. Click the Attributes tab in the Character palette.
3. Use the Font popup menu to apply a font that supports OpenType features.
4. Use the OpenType popup menu to choose the feature/s you wish to enable. Refer to
Character Palette Description on page 337 for a complete description of the diﬀerent
options.
Note: OpenType features are only available in special OpenType fonts. However, not all
OpenType fonts support all OpenType features.
Note: Enabled features are indicated by a black tick.

M. Setting Character Capitalization
To set the character capitalization style:
1. Select the text you wish to style.
2. Click the Attributes tab in the Character palette.
3. Use the Case popup menu to choose the desired capitalization style. Refer to Character
Palette Description on page 337 for a complete description of the diﬀerent options.

N. Enabling Ligatures
Ligatures occur when two letters or more are joined into a single glyph, as shown in the
following figure:
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Figure 5-1: Ligature Examples
Note: Accented characters (such as ü, é, ç, etc.) are not considered ligatures.
To enable using ligatures in your document:
1. Select the text you wish to enable ligatures for.
2. Click the Attributes tab in the Character palette.
3. Check the Ligatures checkbox to enable ligatures.
Tip: When using a monospaced font (e.g., Courier or Monaco), it is recommended to turn
Ligatures oﬀ to avoid creating ligatures (such as fl, fi, ﬄ, etc.) with those fonts that would break
the even letters spacing.

O. Enabling Kashida
Kashida is a unique type of justification used in languages based on Arabic script. Kashida
justification is accomplished by elongating the actual characters at certain points.
Kashida is enabled by default, but you can disable it by doing the following:
1. Select the text you wish to disable Kashida for.
2. Click the Attributes tab in the Character palette.
3. Click the Options button.
4. Clear the Kashida checkbox.

P. Styling the Secondary Font
When writing bi-lingual texts, you can style the secondary character/font by setting its font
type, font face, script and size. Refer to Using a Secondary Font on page 272 for more
information.

1. Setting the Secondary Font Script
Mellel enables you to automatically apply a set of secondary font attributes when switching to

a diﬀerent script (Arabic, Hebrew, etc.). For example, if you set the script to Arabic (and set the
appropriate font, of course), when you switch to an Arabic script, Mellel will automatically
select and use the font, face, and size set for the secondary font.
Perform the following instructions to set the secondary font script:
1. Select the bi-lingual text you wish to style.
2. Click the Attributes tab in the Character palette.
3. Click the Options button.
4. Use the Script popup menu to choose the desired font script. Refer to Character Palette
Description on page 337 for a complete description of the diﬀerent options.
Note: All the other Secondary font fields are disabled until a script is set.

2. Setting the Secondary Font Type
To set the secondary font type (Arial, Times New Roman, Helvetica, etc.):
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1. Select the bi-lingual text you wish to style.
2. Click the Attributes tab in the Character palette.
3. Click the Options button.
4. Use the Font popup menu to choose the desired font type.
Note: This feature is disabled until selecting a secondary font script. Refer to Setting the
Secondary Font Script on page 161 for step-by-step instructions.
Note: The availability of items in the Font popup menu is determined by the fonts installed on
your computer.

3. Setting the Secondary Font Face
To set the secondary font face (Bold, Italic, etc.):
1. Select the bi-lingual text you wish to style.
2. Click the Attributes tab in the Character palette.
3. Click the Options button.
4. Use the Face popup menu to choose the desired font face.
Note: This feature is disabled until choosing a secondary font script. Refer to Setting the
Secondary Font Script on page 161 for step-by-step instructions.
Note: The availability of items in the Face popup menu is determined by the selected font
type. Diﬀerent fonts have diﬀerent faces that can be applied to them. Some fonts have many
faces, but other fonts may have but a single, regular face.

4. Setting the Secondary Font Size
The secondary font size is set in relation to the main font size by doing the following:
1. Select the bi-lingual text you wish to style.
2. Click the Attributes tab in the Character palette.
3. Click the Options button.
4. Use the Size slider to change the size of the secondary font in relation to the main font.
The adjacent percentage and points read-only fields indicate the secondary font size in
relative (percentages) and absolute (points) units, respectively.
Note: This feature is disabled until choosing a secondary font script. Refer to Setting the
Secondary Font Script on page 161 for step-by-step instructions.

Q. Assigning Languages to a Text
You can assign a language to a text to determine what spelling dictionary is used to spell
check it (refer to Selecting Spelling Dictionary on page 234 for more information). By default,
Mellel automatically identifies the language, but if you need to manually assign it, perform the
following actions:
1. Select the text you wish to assign a language to.
2. Click the Styles tab in the Character palette.
3. Use the Language popup menu to choose the desired language.
Note: Languages can be synchronized with keyboard layouts, so that whenever you switch to
a certain keyboard layout, a preset language is automatically assigned to the typed text. Refer
to Synchronizing Language and Keyboard Layout on page 234 for step-by-step instructions.
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2. Copying and Pasting Character Attributes
You can copy character attributes (without the content) and paste it to another text to apply
the same attributes. Refer to Copying and Pasting Attributes on page 40 for step-by-step
instructions.

3. Styling Characters Using Styles
Styling characters using styles is similar to using styles with any other document element.
Refer to Working with Styles on page 186 for step-by-step instructions for applying and
managing character styles.
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3. Paragraph Formatting
1. What are Paragraphs?
Paragraphs are strings of characters separated by a Return character. Every paragraph in Mellel
has several attributes, such as alignment, line spacing, space above and below it, tabs, and
more. Paragraph attributes can be adjusted using the Paragraph palette, the Edit Paragraph
window and the Paragraph Style menu.
Two additional UI elements are used to style paragraphs:
• Ruler: Located directly above the document area, and is used to display visual indications for
the paragraph margins, indentions and tabs. Changes made to paragraph attributes are
reflected in the ruler. Refer to Ruler on page 330 for more information.
• Tabs Well: Located at the left-end of the toolbar and is used to add diﬀerent types of tabs
into the document. These tabs would appear in the Ruler. Refer to Tab Well on page 328 for
more information.

2. Paragraph Styling Tasks
1. Styling Paragraphs Using Attributes
Note: The following paragraph attributes can only be adjusted using styles, as they are not
available in the Attributes tab:
1. Using hyphenation.
2. Keeping lines together.
3. Setting the next paragraph style.
4. Setting an associated character style.
Refer to Styling Paragraphs Using Styles on page 169 for more information regarding these
paragraph attributes.

A. Aligning Paragraph Text
To align the paragraph text:
1. Select the text you wish to style.
2. Do one of the following:
• Open the Paragraph palette, click the Attributes tab and use the Alignment buttons to
choose the desired alignment. Refer to Paragraph Palette Description on page 342 for a
complete description of the diﬀerent options.
Or
• Choose the desired alignment option from the Alignment Panel at the top left corner of
your screen, which oﬀers the same options as the Paragraph palette.

B. Changing Paragraph Direction
To change the paragraph direction (switching between right-to-left and left-to-right):
1. Select the text you wish to style.
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2. Do one of the following:
• Using the toolbar:
1) Click the Direction button (

•

) at the left side of the toolbar.

Using the Paragraph palette:
1) Open the Paragraph palette.
2) Click the Attributes tab.
3) Click the Direction button (

).

C. Setting Paragraph Line Spacing
To set the paragraph line spacing (the distance between each pair of lines):
1. Select the text you wish to style.
2. Open the Paragraph palette.
3. Click the Attributes tab.
4. Use the Units popup menu to set the line spacing units (either lines or points).
5. Use the Amount popup menu to set the line spacing value.

D. Setting Paragraph Spacing
To set the spacing between paragraphs:
1. Select the text you wish to style.
2. Open the Paragraph palette.
3. Click the Attributes tab.
4. Use the Above text box to set the value for space (in points) above the paragraph.
5. Use the Below text box to set the value for space (in points) above the paragraph.
Tip: Check the Also at top of pg/col checkbox to use the same spacing when the paragraph
begins at the top of the page/column (this would result a white space before the paragraph if
an Above spacing is set).
Note: If two following paragraphs are using diﬀerent styles with diﬀerent paragraph spacing
values, the highest value is applied. For example, if paragraph A has a set space below of 5
points, while paragraph B following has a set space above of 8 points, the spacing between
the two paragraphs will be 8 points which is the highest value (rather than 5 or 13 points).

E. Setting Paragraph Margins
To set the paragraph margins:
1. Select the text you wish to style.
2. Do one of the following:
• Using the Paragraph palette:
1) Open the Paragraph palette.
2) Click the Attributes tab.
3) Use the Start text box to set the margin between the printable area border and the
beginning of the text.
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4) Use the End text box to set the margin between the printable area border and the
ending of the text.
• Using the Ruler:
1) Click and drag the diamond-shaped Start Margin and End Margin indicators ( ) to
set the desired margin.
Tip: You can enter the margin values in points, centimeters or inches. Refer to Measurement
Units on page 281 for more information.

F. Setting Paragraph Indention
To set the paragraph indention (the size of the empty space that is added at the beginning of
each paragraph by moving the first line inwards):
1. Select the text you wish to style.
2. Do one of the following instructions sets:
• Using the Paragraph palette:
1) Open the Paragraph palette.
2) Click the Attributes tab.
3) Use the Indent text box to set the paragraph indention.
• Using the Ruler:
1) Click and drag the triangle-shaped Indent indicator ( ) to set the desired indention.

G. Setting Minimum Word Spacing
To set the Minimum Word Spacing (the minimum width of a space between words in a block
aligned text):
1. Open the Paragraph palette.
2. Click the Attributes tab.
3. Set Minimum Word Spacing under Min WS by entering a value or using the stepper to set a
value.

H. Managing Tab Stops and Tabs
Tab Stops are indicators that can be added to the ruler. Once added, they can be used to align
text to them, thus enabling a consistent layout of paragraphs. Tabs are the white-space
characters added to the text that pushes it so that it is aligned with a tab stop.

1. Pushing Text to the Next Tab Stop
To push a block of text to the next tab stop:
1. Place the insertion point at the beginning of the text you want to push.
2. Do one of the following:
• Press the Tab key.
Or
• Choose Insert > Breaks > Tab from the menu bar.

2. Adding a Tab Stop
To add a new tab stop to the ruler:
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1. Click the desired tab from the Tabs well (refer to Tab Well on page 328 for a complete
description of the diﬀerent tabs).
2. Click on the Ruler where you want to add the tab.
The new tab is added and selected, which is indicated by a blue highlight and the appearance of the position text box, as indicated in the following figure:

Figure 5-2: Selected Tab Indication
Tip: You can add several tabs at once by doing the following:
1. Do one of the following:
• Double-click on the Tabs well.
Or
• Right-click on the Ruler and choose Add Tab Stops.
The Add Tab Stops window is displayed:

Figure 5-3: Add Tab Stops Window
2. Use the diﬀerent fields to adjust the added tabs. Refer to Add Tab Stops Window on page
422 for a detailed description of the diﬀerent options.
3. Click OK.

3. Showing Tabs in the Document Area
Tabs can be shown in the document area by choosing View > Show Hidden > Tabs from the
menu bar. The following figure shows an example for a tab in the document area:
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Figure 5-4: Tabs Indication in Document Area

4. Moving a Tab Stop
Perform the following instructions to move an existing tab stop:
1. Click the tab you wish to move in the Ruler.
2. Do one of the following:
• Enter a new value in its position text box.
• Drag the selected tab to the new position.
Note: When editing Combo Tabs, you can move either arm of the tab (or both).
Note: Tabs cannot be dragged outside the set paragraph margins.

5. Setting Decimal Alignment Character
You can add decimal tabs to Mellel documents, which allow aligning text around a decimal
separator character (refer to Tab Well on page 328 for more information). To choose the
decimal character to align on:
1. Select the decimal tab you want to set an alignment character for.
2. Open the Paragraph palette.
3. Click the Attributes tab.
4. Use the Dec. align on text box to enter the character to align the decimal tab on.
Note: This option is disabled unless a decimal tab is selected.
Tip: If you are commonly using the same character to align decimal tabs on, set it as the
default by doing the following:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Typography tab.
3. Use the Default Decimal Tab Character text box to enter the default character.

6. Deleting a Tab Stop
To delete an existing tab stop:
1. Click the tab you wish to delete in the Ruler.
2. Drag the tab upwards or downwards outside the Ruler.
Tip: You can remove all tabs from the ruler by performing one of the following:
• Right-click on the Ruler and choose Remove All Tab Stops.
Or
• Press and hold the Option key while dragging any tab upwards or downwards outside the
Ruler.

7. Adding a Lead to a Tab Stop
You can add a leading character to a tab stop. This character will be repeated from the end of
the text until the tab stop position.
To add a character lead to a tab stop:
1. Click the tab stop you wish to add a lead to in the Ruler.
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2.
3.
4.
5.

Open the Paragraph palette.
Click the Attributes tab.
Use the Lead popup menu to choose the lead type.
Use the Position text box to set the position of the lead.

2. Copying and Pasting Paragraphs Attributes
You can copy paragraph attributes (without the content) and paste it to text in the document
to apply the same attributes. Refer to Copying and Pasting Attributes on page 40 for step-bystep instructions.

3. Styling Paragraphs Using Styles
Styling paragraphs using styles is similar to using styles with any other document element.
Refer to Working with Styles on page 186 for step-by-step instructions for applying and
managing character styles.
The following paragraphs attributes can only be adjusted using styles:
1. Using hyphenation.
2. Keeping lines together.
3. Setting the next paragraph style.
4. Setting an associated character style.
Refer to the following sub-sections for step-by-step instructions.

A. Managing Paragraph Hyphenation
1. What is Hyphenation?
Hyphenation is splitting a word in two at the end of a line. A hyphen (-) is inserted in the
middle of the word at the end of the line, and the rest of the word is moved to the next line.
Hyphenation is often used with text in columns and when the text is fully justified, to allow
dividing the text into lines of approximately even length. Hyphenation does not change the
actual text, just its rendering across diﬀerent lines.
The following figure depicts text that is not hyphenated. Without hyphenation, some lines
have very large spaces between words.

Text without Hyphenation
With hyphenation activated, some words are hyphenated and the wide spaces vanish:
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Text with Hyphenation
Hyphenation is not applied blindly whenever a word is too long to fit in a certain line. The
decision whether or not to hyphenate follows a certain logic. This logic is partly configured by
the user and partly based on an hyphenation dictionary which details what words can be split
and how.
In Mellel, hyphenation is part of the paragraph attributes that are adjusted using the Edit
Paragraph Style window.
Note: Some users have very specific and elaborate requirements regarding the way
hyphenation should function. Such requirements can be met using Mellel Hyphenation Lab
(MHL). This application, which is oﬀered as a free download from RedleX’s site, enables you to
create and edit hyphenation dictionaries. For more information visit http://www.mellel.com.

2. Hyphenation Tasks
A. Activating Hyphenation
To enable hyphenation in a paragraph style:
1. Edit the paragraph style you wish to enable hyphenation for (refer to Editing a Style on
page 190 for step-by-step instructions).
The Edit Paragraph Style window is displayed.
2. Check the Hyphenation checkbox.
3. Use the Dictionary popup menu to choose an hyphenation dictionary.
4. Click Save.

B. Setting Hyphenation Lines Limit
To set the maximum number of consecutive lines that can end in an hyphen:
1. Edit the paragraph style you wish to set the hyphenation lines limit in (refer to Editing a
Style on page 190 for step-by-step instructions).
The Edit Paragraph Style window is displayed.
2. Check the Hyphenation checkbox.
3. Use the Hyphenation limit text box to enter the desired value.
4. Click Save.
Tip: The default value is three (3). A larger value (4 or 5) may be useful with text laid out in
narrow columns. A smaller value is more suitable for text that is laid out in one column.
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C. Customizing Minimum Hyphenation Length
Hyphenation dictionaries set their own minimum word length and minimum number of
characters before and after a hyphen. These settings should suﬃce for most use cases, but can
be overridden to make the hyphenation rules more strict (less hyphenating) or more lenient
(more hyphenating).
To customize the minimum hyphenation length attributes:
1. Edit the paragraph style you wish to customize the minimum hyphenation length
attributes in (refer to Editing a Style on page 190 for step-by-step instructions).
The Edit Paragraph Style window is displayed.
2. Check the Hyphenation checkbox.
3. Check the Customize minimum checkbox.
4. Use any of the following text boxes to customize their values:
• Word length: Set the minimum length for a word to be hyphened.
• Before hyphen: Set the minimum length of the first part of a hyphened word.
• After hyphen: Set the minimum length for the second part of a hyphened word.

D. Setting the Hyphenation Zone
You can set the maximal size of the Hyphenation Zone. When the text is aligned to the left or to
the right, this is the white space at the end of a line. When the text is justified, it is the white
spaces between words. In both cases, larger zones require less hyphenation.
To set the maximal hyphenation zone size:
1. Edit the paragraph style you wish to customize the minimum hyphenation length
attributes in (refer to Editing a Style on page 190 for step-by-step instructions).
The Edit Paragraph Style window is displayed.
2. Check the Hyphenation checkbox.
3. Use the Hyphenation zone text box to enter the desired value.

E. Editing User Hyphenation Dictionary
You can edit a personal hyphenation dictionary, which overrides the hyphenation dictionaries
used in the document. The main purpose of the personal hyphenation dictionary is to allow
you to set some words so that they are never hyphenated or, alternately, only hyphenated in a
specific way.

F. Adding a Word to the Personal Hyphenation Dictionary
To add a word to the personal hyphenation dictionary:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Hyphenation tab.
3. Click the User Dictionary tab.
4. Click Add.
5. Do one of the following:
• Type in a word without an hyphen to prevent it from being hyphened.
Or
• Type in a word with an hyphen to determine how it will be hyphened.
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G. Editing a Word in the Personal Hyphenation Dictionary
To edit a word in the personal hyphenation dictionary:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Hyphenation tab.
3. Click the User Dictionary tab.
4. Double-click on the word you wish to edit.
5. Enter the new value.

H. Deleting a Word from the Personal Hyphenation Dictionary
To delete a word from the personal hyphenation dictionary:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Hyphenation tab.
3. Click the User Dictionary tab.
4. Choose the word you wish to delete.
5. Click Delete.

I. Entering a Soft Hyphen
Soft hyphens are hidden hyphenation marks (often called “discretionary hyphens”) that can be
added to any word in the text. A soft hyphen is an option for hyphenation. That is, it will
remain invisible and will have no eﬀect on the text, unless it is at the end of the line that must
be hyphenated, when it will be used to determine how to hyphenate the word.
To enter a soft hyphen:
1. Place the insertion point where you want to insert the soft hyphen.
2. Choose Insert > Special Characters > Hyphen & Dash > Soft Hyphen from the menu bar.
Tip: You can show/hide soft hyphens by choosing View > Show Hidden > Soft Hyphens from
the menu bar. Soft hyphens are displayed as blue vertical lines, as shown in the following
figure:

Figure 5-5: Soft Hyphen
Note: Soft hyphens should be used sparingly and only where automatic hyphenation or the
user dictionary cannot address a problem (mostly when you want to hyphenate a word but
don’t want the same hyphenation logic to be applied anywhere else).

B. Keeping Lines Together
You can configure paragraph styles so that their lines are kept together. This prevents any
single lines appearing on a diﬀerent page than the rest of the paragraph (this is often referred
to as widows and orphans).
To adjust how paragraph lines will be kept together:
1. Edit the paragraph style you wish to edit (refer to Editing a Style on page 190 for step-bystep instructions).
The Edit Paragraph Style window is displayed.
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2. Check the Keep lines together checkbox.
3. Use the diﬀerent options to define how are lines kept together. Refer to Edit Paragraph
Style Window on page 405 for a complete description of the diﬀerent options.
4. Click Save.

C. Keeping Paragraphs Together
You can configure paragraph styles so that the current paragraph cannot be separated from
the next paragraph by entering the number of lines from the next paragraph that will be kept
together with the current one. This option is useful to keep headings tied to sub-headings and
to body text at the bottom of the page, and is usually activated only with headings.
To adjust how paragraphs are kept together:
1. Edit the paragraph style you wish to edit (refer to Editing a Style on page 190 for step-bystep instructions).
The Edit Paragraph Style window is displayed.
2. Use the Keep with next text box to enter the number of lines from the next paragraph that
cannot be separated from the current one.
3. Click Save.

D. Setting the Next Paragraph Style
You can configure paragraph styles so that the following paragraph would use a specific style
by default. This enables you to save time when a certain paragraph style in your document
should always be followed by a specific paragraph style (for example, the Figure style is usually
followed by the Figure Caption style).
To set the next paragraph style:
1. Edit the paragraph style for which you wish to change the next paragraph style (refer to
Editing a Style on page 190 for step-by-step instructions).
The Edit Paragraph Style window is displayed.
2. Use the Next paragraph style popup menu to choose the desired style.
3. Click Save.
Note: This setting is only applied when typing paragraphs. E.g. if you apply the style to a
certain paragraph, it will not automatically change the style of the existing paragraph
following it, only the new paragraph that will be created when placing the insertion point at
the end of the paragraph and pressing the Return key.

E. Setting an Associated Character Style
You can configure paragraph styles so that they use a specific character style by default. This
enables you to save time by applying both styles together with a single action.
To set the associated character style:
1. Edit the paragraph style you wish to set an associated character style to (refer to Editing a
Style on page 190 for step-by-step instructions).
The Edit Paragraph Style window is displayed.
2. Use the Associated character style popup menu to choose the desired style.
3. Click Save.
173 | Styling your Document

Note: This setting is only applied when applying a style to a paragraph. E.g. if you edit the style
and save your changes no changes will occur in existing paragraphs and their associated
character style. Changes will only occur when you explicitly apply the new style to an existing
paragraph.
Note: Choosing None from the Associated character style popup menu would prevent Mellel
from applying any character attributes when the edited paragraph style is applied.
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4. Section Formatting
1. What are Sections?
Sections are blocks of text, spanning over one paragraph or more, which start and end with a
section break. Within a section, you can arrange text in columns and style those columns using
the various tools available.
The following figure shows a page with four sections, each styled and formatted diﬀerently.
However, a page may include more than four sections, and a single section can span several
pages and sometimes the entire document.

Section breaks

Figure 5-6: Page Divided into Four Sections
Note: The beginning and the ending of a document are also considered section breaks.

2. Section Styling Tasks
1. Styling Sections Using Attributes
A. Creating a Section
When a new document is created, it includes a single section by default. Do one of the
following to create a new section in a document:
• Creating a section from existing text:
1. Select the text you wish to turn into a separate section.
2. Choose Edit > Make Section from Selection from the menu bar, or press Cmd + Shift
+ Option + S.
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The selected text is turned into a separate section.

•

Setting a section start/end point:
1. Place the insertion point where you want one section to end and a new section to
begin.
2. Choose Insert > Breaks > Section break from the menu bar, or press Cmd + Option +
L.

B. Setting Section Start Preference
Sections can be configured so that they either start on the same page as the previous section
or on the next page.
To set where the new section would start relatively to the previous section:
1. Place the insertion point within the section you wish to style.
2. Click the Section palette.
3. Click the Attributes tab.
4. Use the Section start popup menu to choose the desired option. Refer to Section Palette
Description on page 349 for a complete description of the diﬀerent options.

C. Setting the Number of Columns
To set the number of columns that comprise a section:
1. Place the insertion point within the section you wish to arrange in columns.
2. Click the Section palette.
3. Click the Attributes tab.
4. Use the Count text box to enter the desired number of columns.

D. Setting Section Background Colour
To set the background colour for a section:
1. Place the insertion point within the section you wish to style.
2. Click the Section palette.
3. Click the Attributes tab.
4. Use the Background popup menu to choose Solid.
5. Click the Colour well (

) to open the Colour window and set the background

colour.

E. Setting Columns Direction
To set the columns direction (e.g. determining whether text should flow from the left column
to the right column or the other way around):
1. Select the columns you wish to style.
2. Click the Section palette.
3. Click the Attributes tab.
4. Use the Order popup menu to choose Left to right or Right to left.
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F. Setting Space above a Section
To set the space above a section:
1. Place the insertion point within the section you wish to style.
2. Click the Section palette.
3. Click the Attributes tab.
4. Use the Space above text box to enter the desired value.

G. Balancing Columns
To balance the text between columns (i.e. the same number of lines will appear in each
column):
1. Select the columns you wish to style.
2. Click the Section palette.
3. Click the Attributes tab.
4. Check the Balanced checkbox to enable balancing.

H. Styling the Gutter
The gutter is the space between adjacent columns. To style the gutter appearance:
1. Place the insertion point within the section whose gutter you wish to style.
2. Click the Section palette.
3. Click the Attributes tab.
4. Use any of the following options to format the gutter appearance:
• Use the Width text box to determine the gutter's width. This is essentially the distance
between the columns.
• Use the Line type popup menu to determine the type of line used to separate columns.
• Use the Line weight popup menu to set the gutter line width.
• Use the Line Colour well to open the colour window and set the gutter line colour.
• Use the Space above text box to set the distance between the top of the column and
the top of the gutter line.
• Use the Space below text box to set the distance between the bottom of the column
and the bottom of the gutter line.
Note: If None is chosen in the Line type popup menu, all other options but Width are disabled.

I. Adding Line Numbers
Line numbers are added on a per-section basis. Refer to Line Numbering on page 106 for more
information.

2. Styling Sections Using Styles
Styling sections using styles is similar to using styles with any other document element. Refer
to Working with Styles on page 186 for step-by-step instructions for applying and managing
character styles.
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5. Page Formatting
1. What are Pages?
Pages are frames within your document that can contain text and/or graphics. Page styling
includes features such as headers, footers and numbering.
Text in Mellel is divided into one or more page ranges, that include any number of pages that is
required to fit the document elements you insert. Each page range begins and ends with a
Page Style Break. Using these breaks you can create diﬀerent page ranges within the
document, each using a diﬀerent page style. This enables, for example, to create two diﬀerent
page ranges with diﬀerent numbering schemes (e.g. 1,2,3 and i, ii, iii) in the same document.
Note: The beginning and ending of a document are also considered page style breaks.

2. Page Styling Tasks
1. Styling Pages Using Attributes
A. Inserting a Page Break
Page breaks are used to start a new page in the document without creating a new page range
and applying a new page style. To insert a page break:
1. Place the insertion point where you want to enter the page break.
2. Choose Insert > Breaks > Page break from the menu bar, or press Shift + Fn + Enter.

B. Inserting a Page Style Break
Page style breaks are used to create a new page range which uses a diﬀerent page style. To
insert a page style break:
1. Place the insertion point where you want to enter the page style break.
2. Choose Insert > Breaks > Page style break from the menu bar, or press Shift + Cmd + Fn
+ Enter.

C. Enabling Diﬀerent Attributes for the First Page
It is often required to use diﬀerent page attributes for the first page in a page range. For
example, you may choose to exclude the page number from the first page.
To enable applying diﬀerent page attributes for the first page in a page range:
1. Select the page range you wish to change the first page for.
2. Click the Page palette.
3. Click the Attributes tab.
4. Check the Diﬀerent first page checkbox.
The First Page icon (

) is displayed, enabling you to click it and edit the first page

attributes.
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D. Enabling Diﬀerent Attributes for Even and Odd Pages
It is often required to use diﬀerent page attributes for even and odd pages. For example, you
may want your logo to always appear on the external side of the page, which requires
positioning it diﬀerently in even and odd pages.
To enable using diﬀerent page attributes for even and odd pages in a page range:
1. Select the page range you wish to apply diﬀerent settings for.
2. Click the Page palette.
3. Click the Attributes tab.
4. Check the Diﬀerent odd/even pages checkbox.
The Odd Page (

) and Even Page (

) icons are displayed, enabling you to click them

and edit the odd/even page attributes.

E. Editing Diﬀerent Attributes for Diﬀerent Page Types
When the page range is configured to use diﬀerent attributes for the first page and/or
diﬀerent attributes for odd and even pages, perform the following instructions to edit those
diﬀerent attributes:
1. Place the insertion point within the page range you wish to edit.
2. Click the Page palette.
3. Click the Attributes tab.
4. Click one of the following to:

•
•
•
•

Edit the attributes of the all pages in the range.
Edit the attributes of the first page in the range.
Edit the attributes of all odd pages in the range.
Edit the attributes of all even pages in the range.

The Editing indication would change to the corresponding page type, as shown in the following figure:
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Figure 5-7: Editing First Page Indication
5. Change any required attributes.
Note: All changes would only apply to the selected page type in the selected page range.

F. Navigating a Page Range
To navigate within a page range:
1. Place the insertion point within the page range you wish to navigate.
2. Click the Page palette.
3. Click the Attributes tab.
4. Click one of the following buttons to:

•
•
•

Navigate to the first page in the range.
Navigate to the first odd page in the range.
Navigate to the first even page in the range.

Note: Navigating to the first page and navigating to the first odd/even page are only available
when diﬀerent first page and diﬀerent odd/even pages are enabled, respectively.

G. Setting the Page Range Start Preference
To configure page ranges to only start on either an odd or even page:
1. Place the insertion point within the page range you wish to edit.
2. Click the Page palette.
3. Click the Attributes tab.
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4. Use the Range Start popup menu to choose the desired option.
Note: When this option is used, Mellel might be required to insert a blank white page before
the beginning of the page range to allow it to start on an odd/even page.

H. Creating Headers and Footers
To add a header and/or a footer to the selected page range:
1. Place the insertion point within the page range you wish to edit.
2. Click the Page palette.
3. Click the Attributes tab.
4. Check the Header and/or Footer checkboxes to insert a header and/or footer, respectively.
Tip: When headers and/or footers are added to a page range, they have a reserved area at the
top/bottom of the page. You can show this area by choosing View > Show Hidden > Header/
Footer Frames from the menu bar.

I. Editing Headers and Footers
To edit either a header or a footer, click on them. The header/footer border and Header/Footer
insert menu are displayed, as shown in the following figure:

Figure 5-8: Footer in Edit Mode

1. Setting Header/Footer Height
To set the height of the header/footer:
• Using the document area:
1. Edit the header/footer, as detailed in Editing Headers and Footers above.
2. Hover over the two horizontal lines in the middle of the header/footer border until the
cursor changes into a bi-directional black arrow.
3. Click and drag the horizontal lines upwards or downwards to set the header/footer
height.
• Using the Page palette:
1. Select the page range you wish to edit.
2. Click the Page palette.
3. Click the Attributes tab.
4. Choose the page type you wish to edit the header/footer for, as detailed in Editing
Headers and Footers above.
5. Use the text boxes next to the header/footer checkboxes to manually enter the header/
footer height.
Tip: Double-click the two horizontal lines to automatically snap the header/footer to its
optimal size (i.e. to exactly fit all of its content).
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Note: When entering content to the header/footer, Mellel automatically adjusts their height so
that all the content is visible. If you reach the height limit (one third of the page height) an
overflow indicator is displayed to indicate that some of the header/footer content cannot be
displayed).

2. Inserting Page Numbers
To insert the current page number into the header/footer:
1. Edit the header/footer, as detailed in Editing Headers and Footers on page 181.
2. Use the Insert element popup menu to choose Page number.
Note: You can apply any style attributes to the page numbers just like you would for any other
text element in your document.

A. Configuring Page Numbers
To configure the page numbers added to a page range:
1. Select the page range you wish to edit.
2. Click the Page palette.
3. Click the Attributes tab.
4. Configure the page numbers by using any of the following options:
• Use the Numbering popup menu to choose the desired numbering scheme. Refer to
Page Palette Description on page 352 for a complete description of the diﬀerent
options.
• Check the Start at checkbox and enter a value in the adjacent text box to set the initial
number for the numbering sequence.
Note: If the Start at checkbox is not checked, numbering will continue from the previous page
range.

B. Current Page Number Indication
The current page number is indicated in the page status bar at the bottom of the document
area, as shown in the following figure:

Figure 5-9: Page Status Bar

• Current page style: Indicates the page style used for the current page. Refer to Inspecting
•
•

the Applied Style on page 188 for more information.
Current page number: Indicates the current page number, in the numbering unit selected
for its page range. Refer to Configuring Page Numbers above for more information.
Absolute page number: Indicates the absolute number of the current page out of the
absolute total number of pages in the document.

3. Inserting Total Number of Pages
To insert the total number of pages in the document into the header/footer:
1. Edit the header/footer, as detailed in Editing Headers and Footers on page 181.
2. Use the Insert element popup menu to choose Total number of pages.
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4. Inserting a Table
To insert a table into the header/footer:
1. Edit the header/footer, as detailed in Editing Headers and Footers on page 181.
2. Use the Insert element popup menu to choose Table.
3. The Insert Table dialogue-box is displayed. Refer to Inserting a Table on page 72 for more
information.

5. Inserting a Time Stamp
To insert a time stamp into the header/footer:
1. Edit the header/footer, as detailed in Editing Headers and Footers on page 181.
2. Use the Insert element popup menu to choose Date.
3. The Insert Date dialogue-box is displayed. Refer to Inserting a Date and Time Stamp on
page 126 for more information.

6. Inserting Mentions
It is often required to enter a dynamic element that references a specific heading level. For
example, you may want each page header to show the title of the current chapter. In Mellel
these elements are referred to as Mentions, and they are referred to as Running Headers in
other applications.
Mentions in Mellel can only be inserted into headers and footers, and they are referencing a
selected flow of Auto-titles. The mentions change dynamically to reflect the current heading
of the referenced level.
For example, when creating a reference to the Chapter level Auto-title, it will appear diﬀerently
on diﬀerent pages, based on the chapter those pages are part of.
To insert a mention into your header or footer:
1. Edit the header/footer, as detailed in Editing Headers and Footers on page 181.
2. Do one of the following to insert a mention:
• In the header/footer edit area, use the Insert Mention popup menu to choose the
desired Auto-title flow to be added.
Or
• Place the insertion point within the header/footer edit area and use any of the
methods described in Inserting an Auto-Title on page 46.
The current element of the selected Auto-title flow type is inserted and automatically updated in all the headers/footers in the selected page range and page type.

A. Formatting Mentions
To format the way mentions appear in your header/footer, refer to Use a Diﬀerent Format for
Diﬀerent Auto-Titles Usages on page 57.

J. Setting Page Background
To set the selected page range background:
1. Select the page range you wish to edit.
2. Click the Page palette.
3. Click the Attributes tab.
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4. Use any of the following tools to set a background:
• Setting a solid colour as the page background:
1) Click the Colour well (

•

) to open the Colour window.

2) Use the Colour window and set a background fill colour. Refer to Colour Window on
page 281 for more information on using the Colour window.
Setting an image as the page background:
1) Check the Image checkbox.
2) Click the Select button.
3) Locate and select the desired image.
4) Click Open.
5) Use the Position popup menu to set the image position (refer to Page Palette
Description on page 352 for a complete description of the diﬀerent options).
6) Use the Opacity slider to set the image opacity level.

K. Setting Page Orientations
To set the orientation for the selected page range:
1. Select the page range you wish to edit.
2. Click the Page palette.
3. Click the Attributes tab.
4. Click Margins & Orientation.
The Margins and Orientation window is displayed:

Figure 5-10: Margins and Orientation Window
5. Use one of the Orientation buttons to choose the desired option:

•
•

Portrait
Landscape
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Note: You may have both portrait and landscape pages in the same document, but a single
page range can only have one orientation applied to it.

L. Setting Page Margins
Page margins are the distance from the edge of the page to the text area. Perform the
following instructions to set the margins for the selected page:
1. Select the page range you wish to edit.
2. Click the Page palette.
3. Click the Attributes tab.
4. Click Margins & Orientation.
The Margins and Orientation window is displayed:

Figure 5-11: Margins and Orientation Window
5. Use the Top, Bottom, Left and Right text boxes to enter the desired values.
Tip: Check the Facing Pages checkbox to use mirrored margins, where even and odd pages
mirror each other. This enables you to set the Inside and Outside margins rather than left or
right ones. This is useful for achieving an optimal layout for facing pages in a printed book.
Note: Although you can technically set the page margin values to 0 (that is, no page margins),
you should consider that most printers cannot print to the edge of the page and require a
page margin of at least 0.15 inches (0.4 cm) on each end of the page. For the minimum margin
size, consult your printer documentation.

2. Styling Pages Using Styles
Styling pages using styles is similar to using styles with any other document element. Refer to
Working with Styles on page 186 for step-by-step instructions for applying and managing
character styles.
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6. Working with Styles
1. What are Styles?
A style is a set of formatting attributes that define the appearance of an element in the
document. For example, a character style will contain font or font face attributes, while a
paragraph style will contain paragraph alignment and line spacing attributes.
Every type of style in Mellel has diﬀerent, non-converging, attributes. That is, attributes set for
one type of style are never set by another type of style. Every style is managed individually, and
they are all independent of each other.
At heart, styles are no more than shortcuts to applying multiple attributes to document
elements. You can work without using them at all, and with notes, letters or short documents
you’d probably be doing the smart thing. But with longer documents, or where consistency in
styling is required, styles will prove to be an invaluable tool, oﬀering three main advantages:
• Eﬃciency: It is a type of a shortcut. It allows you to apply several styling attributes with a
single action, thus saving valuable time.
• Simplicity: It minimizes the number of features you must adjust to reach the desired
outcome. Instead of using ten diﬀerent functionalities to apply ten diﬀerent attributes, you
must only apply one attribute - the style itself.
• Consistency: All the document elements that use a particular style will look the same, with
no exceptions. Furthermore, if you chooses to change a certain attribute of the style (for
example, changing the font size of the character style) it is automatically applied to all the
document elements that are using that style.

1. Style Sets
Diﬀerent styles can be organized in a single Style Set. Style sets are compilations of character,
paragraph, list, section, page, note, and index styles. They allow you to group various types of
styles for specific tasks. For example, you can create a style set to use when writing letters,
another for articles, a third for books, and so on.
Style sets are saved to a special folder and are available with every document you write in
Mellel. Moreover, the style set used with a particular document is also saved into the document
itself. This means that if someone opens this document on a diﬀerent machine they will be
able to use the style set and all the individual styles comprising it.
You can manage your style sets by creating new styles, editing existing ones and organizing
them in their respective style palettes for optimal usability.
Global style sets include styles that are available across all the documents in a specific work
environment. Document style sets include styles that are only available in a specific document
that was imported into the environment. You can convert document style sets into global style
sets to make these styles available in other documents as well.
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2. Character Style Variations
Character styles have a unique functionality called Style Variations. Each character style
contains eight (8) sub-styles, which allow you to include several variations within the style
instead of creating eight separate styles. For example, you can use variations to create a bold,
bold-italic or underlined variations to the style, sharing the remaining attributes.
Variations support inheritance. That is, changes you make to attributes of the base variation
are automatically applied in all the child variations, unless you explicitly changed this attribute
in a variation.
For example, if you change the text colour for the base variation to red, the colour for all the
other variations will change to red, unless there is a variation where you have changed the text
colour to another colour.

3. Changes to Styles
When styles are applied to a document element, that does not mean that you can no longer
manually apply diﬀerent attributes to it. When you apply a style to an element and later
change one ore more of its style attributes manually (for example, selecting a diﬀerent font
size), the change is applied to the text and indicated by a black plus sign (+) in the
corresponding palette Styles tab as well as the corresponding styles sub-menu (refer to
Palettes on page 337 and Styles Sub-Menus on page 322 for examples).
You can later choose whether to save your changes to the current style or as a new style.

2. Styles Tasks
1. Managing Styles
A. Applying a Style
Applying a style to a document element overwrites any attributes that were applied ad-hoc
and are included in the applied style. For example, if you set the character font colour to be
blue ad-hoc using the Character palette Attributes tab, but later apply a style that uses red as its
font colour, the applied document element will change to red.
To apply a style to a document element:
1. Select the element you wish to apply the style to.
2. Do one of the following instructions sets:
• Using the Style tab in the corresponding palette:
1) Open the palette corresponding to the element you wish to apply a style to
(Character, Paragraph, List, Section or Page).
2) Click the Styles tab.
3) Choose the style you wish to apply.
4) Click the Apply style button (

•

).

Using the Styles menu:
1) Choose Styles from the menu bar.
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2) Choose the menu corresponding to the element you wish to apply a style to
(Character Style, Paragraph Style, Section Style or Page Style).
3) Choose the style you wish to apply from the available styles list.
Note: When applying a character style, Mellel performs a smart match of attributes, and will
use character style variations where applicable. For example, if the text you’re applying the
style to contains text in bold or italic face, Mellel will look for style variations with similar
attributes and use them when applying the new style. To disable this feature, press and hold
the Option key while applying the character style.

B. Inspecting the Applied Style
To find out what style is applied to a document element and to check its status:
1. Select the element you wish to inspect.
2. Do one of the following:
• Using the corresponding Styles palette:
1) Open the palette corresponding to the element you wish to inspect (Character,
Paragraph, List, Section or Page).
2) Click the Styles tab.
The current style is indicated by a blue tick, as shown in the following figure:

Figure 5-12: Current Style Indication
If the style is applied but there were changes performed to one or more of its attributes, it is
indicated by a black plus sign, as shown in the following figure:

Figure 5-13: Changed Style Indication
If the selection includes more than one style, all the used styles are marked by a black minus
sign, as shown in the following figure:

Figure 5-14: Multiple Styles Indication
If the style is not part of the current style set and is only available in the current document
(these styles are referred to as Document Styles), it is marked by a black diamond, as shown in
the following figure:

Figure 5-15: Document Style Indication

•

Using the Styles menus:
1) Choose Styles from the menu bar.
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•

2) Choose the sub-menu corresponding to the style you wish to inspect (Character
Style, Paragraph Style, Section Style or Page Style).
3) The current style is marked by a black tick.
Using the Style Well: The Style Well is included in the toolbar by default and indicates
the character and paragraph styles used in the current selected element, as shown in
the following figure:

Figure 5-16: Style Well Indications
Note: The string in parenthesis following the character style indicates the applied character
style variation.
• Using the Page Status bar: The Page Status bar is located at the bottom part of the
screen and indicates the page style used in the current page, as shown in the following
figure:

Figure 5-17: Page Status Bar

C. Creating a New Style
To create a new style:
• Using the corresponding Style palette:
1. Open the palette corresponding to the style you wish to create (Character, Paragraph,
List, Section or Page).
2. Click the Create new style button (

).

The corresponding Edit Style window is displayed, showing the name and attributes
of the currently applied style.
3. Adjust the new style attributes as required. Refer to the corresponding Edit Style
window description for a complete description of the diﬀerent attributes (Edit
Character Style Window on page 404, Edit Paragraph Style Window on page 405, Edit
List Style Window on page 408, Edit Section Style Window on page 418 or Edit Page
Style Window on page 419).
4. Click Create.

•

Using the Style Sets window:
1. Choose Styles > Edit Style Set from the menu bar.
2. Click the tab corresponding to the style you wish to create (Character, Paragraph, List,
Section, Page, Note or Index). The corresponding Edit Style window is displayed, showing
the name and attributes of the currently applied style.
3. Click the Create new style button (

).

The corresponding Edit Style window is displayed.
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3. Adjust the new style attributes as required. Refer to the corresponding Edit Style
window description for a complete description of the diﬀerent attributes (Edit
Character Style Window on page 404, Edit Paragraph Style Window on page 405, Edit
List Style Window on page 408, Edit Section Style Window on page 418 or Edit Page
Style Window on page 419).
4. Click Create.

•

Using the corresponding Style menu:
1. Choose Styles from the menu bar.
2. Choose the sub-menu corresponding to the style you've edited (Character Style,
Paragraph Style, Section Style or Page Style).
3. Choose Create new <style type> style where <style type> is replaced by the type of
style you wish to create.

D. Editing a Style
There are two general methods for editing a style in Mellel:
• Using the Document Area: Performing changes to an element in the document area, and
then saving those changes as a new style.
• Using the Edit Style Window: Changing the style directly using its corresponding Edit Style
window.

1. Editing a Style Using the Document Area
To edit an existing style from the document area:
1. Select the element whose style you wish to change.
2. Apply changes to the element's attributes using the corresponding Attributes palette
(Character, Paragraph, List, Section or Page).
3. Do one of the following:

•

Click the Save changes to style button (

•

(Character, Paragraph, List, Section or Page).
Or
Choose Styles from the menu bar, choose the sub-menu corresponding to the style
you've edited (Character Style, Paragraph Style, Section Style or Page Style) and choose
Save changes to <style name> where <style name> is replaced by the name of the
style you've changed.

) from the corresponding Styles palette

2. Editing a Style Using the Relevant Edit Style Window
To edit a style using its relevant Edit Style window:
1. Do one of the following to open the relevant Edit Style window:
• Using the relevant Styles palette:
1) Open the palette corresponding to the style you wish to edit (Character, Paragraph,
List, Section or Page).
2) Click the Styles tab.
3) Choose the style you wish to edit.

Working with Styles | 190

4) Click the Edit style button (

).

Tip: You can also press and hold the Option key while double-clicking a style to edit it.
• Using the corresponding Styles menu:
1) Choose Styles from the menu bar.
2) Choose the sub-menu corresponding to the style you wish to edit (Character Style,
Paragraph Style, Section Style or Page Style).
3) Choose Edit <style name> where <style name> is replaced by the name of the
style applied to the selected document element.
• Using the Style Sets window:
1) Choose Styles > Edit style sets from the menu bar.
2) Click the tab corresponding to the style you wish to edit (Character, Paragraph, List,
Section, Page, Note or Index).
3) Choose the style you wish to edit.
4) Click the Edit style button (

).

Tip: You can also press and hold the Option key while double-clicking a style to edit it.
• Using the Style Well (paragraph and character styles only):
1) Click either the character or paragraph style names to edit them.
The corresponding Edit Style window is displayed.
2. Adjust the style attributes as required. Refer to the corresponding Edit Style window
description for a complete description of the diﬀerent attributes (Edit Character Style
Window on page 404, Edit Paragraph Style Window on page 405, Edit Section Style
Window on page 418 or Edit Page Style Window on page 419).

E. Renaming a Style
To rename an existing style:
1. Edit the style you wish to rename as detailed in Editing a Style on page 190.
2. Use the Style Name text box to insert the new name.
3. Click Save.

F. Setting a Default Style
To set default styles for document templates:
1. Open the template you wish to set a default style for.
2. Choose the style you wish to set as the default style.
3. Save the template.

G. Managing Character Style Variations
1. Editing a Character Style Variation
When editing character styles, changes are only applied to the selected variation. To select a
specific variation for editing:
• Using the Edit Character Style window:
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1. Open the Edit Character Style window by performing one of the instructions sets
described in Editing a Style on page 190).
2. Choose the variation you wish to edit from the Style variations list.
3. Edit the variation as you would any other style (Refer to Edit Character Style Window on
page 404 for a complete description of the diﬀerent options).
4. Click Save.
• Using the Character palette Styles tab:
1. Click the Character palette.
2. Click the Styles tab.
3. Use the Variation popup menu to choose the variation you wish to edit.
4. Edit the variation as you would any other style (Refer to Editing a Style on page 190 for
step-by-step instructions).
Tip: When editing a variation in the Edit Character Style window, click the Reset Variation
(
) button to reset all attributes of the current variation to the base variation attributes, or
click the Reset All Variations button (

) to reset all attributes of all variations to the base

variation attributes.
Note: When making changes to a character style variation, they are only applied to the current
variation and must be manually replicated in other variations (unless it is the base variation
you are editing).

2. Renaming Character Style Variations
By default, the eight character style variations are titled Base and the letters B-H. To rename
the style variations:
1. Choose Mellel > Preferences from the menu bar.
2. Click the General tab.
3. In the Character style variation name box, double-click the variation whose name you wish
to change.
4. Enter a new name for the variation.
Note: Renaming character styles only applies to your own work environment. I.e., when you
send the document to a diﬀerent user they will see their own character style variations names.

H. Deleting a Style
When you delete a style, it is removed from the respective list in the style set.
To delete an existing style:
• Using the corresponding Styles palette:
1. Open the palette corresponding to the style you wish to edit (Character, Paragraph, List,
Section or Page).
2. Click the Styles tab.
3. Choose the style you wish to delete.
4. Click the Delete style button (

•

).

Using the Style Sets window:
1. Choose Styles > Edit style sets from the menu bar.
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2. Click the tab corresponding to the style you wish to delete (Character, Paragraph, List,
Section, Page, Note or Index).
3. Choose the style you wish to delete.
4. Click the Delete style button (

).

I. Assigning a Shortcut to a Style
Assigning shortcuts to styles can save valuable time and improve the user experience. To
assign a shortcut to a character or paragraph style:
1. Choose Styles > Edit style sets from the menu bar.
2. Click the tab corresponding to the style you wish to assign a shortcut to (Character or
Paragraph).
3. Click to the right of the style you wish to assign a shortcut to.
4. Choose the desired shortcut from the popup menu.
Note: You can only assign shortcuts to character and paragraph styles.

J. Repositioning a Style
You can change the order in which styles are displayed in the Style palette, Style menu and in
the Style Sets window. This enables improving the user experience by allowing you to make it
easier to access frequently used styles.
Note: All three above-mentioned lists share the same order of styles.
To reposition a style within the diﬀerent lists:
1. Choose Styles > Edit style sets from the menu bar.
2. Click the tab corresponding to the style you wish to reposition (Character, Paragraph, List,
Section, Page, Note or Index).
3. Click the style you wish to reposition and drag it to its new position.
Tip: If you wish to insert a separator (divider) into any of your styles list, perform the following
instructions:
1. Create a new style, as detailed in Creating a New Style on page 189
2. Rename it to a hyphen (-), as detailed in Editing a Style on page 190
3. Reposition it to the desired position for the separator, as detailed in Repositioning a Style
above.

2. Replacing Styles
One of the most important tasks in text editing is maintaining a consistent appearance and
styling of the text throughout the document. This becomes especially important when
documents are shared across several computers and users, which usually results in the
addition of new styles to the document. Replace Styles is an option that enables you to replace
every paragraph and character styling variation in a document with a style or a style variation
of your choice, thus achieving consistency by using only a limited and well defined set of
styles.
To replace a style:
1. Choose File > Replace Styles from the menu bar.
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The Replace Styles window is displayed (refer to Replace Styles Window on page 425 for a
complete description of the window and its functionalities).
2. Choose the style type (Character or Paragraph) using the style tabs.
3. Choose the style you which to replace from the Used Styles list.
Tip: You can select multiple styles that will be replaced by a single style by holding down the
Cmd (for individual selection) or Shift (for range selection) buttons.
4. Under Replace with use the Style popup menu to choose the new style that will replace the
used style.
5. Click OK.
Tip: Replace styles is an extremely powerful feature and can save hours of tedious style editing
if used wisely. Following are some best practices to help you use this option eﬃciently right
from the start:
• Design first, then replace: Often, it is tempting to start working on a document by
replacing unwanted styles. This method will probably work just fine while replacing the
document regular body text with your own body text, but further on, when you get into the
nitty-gritty stuﬀ of titles and special styles, you will find yourself stuck in the middle, lacking
the proper replacement style for some styles. It is better, therefore, to examine the
document thoroughly and design your styles to cover all possible cases before you actually
start the replacement process.
• Use the source: If you plan to use the existing styles in a document (which may be the case
with a Mellel document received from someone else), try to create new styles based on the
existing document styles. If you stick with the original document style names, the
replacement process will become much easier.
• Associated styles: Many Mellel users associate paragraph and character styles (refer to
Setting an Associated Character Style on page 173 for step-by-step instructions). If you have
created paragraph styles based on existing document paragraph styles, make sure that
those paragraph styles are associated with your own styles, not the document styles, before
you start replacing styles.
• Character styles variations: Many Mellel users associate paragraph and character styles
(refer to Setting an Associated Character Style on page 173 for more information). If you do
this, try to replace the character styles first and only then replace the paragraph styles.
Otherwise, replaced paragraph styles associated with character styles will flatten your
character styles so that they will all be using the base variation.

3. Managing Style Sets
A. Selecting a Style Set
Mellel allows you to change the style set used with a document. This feature is useful, for

example, to change the appearance of the entire document in one fell swoop; to streamline
documents to certain styles; or to switch from a style set used with a document you’ve
received.
To select a style set:
1. Do one of the following to select the style set:
• Using the Style sets window:
1) Choose Styles > Edit style sets from the menu bar.
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2) Choose the desired style set from the Style set list.
3) Click Save.
• Using the Styles menu:
1) Choose Styles from the menu bar and choose the desired style set from the
available options in the style sets area. Refer to Style Sets Area on page 324 for
more information.
2. Choose the desired style matching preference from the popup Style Matching dialoguebox, depicted in the following figure:

Figure 5-18: Style Matching popup

•

Match identical styles: Mellel will match styles that are identical in name and
attributes. Non-identical styles will become document styles.
• Match by style name: Mellel will match styles by their names, ignoring their attributes.
Styles without a matching name will become document styles.
• Match by style attributes: Mellel will match styles by their attributes, ignoring their
names. Styles with attributes that have no exact match in the new style set will become
document styles.
Tip: When to use which preference?
• Matching identical styles is the best choice if you want to switch between sets with
minimal ‘repercussions’, as it will not change the document appearance in any way. Styles
that are identical in every way will replace the styles in the old style set, and the rest will
become document styles and can later be replaced using the Replace Styles feature. This
option is very useful in cases where you’ve created a new style set based on an existing set,
and want to move to the new set smoothly.
• Match by style name is a useful choice when maintaining the document appearance is not
an issue. A typical case can be one where you have a ‘work set’ and a ‘print set’. Both sets have
styles with the same name, but with diﬀerent attributes. The ‘work set’ may have larger text
that is easier to work with when writing, and the ‘print set’ may have the text set to look
better in print.
• Match by style attributes is a powerful streamlining option. It checks to see the attributes
used in the text and minimize the number of styles used as much as possible. This is useful as
part of an import workflow where incoming documents have a similar styling. You can then
base a style set on one such document and use this option to apply the same style set for
any subsequently imported files.

195 | Styling your Document

B. Creating a Style Set
To create a new style set:
1. Choose Styles > Edit style sets from the menu bar.
2. Do one of the following:

•
•

Click the Create New Style Set button (
Click the Duplicate style set button (

) to add a new blank style set.
) to add a copy of an existing style set.

3. Add styles to the diﬀerent tabs. Refer to Creating a New Style on page 189 for step-by-step
instructions.
4. Click Save.
Note: Created style sets are always global (i.e. they are available in all documents in the
current environment).
Note: A style set must have at least one style in each category to be available for selection.

C. Editing a Style Set
To edit an existing style set:
1. Choose Styles > Edit style sets from the menu bar.
2. Choose the style set you wish to edit from the Style set list.
3. Perform any required changes (refer to Managing Styles on page 187 for step-by-step
instructions).
4. Click Save.

D. Locking a Style Set
To lock a style set so that it cannot be edited:
1. Choose Styles > Edit style sets from the menu bar.
2. Click the Lock icon (
lock is closed (

) next to the style you wish to lock in the Style set list. When the

) the style set cannot be edited.

Note: Locking a style set is only available for global style sets.

E. Handling Changes to Style Sets
When you edit and save a style that is part of a global style set, changes are immediately
applied to all open documents and saved into the style set. When you later open another
document that is using the same style set, Mellel needs to know how to handle this document.
That is, whether or not to change the document by applying the changes made to the styles it
uses.
To configure how Mellel handles changes to styles:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Open & Save tab.
3. Use the Changes to styles radio button to choose the desired option:
a. Preserve Document Styles: Ignore any updates to the styles and keep the original
document style set the way it is.
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b. Update Document Styles: Update the document by applying all changes made to the
styles.

F. Deleting a Style Set
To delete an existing style set:
1. Choose Styles > Edit style sets from the menu bar.
2. Choose the style set you wish to delete from the Style set list.
3. Click the Delete style set button (

).

4. Click Save.
Note: Only global document styles can be deleted. Deleted styles remain available as
document style sets in any document that used them prior to their deletion.

G. Renaming a Style Set
To rename an existing style set:
1. Choose Styles > Edit style sets from the menu bar.
2. Choose the style set you wish to rename from the Style set list.
3. Click on the name of the selected style set.
4. Insert the new name.
5. Click anywhere outside the style name to apply the new name.
6. Click Save.

H. Making a Document Style Set Global
To turn document styles into global styles (thus making them available in other documents):
1. Choose Styles > Edit style sets from the menu bar.
2. Choose the document style set you wish to convert into a global style set.
3. Click the Make style set global button (
4. Click Save.
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).

7. Templates
1. What are Templates?
Templates are pre-formatted documents, intended to speed up the creation of commonly
used document types such as letters, fax forms, or envelopes. Templates are also used as
guidelines for creating documents in a specific format (for example, the required format for
submitting a paper to a scientific journal).
Templates in Mellel are simple Mellel files with a unique filename extension (.meltem). When you
open a Mellel template file, Mellel creates a new untitled document which is a duplicate of the
template. This way, you can change the document and save it, without aﬀecting the template,
which will remain unchanged for future use.
Any new Mellel document is created based on a template. Either you select one manually, or
Mellel uses the default template for new documents. Refer to Creating a New Document on
page 19 and Setting the Default Template below for more information.
Mellel oﬀers two types of templates:
• Default Templates: These templates are part of Mellel and cannot be changed.
• Custom Templates: These templates are created by users and can be edited as required.

2. Template Tasks
1. Setting the Default Template
To set the default template that is used when new documents are created:
• Using the Preferences window:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Open & Save tab.
3. Under Default template click the Browse button. The Template Browser is displayed.
4. Choose the template you wish to set as default.
5. Click Choose.
• Using the Save as Template functionality:
1. Open the template you wish to set as default.
2. Choose File > Save as Template from the menu bar.
3. Check the Make Default checkbox.
4. Click Save.

2. Creating a Template
To create a new template, you must first create a document that includes all the features you
want to include in the template (e.g. style sets, auto-title flows setup, page numbers and any
additional settings). Once the document is ready, refer to Saving a Document as a Template on
page 23 for step-by-step instructions for saving the document as a template.
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3. Editing a Template
To edit a template, create a new document based on the desired template (refer to Creating a
New Document on page 19), perform any required changes and follow the instructions
detailed in Saving a Document as a Template on page 23 to save the changes.
By default, the saved template would use the same name and category as the one you've
edited, thus allowing you to overwrite the previous template with your updated one.
Note: You can edit custom templates created by users, but not the default templates shipped
with Mellel.

4. Creating a Template Category
To create a new template category you must save at least one template in it, by following the
instructions detailed in Saving a Document as a Template on page 23. When prompted to
choose a category, perform the following instructions:
1. Use the Category popup menu to choose New Category.
2. Enter a name for the new category.
3. Click OK.
4. Complete the save process.
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8. Advanced Typography
Mellel oﬀers several advanced typography options. Many of these options depend, at this
point, on Mellel’s support of the OpenType technology. To use any of the OpenType features

described below, refer to Using OpenType Features on page 160.

1. Small Caps
Small caps are small capital letters, approximately the size of lower case letters. This is an
example of small caps in Mellel:

Figure 5-19: Mellel Small Caps
As you might note, Mellel is using a set of letters especially designed to be used as small caps,
including special kerning between capital letters and small caps (as with To and Th).
To enable small caps follow the instructions detailed in Using OpenType Features on page 160
and choose one of the following options from the OpenType popup menu in the Character
palette Attributes tab.
• Small Capitals: All letters in the selected text will be converted to small caps.
• Small Capitals from Capitals: Only the capital letters in the selected text will be converted
to small caps, leaving the remaining letters lower cased.
Tip: If you don’t want to use an OpenType font but still need to use Small Caps in your text, you
can apply Mellel’s built in Small Caps character attribute. Refer to Setting Character
Capitalization on page 160 for step-by-step instructions.

2. Fractions
OpenType fractions usually use specially made fraction ligatures for common fractions and
special superscripted numbers for non-common fractions, as shown in the following figure:

Figure 5-20: Fractions Example
To enable fractions follow the instructions detailed in Using OpenType Features on page 160
and choose Fractions from the OpenType popup menu in the Character palette Attributes tab.
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3. Ordinals
Ordinals are automatic and context-sensitive switching of characters from regular type to
superscripted type. Ordinals are usually used to denote numbering schemes, as shown in the
following figure:

Figure 5-21: Ordinals Examples
To enable ordinals follow the instructions detailed in Using OpenType Features on page 160
and choose Ordinal from the OpenType popup menu in the Character palette Attributes tab.
Tip: It is recommended to apply this feature locally rather than globally as part of a style, as
some ordinal combinations also occur in regular text (e.g. Nothing).

4. Swash
Swash characters are styled versions of specific letters, appearing mainly at the start or at the
end of a word, as shown in the following figure:

Figure 5-22: Swash Example
To enable swash follow the instructions detailed in Using OpenType Features on page 160 and
choose Swash from the OpenType popup menu in the Character palette Attributes tab.
Note: Most OpenType fonts only oﬀer Swash alternatives when using the Italic font face.

5. Titling Alternates
Titling alternates are a set of characters designed especially for titles and headings.
To enable titling alternates follow the instructions detailed in Using OpenType Features on
page 160 and choose Titling alternates from the OpenType popup menu in the Character
palette Attributes tab.
Note: Titling alternates are rarely found in ordinary OpenType fonts.

6. Stylistic Alternates
Stylistic alternates are a secondary form of a character, most often used with cursive fonts and
languages to enhance the hand-written look of the font. For example, the following figure
depicts the same Arabic text with and without stylistic alternates:
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Figure 5-23: Arabic Text without (left) and with (right) Stylistic Alternates
To enable stylistic alternates follow the instructions detailed in Using OpenType Features on
page 160 and choose Stylistic alternates from the OpenType popup menu in the Character
palette Attributes tab.

7. Justification Alternates
Justification alternates are used mainly in cursive languages where justification is usually
achieved not by extending the space between the characters but by extending the width of
some characters, as shown in the following example:

Figure 5-24: Arabic text without (top) and with (bottom) Justification Alternates
To enable justification alternates follow the instructions detailed in Using OpenType Features
on page 160 and choose Justification alternates from the OpenType popup menu in the
Character palette Attributes tab.
Tip: When writing fully justified text in Arabic or Farsi, Kashida is most often used (refer to
Enabling Kashida on page 161 for more information). Using Justification alternates instead
seems like a viable alternative, but it is not. Text drawn using Justification alternates alone will
not look good enough, and in many cases the space between characters will be stretched
more than it should be.
The recommended best practice is to enable Kashida and only use justification alternates to
embellish the text or add some special flavor to bits of text.
Justification alternates are more useful when full justification is not activated (e.g., if the text is
simply aligned to the right), to make the text look more alive in such situations.
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Note: This feature is common mainly in Arabic OpenType fonts, but exists in some Hebrew
OpenType fonts as well.

8. Contextual Alternates
Contextual alternates are substitute letter forms that occur only in certain contexts,
depending on the preceding and following letters. This feature is commonly found in some
cursive fonts to achieve a more realistic eﬀect.
To enable contextual alternates follow the instructions detailed in Using OpenType Features
on page 160 and choose Contextual alternates from the OpenType popup menu in the
Character palette Attributes tab.

9. Subscript and Superscript
Superscript/superior and Subscript/inferior are features providing specially designed letters
and numbers that are smaller than regular letters and appear above or below the baseline.
To enable either subscript or superscript follow the instructions detailed in Using OpenType
Features on page 160 and choose Superscript/Superior or Subscript/Inferior from the
OpenType popup menu in the Character palette Attributes tab.
Note: Superscripted characters are usually only supported for all numbers and the following
letters: A a b d e h i l m n o r s t. Subscript characters are usually only supported for all numbers
and punctuation marks.
Note: If you ponder whether to use the superscript and subscript options oﬀered by Mellel (i.e.,
faux superscript and subscript) or those oﬀered in OpenType fonts—simply don’t. OpenType
fonts look much better so should always be used when possible. The following figure provides
an example for the visual diﬀerences:

Figure 5-25: OpenType Superscript (left) versus Faux Superscript (right)
The OpenType version is much more visually appealing and also enjoys correct kerning.

10. Numerator and Denominator
A special set of OpenType characters is used to display numerator and denominator
characters. These characters are diﬀerent from superscripted and subscripted text in their
vertical shift, with the numerator numbers usually located slightly above the x height point
and the denominator numbers located right on the baseline. The following figure shows an
example for numerator and denominator characters:
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Figure 5-26: Numerator and Denominator Example
To enable either numerator or denominator follow the instructions detailed in Using
OpenType Features on page 160 and choose Numerator or Denominator from the OpenType
popup menu in the Character palette Attributes tab.
Note: The numerator and denominator features should only be used with combinations not
supported by the Fractions OpenType feature.

11. Figure Types
The OpenType technology supports four types of figure types:
• Tabular Lining: Equal width and height, as shown in the following figure:

Figure 5-27: Tabular Lining Figures

• Tabular Old Style: Equal width and changing height, as shown in the following figure:

Figure 5-28: Tabular Old Style Figures

• Proportional Lining: Proportional width and equal height, as shown in the following figure:

Figure 5-29: Proportional Lining Figures

• Proportional Old Style: Proportional width and changing height, as shown in the following
figure:
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Figure 5-30: Proportional Old Style Figures
To enable any of the diﬀerent figure features, follow the instructions detailed in Using
OpenType Features on page 160 and choose the desired option (Tabular lining, Proportional
lining, Proportional old style or Tabular old style) from the OpenType popup menu in the
Character palette Attributes tab.

12. Typographer's Quotes
1. What are Typographer's Quotes?
Typographer’s Quotes (also known as Smart Quotes or Curly Quotes) is the use of stylish (curly,
angled, rounded) open and close, primary and alternative quotation marks instead of the
straight quotes found on a keyboard. Typographer’s Quotes are used in books, publications,
magazines, and newspapers, but are less common in email messages, web pages, and letters.
Mellel distinguishes between primary and alternative quotation marks. Primary quotation
marks are used on both ends of a quote, while alternative quotation marks are used to mark a
quote within a quote, as shown in the following example:

Figure 5-31: Primary and Alternative Quotation Marks
Mellel automatically determines which quotation mark to use according to its location in the

text.

2. Typographer's Quotes Tasks
A. Activating Typographer’s Quotes
To use typographer’s quotes in your document:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Typography tab.
3. Check the Activate Typographer’s Quotes checkbox.
4. Use the Type popup menu to choose a quotation marks style.
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Once activated, Mellel will automatically use the selected typographer's quotes characters
instead of the standard straight quotes whenever you type in any quote characters. It will not,
however, change any existing text.
Note: Diﬀerent languages use diﬀerent quotation marks styles.

B. Customizing the Quotation Marks Characters
In some cases it might be required to use special quotation marks to suit a special output
option (HTML, code, spreadsheet, etc.) or for any other reason.
To customize the quotation marks characters:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Typography tab.
3. Check the Activate Typographer’s Quotes checkbox.
4. Use the Open Primary, Close Primary, Open Alternative and Close Alternative text boxes to
enter the custom characters to be used.
For example, in the following figure the quotation marks are replaced by HTML acceptable
characters:

Figure 5-32: Quotation Marks Replaced in HTML Text

C. Overriding Typographer’s Quotes
Mellel automatically determines which quotation mark to use according to its location in the

text. It is not smart enough, however, to detect the correct quotation mark to be used in all
cases. Consider the following example:

Figure 5-33: Problematic Typographer Quotation Mark Example
To correct this, press Ctrl + ' or Ctrl + Shift + ' to insert straight quotes instead of the
typographer’s quotes, as shown in the following figure that will have have Lewis Carroll
chortle with joy:

Figure 5-34: Problematic Typographer Quotation Mark Corrected
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D. Replacing Straight Quotes
Many documents, such as e-mail messages or plain text documents, contain straight quotes
instead of Typographer’s Quotes. You can replace these straight quotes quickly and eﬃciently
using Mellel’s Find and Replace feature. You can save the diﬀerent Find Actions you will create to
run them in the future, and even create a FindSet to run all the find actions automatically, one
by one (refer to Find and Replace on page 209 for more information).
To replace straight quotes with Typographer's quotes:
1. Open the document containing the straight quotes.
2. Choose Edit > Find > Find from the menu bar (or press Cmd + F).
3. In the Find area, choose Whitespace from the Insert menu ( ).
4. Click the whitespace icon (

) and choose Group from the Insert menu ( ).

5. Enter a straight quote (") character after the group.
Note: In steps 4 and 5 you’ve instructed Mellel to find every open double quote that comes
following a space of any sort. This is rather crude, but will fit almost all cases where an open
double quote is required. You can improve this by adding other cases such as adding Em Dash
as another place after which open quotation marks are required.
6. Move to the Replace area, and from the Element menu choose Backreference.
7. Enter your preferred opening double quotation mark after the backreference element.
8. Choose Save Find Action from the Settings menu.
9. Click Replace All.
10. Repeat steps 3 to 9 to replace all open single quotation marks. You should now have all
open straight quotes replaced by your selected typographer's quotes.
11. To complete the process and replace all close double and single quotation marks, enter "
and ' as the strings to find, and ’ and ” (or any other desired close double and single
quotation mark characters) as the strings to replace them.
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Chapter 6

Reviewing and Editing your
Document

1. Find and Replace
1. What is Find and Replace?
The Find and Replace feature allows you to perform both simple and complex searches within
your document, and to modify the search matches as required. This includes basic searches for
defined strings, as well as advanced searches incorporating regular expressions, styling and
manipulating search matches.
A simple search that merely locates the search string in the document is referred to as a Find
Action, while a complex action that also manipulates the search match is referred to as a Find
and Replace action.
To run a Find Action, you need only to define the search expression, which is the text you wish
to find in your document. Now, run the search to let Mellel locate occurrences of the search
expression in your document.
To run a Find and Replace action, you must begin again by defining the search expression, and
then also define the replace expression, which is the element you wish to replace the find
expression with. When you run the Find and Replace action Mellel will locate occurrences of
the search expression in your document, and allow you to replace them with the replace
expression.
You can create a set of Find and/or Find and Replace actions that will be run in sequence with a
single click. These are referred to as Find Sets. Find Sets can be shared between diﬀerent users
and enable reusability, consistency and time saving.

2. Find and Replace Tasks
1. Performing a Basic Find Action
To perform a basic find action:
1. Choose Edit > Find form the menu bar or press Cmd + F.
The Basic Find panel is displayed.
2. Enter the desired search string in the Find text box.
3. Use the Previous (or press Cmd + D) and Next (or press Cmd + G) buttons to cycle
between search matches.
Tip: You can select any text in the document area and choose Edit > Find > Use Selection for
Find from the menu bar or press Cmd + E to use the selection as the search string.
Note: If Previous/Next is selected and there are no more matches until the start/end of the
document, Mellel will sound a beep. The next time the same option is selected, the search will
start again from the top/bottom of the document.

2. Searching for Text with Particular Character Attributes
The basic find action can be configured so that only text that matches the search string and
particular character attributes is returned.
To search for text with particular applied character attributes:
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1. Choose Edit > Find form the menu bar or press Cmd + F.
The Basic Find panel is displayed.
2.
3.
4.
5.
6.

Enter the desired string to find in the Find text box.
Open the Character palette.
Click the Attributes tab.
Place the insertion point in the Find text box.
Apply the diﬀerent attributes you wish to search for.
When any attribute is applied, the Format indicator is changed from its inactive (
active (

) to

) status to indicate that style attributes are applied to the search string.

7. Use the Previous (or press Cmd + D) and Next (or press Cmd + G) buttons to cycle
between search results that match both the search string and the set attributes.
Tip: You can search for any text in the document that includes particular character attributes
by inserting the Anything element from the Insert menu and applying the desired attributes
using the Character palette.

3. Searching for Whole Words
Checking the Whole words checkbox configures the basic find feature so that only whole
words that match the search string are returned.
For example, if you use find as a search expression, Mellel will match find but not finder when
the Whole words checkbox is checked.

4. Considering Capitalization
By default, the Ignore Case checkbox is checked. This means that Mellel ignores capitalization
when searching. For example, if you use Mellel as a search expression, both mellel and Mellel will
be matched when the Ignore Case checkbox is checked.
Uncheck the Ignore Case checkbox to only return results that match the search expression
capitalization exactly.

5. Repeating a Recent Search
Mellel saves all performed find actions and enables you to repeat them without having to

create them manually again.
To repeat a recent basic find action:
1. Choose Edit > Find form the menu bar or press Cmd + F.
The Basic Find panel is displayed.
2. Click the Settings button (

).

3. Choose any of the displayed recent find actions to run it.
Note: The ten (10) recent searches are displayed.

6. Showing the Advanced Find Panel
Perform the following instructions to show the Advanced Find panel:
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1. Choose Edit > Find form the menu bar or press Cmd + F.
The Basic Find panel is displayed.
2. Click the Expand button (

) to show the Advanced Find panel.

The Advanced Find panel is displayed, and the Expand button is replaced by the Shrink
button (
) that can be used to change back to the Basic panel.
Note: If there are certain preferences used in the Advanced panel that cannot be displayed in
the Basic panel (for example, Ignore Diacritics is checked), the Expand button is highlighted in
Red when the Advanced panel is minimized (
).

7. Performing an Advanced Find Action
The main diﬀerence between basic and advanced find actions is that you can search for
regular expressions instead of just searching for plain text.
To perform an advanced find action:
1. Choose Edit > Find form the menu bar or press Cmd + F.
The Basic Find panel is displayed.
2. Click the Expand button (

) to show the Advanced Find panel.

3. Use the Find text box and the Character palette Attributes tab to create simple textual
search strings (as described in Performing a Basic Find Action on page 209 and Searching
for Text with Particular Character Attributes on page 209), or use the adjacent Insert popup
menu ( ) to create complex expressions (refer to Creating Find and Replace Expressions on
page 212 for step-by-step instructions).
4. Use the Search in popup menu to limit the search to particular elements in the document
(optional).
5. Use the Previous (or press Cmd + D) and Next (or press Cmd + G) buttons to cycle
between search matches.
Tip: You can create powerful and intelligent advanced find actions with proper use of search
expressions. Refer to Creating Find and Replace Expressions on page 212 and Find and
Replace Expression Elements on page 283 to learn more about available options.

8. Performing a Find and Replace Action
The Advanced Find panel allows you to replace search matches with a diﬀerent regular
expression or simple text string. This enables you to quickly and eﬃciently edit your
documents and fix common errors.
To perform a find and replace action:
1. Follow the instructions in Performing an Advanced Find Action above to define your
search expression.
2. Use the Replace text box and the Character palette Attributes tab to create simple textual
replacement strings (as described in Performing a Basic Find Action on page 209 and
Searching for Text with Particular Character Attributes on page 209), or use the adjacent
Insert popup menu ( ) to create complex expressions (refer to Creating Find and Replace
Expressions on page 212 for step-by-step instructions).
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3. Do one of the following:
• To replace individual results: Use the Previous and Next buttons to cycle between find
results, then click the Replace button to replace the current match with the replace
expression.
• To replace all results: Click the Replace All button to replace all matched find results
with the replace expression.
Tip: Click the Replace & Find button to replace the current match and immediately find the
next one.

9. Creating Find and Replace Expressions
Find and replace expressions are used to locate complex textual patterns or combination of
characters. Find and replace expressions can include the following elements:
• Literal Text: Simple text strings.
• Special Elements: Can be used to locate certain patterns such as Any Character, Word
boundary, and others (refer to Find and Replace Expression Elements on page 283 for a
complete description of the diﬀerent special elements and their usage).
• Groups: Text and special elements can be joined into groups within the expression. Groups
can be referred to in the replace expression to enable complex Find and Replace actions.
• Or: This special token is used to enable multiple options within the expression. When it is
inserted, Mellel would look in the text for either of the expressions on both sides of the Or
token.
To create a find/replace expression, perform the following instructions:
1. Place the insertion point in the Find/Replace text box.
2. Do one of the following:
• Type in any text to add literal text to the expression.

•

Use the Insert ( ) popup menu to enter any Special Element or the Or token into the

•

expression.
Select any existing elements in the Find/Replace text box and choose Group from the
Insert popup menu ( ) to group them together. Once created, groups can be referred

to in the replace expression to enable complex Find and Replace actions.
3. Double-click any Special Element or Group to edit their repetition attributes (refer to Find
and Replace Expression Elements on page 283 for a complete description of the diﬀerent
attributes).

10. Saving Find and Replace Expressions
To save commonly used find and replace expressions:
1. Select the expression in the find/replace text box.
2. Use the Insert ( ) popup menu to choose Add Selection to Menu.
3. The Save Custom Find Expression dialogue-box is displayed.
4. Enter a name for the new find expression.
5. Click OK.
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Saved expressions are available in the Insert popup menu across all documents.

11. Setting the Search Start Point
Checking the From Beginning checkbox configures configures advanced find actions so that
the search is performed from the beginning of the document rather than the insertion point.
Note: This feature is only available for advanced find actions.

12. Ignoring Diacritics
Checking the Ignore Diacritics checkbox configures advanced find actions to ignore accents
and diacritical marks in the text.
For example, if you use fruit as the search expression then fruit, fruït and früit will all be
matched when Ignore Diacritics is checked. This feature also applies to vowel marks in Arabic,
Hebrew, or any other language that uses them.
Note: This feature is only available for advanced find actions.

13. Managing Find Actions
Find Actions are saved find and replace actions. They include the Find and Replace expressions
as well as all other search settings such as Whole Words, Ignore Case etc.. Mellel allows you to
save find and replace actions, load them when you want to reuse them, edit those actions,
overwrite them, and even create Find Sets—sets of one ore more Find and Replace actions
you can run sequentially.

A. Running a Find Action
To load an existing find action and run it:
• Using the Advanced Find and Replace panel:
1. Choose Edit > Find form the menu bar or press Cmd + F. The Basic Find panel is
displayed.
2. Click the Expand button (
) to show the Advanced Find panel.
3. Click the Settings button (

).

4. Choose Load Find Action. The Load Find Action dialogue-box is displayed, as shown in
the following figure:
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Figure 6-1: Load Find Action dialogue-box

•

1. Use the Find Set popup menu to only show find actions from the selected find set, or
choose None to show all find actions.
2. Choose the desired find action from the list.
3. Click Load.
4. Use the Replace All, Replace & Find, Replace, Previous or Next buttons to use the
loaded Find Action, as described in Performing a Find and Replace Action on page 211.
Using the Find Set window:
1. Choose Edit > Find > FindSet from the menu bar, or press Cmd + Shift + F to open the
Find Set window.
2. Locate and select the Find Set that includes the desired Find Action in the Find Sets list.
If you are not sure what Find Set includes the desired Find Action, choose All Actions.
3. Locate and select the desired Find Action in the Find Actions list by either scrolling
through the list or using the search box at the bottom of the list.
4. Click Run to run the selected Find Action in Replace All mode on the active document.
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Note: When using the Find Set window, you can choose a Find Action and click the Open in
Panel button (
) to load the selected Find Action into the Advanced Find and Replace panel
and run it in modes other than Replace All.

B. Creating a Find Action

To create a new Find Action:
•

Using the Advanced Find and Replace panel:
1. Choose Edit > Find form the menu bar or press Cmd + F. The Basic Find panel is
displayed.
2. Click the Expand button (
) to show the Advanced Find panel.
3. Create your advanced find and replace action as detailed in Performing an Advanced
Find Action on page 211 and Performing a Find and Replace Action on page 211.
4. Click the Settings button (

).

5. Choose Save Find Action As. The Save Find Action dialogue-box is displayed, as shown
in the following figure:

Figure 6-2: Save Find Action dialogue-box

•

6. Use the Find Set popup menu to save the Find Action as part of en existing Find Set, or
choose None to save it without associating it with any Find Set.
7. Use the Name text box to enter a name for the saved find action.
8. Click Save.
Using the Find Set window:
6. Choose Edit > Find > FindSet from the menu bar, or press Cmd + Shift + F to open the
Find Set window.
7. If you wish to create the new Find Action as part of a Find Set, choose the desired Find
Set from the Find Sets list.
8. Click the Add Find Action button (
Find Action list.
9. Enter a name for your new Find Action.
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). A new untitled Find Action is added to the

10. Use the Find Action Details area to create your Find Action, using the same
functionalities described in Performing an Advanced Find Action on page 211 or
Performing a Find and Replace Action on page 211.
11. Use the Comment text box to add any comments to the Find Action, such as its purpose
or recommendations on how to use it.
12. Click the Save button (

).

Note: Rather than creating an empty Find Action, you can duplicate an existing one by
choosing it from the Find Actions list and clicking the Duplicate Find Action button ( ).

C. Editing a Find Action
To edit an existing Find Action:
• Using the Advanced Find and Replace panel:
1. Choose Edit > Find form the menu bar or press Cmd + F. The Basic Find panel is
displayed.
2. Click the Expand button (
) to show the Advanced Find panel.
3. Load the desired Find Action, as described in Creating a Find Action on page 215.
4. Perform any required changes, as detailed in Performing an Advanced Find Action on
page 211 and Performing a Find and Replace Action on page 211.
5. Click the Settings button (

•

).

6. Choose Save Find Action.
Using the Find Set window:
1. Choose Edit > Find > FindSet from the menu bar, or press Cmd + Shift + F to open the
Find Set window.
2. Locate and select the Find Set that includes the desired Find Action in the Find Sets list.
If you are not sure what Find Set includes the desired Find Action, choose All Actions.
3. Locate and select the desired Find Action in the Find Actions list by either scrolling
through the list or using the search box at the bottom of the list.
4. Use the Find Action Details area to perform any required changes, using the same tools
described in Performing an Advanced Find Action on page 211 or Performing a Find
and Replace Action on page 211.
5. Click the Save button (

).

Note: When editing a Find Action using the Find Sets window, press the Reset button (
any time to discard your changes and load the original Find Action.

) at

14. Managing Find Sets
Find Sets are collections of Find Actions that you can run sequentially. When you run a Find
Set, all the Find Actions that are included in it are run in sequence. Mellel allows you to create
Find Sets, save them, and run them.
There are three important things to note about Find Sets:
• Find Sets are run sequentially, from the first Find Action in the list to the last one.
• Running a Find Set means that you perform Replace All for every Find Action in it.
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• Find Actions are not contained in a Find Set but only referenced by it. This means that one
Find Action can be referenced by more than one Find Set, and that changes to Find Actions
are reflected in the Find Set when it is run. That is, if you edit, change, or delete a Find Action,
the changes you make will aﬀect all the Find Sets that reference it.

A. Running a Find Set
To run a find set:
1. Choose Edit > Find > FindSet from the menu bar, or press Cmd + Shift + F to open the Find
Set window.
2. Choose the set you wish to run from the Find Sets list at the left side of the window.
3. Click the Run button (

).

All the Find Actions in the selected Find Set will run in sequence in Replace All mode. Status for
the diﬀerent find actions is shown in the log area, as shown in the following figure:

Figure 6-3: Run Find Set Status
Each find action is indicated by its name. the time when it started running, and the number of
changes it had resulted in. When the find action is completed, it is indicated by a green tick.

B. Creating a Find Set
To create a new find set:
1. Choose Edit > Find > FindSet from the menu bar, or press Cmd + Shift + F to open the Find
Set window.
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2. Click the Add Find Set button (

).

A new Untitled find set is added o the Find Set list.
3. Enter a name for your new find set.
Tip: Choose an existing Find Set, then click the Settings button (
) followed by Duplicate
Find Set to duplicate an existing Find Set instead of creating an empty one.

C. Editing a Find Set
To edit an existing Find Set:
1. Choose Edit > Find > FindSet from the menu bar, or press Cmd + Shift + F to open the Find
Set window.
2. Do one of the following to add find actions to the Find Set:
• Drag a Find Action from any existing Find Set into another.
Or

•

Choose the Find Set you wish to edit, then click the Add Find Action button (
) to
create a new Find Action in the Find Set. An empty find action is added to the find
actions list, allowing you to edit it using the same tools available in the Advanced Find
Panel.

D. Deleting a Find Set
To delete a Find Set:
1. Choose Edit > Find > FindSet from the menu bar, or press Cmd + Shift + F to open the Find
Set window.
2. Choose the Find Set you wish to delete.
3. Click the Settings button (

).

4. Do one of the following:
• Choose Delete Find Set to delete the selected Find Set, but not the Find Actions in it.
• Choose Delete Find Set and Actions to delete the selected Find Set and all the Find
Actions in it.
Note: Choosing Delete Find Set and Actions deletes all the Find Actions that are referenced
by the deleted Find Set, which means that they will be removed from all other Find Sets that
have referenced the deleted Find Actions as well.

E. Exporting a Find Set
To export an existing Find Set as a file (thus enabling sharing it with other users on other
computers):
1. Choose Edit > Find > FindSet from the menu bar, or press Cmd + Shift + F to open the Find
Set window.
2. Choose the Find Set you wish to export.
3. Click the Settings button (

).

4. Choose Export Find Set to file.
5. Enter a location and a name for your exported File Set file.
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6. Click Save.
The selected Find Set is exported as a .pfs file, and can now be imported by other users.

F. Importing a Find Set
To import an external Find Set to use in your documents:
1. Choose Edit > Find > FindSet from the menu bar, or press Cmd + Shift + F to open the Find
Set window.
2. Click the Settings button (

).

3. Choose Import Find Set from file.
4. Locate and select the Find Set file (with a .pfs extension).
5. Click Open.
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2. Track Changes
1. What is Track Changes?
The track changes feature enables you to track changes in the document, so that you can
review those changes and decide if you want to accept them (incorporate them in the
document) or reject them (discard the change). Track changes is a useful feature if you work in
collaboration with others and need to review their changes.
Tracked changes are displayed in bubbles in the Annotations Pane, to the left of the document
area. The following figure depicts a tracked change and the diﬀerent information it includes:

• Location Arrow: Points at the document location where the change was made.
• User (Mellel): Indicates the user who performed the change. The user is also indicated by the
bubble background colour.
• Time Stamp (20 Apr 2017, 11:09): Indicates when the change was made.
• Changes Details (Insert: <Paragraph Break>): Details the type of change (Insert, Delete or
Style) and the details (what was inserted/deleted or what attributes were changed).
Not all the changes you make in a document are tracked. As a useful rule of thumb, Mellel will
track just about any editing or styling change, but it will not track changes to saved styles. The
following table details what changes are tracked:
Table 6-1: Tracked and Untracked Changes
Tracked Changes

Untracked Changes

Any text editing

Changes to style sets

Changes to paragraph attributes

Changes to note styles

Changes to character attributes

Changes to Auto-titles flow setup

Changes to section attributes

Scanning/unscanning of bibliography

Changes to page attributes

Changes to floating Images

Changes using find and replace
Changes to tables text
Changes to Auto-titles
Changes to citations
Replacing Styles
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2. Track Changes Tasks
1. Activating Track Changes
To activate track changes, Do one of the following:

• Click the Changes icon (

) in the toolbar.

Or
• Choose Edit > Track Changes > Activate Track Changes from the menu bar.
Or
• Press Ctrl + Cmd + T.
The Track Changes Bar is displayed, and changes are now tracked.
Note: Repeat the same instructions to deactivate tracked changes. When deactivating track
changes, Mellel prompts you to decide how to handle current changes with the following
dialogue-box:

Figure 6-4: Deactivating Track Changes

• Cancel: Closes the dialogue-box without deactivating track changes.
• Reject All Changes: Rejects all changes and deactivates track changes.
• Accept All Changes: Accepts all changes and deactivates track changes.
If you only wish to momentarily pause tracking changes without rejecting or accepting all
changes, refer to Pausing Track Changes on page 222.

2. Showing/Hiding the Annotation Pane
The annotations pane is located to the left of the document area, and is used to display any
tracked changes, as well as comments added to the document. You can show/hide the
annotation pane by doing the following:
1. Activate track changes (refer to Activating Track Changes above for step-by-step
instructions).
2. Use the Show/Hide Annotations Pane button (

) in the Track Changes bar to toggle

between showing and hiding the pane.
When the pane is shown, it will show tracked changes. When it is hidden, tracked changes are
marked in the document area using grey (style changes) or black (text changes) vertical lines.
Note: When the annotations pane is shown, it will be included with the document when it is
printed or exported. This means that the document view is scaled down to allow room for the
pane to be displayed.
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3. Setting The Track Changes Display Mode
To set the display mode for showing tracked changes:
1. Activate track changes (refer to Activating Track Changes on page 221 for step-by-step
instructions).
2. Use the Display mode popup menu in the Track Changes bar to choose the desired option.
Refer to Track Changes Bar on page 331 for a complete description of the diﬀerent options.

4. Pausing Track Changes
To momentarily pause tracking changes without disabling the function completely:
1. Activate track changes (refer to Activating Track Changes on page 221 for step-by-step
instructions).
2. Do one of the following:

•

Use the Pause button (

•

Or
Press Ctrl + Cmd + P.

) in the in the Track Changes bar.

Track changes is paused, and the Pause button is highlighted in red (

).

Note: Repeat the same instructions to resume tracking changes.

5. Accepting/Rejecting Changes
When reviewing tracked changes, you can determine whether to accept them (incorporate
them in the document) or reject them (discard the change).
To accept/reject changes:
1. Show the Annotations Pane (refer to Showing/Hiding the Annotation Pane on page 221 for
step-by-step instructions).
2. Locate the change you wish to accept/reject in the Annotations Pane.
3. Do one of the following:

•
•
•

Hover over the change bubble and click either the Accept (

) or Reject (

)

buttons.
Or
Select the change bubble and then choose either Edit > Track Changes > Accept
Change or Edit > Track Changes > Reject Change from the menu bar.
Or
Select the change bubble and press either Ctrl + Cmd + N to accept the change or Ctrl
+ Cmd + O to reject it.

6. Filtering Displayed Changes by Author
When multiple authors are working on the same document, you can filter the tracked changes
to only display changes made by a specific author.
To filter displayed changes by author:
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1. Activate track changes (refer to Activating Track Changes on page 221 for step-by-step
instructions).
2. Use the Author popup menu in the Track Changes bar to choose the desired author.
Note: Repeat the same instructions and choose All from the Author popup menu to display all
tracked changes.

7. Changing Author Name and Colour
Mellel indicates what user made the change by using diﬀerent author names and colours. To

configure your own author name and colour:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Document Setup tab.
3. Use the User Name text box to enter your preferred author name.
4. Use the User Colour popup menu to set the colour that will indicate your changes.
Note: Changes will only take eﬀect the next time you activate track changes, and will not
aﬀect any existing tracked changes.

8. Navigating between Changes
To navigate between tracked changes:
1. Show the Annotations Pane (refer to Showing/Hiding the Annotation Pane on page 221 for
step-by-step instructions).
2. Do one of the following:

•

Click the Previous Change (

) or Next Change (

) buttons in the Track Changes

bar.
Or
• Choose Edit > Track Changes > Next Change or Edit > Track Changes > Previous
Change from the menu bar.
Or
• Press Ctrl + Cmd + ↓ to navigate to the next change or Ctrl + Cmd + ↑ to navigate to
the previous change.
Note: If a specific author is selected (refer to Filtering Displayed Changes by Author on page
222 for more information), performing the above instructions would only navigate between
changes made by the selected author.

9. Viewing Hidden Changes
When there are many tracked changes in the same section of the document, it might not be
possible to display them all in the Annotations Pane. In such cases, navigation buttons appear
at the bottom part of the Annotations pane, allowing you to scroll between the diﬀerent
changes, as shown in the following figure:
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Figure 6-5: Annotation Pane Navigation Buttons

10. Exporting Tracked Changes in a PDF
When Mellel documents with tracked changes are exported as PDF documents, the changes
can be exported as well. Refer to Exporting as PDF on page 27 for step-by-step instructions.

3. Collaborating Using Tracked Changes
Track changes is a valuable tool for collaboration, and its main features are tailored to working
in collaboration with others and adhere to the accepted ‘lingo’ and terms of track changes
elsewhere. The following list includes some best practices to follow when using track changes
for collaboration:
1. If you’re used to making changes in your document via changing styles in Mellel, you
should consider the fact that changes to styles are not tracked. Perform stylistic
manipulations directly (i.e., change the text to bold manually instead of switching styles).
2. Changes in floating images, or changes in table structure (except for the text in the table)
are not recorded. If you make changes to those, make note of the change so your
collaborator will know what happened.
3. If you’re working with someone using Mellel, you can collaborate making changes to the
same manuscript saved on a remote disk—your respective changes will be saved under
your name and you’ll be able to filter out your changes while working on changes made by
the other party.
4. If you prefer to make changes without seeing them (a method common to manny editors)
simply hide the Track Changes pane and work in Final display mode. This will keep the
visual hassle of tracking changes to a minimum.
5. When sending a manuscript with changes to a person working with MS Word, save the file
as a RTF or in Word format and request the person at the other end to save them as RTF
before sending them to you. It’s also a good thing if that person makes the changes in
styling ad-hoc.
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3. Comments
1. What are Comments?
Comments are side notes that can be added to a document. They are not part of the
document text and do not aﬀect its layout in any way. Comments appear in the Annotations
pane, alongside tracked changes, as shown in the following figure:

Figure 6-6: Example Comment

• Location

Arrow: Points at the document location where the comment was added.
Comments can be added to specific points in the text or to a wider selection.
• User (Avner Matan): Indicates the user who added the comment. The user is also indicated
by the comment's background colour.
• Time Stamp (20 Apr 2017, 13:12): Indicates when the comment was added.
• Comment Content (I believe this paragraph makes no sense): Includes the comment text as
inserted by the user.
Note: It is not required to activate track changes to view, add or delete comments. Though
both comments and tracked changes are displayed via the Annotations Pane, they are
completely independent features.

2. Comments Tasks
1. Adding a Comment
To add a new comment:
1. Select the document element on which you want to comment.
2. Perform any of the following:

•

Click the Comment icon (

) in the toolbar.

Or
• Choose Edit > Comment > Add Comment from the menu bar.
Or
• Press Cmd + K.
A new empty comment is added, allowing you to insert text into it.
3. Add content to the comment just as you would add text to the document area.
4. Click anywhere outside the comment.
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2. Editing a Comment
To edit an existing comment:
1. Click anywhere inside the comment's bubble.
2. Perform the required changes just as you would edit text in the document area.
3. Click anywhere outside the comment.
Note: The timestamp shown in the comment would always show the comment creation time,
not its most recent edit time.

3. Deleting a Comment
To delete an existing comment:
1. Hover your cursor over the comment you wish to delete.
2. Click the Delete Comment button (

).

Tip: To delete all the comments in the document, choose Edit > Comment > Delete all
Comments from the menu bar.

4. Navigating Comments
Do one of the following to navigate between comments:
• Choose Edit > Comment > Previous Comment or Edit > Comment > Next Comment from
the menu bar.
Or
• Press Shift + Cmd + , to navigate to the previous comment or Shift + Cmd + . to navigate to
the next comment.

5. Showing/Hiding the Annotations Pane
Do one of the following to show/hide the Annotations pane:
• Choose View > Annotations Pane from the menu bar.
Or
• Press Option + Cmd + O.
Note: The Annotations pane is automatically shown when a new comment is added.
Note: When the annotations pane is shown, it will be included with the document when it is
printed or exported. This means that the document view is scaled down to allow room for the
pane to be displayed.

6. Setting Comments Character Attributes
You can apply character attributes to comments just like you would to any other text in the
document area by selecting text inside the comment bubble and select any attributes from
the Character palette. Refer to Character Formatting on page 157 for more information.
To set the default character attributes for comments:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Document Setup tab.
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3. Use the popup menu in the Comment Character Attributes area to open a character
attributes panel and apply and desired attributes. Refer to Character Formatting on page
157 for more information.

7. Setting User Name
Mellel indicates what user added which comment by using diﬀerent user names. To configure

your own user name:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Document Setup tab.
3. Use the User Name text box to enter your preferred user name.
4. Use the User colour popup menu to set the colour that will indicate your comments.
Note: Changes will only take eﬀect the next time you add a comment, and will not aﬀect any
existing comments.

8. Exporting Comments in a PDF
When Mellel documents with comments are exported as PDF documents, the comments can
be exported as well. Refer to Exporting as PDF on page 27 for step-by-step instructions.
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4. Sorting
1. What is Sorting?
Sorting allows you to select text elements or tables in your document and sort them in a
particular order. It can be used for simple ordering of paragraphs in ascending or descending
order, or for more complex and delicate sorting tasks.

2. Sorting Tasks
1. Basic Sorting
Basic sorting it used to sort the selected elements alphabetically in ascending or descending
order. Elements that can be sorted this way include paragraphs and tables.
To perform basic sorting:
1. Select the elements you wish to sort.
2. Choose Edit > Sort > Sort Ascending or Edit > Sort > Sort Descending from the menu
bar.
Note: When sorting data in tables, you can either select individual rows or columns, parts of
individual rows or columns, or the entire table.

2. Advanced Sorting
Advanced sorting allows further configuration of the sorting logic to enable complex sorting
options and functionalities. Elements that can be sorted using advanced sorting includes
paragraphs, sections and words.
To perform advanced sorting:
1. Select the elements you wish to sort.
2. Choose Edit > Sort > Advanced Sort from the menu bar.
3. Use any of the following options to define your advanced sorting:

•
•
•

Use the Sort order buttons to sort by Ascending (

) or Descending (

) order.

Use the Sort By popup menu to set the elements to sort by.
Use the Sort Method popup menu to choose whether to sort alphabetically or
numerically, and the adjacent Language popup menu to choose the language to sort
alphabetically by.
• Use the Secondary Sorting, Ignoring Words when Sorting on page 230 and Ignoring
Enclosed Text on page 230 (see below for a complete description and step-by-step
instructions) options for fine tuning your sorting.
4. Click Sort.
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3. Secondary Sorting
You can use secondary sorting to sort elements that include multiple levels. This means that
items on the same level are sorted amongst themselves, but are kept as one group. For
example, the following list includes two levels - one that includes the category (Vegetables
and Fruits) and one that includes diﬀerent items within those categories (Banana, Apple,
Tomato, etc.):

Figure 6-7: Unsorted List Example
Using secondary sorting, you can first sort the groups alphabetically (so Fruits should come
before Vegetables), and then also sort all the items within each group, while keeping them
separated under Fruits and Vegetables, as shown in the following figure:

Figure 6-8: Sorted List Example
To use secondary sorting, you must define a prefix that distinguishes the diﬀerent levels. In our
example, the prefix was a tab, but it can be any custom character you choose.
To use secondary sorting:
1. Select the elements you wish to sort. Make sure they include at least two distinguished
levels.
2. Choose Edit > Sort > Advanced Sort from the menu bar.
3. Check the Secondary sort checkbox.
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4. Use the Secondary item Prefix popup menu to set the prefix that distinguishes the
diﬀerent levels.
5. Click Sort.
Note: Secondary sorting is recursive. That is, items prefixed by two tabs will be considered
(and sorted as) items of the third level, items prefixed by three tabs will be considered fourth
level items, and so on.

4. Ignoring Words when Sorting
You can configure Mellel to ignore certain words when sorting. This is useful when you want to
ignore common prefixes such as the, On, A, and An.
To set words that will be ignored when sorting:
1. Select the elements you wish to sort.
2. Choose Edit > Sort > Advanced Sort from the menu bar.
3. Check the Sort ignoring checkbox.
4. Click the Add button (

).

5. Enter the word to be ignored.
6. Click Sort.
Note: Any word added to the list will be ignored in all subsequent advanced sorting actions.
To remove a word from the list, choose it and then click the Delete button (
).

5. Ignoring Enclosed Text
You can configure Mellel to ignore text enclosed by certain characters (such as parenthesis or
brackets) when sorting. This is useful in the following cases:
• When you want to ignore a word without adding it to the ignored words list.
• In some languages when a prefix letter (or letters) is common but the letter may also be part
of a word in other cases.
To ignored text enclosed in certain characters:
1. Select the elements you wish to sort. Make sure the text you wish to ignore is enclosed in
the correct characters.
2. Choose Edit > Sort > Advanced Sort from the menu bar.
3. Check the Ignore text enclosed by checkbox.
4. Use the adjacent popup menu to choose the characters that enclose the text to be
ignored.
5. Click Sort.
Tip: Check the Remove enclosing after sort checkbox to remove the enclosing characters
after sorting is complete, so they do not appear in the sorted text.

6. Repeating the Previous Sorting
When performing the same sorting action repeatedly, you can choose Edit > Sort > Repeat
last Sort to apply the last performed sort to the selected elements.
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5. Spell Checking
1. What is Spell Checking?
Spell checking is the ability to automatically scan a document, locate spelling errors and
suggest possible corrections. Mellel allows you to check spelling in your documents using the
spell checkers built into macOS, third party spelling services and other spell checkers. Mellel is
also compatible with a variety of third party free, shareware and commercial thesauri.
Usually, checking spelling in your document is preformed automatically as you type, and
based on the language you use. However, you can adjust those preferences to meet any
special requirements.
Words recognized as spelling errors are highlighted in red, as shown in the following figure:

Figure 6-9: Spelling Error Indication

2. Spell Checking Tasks
1. Checking Spelling
A. Checking Spelling in the Entire Document
To check spelling in your entire document:
• To check for spelling without using the Spelling and Grammar window, choose Edit >
Spelling > Check Spelling in Document from the menu bar. Any word that is not found in
the spelling dictionary will be highlighted in red (as shown in Figure 6-9 above), allowing
you to handle it as detailed in Handling Spelling Errors on page 232.
Or
• To check for spelling using the Spelling and Grammar window, choose Edit > Spelling >
Spelling from the menu bar or press Cmd + Shift + ;. The Spelling and Grammar window is
displayed, allowing you to navigate and handle spelling errors in your document, as
detailed in Handling Spelling Errors on page 232.

B. Checking Spelling in Selected Text
To check spelling only in part of the texts:
1. Select the text you wish to spell check.
2. Choose Edit > Spelling > Check Spelling in Selection from the menu bar.
Any word in the selected segment that is not found in the spelling dictionary will be
highlighted in red (as shown in Figure 6-9 above). Refer to Handling Spelling Errors on page
232 for more information on handling identified spelling errors.
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C. Checking Spelling in Real Time
To configure Mellel to continuously check spelling in real time as you type, choose Edit >
Spelling > Check Spelling As You Type from the menu bar.
Mellel will spell check every word in real time when it is completed (i.e. after pressing the Space
key), and highlight any word that is not found in the spelling dictionary in red (as shown in
Figure 6-9 on page 231). Refer to Handling Spelling Errors below for more information on
handling identified spelling errors.

D. Checking Spelling Per Paragraph
To configure Mellel to check spelling whenever you complete a paragraph choose Edit >
Spelling > Check Spelling Per Paragraph from the menu bar.
Mellel will spell check every paragraph after a new paragraph is created (i.e the Return key is
pressed), and highlight any word that is not found in the spelling dictionary in red (as shown in
Figure 6-9 on page 231). Refer to Handling Spelling Errors below for more information on
handling identified spelling errors.

E. Disabling Spell Check
To disable spell checking in the document, choose Edit > Spelling > Don't Check Spelling
from the menu bar, or press Option + Cmd + ;.
Disabling spell check removes all the spelling errors highlights from the text.

2. Handling Spelling Errors
A. Navigating Spelling Errors
To navigate between words highlighted as spelling errors in your document:
• Using the menu bar:
1. Choose Edit > Spelling > Check Spelling from the menu bar.
• Using the keyboard:
1. Press Cmd + ;.
• Using the Spelling and Grammar window:
1. Choose Edit > Spelling > Spelling from the menu bar or press Cmd + Shift + ; to open
the Spelling and Grammar window.
2. Click Find Next to ignore the spelling error and move to the next one.

B. Correcting Spelling Errors
To correct a spelling error:
• Using the right-click menu:
1. Right-click the spelling error.
2. Choose one of the suggested options on top of the right-click menu to replace the
misspelled word with the selected suggestion.
• Using the Spelling and Grammar window:
1. Choose Edit > Spelling > Spelling from the menu bar or press Cmd + Shift + ; to open
the Spelling and Grammar window.
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2. Choose a suggestion from the suggestion box.
3. Click Change to replace the spelling error with the selected suggestion.

C. Ignoring Spelling Errors
You can set the spell checker to ignore a certain word or string that is not included in the
dictionary, and to stop treating it as a spelling error. Ignore is document specific, and is useful
when you have unique words or acronyms that are commonly used in one document.
To ignore a spelling error:
• Using the right-click menu:
1. Right-click the spelling error.
2. Choose Ignore Spelling to ignore the spelling error.
• Using the Spelling and Grammar window:
1. Choose Edit > Spelling > Spelling from the menu bar or press Cmd + Shift + ; to open
the Spelling and Grammar window.
2. Click Ignore to ignore the spelling error.
The word will no longer be marked as a spelling error in the current document.

D. Adding Words to the Dictionary
While the Ignore functionality stops marking a certain word as a spelling error within a specific
document, in some cases it is required to add a word to the spelling dictionary so that Mellel
does not mark it as a spelling error in any document (and in any other application that is using
the same spelling dictionary).
To add a word highlighted as a spelling error into the dictionary:
• Using the right-click menu:
1. Right-click the spelling error.
2. Choose Learn Spelling to add the word to the dictionary and prevent it from being
identified as a spelling error in the future.
• Using the Spelling and Grammar window:
1. Choose Edit > Spelling > Spelling from the menu bar or press Cmd + Shift + ; to open
the Spelling and Grammar window.
2. Click Learn to add the word to the dictionary and prevent it from being identified as a
spelling error in the future.

E. Defining Words
To define words using the set macOS dictionary:
1. Right-click the word you wish to define.
2. Choose Look Up in Dictionary.
Note: Mellel supports a variety of thesauri, including the macOS X built-in Thesaurus
Dictionary. Other third-party thesauri include several free thesauri based on Word-Net and
several commercial thesauri.
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3. Configuring Spell Check
A. Selecting Spelling Dictionary
Mellel selects which spelling dictionary to use based on the language assigned to the text

(refer to Assigning Languages to a Text on page 162 for more information). To select which
spelling dictionary is used with a particular language:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Language tab.
3. From the Language list, choose the language you wish to set a spelling dictionary for.
4. Use the Spelling Language popup menu to choose the spelling dictionary that will be used
with that language.
Note: By default, no languages are assigned to any text in the document. This means that the
language is detected automatically and the relevant dictionary is used. If you want to use a
diﬀerent dictionary, you must assign the relevant language to the text, as detailed in Assigning
Languages to a Text on page 162.

B. Synchronizing Language and Keyboard Layout
Mellel associates each keyboard layout with a language to ease the language assignment

process (refer to Assigning Languages to a Text on page 162 for step-by-step instructions for
assigning a language to a text). Once synchronized, whenever you switch to a certain
keyboard layout, Mellel will automatically assign the language (and the corresponding spelling
dictionary) to the typed text.
To synchronize a language with a keyboard layout:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Language tab.
3. From the Language list, choose the language you wish to synchronize.
4. Use the Associated Keyboard Layout popup menu to choose the associated keyboard
layout.
5. Check the Synchronize Language and Keyboard checkbox.

Spell Checking | 234

6. Markers
1. What are Markers?
Markers allow you to mark any element in your document, similar to a real-life highlight
marker. You can easily and quickly navigate between marked segments of your documents
without relying on having to visually locate the markers. Mellel includes eight (8) default
marker colours, which allows great flexibility in using markers for diﬀerent purposes. You can
also change the default markers colours and names as required.
The following figure shows an example for using markers in a text:

Figure 6-10: Marked Text Example
Note: Markers are not part of the character attributes, and are not designed to style your
document bur rather as a way to mark text while working on the document. To use text
highlighting as a character attribute, refer to Setting Character Background Fill on page 158,

2. Markers Tasks
1. Marking Text
To mark text in the document:
1. Select the element you wish to mark.
2. Do one of the following:
• Using the Markers palette:
1) Click the Markers palette.
2) Choose the marker colour you wish to apply.
3) Click the Apply button (

•

•
•

) or double-click the desired colour.

Using the right-click menu:
1) Right click on the selected text.
2) Choose Mark from the right-click menu.
3) Choose the marker colour you wish to apply.
Using the Marker sub-menu:
1) Choose Edit > Markers from the menu bar.
2) Choose the marker colour you wish to apply.
Using the keyboard:
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1) Press Cmd + Ctrl + any number from zero (0) to eight (8) (zero equals None and one
through eight are allocated to each of the marker colours).
Note: When you mark an Auto-title or a Story Point in the document area, they'll be marked in
the corresponding tab in the Side Pane as well.

2. Removing Marking from a Text
To remove the marking from text in the document:
1. Select the text you wish to remove the marking from.
2. Perform any of the methods described in Marking Text on page 235 and choose None
instead of a marking colour.
Tip: Select the entire document (Cmd + A) before performing any of the methods described in
Marking Text on page 235 to remove all markers from the document text.

3. Customizing Marker Names and Colours
Mellel is shipped with a default set of eight markers that are named after their corresponding

colours. To customize marker names and colours:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Tags & Markers tab.
3. Perform any of the following:
• To rename a marker, click on it and enter the new name.
• To set a new colour for a marker, click on its corresponding coloured square to open the
Colour window and set the desired colour. Refer to Colour Window on page 281 for
more information.
Tip: Click the Reset button to discard all changes and load the default markers set.

4. Navigating Marked Text
You can navigate between marked text to quickly and easily review the marked segments
without having to rely on visually identifying the markers. You can either navigate between all
marked text in the document, or only navigate between text that is marked by a specific
marker.
To navigate between any marked text in the document:
• Using the Markers palette:
1. Click the Markers palette.
2. Use the Find previous marked text (

•
•

) and Find next marked text (

) buttons to

navigate between marked text.
Using the right-click menu:
1. Right click on any text in the document.
2. Choose Marker > Find previous marked text or Marker > Find next marked text.
Using the Marker sub-menu:
1. Choose Edit > Markers > Find previous marked text or Edit > Markers > Find next
marked text from the menu bar.
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•

Using the keyboard:
1. Press Cmd + Ctrl + [ to navigate to the previous marked text or Cmd + Ctrl + ] to
navigate to the next marked text.
To navigate between text marked by a specific marker:
1. Click the Markers palette.
2. Do one of the following:
• Press and hold the Cmd key while double-clicking any marker to navigate to the next
text it is applied to.
Or
• Press and hold the Cmd + Option keys while double-clicking any marker to navigate to
the previous text it is applied to.

5. Filtering Marked Text
Markers can also be used to filter marked elements to assist you in locating specific elements.
This is relevant to cross references, auto-titles, story points. Refer to Inserting a Cross Reference
on page 114, Filtering Outline Items on page 144, and Filtering Story Points, Characters and
Locations on page 151 for more information.

6. Printing Markers
To configure whether markers are printed as part of the document:
1. Choose File > Print from the menu bar or press Cmd + P to print the document.
2. Choose Mellel from the options popup menu.
3. Check the Print Markers checkbox to print the markers with the document or uncheck it to
leave them out.

7. Exporting a Document with Markers
When exporting a Mellel document that includes markers as RTF or PDF documents, you can
determine whether or not markers are exported as part of the document. Refer to Exporting as
RTF on page 26 and Exporting as PDF on page 27 for more information.
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7. Document Statistics
1. What are Document Statistics?
Mellel keeps track of various statistical information regarding your document, mainly counting

diﬀerent elements such as characters, words, paragraphs, notes, tables, images and others.
This information is displayed in the Statistics palette and is updated in real time as you are
editing the document.

2. Document Statistics Tasks
1. Viewing Document Statistics
To view the Statistics palette, choose Window > Palettes > Statistics from the menu bar. Refer
to Statistics Palette Description on page 366 for a complete description of the diﬀerent
information available in the palette.

2. Viewing Statistics for Parts of the Document
To view the statistics for just a part of the document, select the part you wish to inspect in the
document area. The number of Characters, Words and Paragraphs in the selected segment will
be displayed in the Statistics palette General area in parenthesis, as shown in the following
figure:
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Figure 6-11: Statistics Palette with Selected Text
According to the image above, the selected text includes 593 characters, 93 words and 5
paragraphs.

3. Setting Statistics Preferences
You can configure Mellel to determine how it counts diﬀerent elements. For example, whether
or not to count blank characters as part of the overall characters.
To set the statistics preferences:
1. Choose Mellel > Preferences from the menu bar.
2. Click the General tab.
3. Use the following Statistics checkboxes to set the desired behavior:
• Include blank characters: When checked, Mellel counts blank characters (i.e. spaces) as
regular characters.
• Include break characters: When checked, Mellel counts break characters (i.e. line
breaks) as regular characters.
• Include punctuation: When checked, Mellel counts punctuation marks as regular
characters.
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8. Document Information
Perform the following instructions to set document keywords, category and comments:
1. Choose File > Document Setup from the menu bar.
2. Use the Keywords, Category and Comments text boxes to enter the desired information.
3. Click Save.
Note: This information serves as general data regarding the document. It cannot be
automatically inserted as text into the document itself. This functionality is implemented by
the Document Variables feature, as described in Variables on page 124.
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9. Printing
1. Printing a Document
To print your Mellel document, choose File > Print from the menu bar or press Cmd + P.
Note: When printing Mellel documents, the standard macOS printing options are available.

2. Setting Printing Preferences
Printing preferences are adjusted mostly using the Page Setup dialogue-box. To open the Page
Setup dialogue-box, either choose File > Page Setup from the menu bar or press Shift + Cmd
+ P.
The exact options available in the Page Setup dialogue-box depend on your printer and the
printer drivers installed on your computer. macOS oﬀers several default options that are
available even if you do not have any printer drivers installed, as shown in the following figure:

Figure 6-12: Page Setup dialogue-box

• Paper Size: This popup menu allows selecting the paper size from a list of preset paper sizes.
• Orientation: These buttons can be used to select between portrait and landscape page
•

orientation.
Scale: This text box is used to scale the printed page in order to fit the selected paper size.
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10. Indexing
1. What is Indexing?
An index is a section of the document which comprises a list of entries and locators that point
to where useful material relating to each entry can be found in the document. Entries can
include names of people, places, events, and any other concepts that are of interest to readers.
Locators are merely the page/s where the reader can find relevant information. Indexes are
designed to help the reader find information quickly and easily.
The following figure provides an example for an index which includes entires for diﬀerent
cities in the world, and locators to where you can find information about these cities in the
document:

Figure 6-13: Index Example
Mellel's Index feature was developed to enable you to easily and eﬃciently create a useful

index, and to format that index in accordance with various publication guidelines and
personal preferences.
In Mellel, index entries are defined by creating Index Records, and locators are rendered by
marking parts of the documents and associating them with Index Records. These parts are
referred to as Index Marks. As soon as they are marked, they are dynamically updated so
whenever the index is inserted into the document, the correct locators are used to point to the
location of the diﬀerent Index Marks in the document.
Generating an index comprises the following steps:
1. Creating an empty index (a single document can have multiple indexes).
2. Creating Index Records, which are the entries that comprise the index.
3. Marking the relevant document elements as Index Marks for the created Index Records.
4. Configuring the index format and style.
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5. Inserting the index into the document.
This process can either be performed while writing the document or once you’re finished. It
can also be used to index documents that were created in other applications and imported
into Mellel.

2. Indexing Tasks
1. Managing Indexes
A. Creating an Index
To create a new index:
1. Click the Index tab in the side pane.
2. Click the Settings button (

).

3. Choose New Index.
4. Enter a name for your new index.
5. Click OK.
The new index is created and selected by default in the Index pane.
Note: You can have more than one index in the same document.

B. Renaming an Index
To rename an existing index:
1. Click the Index tab in the side pane.
2. Use the index popup menu to choose the index you wish to rename.
3. Click the Settings button (

).

4. Choose Rename <index name> where <index name> is replaced by the name of the
selected index.
5. Enter the new name for the index.
6. Click OK.
Note: You can also apply character attributes to the index name by using the Character palette
(refer to Styling Characters Using Attributes on page 157 for more information). These
attributes will be applied to the index title when it is inserted into the document. Click the
Remove Attributes button (
) to remove any applied attributes from the title.

C. Deleting an Index
To delete an existing index:
1. Click the Index tab in the sidebar.
2. Use the index popup menu to choose the index you wish to delete.
3. Click the Settings button (

).

4. Choose Delete <index name> where <index name> is replaced by the name of the
selected index.
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Note: Deleting an index will remove all of its Index Records and all Index Marks referencing
these records.

2. Building an Index
Building an index comprises adding Index Records, adding Index Marks and finally inserting the
index into the document.

A. Managing Index Records
1. Adding Index Records
Index Records are the items that comprise the index. These are names of people, places, events
and any other concept of relevance.
To add Index Records:
1. Do one of the following:

•

Click the Add New Index Record button (

) in the Index pane.

Or
• Choose Insert > Index > New Record from the menu bar.
A new empty Index Record is created in the Index pane, and the Index Record popover is
displayed:

Figure 6-14: Index Record Popover
2. Enter a name for the new record. If any text was selected in the document when creating
the index record, it will be used as the name by default.
3. Use the Remarks text box to enter remarks regarding the record (optional).
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4. Use the Tags text box to add tags to the record by typing them in and pressing the Return
key (optional). Index records can later be filtered by their tags.
5. Assign a marker to the record by choosing the desired colour from the Marker area
(optional). Index records can later be filtered by the markers applied to them.
Note: To close the Index Record popover, double-click it.
Note: You can also apply character attributes to the record title by using the Character palette
(refer to Styling Characters Using Attributes on page 157 for more information). These
attributes will be applied to the text when the index is inserted into the document. Click the
Remove Attributes button (
) to remove any applied attributes from the title.

2. Editing Index Records
To edit an existing Index Record double-click it in the Index pane, or right-click it and choose
Open Record. The Index Record popover is displayed, with the same functionalities described
in Adding Index Records on page 244.

3. Renaming Index Records
To rename an existing Index Record:
• Edit it as described in Editing Index Records above.
Or
• Right-click it and choose Edit Record Name.
Or
• Click its name.

4. Deleting Index Records
To delete an existing Index Record select it and press Command + Backspace or right-click it
and choose Delete Record.

5. Managing Index Records Hierarchy
Index Records can be arranged in a hierarchical structure, in which Index Records can be set as
siblings or child records of other Index Records. This structure is later reflected in the generated
index structure.
By default all records are added on the root level. To create a hierarchy, Do one of the
following:
• Click and drag an index record onto another record to change the dragged record into a
child record.
Or
• Right click an existing index record and choose Add Child Record to add a new record as a
child record of the right-clicked record.
Child record are indented under their parent record, as shown in the following figure:
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Figure 6-15: Index Child Records

6. Duplicating Index Records
To duplicate an existing Index Record, right-click it and choose Duplicate record.

7. Changing Sorting Name for an Index Record
By default, Index Records are sorted alphabetically in the generated index by their name.
However, you can choose to sort records based on a diﬀerent text string. This is useful, for
example, when certain prefixes must be ignored when sorting index records or when sorting
records that appear as a number. If you have an Index Record for the year 1886, for example,
you might want it to be sorted based on how the number is explicitly spelled (eighteen eighty
six).
Note: The original name is still displayed in the index, the entry is just sorted diﬀerently.
To change the sorting name for an index record:
1. Edit the desired Index Record (refer to Editing Index Records on page 245 for step-by-step
instructions).
2. Click the hyperlink to the right of the Sort as: title (the hyperlink will show use record name
by default and the sorting name if it had already been changed).
3. Click Use and enter the desired sorting name.

8. Excluding Records From an Index
You might choose to exclude certain Index Records from the generated index. This means that
they are still tracked in the document, but will not appear when an index is added to the
document.
To exclude records from an index:
1. Edit the desired Index Record (refer to Editing Index Records on page 245 for step-by-step
instructions).
2. Check the Exclude from index checkbox.

9. Creating Alias Records
Sometimes it is required to include two diﬀerent records in the index that refer to the same
term, and should therefore point to the same locators, or Index Marks, in the text. This is useful
when you have the same term included in two diﬀerent groups in your index. For example,
you might have a London entry under European Cities as well as under World War 2 Battles.
The London entry should refer to the same places in document, but it will appear twice in the
index.
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To avoid creating the same Index Marks twice for the two Index Records, Mellel enables you to
define an Alias record. Once an Index Record is set as an alias of another Index Record, they will
share the same locators, so that every Index Mark that is linked to either record will be included
in both when the index is generated.
To add an alias for an Index Record:
1. Edit the desired Index Record (refer to Editing Index Records on page 245 for step-by-step
instructions).
2. Check the Alias checkbox.
3. Use the popup menu to choose the index which includes the alias record.
4. Choose the alias record from the Records list (use the filtering tools to simplify the search).
5. Click Select.
The name of the alias record is displayed next to the Alias checkbox, and every locator that was
associated with the original record is now associated with the alias record as well and will be
displayed with it when the index is generated.

10. Referencing Index Records
Index Records can reference other records that are relevant to the same topic. This is handy for
creating more useful indexes, that enable the reader to locate all relevant information using
the index.
When an Index Record references another record, a See prefix is used when the referencing
record has no Index Marks associated with it (i.e., the only place to find information about this
topic is in the referenced record), as shown in the following image:

Figure 6-16: Index Record Reference - See Prefix
A See Also prefix is used when the referencing record has at least one Index Mark associated
with it (i.e., readers can find additional information about this topic in the referenced record).,
as shown in the following image:

Figure 6-17: Index Record Reference - See also Prefix
Mellel automatically applies the correct prefix when generating the index.

To reference one index record to another:
1. Edit the desired Index Record (refer to Editing Index Records on page 245 for step-by-step
instructions).
2. Click the Add a Reference button and Do one of the following:
• To add a direct reference (to a specific record):
1) Click Add Direct Reference.
2) Use the popup menu to choose the index which includes the referenced record.
3) Choose the referenced record from the Records list (use the filtering tools to
simplify the search).
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•

4) Click Select.
To add a generic reference (to a general area in the index rather than a specific record):
1) Click Add Generic Reference.
2) Enter the text for the generic reference.
3) Click Set.

11. Editing Index Record References
To edit an existing index record reference:
1. Edit the desired Index Record (refer to Editing Index Records on page 245 for step-by-step
instructions).
2. Click the Edit button (

) next to the desired reference.

The relevant popover is displayed, including the same options described in Referencing
Index Records on page 247.

12. Deleting Index Record References
To delete an existing index record reference:
1. Edit the desired Index Record (refer to Editing Index Records on page 245 for step-by-step
instructions).
2. Click the Delete button (

) next to the desired reference.

13. Filtering Index Records
You can filter the records displayed in the Index pane to easily locate specific records. There are
three available methods for filtering the displayed index records:
• Text: To only show records that include a specific text string, type the string into the Filter
text box. The records are filtered in real time as you type.
• Marker: To only show records that were marked with a specific marker, click the Filter
Markers button (
) and choose the desired colour. You can choose more than one colour,
and any records that were marked with either of the chosen colours will be displayed.
Note: Markers are indicated in the index pane by an underlying line in the corresponding
colour, as shown in the following example, showing the green marker indication:

Figure 6-18: Index Marker Indication

• Tags: To only show records that include a specific tag, click the Filter Tags button (

) and

then choose the desired tag. Only tags that are applied to records in the current index are
included in the shown list. You can choose more than one tag, and any records that include
either tag will be displayed.
Note: Records tagged with Mellel default tags are indicated by an icon in the index pane, as
shown in the following example, showing a record tagged with the geography tag:
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Figure 6-19: Index Geography Tag

B. Managing Index Marks
1. Adding Index Marks
Index Marks are the places in the document where readers can find information regarding the
Index Records.
There are several methods to mark document elements as Index Marks:
• Starting from the Index pane:
1. Choose the desired Index Record from the Index pane.
2. Select the relevant element in the document area.
3. Click the Insert Index Mark button (

) in the Index pane.

•

Starting from the document area:
1. Select the relevant element in the document area.
2. Right-click the desired Index Record in the Index pane.
3. Choose Insert Index Mark for Record.
• Using the menu bar (this option creates a new Index Record and marks the selected text as
a locator for this record):
1. Select the relevant element in the document area.
2. Choose Insert > Index > New Record & Mark from the menu bar.
3. Create the Index Record as detailed in Adding Index Records on page 244.
• Using Quick Index:
1. Refer to Using Quick Index on page 251.
Index Marks are indicated in the text by a small circle, as shown in the following figure:

Figure 6-20: Index Mark Indication
Hovering the mouse cursor over the small circle will show the name of the Index Record this
Index Mark is linked to, as shown in the following figure:

Figure 6-21: Linked Index Record Indication

2. Editing Index Marks
To edit an existing Index Mark:
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1. Perform any of the following:
• Hover over its indication circle in the text and click the Index Record name when it
appears.
• Right click the Index Record which is referenced by the desired Index Mark, choose
Index Marks and select the desired Index Mark from the list.
The Index Mark popover is displayed:

Figure 6-22: Index Mark Popover
2. Edit the Index Mark as required::
• Change the linked Index Record by using the index popup menu to choose the desired
index and then choose the desired record from the list below.
• Use the Type popup menu to set the locator type (refer to Configuring Locator Types on
page 258 for more information).
• Use the Scope popup menu to set the locator scope (refer to Configuring Ranges on
page 257 for more information). This enables you to determine the exact scope of the
references so that Mellel can point to the exact location in the text. If Paragraph is
selected, use the Number of Paragraphs text box to enter the number of paragraphs
that are associated with this locator.
• Use the Prefix and/or Suﬃx text boxes to append certain characters to the locator.
These characters will appear next to the locator of the current Index Mark in the
generated index.
3. Click anywhere outside the popover to apply your changes.

3. Deleting Index Marks
To delete an existing Index Mark:
1. Hover over the mark indication circle in the text and click the Index Record name when it
appears.
2. Click the Delete button (

).
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4. Navigating Index Marks
To navigate between all the Index Marks for a given Index Record, right-click the desired Index
Record in the Index pane and choose Index Marks. A sub-menu is displayed, detailing all Index
Marks that are associated with the selected Index Record, their type and location in the
document. Click any of the Index Marks to navigate to it and open the Index Mark popover.

5. Using Quick Index
Quick Index is a unique feature that allows you to quickly and eﬃciently browse through the
document, select text manually (or using a search expression) and quickly mark it as an Index
Mark for selected Index Record. This turns the indexing process into a simple and eﬀective
workflow that can be completed in minutes instead of hours.
To use Quick Index:
1. Choose Insert > Index > Quick Index from the menu bar.
The Quick Index popover is displayed:

Figure 6-23: Quick Index Popover
2. Select the element that you wish to mark as an Index Mark in the document area. Your
selection is displayed in the Select Text area.
3. Use the Index popup menu to choose the desired index, then choose the desired Index
Record from the list.
4. Use the Type and Scope popup menus to set corresponding preferences (refer to Editing
Index Marks on page 249 for more information).
5. Click Mark to mark the selected text as an Index Mark for the selected Index Record.
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Tip: You can use the search panel at the bottom of the popover window to find specific text in
the document. The options in the search panel are identical to those described in Performing a
Find and Replace Action on page 211.When using the search panel:
• Click Mark All to mark all matches of the search expression as an Index Mark for the selected
Index Record.
• Click Next to find the next match without marking it.
• Click Mark & Next to mark the current match as an Index Mark for the selected Index Record
and navigate to the next match.
Tip: You can click Add Record to add a new Index Record (optional).

6. Adding Manual Locators
You can add manual locators for Index Records. These locators will appear in the generated
index, but they are not automatically updated with any changes to the document. This is
useful for indexing documents imported from other applications.
To add manual locators:
1. Right-click the desired Index Record in the Index pane.
2. Choose Manage Manually Entered Locators.
3. Click the Add button (

).

4. Use the Type popup menu to choose the type of locator (refer to Configuring Locator Types
on page 258 for more information).
5. Double-click the Locator text box to insert the locator (this is the document location the
index record will refer to. It will appear in the generated index exactly as you type it).

7. Editing Manual Locators
To edit an existing manual locator:
1. Right-click the desired Index Record in the Index pane.
2. Choose Manage Manually Entered Locators.
3. Select the locator you wish to edit.
4. Perform any required changes, as detailed in Adding Manual Locators above.

8. Deleting Manual Locators
To delete an existing manual locator:
1. Right-click the desired Index Record in the Index pane.
2. Choose Manage Manually Entered Locators.
3. Choose the locator you wish to delete.
4. Click the Delete button (

).

C. Inserting an Index
When all the Index Records and Index Marks are ready, you can insert your index into the
document.
Once an index is inserted into the document it is just plain text, and you will only be able to
format it manually. Thus, it is recommended to complete the configuring and formatting of
the index before inserting it into the document. Refer to Configuring an Index on page 253 for
more information.
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Note: While the index is inserted as plain text into the document, if the latter is exported as a
PDF, the index locators are exported as live objects, i.e. users can click them to navigate to the
corresponding document location.
To insert an index into the document:
1. Place the insertion point in the document where you want to insert the index.
2. Do one of the following:
• Using the menu bar:
1) Choose Insert > Index > Insert Index from the menu bar.
2) Use the popup menu to choose the index you wish to insert.
3) Click Insert.
• Using the Index pane:
1) Use the popup menu to choose the index you wish to insert.
2) Click the Settings button (

).

3) Choose Insert Index for <index name> where <index name> is replaced by the
name of the selected index.

3. Configuring an Index
A. Configuring Sorting
To configure how Index Records are sorted in the generated index:
1. Click the Settings button (
2.
3.
4.
5.

) in the Index pane.

Use the popup menu to choose the index you wish to configure.
Choose Edit Index Attributes.
Click the Sorting & Grouping tab.
Perform any of the following configuration:
• Select Sorting Language: Use the Sorting Language popup menu to choose the
language that is used to alphabetically sort the index.
• Select Sorting Type: Use the Sorting Type popup menu to choose the type of sorting
to perform:
• Simple: The basic sorting principles used by the macOS Finder are applied.
• Letter by Letter: In the letter-by-letter system, sorting continues up to the first
parenthesis or comma and then starts again after the punctuation point, while
ignoring word spaces and all other punctuation marks. Both open and hyphenated
compounds such as New York are treated as single words. The order of precedence
is one word, word followed by a parenthesis, and word followed by a comma,
number, or letters.
• Word by Word: In the word-by-word system, sorting continues only up to the end of
the first word (counting hyphenated compounds as one word), using subsequent
words only when additional headings begin with the same word. As in the letterby-letter system, sorting continues up to the first parenthesis or comma and then
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starts again after the punctuation point. The order of precedence is one word, word
followed by a parenthesis, word followed by a comma, word followed by a space,
and word followed by a comma, number, or letters.
6. Click Save.

B. Configuring Grouping
To configure how Index Records are grouped in the generated index:
1. Click the Settings button (
2.
3.
4.
5.

) in the Index pane.

Use the popup menu to choose the index you wish to configure.
Choose Edit Index Attributes.
Click the Sorting & Grouping tab.
Perform any of the following configuration:
• Enable Grouping: Check the Grouping On checkbox to enable grouping by first
character of record. If the checkbox is not checked records are only sorted, not
grouped.
• Set Group Heading: Use the Group Heading text box to insert a text that will appear
before each group. Click the small arrow at the left side of the box and choose Group
Letter to insert a dynamic element that is replaced with the group's first letter or
symbol.
• Use Separate Lines for Headings: Use the Separate line for group heading checkbox to
determine whether group headings will appear in separate lines or inline with the
records.
• Style Group Heading: Click the panel next to the Paragraph Style attributes button
(
) to open the paragraph attributes popover and style the group heading

•

paragraph attributes. Any changes are reflected in the preview area in real time.
Separate Numbers and Symbols: Use the Numbers & Symbols Grouping popup menu
to determine how will numbers and symbols be grouped in your index:
• Don't Group Separately: Each number and/or symbol appears in a group of their
own, just like any other letter in the index.
• Group Numbers Separately: All index records that begin with a number are grouped
separately from other records. When this options is selected, the Numbers Group
Heading text box is available, enabling you to enter a heading for the group.
• Group Symbols Separately: All index records that begin with a symbol are grouped
separately from other records. When this options is selected, the Symbols Group
Heading text box is available, enabling you to enter a heading for the group.
• Group Numbers & Symbols Separately: All index records that begin with a number or
a symbol are grouped separately from other records, in two diﬀerent numbers and
symbols groups. When this options is selected, both the Numbers Group Heading
and the Symbols Group Heading text boxes are available, enabling you to enter a
heading for the groups.
• Group Numbers & Symbols Together: All index records that begin with a number or a
symbol are grouped separately from other records in a single numbers and symbols
group. When this options is selected, the Numbers & Symbols Group Heading text
box is available, enabling you to enter a heading for the group.
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•

Set Headings for Numbers and Symbols: Use the Numbers Group Heading, Symbols
Group Heading and Numbers & Symbols Group Heading text boxes to insert the heading
for the corresponding group. Text boxes availability is determined by your selection in
the Separate Numbers and Symbols popup menu.

C. Configuring Index Layout
1. Configuring Style
To configure the style used for the generated index:
1. Click the Settings button (
2.
3.
4.
5.

) in the Index pane.

Use the popup menu to choose the index you wish to configure.
Choose Edit Index Attributes.
Click the Layout tab.
Perform any of the following configuration:
• Check the Include Heading checkbox to display the index heading above the index
records.

•

Click the panel next to the Character Style attributes button (

) under the Heading

title to open the character attributes popover and style the index heading character
attributes. Any changes are reflected in the preview area in real time.

•

Click the panel next to the Paragraph Style attributes button (

) under the Section &

Paragraph title to open the paragraph attributes popover and style the index
paragraph attributes. Any changes are reflected in the preview area in real time.

•

Click the panel next to the Section Style attributes button (

) under the Section &

Paragraph title to open the section attributes popover and style the index section
attributes. Any changes are reflected in the preview area in real time.

2. Configuring Index Records to Indent or Run-In
Index Records can appear in the index either indented or in-line following their group heading
(when grouped), as shown in the following examples:

Figure 6-24: Indented Index Records

Figure 6-25: Run-In Index Records
To enable and configure index records to indent or run-in:
1. Click the Settings button (

) in the Index pane.
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2.
3.
4.
5.

Use the popup menu to choose the index you wish to configure.
Choose Edit Index Attributes.
Click the Layout tab.
Do one of the following:
• To enable indention, choose the Indent radio button and perform any of the following
configuration:
• Check the Run-in first checkbox to have the first item in the group appear in-line
with the group heading.
• When the Run-in first checkbox is checked, you can use the First Separator text box
to enter the character/s that will separate the group heading from the first record.
• To enable run-ins choose the Run-in radio button and perform any of the following
configuration:
• Use the Start at level popup menu to choose the hierarchy level to enable run-in
from.
• Check the Indent if record has subrecords checkbox to always use indention for
records that have child records, regardless of any other settings.
• Use the Run-in Separator text-box to insert the character/s that will be used to
separate in-line index records.
• Use the Run-in Separator without locators text-box to insert the character/s that will
be used to separate in-line index records when they don't have any locators
associated with them (for example, parent records that don't directly refer to any
text location).

D. Configuring Format
1. Configuring See/See Also Prefixes
Index records can include references to other records (refer to Referencing Index Records on
page 247 for more information). In these cases, the generated index will display these
references with a corresponding See/See Also prefix in a configurable format.
Note: The See prefix is used when the referencing record has no Index Marks associated with it
(i.e., the only place to find information about this topic is in the referenced record). The See Also
prefix is used when the referencing record has at least one Index Mark associated with it (i.e.,
readers can find additional information about this topic in the referenced record). Mellel
automatically uses the required format when generating the index.
To configure the See/See Also format in the generated index:
1. Click the Settings button (
2.
3.
4.
5.

) in the Index pane.

Use the popup menu to choose the index you wish to configure.
Choose Edit Index Attributes.
Click the See, See Also tab.
Perform any of the following configuration:
• Use the See Prefix and See Also Prefix text boxes to insert the corresponding prefixes to
be displayed in the index for these type of references.
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•

•

•

•

•

Use the Main Record Name Format text box to edit the format that will be used to
display the referenced record when it is a parent record. Click the small triangle to the
left of the text box and choose Record Name to insert a dynamic element that is
replaced by the referenced record title.
Use the Sub Record Name Format text box to edit the format that will be used to display
the referenced record when it is a child record. Click the small triangle to the left of the
text box and choose Super Record Name and/or Record Name to insert a dynamic
element that is replaced by either the referenced record parent title or the referenced
record child title, respectively.
Check the Special format for sub record with same name checkbox and then insert the
desired format in the text box below to use a diﬀerent format if both the referencing
and the referenced record have the same title. Click the small triangle to the left of the
text box and choose Super Record Name and/or Record Name to insert a dynamic
element that is replaced by either the referenced record parent title or the referenced
record child title, respectively.
Use the Reference Format From a Main Record text box to edit the format that will be
used to display the reference when the referencing record is a parent record. Click the
small triangle to the left of the text box and choose Reference Body to insert a
dynamic element that is replaced by the actual reference. Check the Capitalize reference
body checkbox to capitalize the first word in the reference.
Use the Reference Format From a Sub Record text box to edit the format that will be used
to display the reference when the referencing record is a child record. Click the small
triangle to the left of the text box and choose Reference Body to insert a dynamic
element that is replaced by the actual reference. Check the Capitalize reference body
checkbox to capitalize the first word in the reference.

2. Configuring Locators
A. Configuring Locators Format
Locators are the page numbers/ranges that are used to indicate the location of Index Marks in
the text. To configure to format of locators in the generated index:
1. Click the Settings button (
2.
3.
4.
5.

) in the Index pane.

Use the popup menu to choose the index you wish to configure.
Choose Edit Index Attributes.
Click the Locators tab.
Perform any of the following configuration:
• Use the Locators Prefix text box to insert the character/s to use as a separator between
the record title and its locator.
• Use the Locators Separator text box to insert the character/s to use as a separator
between each two adjacent locators of the same record.

B. Configuring Ranges
When records are referencing to a range of pages rather than a single page, the way this range
is displayed in the generated index can be configured.
To configure the format of locator ranges:
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1. Click the Settings button (
2.
3.
4.
5.

) in the Index pane.

Use the popup menu to choose the index you wish to configure.
Choose Edit Index Attributes.
Click the Locators tab.
Perform any of the following configuration:
• Use the Range Separator text box to insert the character/s to use as a separator in the
locator pages range.
• Use the Range Abbreviation Type popup menu to choose the type of abbreviation that
will be used for the locator pages range:
• No Abbreviation: Page numbers appear in their whole in the page number.
• Last Two Digits: Only the last two digits are displayed for the last page.
• Changed Digits: Only the digits that are diﬀerent between the first and last page are
displayed.
• Chicago: Page ranges are abbreviated according to the Chicago Manual of Style
publishing specification.

C. Configuring Locator Types
Index records can refer to diﬀerent elements in the document. This includes plain text,
footnotes, figures and other elements. These are referred to as Locator Types. When you create
an Index Mark, you can select its locator type (refer to Adding Index Marks on page 249 for
step-by-step instructions). This selection aﬀects which locator type settings are applied when
the final index is inserted into the document.
For example, in the following figure the locator which references page 101 has a ft suﬃx
appended as it references a footnote:

Figure 6-26: Locator Type Example
To edit the diﬀerent locator types settings:
1. Click the Settings button (
2.
3.
4.
5.

) in the Index pane.

Use the popup menu to choose the index you wish to configure.
Choose Edit Index Attributes.
Click the Locators tab.
Choose any of the items in the Locator Types list and edit the following:

•
•

Click the panel next to the Character Style attributes button (

) to open the character

attributes popover and style the locator character attributes. Any changes are reflected
in the preview area in real time.
Use the Display Separately checkbox to determine whether this type of locator will be
separated from other locators for the same index record.
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•

•
•

Use the Join References to ranges checkbox to determine whether ensuing pages are
joined to a single locator with a page range (e.g. if the same index record is referencing
locators in page 99, 100 and 101, the index will include a single locator for the 99-101
page range).
Use the Prefix and Suﬃx text boxes to insert text strings that will be appended to this
type of locators.
Click the Clear Current Type Attributes button (

) to cancel any changes made to

the attributes of the selected locator type.

•

Click the Clear All Types' Attributes button (

) to cancel any changes made to the

attributes of all locator types.

E. Using Index Styles
All the configuration and formatting of an index can be saved as a style. This saves time and
allows you to maintain consistency across your documents.
Note: Index styles can also be managed using the Style Sets window. Refer to Managing Style
Sets on page 194 for more information.

1. Selecting an Index Style
To select an index style:
1. Click the Settings button (

) in the Index pane.

2. Use the popup menu to choose the index you wish to configure.
3. Choose Edit Index Attributes.
4. Use the Style popup menu to choose the style you wish to use.

2. Creating an Index Style
To create a new index style:
1. Click the Settings button (

) in the Index pane.

2. Use the popup menu to choose the index you wish to configure.
3. Choose Edit Index Attributes.
4. Click the Create new style button (

).

5. Insert a name for your new index style.
6. Click Create.

3. Editing an Index Style
To edit an existing index style:
1. Click the Settings button (
2.
3.
4.
5.

) in the Index pane.

Use the popup menu to choose the index you wish to configure.
Choose Edit Index Attributes.
Use the Style popup menu to choose the style you wish to edit.
Perform any required changes. Once the style is changed, it is indicated by a black plus
icon next to its name, as shown in the following figure:
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Figure 6-27: Changed Style Indication
6. Click the Save changes to style button (

).

4. Deleting an Index Style
To delete an existing index style:
1. Click the Settings button (

) in the Index pane.

2. Use the popup menu to choose the index you wish to configure.
3. Choose Edit Index Attributes.
4. Use the Style popup menu to choose the style you wish to delete.
5. Click the Delete style button (

).

Note: You will not be able to delete an index style if it is the only style available in the style set.

4. Changing the Index Pane Layout
You can change the layout of the story pane using any of the following methods:
• Show/Hide the Index Pane:
• Choose View > Index from the menu bar.
Or

• Click the Show/Hide side panel button (

).

• Resize the Index Pane: Click and drag either the pane border or the Resize side pane
button (

).
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Chapter 7

Configuring Mellel

1. Setting Binding Direction
Mellel documents have a default binding direction that determines the direction of the

following document elements:
• Default tables direction.
• Default notes direction.
• Order of pages in spread or view mode.
To change the default binding direction:
1. Choose File > Document Setup from the menu bar.
2. Use the Binding Direction popup menu to choose the desired option (Left to Right or
Right to Left).
3. Click Save.
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2. View Settings
1. What are View Settings?
Diﬀerent users use Mellel in diﬀerent ways. Thus, Mellel's display layout can be configured to
optimize the work environment for various needs. This takes form in three main ways:
• Document View: Using multiple tabs and/or windows at the same time to work on diﬀerent
documents concurrently, and changing how much of the screen Mellel occupies.
• User Interface Layout: Showing, hiding and customizing diﬀerent UI elements.
• Document Elements Display: Showing or hiding diﬀerent document elements.

2. Display Layout Tasks
1. Adjusting the Document View
A. Changing Document View Modes
Mellel allows you to set the document view to either Mellel View or Compact View.

• Mellel

View: This is the default view, displaying both the printable and non printable
document areas.
• Compact View: In this view the non-printable document areas (i.e. everything outside the
page margins) are hidden. The compact view allows you to fit the same amount of text in a
smaller window.
To set the document view mode choose View > Mellel View or View > Compact View from
the menu bar. The currently chosen view mode is indicated by a black tick.

B. Working in Full Screen Mode
In Mellel’s full screen mode the document covers the entire screen, automatically hiding the
macOS built in Dock and menu bar.
To enter full screen mode choose View > Full Screen from the menu bar or press Cmd + Ctrl +
F.
To exit the full screen mode, press Esc or Cmd + Ctrl + F.
When in full screen mode, move the mouse cursor to the top of the screen to show the menu
bar and access all of Mellel's functionalities.
Note: While hidden by default in full screen mode, the ruler, toolbar and bottom bar can be
shown using the View menu.
Tip: To maximize the viewable area of the document without entering full screen mode, you
can use the View menu to hide diﬀerent UI elements. Refer to Showing/Hiding UI Elements on
page 266 for step-by-step instructions.
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C. Working with Multiple Documents
By default, diﬀerent Mellel documents are opened in separate windows. All open Mellel
documents are shown in the Window menu. You can switch between document windows by
selecting them from the Window menu. The active window is indicated by a black tick, as
shown in the following figure:

Figure 7-1: Multiple Documents

D. Working with Multiple Tabs
Multiple documents can be opened in multiple tabs in the same window. To merge multiple
document windows as multiple tabs in the same window, choose Window > Merge all
Windows from the menu bar.
To switch a tab back into a separate window, either click the tab and drag it outside the
document area, or click the tab and then choose Window > Move Tab to New Window from
the menu bar.
Note: Multiple tabs are only supported for MacOS 10.12 (Sierra) and later versions.

E. Navigating Tabs
When multiple tabs are open, switch to any tab by clicking it, or choose Menu > Show
Previous Tab or Menu > Show Next Tab from the menu bar to switch between tabs.

F. Changing the Document Zoom Level
The Zoom popup menu allows you to set the document zoom level, from zooming in on a
specific page to showing multiple pages at the same time. The following figure depicts the
menu and its functionalities:
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Figure 7-2: Zoom popup Menu

• Fit Width: Automatically adjusts the zoom level so that the document fits the width of the

document window. Alternatively, use the Cmd + Option + Shift + W keyboard shortcut.
• Fit Page: Automatically adjusts the zoom level so that an entire page fits in the document
window. Alternatively, use the Cmd + Option + G keyboard shortcut.
• Zoom Levels: Allows choosing from a selection of preset zoom levels, from 10 to 1600
percent. Alternatively, use the Cmd + + or Cmd + - keyboard shortcuts to zoom in and out,
respectively. The default zoom level is 128%.
• Other: Allows manually setting the zoom level (in percentages).
• Multiple Page Views: Allows setting Mellel to display multiple pages side by side. Available
options include One up (default), Two up, Four up or Spread (which lays out facing pages next
to each other).
Note: To allow viewing multiple pages, you must manually choose a zoom level that allows
fitting multiple pages in the same window, or alternatively choose Fit Width.

2. Adjusting the User Interface Layout
A. Setting the On-Screen Background Colour
To support improved accessibility, you can select a diﬀerent background colour for the
document (rather than the default White) by doing the following:
1. Choose File > Document Setup from the menu bar.
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2. Check the Background (on screen) checkbox.
3. Click the Colour well (

) to open the Colour window and choose the desired colour

for the document area background. Refer to Colour Window on page 281 for more
information on using the Colour window.
4. Click Save.
Note: This setting only aﬀects the on screen background colour. It does not aﬀect the actual
background of the document when printing or exporting to a diﬀerent application (refer to
Setting Page Background on page 183 for step-by-step instructions for changing the actual
background colour).

B. Setting the Document Background Colour
You can set a diﬀerent background colour for the area displayed behind the pages in Mellel
View (rather than the default Grey), either in normal or full screen mode, by doing the
following:
1. Choose Mellel > Preferences from the menu bar.
2. Click the General tab.
3. Use the Document Background and/or Fullscreen Background popup menus to set a
diﬀerent background colour.
Tip: Choose Custom from the popup menu and then click the adjacent Colour well to open
the Colour window and choose a custom colour (refer to Colour Window on page 281 for more
information on using the Colour window).

C. Showing/Hiding UI Elements
To allocate more space for the document area, you can choose whether to show or hide
diﬀerent UI elements.
To show/hide diﬀerent UI elements, choose View from the menu bar, then choose any of the
following options to show/hide the corresponding elements:
• Show Tab Bar.
• Outline (alternatively, press Cmd + Shift + O to show/hide the outline pane).
• Annotations Pane (alternatively, press Cmd + Option + O to show/hide the annotations
pane).
• Show Toolbar.
• Show Ruler.
• Show Bottom Bar.

D. Configuring the Palette Layout
Mellel enables you to open palettes, close them, group them, and so on. All the palettes in
Mellel are the same height and width so they oﬀer both flexibility and expectability: you can

combine all or any of them together any way you like, but when you click one, the options are
always displayed where you expect them to be, regardless of the palette position within a
palette group.
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1. Opening a Palette or Palette Group
To open a palette or a palette group, choose Window > Palettes from the menu bar, then
choose the desired palette. Mellel will open the palette, or the palette group the palette is in. If
the palette is already open, Mellel will select it.
Tip: Choose Window > Palettes > Reset Palettes from the menu bar to revert to the default
palette layout and positioning.

2. Closing a Palette or Palette Group
To close a palette or a palette group:
• Click the Close button ( ) at the top-left edge of the desired palette/palette group.

•

Or
Click the Palette Management button ( ) at the top-right edge of the palette/palette
group and choose the desired palette from the Remove Palette area.

3. Showing All Available Palettes
To show/hide all available palettes without closing them:
• Choose Window > Palettes > Toggle Palettes from the menu bar.
Or
• Press Cmd + *.

4. Adding a Palette to a Group
To add a palette to a palette group:
• Click the palette and drag it to the desired group tab rail.
Or
• Click the Palette Management button ( ) at the top-right edge of the desired palette
group and choose the desired palette from the Add Palette area.

5. Moving Palettes
To move a palette, click and drag it to its new location:
• Drag it into a diﬀerent palette group tab rail to move the palette into that group.
Or
• Drag it outside any palette group tab rail to create a new palette group.
Tip: To dock two palettes or palette groups together, drag one of them to the bottom border
of the other.

6. Adjusting Palette Tabs Display
To adjust the display of the palette tabs:
1. Click the Palette Management button ( ) at the top-right edge of any palette/palette
group.
2. Choose one of the following options to determine what is displayed on the palette tabs:
• Icon and Text.
• Icon Only.
• Text Only.
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E. Customizing the Toolbar
The toolbar is used to enable easy access to commonly used functionalities. As such, it can be
customized to meet each user's unique requirements.
To customize the toolbar:
1. Choose View > Customize Toolbar from the menu bar. The Customize Toolbar dialoguebox is displayed:

Figure 7-3: Customize Toolbar dialogue-box
2. To add an item into the toolbar, click and drag it into the desired location in the toolbar. To
remove an item from the toolbar, click and drag it outside the toolbar area.
3. Use the Show popup menu to choose whether to show the items' icons, text or both in the
toolbar.
4. Check the Use small size checkbox to use smaller versions of the icons in the toolbar.
5. Click Done.
Tip: Insert the Space item into the toolbar to add an empty space between adjacent items

3. Displaying Document Elements
The Show Hidden sub-menu allows you to show or hide various document elements.
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Note: The same functionality is available using the Show button (

) in the toolbar. This

button is shown by default but can be removed from the toolbar. Refer to Customizing the
Toolbar on page 268 for more information on customizing the toolbar.
To show/hide document elements choose View > Show Hidden from the menu bar, then
choose the element you wish to show/hide. Shown elements are indicated by a black tick, as
shown in the following figure which depicts available options:

Figure 7-4: Show Hidden Sub-Menu
Note: All made changes apply only to the active document and will not aﬀect documents
opened in other windows in the background.
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3. Multilingual Support
1. Multilingual Support in Mellel
Mellel supports over 200 languages. To write in a certain language, you must choose the
keyboard layout or input method and start typing. Mellel language switching capabilities allow

you to do just that, simply and eﬃciently.
The following sub-sections details several features that were developed to support
multilingual documents, as well as tips and best practices for using specific languages and
supporting language-specific use cases.

2. Multilingual Tasks
1. Changing the User Interface Language
Mellel's User Interface (UI) can be localized and displayed in multiple languages. The UI is
automatically displayed in the main language of the macOS. Therefore, to change Mellel's UI

language, you must change your operating system main language and restart the computer.
Mellel will be automatically loaded in the main language when it is launched.
Note: The UI languages is not related to the language/s used in the document. There is no
need to change the UI language to write a document in any specific language.
The UI is available in the following languages:
• English
• Czech
• Danis
• Greek
• French
• German
• Hebrew
• Italian
• Japanese
• Romanian
• Russian
• Spanish
• Chinese (Simplified)
• Dutch
• Finnish
• Norwegian
• Portuguese
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2. Enabling Languages
To enable writing in a certain language, you must first enable it in your macOS by doing the
following:
1. Open System Preferences (

).

2. Click the Keyboard icon (

).

3. Click the Input Sources tab.
4. Click the Add button (

).

5. Choose the desired language from the language list.
6. Choose the keyboard layout from the layout list.
7. Click Add.

3. Switching Languages
Once the desired language is active and available, you can switch to it and use it for writing in
Mellel by doing the following:
1. Open System Preferences (
2. Click the Keyboard icon (

).
).

3. Click the Input Sources tab.
4. Check the Show input menu in menu bar checkbox.
5. Do one of the following to switch languages:
• Use the Input menu (located at the top-right end of the menu bar, usually with a
country flag at the top) to choose the language you want to use.
• Press Cmd + Space to switch between the two recently selected languages.
• Press Cmd + Option + Space to cycle between all available languages.
6. Start typing in the document area. Mellel will automatically use a font suitable for the
selected language.

4. Using Alternative Input Methods
When you want to enter just a word or two in a certain language, or wish to use a special
character, using the regular keyboard layout might be too complicated or even useless.
Another case when the regular keyboard layout is problematic is if you don’t have the desired
language character labels on your keyboard and you’re not a touch typist.
In such cases, you may want to use one of two tools provided with macOS:
• Keyboard Viewer: Allows you to enter text using a virtual keyboard. Perform the following
instructions to use the keyboard viewer:
1. Place the insertion point in the document.
2. Use the Input menu (located at the top-right end of the menu bar, usually with a
country flag at the top) to choose Show Keyboard Viewer.
3. Switch to the desired language (refer to Switching Languages above for step-by-step
instructions). The virtual keyboard will automatically switch to the selected language.
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4. Click the characters in the virtual keyboard that you wish to insert into your document.
Character Palette: Allows you to enter any character from any language into your text.
Refer to Special Characters on page 42 for step-by-step instructions for using the Character
Palette.

5. Highlighting Font Substitutions
When you try to use a certain language, most applications look for the characters you’ve
entered in the currently used font. In most cases, the character is found and displayed in the
text. The trouble begins when the character cannot be found.
The common solutions to this problem are either not to display the text at all (and enter a
replacement character instead) or to switch to a diﬀerent font either explicitly or discreetly.
Mellel takes a diﬀerent route by using a diﬀerent font to render the text, while enabling you to
highlight these substitutions by doing the following:
1. Choose Mellel > Preferences from the menu bar.
2. Click the Typography tab.
3. Check the Highlight font substitutions checkbox.
Mellel will now highlight cases where a substitution font was used. For example, suppose you
enter some text using the default character style, and then switch to a language which is not
supported by the default font. The result may look something like the following:

Figure 7-5: Highlighted Font Substitution
If you select the highlighted text and switch to a font that supports the highlighted characters,
the background highlight will disappear.

6. Using a Secondary Font
Selecting and switching fonts manually is fine, but very tiresome if you need to switch
between languages and fonts very often. In addition, you might prefer to use one font with a
certain language and a completely diﬀerent font with a diﬀerent language. This is where the
secondary font option comes to the rescue. Defining a secondary font, paired with the primary
font, enables a uniform appearance of bilingual texts with minimal manual labour.
To use the secondary font option:
1. Select the text you wish to set a secondary font for.
2. Open the Character palette.
3. Use the Attribute tab to set your preferred font, font face, and size for the main language to
be used in the text. Refer to Styling Characters Using Attributes on page 157 for the
diﬀerent options.
4. Click the Options popup menu.
5. Use the Script popup menu to choose the language script for the secondary font.
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6. Set your preferred font, font face, and relative size for the secondary language to be used
in the text. Refer to Styling the Secondary Font on page 161 for step-by-step instructions.

7. Writing in Right to Left Languages
Mellel was built to support writing in Right-to-Left (RTL) languages such as Hebrew or Arabic.

To write in RTL languages, use the Direction button in the Paragraph palette (as detailed in
Changing Paragraph Direction on page 164) to configure Mellel to handle the document
correctly.
Note: Only change the alignment of the paragraph after setting its direction. Otherwise, Mellel
will automatically revert the alignment when you change the paragraph direction.

8. Breaking Directionality
Mellel fully supports writing bi-lingual texts. However, sometimes it needs help to determine

which parts of the text are related to which language, so that it can correctly apply spaces and
directions.
For example, the following text combines Hebrew and English, but is not rendered properly as
the ‘3’ digit belongs with the second part of the Hebrew sentence, not the English word iPad:

Figure 7-6: Directions Problem Example
To solve this rare issue, you must manually tell Mellel where to change the direction of the text
from English back to Hebrew:
1. Select the space right after the English text should end.
2. Choose Insert > Space > Direction Breaking Space from the menu bar.
The sentence will now be rendered properly, as Mellel knows where to change the paragraph
direction back to Hebrew:

Figure 7-7: Directions Problem Solved

9. Entering Vowel Marks (Niqud)
To insert a Hebrew vowel marks (Niqud), enter the letter first, then use the desired keyboard
combination from the following table:
Table 7-1: Hebrew Vowel Marks
Character

ֲא
ֳא

Vowel

Keystroke with regular
Hebrew keyboard

Keystroke with Hebrew
QWERTY keyboard

Chataf-Patach

Option+1

Option+1

Chataf-Qamatz

Option+2

Option+2
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ֱא
ִא
ֵא
ַא
ָא
ֻא
ֶא
ְא
וּ
א
ֹ
וֹ
שׁ
שׂ
תּ

Chataf-Segol

Option+3

Option+3

Chiriq

Option+4

Option+4

Tsereh

Option+5

Option+5

Patach

Option+6

Option+6

Kamatz

Option+7

Option+7

Kubutz

Option+8

Option+8

Segol

Option+9

Option+9

Shvah

Option+0

Option+0

Shuruk

Option+u

Option+u

Cholam-Chaser

Option and +

Option+o

Cholam-Maleh

Shift+u

Shift+o

Shin

Shift+a

Option+s

Sin

Option+a

Option+w

Dagesh

Letter, then Option+<

Letter, then Option+>

10. Entering Trope Marks (Te’amim)
Mellel supports entry and correct positioning of trope marks (Te’amim) in Hebrew. To make full

use of this option, you’ll need to use a suitable OpenType font (several free ones are oﬀered on
our website) as well as the Emoji palette or a special keyboard layout (refer to Using
Alternative Input Methods on page 271 for more information).
To correctly enter tropes, you must first enter the letter, add the niqud (refer to Entering Vowel
Marks (Niqud) on page 273 for step-by-step instructions) and then use either the Emoji palette
or virtual keyboard to insert the Tropes, as shown in the following figure:
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Final result

Add the trope mark

Add the vowel mark

Figure 7-8: Order of Actions for Adding Tropes
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Enter the letter

4. Configuring Keyboard Shortcuts
1. What are Keyboard Shortcuts?
Keyboard shortcuts are keyboard stroke combinations that enable you to perform an action
without having to use the mouse or make any menu selections.
There are three types of keyboard shortcuts available in Mellel:
• Fixed Shortcuts: These shortcuts are set in advance and cannot be changed. For example,
pressing the Command key and then the F key is the equal of choosing Edit > Find > Find
from the menu bar and will result in opening the Find panel. One of the basic principles of
operation in the macOS is that most functionalities are available via the menu bar. The menu
bar also indicates the diﬀerent functionalities shortcuts, where applicable.
• Style Shortcuts: These shortcuts are set in advance, but you can change them. For example,
the keyboard combinations Cmd + 0-9 are allocated for applying character styles, and you
can determine which combination will apply which character style. Refer to Assigning a
Shortcut to a Style on page 193 for step-by-step instructions.
• Custom Shortcuts: These shortcuts are created using the macOS built in functionality,
which allows you to assign a shortcut to almost any menu option in Mellel.

2. Keyboard Shortcuts Tasks
1. Creating a Mac Shortcut
To create a Mac shortcut for a Mellel functionality:
1. Run Mellel (if it is not already running).
2. Launch the macOS System Preferences.
3. Click the Keyboard icon.
4. Click the Shortcuts tab.
5. Choose App Shortcuts from the left hand side list.
6. Click the Add Shortcut button (

). The Add Shortcut dialogue-box is displayed:

Figure 7-9: Add Shortcut dialogue-box
7. Choose Mellel from the Application popup menu.
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8. Use the Menu Title text box to enter the name of the menu function you wish to add a
shortcut to.
9. Click inside the Keyboard Shortcut text box and press the keyboard shortcut you wish to
assign to the selected menu title.
10. Click Add.
11. Quit Mellel and relaunch it to begin using your new shortcut.
Note: The number of Mac shortcuts you can assign is almost unlimited. There are, however,
limits to what you can and cannot assign a shortcut to:
• You cannot reassign a set keyboard shortcut. That is, you cannot override an existing
keyboard shortcut with your own.
• You can only assign shortcuts to options that are in menus. That is, you cannot assign a
keyboard shortcut to a text field, or a button.
• You cannot assign a shortcut to two menu items with identical names: Mellel will always
select the first.
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Chapter 8

Appendix

1. Help & Support
1. Searching for Specific Features
To search for help regarding a specific feature:
1. Choose Help from the menu bar.
2. Enter the feature title into the Search text box.
Search results appear in real time and return any Menu Items that include this feature, and/or
any Help Topics that refer to it, as shown in the following figure:

Figure 8-1: Searching for Help
Hovering over any Menu Item will open the menu that includes it, highlighting the specific
item location in it. Clicking any Help Topic will open that help topic in a new window.

2. Displaying Mellel's Online Help
To display Mellel's online help in your default web browser, choose Help > Online Help from
the menu bar.

3. Displaying Mellel's User Manual
To display Mellel's user manual as a PDF file, choose Help > Mellel Guide from the menu bar.
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4. Accessing Mellel’s Learning Resources
To open Mellel's training center in your default web browser, choose Help > Learn from the
menu bar.

5. Contacting Mellel Support
To send a support request to Mellel's support team, choose Help > Support from the menu
bar. The Contact Mellel Support dialogue-box is displayed:

Figure 8-2: Contact Mellel Support dialogue-box
Insert your contact information, support request subject and description and click Send.
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2. Common Functionalities
1. Colour Window
The macOS Colour window is used to set the colour of various elements in Mellel. It is usually
displayed after clicking the colour well in diﬀerent windows/popovers. Once the window is
displayed, use it to select a colour. The select colour will then appear in the colour well and be
applied to the edited element.
The colour window comprises five diﬀerent tabs that enable diﬀerent ways to pick a colour:

• Colour Wheel ( ): Enables picking a colour from a colour wheel.
• Colour Sliders ( ): Enables using diﬀerent sliders to pick a colour.
• Colour Palettes ( ): Enables picking a colour form diﬀerent palettes.
• Image Palettes ( ): Enables picking a colour from any loaded image.
• Pencils ( ): Enables picking a colour from a collection of pencils.
Click the desired tab to select the picking method, then choose the desired colour. The
selected colour is displayed in the bottom left corner of the window.
If you’re frequently picking the same colour, you can drag it from the left corner of the window
to the colour palette at the bottom of the window (this palette is fixed and appears on all tabs).
The dragged colour will remain in the palette and enable picking it quickly the next time to
use the colour window.

2. Measurement Units
Measurement units are used to measure the size of various items and elements. Mellel
supports three diﬀerent measurement units:
• Point: The smallest unit, measuring 1/72 of an inch (about 0.03528 cm).
• Centimeter: Measures about 28.3465 points (about 0.3937 of an inch).
• Inch: Measures 2.54 centimeters (72 points).
Mellel is configured to use one main measurement unit at a time, but you can enter values in all
three measurement units, and Mellel would convert it to the main unit.

1. Setting the Main Measurement Unit
To set the main measurement unit:
1. Choose Mellel > Preferences from the menu bar.
2. Click the General tab.
3. Use the Measurement Units popup menu to set the default unit.
Note: When the measurement unit is changed, it is reflected immediately across the
document. This may cause a round number (for example, 1 cm) to become unrounded as a
result of the conversion.
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2. Using a Diﬀerent Measurement Unit
To use diﬀerent measurement units:
1. Select the text field where measurement units input is required.
2. Enter the desired value followed by cm for centimeters, in for inches or pt for points.
Mellel will automatically convert the value you entered into the default measurement unit.
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3. Find and Replace Expression Elements
Find and replace expressions are used to locate complex textual patterns or combination of
characters. Find and replace expressions can include special elements, which are used to
create the logic underlying the expression. Refer to Creating Find and Replace Expressions on
page 212 for step-by-step instructions.
Special elements are added using the Insert popup menu, as detailed in Performing an
Advanced Find Action on page 211. After adding an element to the Find/Replace field, you can
edit its attributes by double clicking on its respective icon (to edit a group, double-click on its
enclosing brackets).
The following sub-sections detail the various special elements and their attributes.

1. Group
A Group is any number of characters or elements that are separated from other items in the
Find/Replace field by special brackets, as shown in the following figure:

Figure 8-3: Expression Group Example
Groups are used to isolate elements you wish to match or apply some options to separately. ,
and also to refer to and use them in the replace expression. You can group together any
element and any number of other elements, and even a single character.
To use the Group special element:
1. Select the elements you wish to group in the Find/Replace field.
2. Choose Group from the Insert popup menu.
Tip: Literal text is plain text entered into the Find/Replace fields. You cannot assign any
attributes to literal text, but you can put literal text in a group and assign attributes to that
group. For example, if you want to find any case of a, aa or aaa in the text, you can enter a as
literal text in the Find field, group it, and assign the attributes Greedy (enabled) and Repetition
(Once or more) to the group.
The Group element includes the following common attributes (refer to Common Attributes on
page 291 for a complete description):
• Repetition
• Greedy
• Negated
In addition, it includes the following unique attributes:
• Capturing: When this checkbox is checked (this is the default option), the element that is
matched by the group content is saved by the search engine and can be used with a
Backreference element later on (refer to Backreference on page 289 for more information).
When a group is set as Capturing, it is numbered, as shown in the following image (the group
is numbered 1):
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Figure 8-4: Numbered Group Example

• Name: This text box is used to enter a name for the group.
• Display name: This checkbox is used to display the group name instead of its content in the
Find/Replace fields.

1. Ungrouping
To ungroup a grouped element:
1. Select it in the Find/Replace field.
2. Choose Ungroup from the Insert drop-down menu.

2. Advanced Group Usage
Groups can be useful in more complex cases. For example, if you want to find the word grey in
alternative spellings (grey and gray) and with diﬀerent suﬃxes, the following expression would
work:

Figure 8-5: Advanced Search Expression Example
The expression will match any instance of the following strings: grey, gray, grayish, greyish,
graying, and graying. The second group has the attributes Repetition set as Zero or more and
the option Greedy enabled. Zero or more repetitions means that the endings ish and ing will be
part of the match if found (e.g., with greyish) but they don’t have to be part of the match
(otherwise grey, for example, will not be matched). The Greedy option tells the search engine
to look for those endings and match them too, if possible, so that the engine will not suﬃce
itself with finding grey when there might be something else to match further (such as an
ending like ish).
The following permutations tree illustrate the options covered by the expression:
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ish
a

y
ing

gr

ish
e

y
ing

Figure 8-6: Advanced Search Expression Permutations

2. Or
The Or element (

) allows you to match either of two or more alternatives. That is, it defines

an either/or relationship between two or more elements. For example, the following
expression will match either the word dogs or cats:

Figure 8-7: Or Element Example

3. Find Expression Elements Descriptions
1. Character Elements
Elements of this type match characters or types of characters.

A. Any Character
The Any Character element (

) matches any character, including variables and line breaks,

but excluding break characters (such as Return, Page Style Break, etc.). It includes the
following common attributes (refer to Common Attributes on page 291 for a complete
description):
• Repetition
• Greedy
Note: This element is useful for matching any character as part of an expression, not for
capturing text for the purpose of matching by style, for which you should use the Anything
element (refer to Anything on page 289 for more information).

B. Digit
The Digit element (

) matches any digit character from 0 to 9, including Arabic Indic digits.

It includes the following common attributes (refer to Common Attributes on page 291 for a
complete description):
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• Repetition
• Greedy
• Negated
C. Whitespace
The Whitespace element (

) matches any type of space character, tabs and breaks. It

includes the following common attributes (refer to Common Attributes on page 291 for a
complete description):
• Repetition
• Greedy
• Negated

D. Letter
The Letter element (

) matches any letter character. For example, a or ü or δ. It includes the

following common attributes (refer to Common Attributes on page 291 for a complete
description):
• Repetition
• Greedy
• Negated

E. Alphanumeric
The Alphanumeric element (

) matches any letter or number character. It includes the

following common attributes (refer to Common Attributes on page 291 for a complete
description):
• Repetition
• Greedy
• Negated

F. Character Range
The Character Range element (

) matches any characters found within a set range. It

includes the following common attributes (refer to Common Attributes on page 291 for a
complete description):
• Repetition
• Greedy
• Negated
In addition, it includes the following unique attributes:
• Unicode: Sets the start and the end points of the character range using unicode values.
• String: Sets the start and end points for the character range using the actual characters.
Note: The Unicode and the String attributes are two diﬀerent ways to enter the same data.
Changing one attribute is reflected in the other.

Find and Replace Expression Elements | 286

G. Character Set
The Character Set element (

) matches any of several characters included in a set. For

example, if you want to find either spelling of the word grey (grey or gray), you can use the
following Character Set in the find expression:

Figure 8-8: Character Set Example
The character set includes the text ae which means either a or e and so, both gray and grey will
be matched.
The Character Set element includes the following common attributes (refer to Common
Attributes on page 291 for a complete description):
• Repetition
• Greedy
• Negated
In addition, it includes the following unique attribute:
• Set: This text box is used to enter the characters that are included in the character set. These
letters are shown on the element icon in the Find/Replace field.

H. Auto-title
The Auto-title element (

) matches any Auto-title objects. It includes the following

attributes (refer to Common Attributes on page 291 for a complete description):
• Repetition
• Greedy
• Negated

I. Citation
The Citation element (

) matches any citation objects. It includes the following attributes

(refer to Common Attributes on page 291 for a complete description):
• Repetition
• Greedy
• Negated

J. Bookmark
The Bookmark element (

) matches any bookmark objects. It includes the following

attributes (refer to Common Attributes on page 291 for a complete description):
• Repetition
• Greedy
• Negated
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K. Reference
The Reference element (

) matches any cross-reference objects. It includes the following

attributes (refer to Common Attributes on page 291 for a complete description):
• Repetition
• Greedy
• Negated

L. Hyperlink
The Hyperlink element (

) matches any hyperlink objects. It includes the following

attributes (refer to Common Attributes on page 291 for a complete description):
• Repetition
• Greedy
• Negated

2. Boundary Elements
Boundary elements are elements that match boundaries between elements rather than the
elements themselves. As such, they are never used alone in an expression, but rather always in
conjunction with other elements. Boundary elements have no attributes.

A. Word Boundary
The Word Boundary element (

) matches the boundary that exists before and after a word in

the text and between word characters and non-word characters. A word character is defined
as any letter (e.g., a, b, c), number (e.g., 1, 2, 3), or the underscore character, and excludes
characters such as punctuation marks, parenthesis, exclamation marks, question marks, etc.
The following figure shows diﬀerent types of word boundaries, indicated by arrows:

Press to start
Figure 8-9: Word Boundary Examples

B. Negated Word Boundary
The Negated Word Boundary element (

) matches any position in the text which is not a

word boundary.

C. Paragraph Boundary
The Paragraph Boundary element (

) matches the boundary between any two paragraphs

in the text. The boundary is located right after the Return character, at the beginning of the
text, and at the end of the text.
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Note: Do not confuse the Paragraph Boundary element with the Return character. The
Paragraph boundary simply points to the position after the Return character.

D. Negated Paragraph Boundary
The Negated Paragraph Boundary element (

) matches any position in the text which is not

a paragraph boundary.

E. Text Start
The Text Start element (

) matches the position at the start of any element in the document

(e.g. text, footnote, table cell, etc.).

F. Text End
The Text End element (

) matches the position at the end of any element in the document

(e.g. text, footnote, table cell, etc.).

3. Anything
The Anything element (

) matches any text and, if formatting or style attributes are applied

to the Find field (refer to Searching for Text with Particular Character Attributes on page 209),
will match any text that is using those attributes.
The Anything element is diﬀerent from other elements. With any other element, Mellel tries to
match the expression in the text. With the Anything element, no comparison or matching is
made and any text will match. The Anything element does not have any attributes.

4. Custom
The Custom sub-menu includes all saved expressions that were added. Refer to Creating Find
and Replace Expressions on page 212 for step-by-step instructions.

4. Replace Expression Elements Descriptions
1. Backreference
The Backreference element (

) references the content of a matched Group that has

Capturing enabled in its attributes (refer to Group on page 283 for more information).
Backreference elements are useful when you want to reuse some parts of an expression, or to
organize them diﬀerently.
The Backreference element includes one attribute:
• Group Index: This popup menu is used to choose the index of the group that is referenced
by this element. The selection is also visually indicated on the element icon in the Find/
Replace fields.
For example, suppose you want to find and eliminate cases in the text where a word was typed
twice in a row by mistake (e.g. “find find” or “replace replace”). One way of doing it is by using
an Alphanumeric element that repeats once or more and is terminated by a word boundary:
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Figure 8-10: Removing Double Words - Find Expression Part 1
Adding a Whitespace element will help locate every such word followed by a space:

Figure 8-11: Removing Double Words - Find Expression Part 2
The problem now is how to tell Mellel to find cases where the word matched (found) in group 1
is repeated again. Here, adding a Backreference can be very useful:

Figure 8-12: Removing Double Words - Final Find Expression
The Backreference element is referring to group 1. The whole expression would be an
instruction to Mellel to find any word, followed by a space, followed by the same word that was
found in part 1 of the expression.
Typically, with such a find expression, our target is to replace it with just one word, eliminating
the space between the words. Entering a Backreference element in the Replace field would do
the job just fine:

Figure 8-13: Removing Double Words - Replacement Expression
Another typical case where Backreference is useful comes when you need to keep the content,
but change the order of element. Let’s say, for example, that you wish to change the date
format in a document from a UK date format (31/05/2007) to a US format (05/31/2007). Your
find expression might look like the following:

Figure 8-14: Date Format Find Expression
That is, you will find any string using the following format: <two digits>/<two digits>/<four
digits>. In the Replace field, you will need to enter the following:
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Figure 8-15: Date Format Replacement Expression
What you have here is the same exact thing, ordered diﬀerently, with group 1 (the day in the
UK format) and group 3 (the month) trading positions.

2. Found Expression
The Found Expression element (

) is only available in the Replace field, and references the

result of a find action. Unlike the Backreference element, the Found Expression element
references the whole search result, not just a specific matched group in the expression.
The Found Expression element does not have any attributes.

5. Common Attributes
After adding an element to the Find/Replace field, you can edit its attributes by double
clicking on its respective icon (to edit a group, double-click on its enclosing brackets). The
following attributes are available:
Note: Not all attributes are enabled for all elements. Refer to individual elements description
for more information.
• Repetition: Determines the group repetition setting. The following options are available:
• Once: When chosen, any text element will be considered a match if it contains the element
once. For example, if you look for e and the word beet is examined, the first and then the
second e will be matched, but not both at once. This is the default selection for the
Repetition menu.
• Optional: When chosen, any text element will be considered a match if it contains the
element once, or not at all.
• Zero or more: When chosen, any text element will be considered a match if it contains the
element once, multiple times or not at all.
• Once or more: When chosen, any text element will be considered a match if it contains the
element once or multiple times.
• Exactly: When chosen, any text element will be considered a match if it contains the
element exactly the number of times entered in the Min text box. For example, if you
search for e with a repetition of Exactly and a minimum value of 2, the ee in meet will be
matched, but the e in met will not.
• This much or more: When chosen, any text element will be considered a match if it contains
the element at least the number of times entered in the Min text box.
• Range: When chosen, any text element will be considered a match if it contains the
element any number of times between the values entered in the Min and Max text boxes.
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• Greedy: When this checkbox is checked, the search engine will try to match the maximal

number of repetitions for the current element before moving on to the next element of the
expression. When it is not checked, the search engine will match only the minimal number of
repetitions. A greedy element is indicated by a small G on its bottom right corner, as shown
in the following figure:

Figure 8-16: Greedy Search Indication
For example, consider a search performed on the following text: To <b>boldly</b> go where no
<colour>person</colour> has gone before.

If we use the expression shown in Figure 8-16 above, then the find engine will match all the
text from the first open tag (<) to the last close tag (>), as shown in the following figure::

Figure 8-17: Greedy Enabled Search Results
The first element in this expression is the open tag (<). After the search engine matches this
element with the < in <b>, it continues to the next element in the expression - Any character.
Since this element is Greedy, Mellel will match the text to the end, since every character in the
text (including the > character) matches as Any character.
Once the engine exhausted Any Character, it will move to the next element in the expression,
the close tag (>). Since the last character in the text is the end of the sentence or the Return
character, there will be no match. Thus, the engine will go back to the greedy Any character
element, subtract the number of repetitions by one and will try to find a match again. This
process of subtraction will continue until there is a match for the close tag element, or until
there are no repetitions of Any Character. In the case above, this will continue until it reaches
the last closing tag, the > in </colour>.
The same expression with greedy turned oﬀ will match only one complete HTML tag, as
shown in the following figure:

Figure 8-18: Greedy Disabled Search Results
When Any Character is not greedy, Mellel will match the first open tag, move to Any character,
and—since Any Character is now not greedy—it will suﬃce itself with the minimum number
of matches (which is zero) and move on immediately to the last element. In our case, since
the character following the first < is b and not >, the search engine will retract to the Any

Find and Replace Expression Elements | 292

character element, add one, and try to find a match again. In this case, it will match b and will
continue to the next element (>). Here, again, it will find a match and the first found match
will be <b>.
Negated: When this checkbox is checked, the element is negated, and the search will match
any text elements that are not defined by the special element. For example, if Negated is
checked for the character set abc, the search will match any character that is not a, b, or c.
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4. Screen Descriptions
1. Menu Bar
The Menu bar is located at the top left side of your screen. It includes the following menus:
• Mellel 4 Menu: Includes general Mellel preferences and licensing functionalities. Refer to
Mellel 4 Menu Description below for a complete description.
• File Menu: Includes file management tools and functionalities. Refer to File Menu
Description on page 305 for a complete description.
• Edit Menu: Includes document editing tools and functionalities. Refer to Edit Menu
Description on page 308 for a complete description.
• Insert Menu: Includes various elements that can be inserted into the document. Refer to
Insert Menu Description on page 317 for a complete description.
• Styles Menu: Includes styling tools and functionalities. Refer to Styles Menu Description on
page 322 for a complete description.
• View Menu: Includes view adjustment functionalities. Refer to View Menu Description on
page 324 for a complete description.
• Window Menu: Includes windows adjustment functionalities. Refer to Window Menu
Description on page 326 for a complete description.
• Help Menu: Includes help and support tools. Refer to Help Menu Description on page 327
for a complete description.

1. Mellel 4 Menu Description
The following figure depicts the Mellel 4 menu and its functionalities:
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Figure 8-19: Mellel 4 Menu

• About Mellel: Shows information about the current Mellel version.
• Buy Mellel: Buy Mellel when using a trial version. This option is replaced by Upgrade License
•
•
•
•
•
•
•
•
•

for users with expired licenses. Refer to Administration and Maintenance on page 8 for more
information.
Registration Code: Displays the registration code for the current Mellel license, or to enter a
new code if applicable. Refer to Administration and Maintenance on page 8 for more
information (not applicable for users who purchased Mellel on the App Store).
Migration Assistant: Migrates settings when upgrading from versions prior to Mellel 4.0.
Choose Migration Assistant then click Migrate in the displayed dialogue-box to migrate all
your settings from the old installation to the new version.
Check for Updates: Checks if there are any software updates available. Refer to Updating
Mellel on page 11 for more information (not applicable for users who purchased Mellel on
the App Store).
Preferences: Opens the Preferences window. Refer to Preferences Window below for a
complete description of the window and its functionalities.
Services: Runs services that are integrated with Mellel, such as picture applications or other
text editors.
Hide Mellel: Hides Mellel and shows other open windows.
Hide Others: Hides other open windows and only shows Mellel.
Show All: Shows all windows after they were hidden.
Quit Mellel: Quits Mellel.

A. Preferences Window
The preferences window is used to configure various Mellel settings. It includes several tabs
that are described in the following subsections.
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1. General Tab
The following figure depicts the Preferences window General tab and its functionalities:

Figure 8-20: Preferences Window - General Tab

• Measurement Units: This popup menu is used to set the default measurement units used in

Mellel to set the size of diﬀerent elements. Refer to Measurement Units on page 281 for more

•
•
•

information.
Page up/down: This popup menu is used to determine the behavior of the page up/down
functionalities. Refer to Navigation on page 35 for more information.
Statistics: These checkboxes are used to configure what document elements are included in
the document statistics. Refer to Document Statistics on page 238 for more information.
Automatically Check for Updates: This popup menu is used to determine the frequency for
automatic updates check. Refer to Updating Mellel on page 11 for more information (not
applicable for users who purchased Mellel on the App Store).
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• Quicklook: This checkbox and the adjacent text box are used to limit the number of pages
•
•
•
•
•
•
•
•

available in the QuickLook preview. Refer to Setting the Number of Pages Available in
QuickLook on page 21 for more information.
Undo Cache: This radio button and the adjacent text box are used to determine the
behavior of the undo/redo caching. Refer to Configuring the Undo Cache on page 43 for
more information.
Document Background: This popup menu and adjacent Colour well are used to set a
diﬀerent colour to the document background. Refer to Setting the Document Background
Colour on page 266 for more information.
Fullscreen Background: This popup menu and adjacent Colour well are used to set a
diﬀerent colour to the document background when working in full screen mode. Refer to
Setting the Document Background Colour on page 266 for more information.
Hyperlink colour: This popup menu and adjacent Colour well are used to set a diﬀerent
colour for hyperlinks in the document. Refer to Changing Hyperlinks Colour on page 105 for
more information.
Story: This checkbox is used to limit the allowed size for images added to characters or
locations in the story pane. Refer to Editing Characters and Locations on page 150 for more
information.
Character style variation names: This list is used to rename character style variations. Refer
to Renaming Character Style Variations on page 192 for more information.
Default reference format: This popup menu is used to determine the default format for
new references inserted into the document. Refer to Setting the Default Reference Format
on page 119 for more information.
Bibliography Application: This popup menu is used to choose the bibliography application
that is used to mange citations in the document. Refer to Selecting a Bibliography
Application on page 130 for more information.

2. Open & Save Tab
The following figure depicts the Preferences window Open & Save tab and its functionalities:
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Figure 8-21: Preferences Window - Open & Save Tab

• Default: This area displays details regarding the default template for new documents, and
•
•
•
•

the Browse button can be used to change the default template. Refer to Setting the Default
Template on page 198 for more information.
Default Plain Text Encoding: This popup menu is used to choose the default encoding for
importing plain text files. Refer to Importing Plain Text Files on page 28 for more
information.
RTF Font Matching Panel: This popup menu is used to determine when is the RTF font
matching panel displayed. Refer to Importing RTF Documents on page 29 for more
information.
Default Template for import: The adjacent Browse button is used to select the default
template that will be used when documents are imported into Mellel. Refer to Importing Files
on page 28 for more information.
Language for import: This checkbox is used to ignore language settings in imported
documents. Refer to Multilingual Support on page 270 for more information.
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• Changes
•
•
•

to styles: This radio button is used to determine how are changes to styles
handled. Refer to Handling Changes to Style Sets on page 196 for more information.
Automatic save: This radio button and adjacent text box are used to configure automatic
save. Refer to Activating Automatic Saving on page 24 for more information.
Automatic backup: This checkbox and adjacent text box are used to configure automatic
backup. Refer to Activating Automatic Backup on page 24 for more information.
Save format: This checkbox is used to configure Mellel to save documents as compressed
packages.

3. Document Setup Tab
The following figure depicts the Preferences window Document Setup tab and its
functionalities:

Figure 8-22: Preferences Window - Document Setup Tab
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• Default Zoom: This popup menu is used to set the default zoom level for a document.
Available options are identical to those described in Zoom popup Menu on page 265. The
default zoom level is 128%.
• Outline Font Size: This popup menu is used to determine the font size for items displayed in
the outline pane. Refer to Changing the Outline Pane Layout on page 145 for more
information.
• Edit Outline With Actual Font & Size: This checkbox is used to determine whether or not
the font and size of outline items matches their corresponding values in the document area.
Refer to Changing the Outline Pane Layout on page 145 for more information.
• User Name: This text box is used to insert the name that will be used to indicate comments
and/or tracked changes made by the current user. Changes are only applied to future
comments/changes, not existing ones.
• User colour: This popup menu is used to set the colour that will be used to indicate
comments and/or tracked changes made by the current user. Changes are only applied to
future comments, not existing ones.
• Comment Character Attributes: This area is used to set the default character attributes for
comments added to the document. Refer to Setting Comments Character Attributes on
page 226 for more information.
• Display User Name: This checkbox is used to determine whether or not the user name is
displayed next to comments and/or tracked changes in the document.
• Display Date and Time: This checkbox is used to determine whether or not the time and
date are displayed next to comments and/or tracked changes in the document.
• Document Variables: This list is used to rename document variables. Refer to Renaming
Document Variables on page 125.
Note: This option only changes the label of the variables. To change their values, refer to
Changing Document Variables Values on page 125.

4. Typography Tab
The following figure depicts the Preferences window Typography tab and its functionalities:
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Figure 8-23: Preferences Window - Typography Tab

• Typographer's
•
•
•
•
•
•
•

Quotes: This checkbox is used to enable typographer's quotes in the
document. Refer to Activating Typographer’s Quotes on page 205 for more information.
Type: This popup menu is used to choose a preset configuration of primary and alternative
quotes based on the selected language. Refer to Activating Typographer’s Quotes on page
205 for more information.
Open Primary: This text box is used to set a custom character to open primary quotes. Refer
to Customizing the Quotation Marks Characters on page 206 for more information.
Close Primary: This text box is used to set a custom character to close primary quotes. Refer
to Customizing the Quotation Marks Characters on page 206 for more information.
Open Alternative: This text box is used to set a custom character to open alternative quotes.
Refer to Customizing the Quotation Marks Characters on page 206 for more information.
Close Alternative: This text box is used to set a custom character to close alternative quotes.
Refer to Customizing the Quotation Marks Characters on page 206 for more information.
Default Decimal Tab Character: This text box is used to set the default character to align a
decimal tab on. Refer to Setting Decimal Alignment Character on page 168 for more
information.
Highlight Font Substitutions: This checkbox is used to determine whether or not font
substitutions are highlighted in the document. Refer to Highlighting Font Substitutions on
page 272 for more information.

5. Hyphenation Tab
The following figure depicts the Preferences window Hyphenation tab and its functionalities:
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Figure 8-24: Preferences Window - Hyphenation Tab

• User Dictionary: This tab is used to display the user dictionary, which includes user-defined
•
•

•
•
•

words that should not be hyphenated or hyphenated in a specific way.
Copyright Information: This tab is used to show copyright information regarding the
diﬀerent hyphenation dictionaries used by Mellel. Choose any language to display its
hyphenation dictionary copyright information, as shown in Figure 8-25 on page 303.
Hyphenation User Dictionary: This list details all the words that were added to the user
hyphenation dictionary. Words that do not include an hyphen will not be hyphenated, while
words that do include an hyphen will be hyphened (when required) exactly the way they
appear in the dictionary.
Refresh Open Documents: Applies changes to the user hyphenation dictionary to all open
documents.
Delete: Deletes the selected word from the hyphenation user dictionary.
Add: Adds a new word to the user hyphenation dictionary. Insert a word without an hyphen
to prevent it from being hyphenated, or insert a word with a hyphen to determine how to
hyphen it, when required.
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Figure 8-25: Hyphenation Dictionary Copyright Information

6. Language Tab
The following figure depicts the Preferences window Language tab and its functionalities:
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Figure 8-26: Preferences Window - Language Tab

• Language: This list details all available languages. The selected language is highlighted in
•
•
•
•
•

blue.
OpenType Language: This popup menu is used to choose the language that will be used
for OpenType features in the selected language. Refer to Using OpenType Features on page
160 for more information.
Spelling Language: This popup menu is used to choose the dictionary that will be used to
spell check text written in the selected language. Refer to Selecting Spelling Dictionary on
page 234.
Associated Keyboard Layout: This popup menu is used to choose the keyboard layout that
is associated with the selected language. Refer to Synchronizing Language and Keyboard
Layout on page 234.
Make Default: This checkbox is used to set the selected language as the default language.
Synchronize Language and Keyboard: This checkbox is used to synchronize the selected
language and keyboard layout. Refer to Synchronizing Language and Keyboard Layout on
page 234.
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7. Tags & Markers Tab
The following figure depicts the Preferences window Tags & Markers tab and its functionalities:

Figure 8-27: Preferences Window - Tags & Markers Tab

• Tags: This list details all available tags and their images.
• Markers: This list is used to customize markers names and colours. Refer to Customizing
Marker Names and Colours on page 236 for more information.

• Add Tag (
•

): Adds a new custom tag. After clicking the button, type in a name for the tag
and drag any jpeg image file onto it to set its image.
Reset: Resets markers names and colours to their default state.

2. File Menu Description
The following figure depicts the File menu and its functionalities:
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Figure 8-28: File Menu

• New: Opens a new blank document. Refer to Creating a New Document on page 19 for more
•
•
•
•
•
•
•
•

information.
New with Default: Uses the default template to create a new blank document, without
opening the template browser. Refer to Creating a New Document on page 19 for more
information.
Open: Opens an existing document. Refer to Opening a Document on page 19 for more
information.
Open Recent: Opens a recently used document. Refer to Opening a Recent Document on
page 20 for more information.
Open Template: Creates a document from a template. Refer to Creating a New Document
on page 19 for more information.
Import: Converts files from diﬀerent formats into Mellel documents. Refer to Importing Files
on page 28 for more information.
Close: Closes the current window without quitting Mellel.
Save: Saves the current document. Refer to Saving a Document on page 23 for more
information.
Save As: Saves the current document under a diﬀerent name. Refer to Duplicating a
Document on page 23 for more information.
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• Duplicate: Creates a copy of the existing document. Refer to Duplicating a Document on
•
•
•
•
•
•
•
•
•

page 23 for more information.
Rename: Renames the current document.
Move To: Moves the current document to a new location.
Save As Template: Saves the current document as a template. Refer to Saving a Document
as a Template on page 23 for more information.
Revert To: Reverts to a previous version of the document, managed by the macOS built in
automatic save functionality. Refer to Reverting to a Previous Version of the Document on
page 20 for more information.
Export: Exports Mellel documents into diﬀerent file formats. Refer to Exporting Files on page
26 for more information.
Replace Styles: Replaces document styles with global styles. Refer to Replacing Styles on
page 193 for more information.
Document Setup: Modifies document properties. Refer to Document Setup Window below
for more information.
Page Setup: Modifies page properties. Refer to Page Setup dialogue-box on page 241 for
more information.
Print: Prints the current document. Refer to Printing a Document on page 241 for more
information.

A. Document Setup Window
The Document Setup window is used to change several document preferences. Settings made
in this window would overwrite any settings made using the Preferences window for the active
document.
To open the window, choose File > Document Setup from the menu bar.
The following figure depicts the Document Setup window and its functionalities:
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Figure 8-29: Document Setup Window

• Binding Direction: This popup menu is used to set the default binding direction for the
•
•
•
•
•

document. Refer to Setting Binding Direction on page 262 for step-by-step instructions.
Background: This checkbox and adjacent Colour well are used to set a non-printable
background colour for the document, for improved visibility. Refer to Setting the On-Screen
Background Colour on page 265 for step-by-step instructions.
Keywords: This text box is used to enter document keywords. Refer to Document
Information on page 240 for more information.
Category: This text box is used to enter the document category. Refer to Document
Information on page 240 for more information.
Comments: This text box is used to enter any comments regarding the document. Refer to
Document Information on page 240 for more information.
Document Variables: This area is used to manage the document variables. Refer to Variables
on page 124 for more information.

3. Edit Menu Description
The following figure depicts the Edit menu and its functionalities:
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Figure 8-30: Edit Menu

• Undo: Cancels the last action you performed. Refer to Undo and Redo on page 43 for more
•
•
•
•

information.
Redo: Repeats the last action that you cancelled. Refer to Undo and Redo on page 43 for
more information.
Cut: Cuts the selected document element to the clipboard. Refer to Basic Editing Tools on
page 40 for more information.
Copy: Copies the selected document element to the clipboard. Refer to Basic Editing Tools
on page 40 for more information.
Copy Special: Copies the selected document element to the clipboard without its style, or
to perform the opposite - to copy certain style attributes of the selected document element
to the clipboard, without the content. Refer to Copying and Pasting as Plain Text on page 40
and Copying and Pasting Attributes on page 40 for more information.
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• Paste: Pastes the clipboard content into the the document. Refer to Basic Editing Tools on
•

•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

page 40 for more information.
Paste Special: Pastes the content of the clipboard without its style, or to perform the
opposite - to paste certain style attributes from the clipboard to the selected document
element without pasting the content. Refer to Copying and Pasting as Plain Text on page 40
and Copying and Pasting Attributes on page 40 for more information.
Clear: Removes the selected document element from the document.
Select All: Selects all the text in the currently edited element. This can be either the entire
document, a table cell, a text box, etc.
Arrange: Arranges floating document elements such as images and text boxes. Refer to
Images on page 92 and Text Boxes on page 98 for more information.
Sort: Opens the Sort sub-menu. Refer to Sort Sub-Menu below for more information.
Right to Left: Sets the selected text paragraph direction as right to left.
Left to Right: Sets the selected text paragraph direction from left to right.
Convert Text to Table: Converts the selected text into a table. Refer to Converting Text to a
Table on page 77 for more information.
Make Section from Selection: Creates a new section from the current document selection.
Refer to Creating a Section on page 175 for more information.
Bibliography: Opens the Bibliography sub-menu. Refer to Bibliography Sub-Menu on page
312 for more information.
Auto-Indent: When the Auto-Indent feature is enabled, this menu is displayed and enables
you to use this feature. Refer to Using Auto-Indent on page 50 for more information.
List: Opens the List sub-menu. Refer to List Sub-Menu on page 313 for more information.
Marker: Opens the Marker sub-menu. Refer to Marker Sub-Menu on page 313 for more
information.
Track Changes: Opens the Track Changes sub-menu. Refer to Track Changes Sub-Menu on
page 314 for more information.
Comment: Opens the Comment sub-menu. Refer to Comment Sub-Menu on page 314 for
more information.
Outline: Opens the Outline sub-menu. Refer to Outline Sub-Menu on page 315 for more
information.
Find: Opens the Find sub-menu. Refer to Find Sub-Menu on page 316 for more information.
Spelling: Opens the Spelling sub-menu. Refer to Spelling Sub-Menu on page 316 for more
information.
Start Dictation: Starts dictating using the macOS built-in dictation functionality.
Emoji & Symbols: Opens the Characters palette which allows inserting diﬀerent characters
into the document without using the keyboard. Refer to Special Characters on page 42 for
more information.

A. Sort Sub-Menu
The Sort sub-menu is used to perform basic and advanced sorting of selected document
elements. Refer to Sorting on page 228 for more information.
The following figure depicts the Sort sub-menu and its functionalities:
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Figure 8-31: Sort Sub-Menu

• Repeat
•
•
•

last Sort: Applies the last sort on the selected document elements. Refer to
Repeating the Previous Sorting on page 230 for step-by-step instructions.
Sort Ascending: Sorts the selected document elements in ascending order. Refer to Basic
Sorting on page 228 for step-by-step instructions.
Sort Descending: Sorts the selected elements in descending order. Refer to Basic Sorting on
page 228 for step-by-step instructions.
Advanced Sort: Opens the Sort window and enables applying advanced sorting to the
selected elements. Refer to Advanced Sorting on page 228 for step-by-step instructions.

B. Auto-Indent Sub-Menu
The Auto-Indent sub-menu is used to control the Auto-Titles Auto-Indent feature when it is
enabled. The sub-menu is only available when Auto-Indent is enabled (refer to Auto-Indent on
page 49 for step-by-step instructions).
The following figure depicts the Auto-Indent sub-menu and its functionalities:

Figure 8-32: Auto-Indent Sub-Menu

• Indent Level: Indents the current paragraph. Refer to Using Auto-Indent on page 50 for
•
•
•

more information.
Outdent Level: Outdents the current paragraph. Refer to Using Auto-Indent on page 50 for
more information.
Clear Level: Clears any Auto-titles from the current paragraph. Refer to Using Auto-Indent
on page 50 for more information.
Continue Same Level: Applies the style of the preceding Auto-title on the current
paragraph. Refer to Using Auto-Indent on page 50 for more information.
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C. Bibliography Sub-Menu
The Bibliography sub-menu is used to insert and manage citations and bibliography into your
document. Refer to Bibliography on page 128 for more information.
The following figure depicts the Bibliography sub-menu and its functionalities:

Figure 8-33: Bibliography Sub-Menu

• Switch
•
•
•
•
•
•
•
•

to Reference Database: Switches to the selected reference management
application.
Find in Reference Database: Opens the search window in the reference management
application with the current selection as the search string. Refer to Opening the Reference
Manager Search Window on page 133 for more information.
Enter Citation Manually: Manually enters a citation. Refer to Inserting Citations Manually
on page 131 for more information.
Convert Text to Citations: Converts the selected text into citations. Refer to Converting Text
to Citations on page 132 for more information.
Verify Citations: Verifies all citations in the document. Refer to Verifying Citations on page
133 for more information.
Scan Document: Scans all the citations in the document, converts them to their final format
and generates a bibliography. Refer to Scanning the Document on page 136 for more
information.
Unscan Document: Unscans the document, which converts all citations to their temporary
format and removes the bibliography. Refer to Unscanning the Document on page 137 for
more information.
Synchronize Database: Synchronizes the reference manager database with the document
to ensure consistency in citations. Refer to Synchronizing the Database on page 130 for
more information.
Bib & Cit. style Mapping: Opens the Bibliography and Citations Styles window to apply style
attributes to bibliography and citations in your document. Refer to Formatting Citations
Using Styles on page 133 and Formatting the Bibliography Using Styles on page 137 for
more information.
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D. List Sub-Menu
The List sub-menu is used to create and manage lists in the document. Refer to Lists on page
69 to learn more about lists.
The following figure depicts the List sub-menu and its functionalities:

Figure 8-34: List Sub-Menu

• Increase One Level: Changes a list item to the next level. If the insertion point is not placed
•
•

within a list item, a new list is created. Refer to Changing a List Item to Next Level on page 70
for step-by-step instructions.
Decrease One Level: Changes a list item to the previous level. If the item is already at the
top level, the list is reset. Refer to Changing a List Item to the Previous Level on page 70 for
step-by-step instructions.
Reset list: Resets the list and remove any list attributes from the selected text. Refer to
Resetting a List on page 70 for step-by-step instructions.

E. Marker Sub-Menu
The Marker sub-menu is used to apply markers to the selected text and to navigate between
marked text. Refer to Markers on page 235 for more information.
The following figure depicts the Marker sub-menu and its functionalities:

Figure 8-35: Marker Sub-Menu

• Markers

List: Lists all available markers, their names and their keyboard shortcut. The
applied marker is indicated by a black tick (if applicable). Refer to Marking Text on page 235
for more information.
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• Find previous marked text: Navigates to the previous marked text. Refer to Navigating
•

Marked Text on page 236 for more information.
Find next marked text: Navigates to the next marked text. Refer to Navigating Marked Text
on page 236 for more information.

F. Track Changes Sub-Menu
The Track Changes sub-menu is used to manage and review tracked changes. Refer to Track
Changes on page 220 for more information.
The following figure depicts the Track Changes sub-menu and its functionalities:

Figure 8-36: Track Changes Sub-Menu

• Activate Track Changes/Turn Oﬀ Track Changes: Activates/deactivates the track changes
•
•
•
•
•

feature. The displayed option is changed accordingly. Refer to Activating Track Changes on
page 221 for step-by-step instructions.
Pause Tracking Changes: Pauses/resumes tracking changes. Refer to Pausing Track
Changes on page 222 for step-by-step instructions. Only enabled when track changes is
active.
Next Change: Navigates to the next tracked change. Refer to Navigating between Changes
on page 223 for step-by-step instructions. Only enabled when track changes is active.
Previous Change: Navigates to the previous tracked change. Refer to Navigating between
Changes on page 223 for step-by-step instructions. Only enabled when track changes is
active.
Reject Change: Rejects the currently selected change. Refer to Accepting/Rejecting
Changes on page 222 for step-by-step instructions. Only enabled when track changes is
active.
Accept Change: Accepts the currently selected change. Refer to Accepting/Rejecting
Changes on page 222 for step-by-step instructions. Only enabled when track changes is
active.

G. Comment Sub-Menu
The Comment sub-menu is used to insert and manage comments in your documents. Refer to
Comments on page 225 for more information.
The following figure depicts the Comment sub-menu and its functionalities:
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Figure 8-37: Comment Sub-Menu

• Add Comment: Adds a new comment to the document. Refer to Adding a Comment on
•
•
•

page 225 for step-by-step instructions.
Previous Comment: Navigates to the previous comment. Refer to Navigating Comments on
page 226 for step-by-step instructions.
Next Comment: Navigates to the next comment. Refer to Navigating Comments on page
226 for step-by-step instructions.
Delete all Comments: Deletes all comments from the document. Refer to Deleting a
Comment on page 226 for step-by-step instructions.

H. Outline Sub-Menu
The Outline Sub-Menu is used to add and edit Outline items. Refer to Inserting Outline Items
on page 140 and Promoting and Demoting Outline Items on page 141 for more information.
The following figure depicts the Outline sub-menu and its functionalities:

Figure 8-38: Outline Sub-Menu

• Increase Level: Moves the selected Outline item (and all of its sub-items, if applicable) one
•
•
•
•

level lower in the Auto-title hierarchy.
Decrease Level: Moves the selected Outline item (and all of its sub-items, if applicable) one
level higher in the Auto-title hierarchy.
Add Sibling: Adds a new sibling for the currently selected Outline item (a sibling is an item
on the same level as the selected item in the hierarchy, with both located under the same
parent).
Add Child: Adds a new child for the currently selected Outline item (a child is an item one
level lower then the selected item in the hierarchy, which is located directly beneath it).
Add Aunt: Adds a new aunt for the currently selected Outline item (an aunt is an item one
level higher then the selected item in the hierarchy, but it is not its direct parent).
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I. Find Sub-Menu
The Find Sub-Menu is used to run diﬀerent find and replace actions, as well as access the Find
Set window. Refer to Find and Replace on page 209 for more information.
The following figure depicts the Find sub-menu and its functionalities:

Figure 8-39: Find Sub-Menu

• Find: Opens the Find panel. Refer to Performing a Basic Find Action on page 209 for step-by•
•
•
•
•

step instructions.
Find Next: Finds the next match in the text to the current find expression. Refer to
Performing a Basic Find Action on page 209 and Performing an Advanced Find Action on
page 211 for step-by-step instructions.
Find Previous: Finds the previous match in the text to the current find expression. Refer to
Performing a Basic Find Action on page 209 and Performing an Advanced Find Action on
page 211 for step-by-step instructions.
Use Selection for Find: Copies the current selection from the document to the Find field in
the Find panel. Refer to Performing a Basic Find Action on page 209 for step-by-step
instructions.
Scroll to Selection: Navigates to the current selection in the document area.
FindSet: Used to open the Find Set window. Refer to Find Set Window on page 429 for a
complete description of the window and its functionalities.

J. Spelling Sub-Menu
The Spelling sub-menu is used to spell check your document, or parts of it. Refer to Spell
Checking on page 231 for more information.
The following figure depicts the Spelling sub-menu and its functionalities:

Figure 8-40: Spelling Sub-Menu
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• Spelling:
•
•
•
•
•
•

Opens the Spelling and Grammar window to handle spelling errors. Refer to
Handling Spelling Errors on page 232 for step-by-step instructions.
Check Spelling: Navigates to the next spelling error, if applicable. Refer to Navigating
Spelling Errors on page 232 for step-by-step instructions.
Check Spelling in Selection: Checks spelling in the selected text. Refer to Checking Spelling
in Selected Text on page 231 for step-by-step instructions.
Check Spelling in Document: Checks spelling in the entire document. Refer to Checking
Spelling in the Entire Document on page 231 for step-by-step instructions.
Don't Check Spelling: Disables spell check. Refer to Disabling Spell Check on page 232 for
step-by-step instructions. When this option is active, it is indicated by a black tick.
Check Spelling As You Type: Enables real time spell check. Refer to Checking Spelling in
Real Time on page 232 for step-by-step instructions. When this option is active, it is indicated
by a black tick.
Check Spelling Per Paragraph: Enables checking spelling whenever a paragraph is
completed (i.e. the Return key is pressed). Refer to Checking Spelling Per Paragraph on page
232 for step-by-step instructions. When this option is active, it is indicated by a black tick.

4. Insert Menu Description
The following figure depicts the Insert menu and its functionalities:
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Figure 8-41: Insert Menu

• Page Variables: Inserts a page variable. Refer to Inserting a Page Variable on page 124 for
•
•
•
•
•
•
•
•

more information.
Document Variables: Inserts a document variable. Refer to Inserting a Document Variable
on page 124 for more information.
Breaks: Opens the Breaks sub-menu. Refer to Breaks Sub-Menu on page 319 for more
information.
Special Characters: Enters special characters into the document. Refer to Special Characters
on page 42 for more information.
Date: Enters a date and time stamp into the document. Refer to Inserting a Date and Time
Stamp on page 126 for more information.
Note: Opens the Note sub-menu. Refer to Note Sub-Menu on page 320 for more
information.
Auto-Title: Opens the Auto-Title sub-menu. Refer to Auto-Title Sub-Menu on page 320 for
more information.
Table of Contents: Inserts a table of contents into the document. Refer to Inserting a Table
of Contents on page 121 for more information.
Table: Inserts a table into the document. Refer to Inserting a Table on page 72 for more
information.
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• Image: Inserts an image into the document. Refer to Inserting an Image on page 93 for more
•
•
•
•
•

information.
Text Box: Inserts a text box into the document. Refer to Inserting a Text Box on page 98 for
more information.
Hyperlink: Inserts a hyperlink into the document. Refer to Inserting a Hyperlink on page 103
for more information.
Cross Reference: Inserts a reference or a bookmark into the document. Refer to Inserting a
Bookmark on page 112 and Inserting a Cross Reference on page 114 for more information.
Story Point: Inserts a new story point in to the document. Refer to Inserting Story Points on
page 147 for more information.
Index: Opens the Index sub-menu. Refer to Index Sub-Menu on page 321 for more
information.

A. Breaks Sub-Menu
The Breaks sub-menu is used to insert diﬀerent breaks to separate documents elements. The
following figure depicts the submenu and its functionalities:

Figure 8-42: Breaks Submenu

• Page break: Inserts a break and starts a new page after it. The new page will use the same
•

•
•
•
•
•

page style as the previous one.
Page style break: Inserts a break and starts a new page with a new page style after it. This
enables dividing the document into diﬀerent page ranges, each starting and ending with a
page style break. Each page range can have unique page attributes. Refer to Page
Formatting on page 178 for more information.
Column break: Inserts a break and starts a new column after it. Refer to Section Formatting
on page 175 for more information.
Section break: Inserts a break and starts a new section after it. Refer to Section Formatting
on page 175 for more information.
Line break: Inserts a break and starts a new line after it, without starting a new paragraph.
Return: Inserts a break and starts a new paragraph after it.
Tab: Inserts a tab. If there is any text after the insertion point, it would be moved to the next
tab stop in the ruler.
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• Direction Breaking Space: Inserts a space character whose directionality matches the set
paragraph directionality. This is diﬀerent from a regular space, which takes its directionality
from the surrounding text. This enables combining Right-to-Left and Left-to-Right
languages in a single paragraph.

B. Note Sub-Menu
The Note sub-menu includes all the note streams available in the document. Refer to Notes on
page 60 for more information.
The following figure depicts the Note sub-menu and its functionalities:

Figure 8-43: Note Sub-Menu

• Note Streams List: Details all note streams that are available in the document. Choose any
•

note stream from the list to add a new note to the document. Refer to Inserting a Note on
page 61 for step-by-step instructions.
Edit note attributes: Opens the Edit Note Attributes window. Refer to Edit Note Attributes
Window on page 376 for more information.

C. Auto-Title Sub-Menu
The Auto-Title sub-menu lists all available Auto-titles flows in the document, allowing you to
insert them into the document. Refer to Auto-Titles on page 44 for more information.
The following figure depicts the Auto-Title sub-menu and its functionalities:
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Figure 8-44: Auto-Title Sub-Menu

• Auto-titles Flows List: Details all available Auto-title flows in the document. Structural flows

•

are separated from Tag flows with a horizontal line. Choose any flow from the list to add a
new Auto-title from that flow into the document. Refer to Inserting an Auto-Title on page 46
for step-by-step instructions.
Edit title flows: Opens the Auto-Titles Flow Setup window. Refer to Auto-Titles Flows Setup
Window on page 370 for more information.

D. Index Sub-Menu
The Index sub-menu is used to insert index records and the actual index into the document.
Refer to Indexing on page 242 for more information.
The following figure depicts the Index sub-menu and its functionalities:

Figure 8-45: Index Sub-Menu

• Quick Index: Opens the Quick Index popover and enables you to quickly add index records
•

and index marks into your document. Refer to Using Quick Index on page 251 for more
information.
New Record: Creates a new index record. Refer to Adding Index Records on page 244 for
more information.
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• New Record & Mark: Creates a new index record and marks the selected document element
•

as a locator for this record. Refer to Adding Index Marks on page 249 for more information.
Insert Index: Inserts the complete index into the document. Refer to Inserting an Index on
page 252 for more information.

5. Styles Menu Description
The following figure depicts the Styles menu and its functionalities:

Figure 8-46: Styles Menu

• Styles Sub-Menus: Manages styles for diﬀerent document elements. Refer to Styles Sub•

Menus below for more information.
Style Sets: Manages document and global style sets. Refer to Style Sets Area on page 324 for
more information.

A. Styles Sub-Menus
The Styles menu includes four sub-menus: Character Style, Paragraph Style, Section Style and
Page Style. They are all used for the same purpose - to manage the corresponding document
element styles. They enable you to apply, edit and delete styles. All four sub-menus are similar
in their functionalities to the Styles tab of the corresponding element palette.
The following figure depicts the Character Style sub-menu and its functionalities, which are
similar to the other three sub-menus:
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Figure 8-47: Character Style Sub-Menu

• Styles List: Lists all available styles and their keyboard shortcut (if applicable), with the
following annotations:
• Black Tick: The style is applied to the currently selected text:

Figure 8-48: Styles Menu Current Style Indication

• Plus Sign: The style was applied to the currently selected text, but some attributes were
changed manually using the corresponding palette:

Figure 8-49: Styles Menu Changes to Current Style Indication

• Minus Sign: The selected text includes more than one style. All used styles are marked with
the minus sign:

Figure 8-50: Styles Menu Multiple Styles Indication

• Black Diamond: The style is being used in the document but is not part of the current style
set (refer to Style Sets on page 186 for more information). These styles are referred to as
Document Styles, and an example is shown in the following figure:

323 | Appendix

Figure 8-51: Styles Menu Document Style Indication

• Red

Exclamation Mark: The selected text includes a font that is not available (only
applicable to character styles):

Figure 8-52: Styles Menu Missing Font Indication

• Save changes to style: Saves changes made in the document area to the current style.
•
•

These changes will be applied to all document elements that are using the saved style. Refer
to Editing a Style on page 190 for step-by-step instructions.
Create new character style: Creates a new style based on the style applied to the current
selection. Refer to Creating a New Style on page 189 for step-by-step instructions.
Edit <style name> (where <style name> is replaced by the style used in the currently
selected text): Edits the style applied to the current selection. Refer to Editing a Style on page
190 for step-by-step instructions.

B. Style Sets Area
The Style Sets area of the Styles menu enable you to manage style sets. The following figure
depicts the area and its functionalities:

Style set
List

Document
Set
Edit
Style sets

Figure 8-53: Styles Menu Style Sets Area

• Style Sets List: Lists all global style sets, sorted alphabetically.
• Document set: Lists document style sets for all the currently open documents. That is, style
•

sets that are used in one of the documents but are not part of your style sets library.
Document style sets are indicated by a black diamond, as shown in Figure 8-53 above.
Edit Style sets: Opens the Style sets window. Refer to Style Sets Window on page 423 for a
complete description of the window and its functionalities.

6. View Menu Description
The following figure depicts the View menu and its functionalities:
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Figure 8-54: View Menu

• Show Tab Bar: Shows/hides the Tab Bar. Refer to Showing/Hiding UI Elements on page 266
•
•
•
•
•
•
•
•

for more information. Tabs are only supported for MacOS 10.12 (Sierra) and later versions.
Full Screen: Enters full screen mode. Refer to Working in Full Screen Mode on page 263 for
more information.
Zoom: Opens the Zoom sub-menu, which includes similar options to the Zoom popup menu
in the bottom bar, as described in Zoom popup Menu on page 265.
Show Hidden: Opens the Show Hidden sub-menu. Refer to Show Hidden Sub-Menu on page
269 for more information.
Outline/Index/Story: Shows/hides the selected pane in the side panel. Refer to Showing/
Hiding UI Elements on page 266 for more information. The active pane is indicated by a
black tick. Selecting the active pane from this menu results in hiding the side panel.
Annotations Pane: Shows/hides the Annotations Pane. Refer to Showing/Hiding UI
Elements on page 266 for more information.
Mellel view/Compact view: Sets the view mode. Refer to Changing Document View Modes
on page 263 for more information. The active mode is indicated by a black tick.
Show Toolbar/Show Ruler/Show Bottom Bar: Shows/hides the selected element. Refer to
Showing/Hiding UI Elements on page 266 for more information. When the element is shown
it is indicated by a black tick.
Navigate: Opens the Navigate sub-menu. Refer to Navigate Sub-Menu on page 326 for more
information.
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• Customize Toolbar: Opens the Customize Toolbar window. Refer to Customizing the Toolbar
on page 268 for more information.

A. Navigate Sub-Menu
The Navigate sub-menu is used to navigate the document. Refer to Navigation on page 35 for
more information.
The following figure depicts the Navigate sub-menu and its functionalities:

Figure 8-55: Navigate Sub-Menu

• Go to Page: Opens the Go to Page dialogue-box, which allows you to navigate to a specific
•
•
•
•

page in the document.
Go to Start: Navigates to the top of the document.
Page Up: Scrolls either one page or one screen length up, based on the preferences
described under Configuring Scrolling Preferences on page 37.
Page Down: Scrolls either one page or one screen length down, based on the preferences
described under Configuring Scrolling Preferences on page 37.
Go to End: Navigates to the bottom of the document.

7. Window Menu Description
The following figure depicts the Window menu and its functionalities:

Figure 8-56: Window Menu
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• Minimize: Minimizes Mellel into the dock.
• Show Previous Tab: Switches to the previous Mellel tab. Refer to Navigating Tabs on page
•
•
•
•
•
•
•

264 for more information. Tabs are only supported for MacOS 10.12 (Sierra) and later
versions.
Show Next Tab: Switches to the next Mellel tab. Refer to Navigating Tabs on page 264 for
more information. Tabs are only supported for MacOS 10.12 (Sierra) and later versions.
Move Tab to New Window: Moves the current tab to a new window. Refer to Working with
Multiple Tabs on page 264 for more information. Tabs are only supported for MacOS 10.12
(Sierra) and later versions.
Merge All Windows: Merges all Mellel windows into multiple tabs in a single window. Refer
to Working with Multiple Tabs on page 264 for more information. Tabs are only supported for
MacOS 10.12 (Sierra) and later versions.
Palettes: Opens the palettes sub-menu and the selected palettes or palette groups. Refer to
Opening a Palette or Palette Group on page 267 for more information.
Welcome to Mellel: Opens Mellel's welcome window, which enables you to create a new
document or load a recent one.
Bring All to Front: Brings all Mellel windows to the front of the screen.
Documents List: Lists all Mellel documents that are currently open. The current document is
indicated by a black tick.

8. Help Menu Description
The following figure depicts the Help menu and its functionalities:

Figure 8-57: Help Menu

• Search: Searches for features within Mellel's menus and online help. Refer to Searching for
•
•
•
•
•

Specific Features on page 279 for more information.
Online Help: Opens Mellel's online help in your default web browser.
Mellel Guide: Displays Mellel's user manual.
Learn: Opens Mellel's learning page in your default web browser.
Support: Sends a support request to Mellel. Refer to Contacting Mellel Support on page 280
for more information.
License Agreement: Displays Mellel's license agreement.
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• Privacy: Displays Mellel's privacy policy.

2. Toolbar
The following items are included in the toolbar by default. However, you can customize the
toolbar to meet your personal requirements, as detailed in Customizing the Toolbar on page
268.

1. Tab Well
Tabs are special stop points you can add to the Ruler. Once added, they can be used to align
text and enable a consistent paragraph layout. Refer to Managing Tab Stops and Tabs on page
166 for more information.
When you press the Tab key on your keyboard, all the text following the insertion point is
pushed forward to the next tab stop, as shown in the following figure:
Insertion
Point

Tab

Tab

Insertion
Point

Figure 8-58: Before (Left) and After (Right) Pressing the Tab Key
Note: If there is no tab stop in the Ruler after the current insertion point position and you press
the Tab key, the text is moved to the next line.
The Tabs Well enables you to add one of six available tab types, as shown in the following
figure:

Figure 8-59: Tabs Well

• Combo Tab (

): The Combo tab allows setting both the start and indent point for a tab. It
comprises two adjustable arms: the Start arm (the smaller arrow) sets the position for all the
lines in the text but the first. The Indent arm (the bigger arrow) sets the position for aligning
the text immediately following the tab. The Combo tab is useful for creating multiple levels
of indented text using the same paragraph style.
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For example, in the following figure the Start arm is positioned at 2 centimeters. This is the
position for all paragraph lines but the first. The Indent arm (indicated in blue) is positioned
at 1.5 centimeters, which is the position of the first paragraph line:

Figure 8-60: Combo Tab Example

• Indent Tab (

): The Indent tab sets the position of the text immediately following the tab
and any subsequent lines in the same paragraph. It is very useful in cases where you want to
align text without creating a list or indent text without starting a new paragraph, as shown
in the following figure:

Figure 8-61: Indent Tab Example

• Regular Tab (

): The Regular tab is the standard and most common tab. It is used as a
reference point for text that is aligned to it, as shown in the following figure:

Figure 8-62: Regular Tab Example

• Centre Tab (

): The Centre tab is used as a reference point for text that is centered around it,
as shown in the following figure:
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Figure 8-63: Centre Tab Example

• Reverse Tab (

): The Reverse tab is used as a reference point for text that is aligned to it

against the text direction, as shown in the following figure:

Figure 8-64: Reverse Tab Example

• Decimal Tab (

): The Decimal tab serves as an alignment point for numbers, based on a
special alignment character set in the Paragraph palette (refer to Setting Decimal
Alignment Character on page 168 for step-by-step instructions).
The Align On character should be the character used in your country as a decimal separator.
For example, in English speaking countries text is aligned on a dot (.), as shown in the following figure:

Figure 8-65: Decimal Tab Example

3. Ruler
The Ruler contains several tools and indications that allow you to set and change paragraph
layout:
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Start
margin

End
margin

Tab

Indent

Selected
tab

Figure 8-66: Ruler

• Start margin (
•

•
•

): Sets and indicates the start position for paragraph lines. Refer to Setting
Paragraph Margins on page 165 for step-by-step instructions.
Indent ( ): Sets and indicates the position for the first line in a paragraph. When it is
positioned after the Start margin, the paragraph will be indented. When it is positioned
before the start margin, it is outdented. Refer to Setting Paragraph Indention on page 166
for step-by-step instructions.
End margin ( ): Sets and indicates the position where all the lines in the paragraph break
and flow to the next line. Refer to Setting Paragraph Margins on page 165 for step-by-step
instructions.
Tabs ( ): Sets and indicates stop points you can add to the Ruler, and to which text can later
be aligned. Refer to Managing Tab Stops and Tabs on page 166 for more information.

4. Track Changes Bar
The Track Changes bar is used to configure the track changes functionality. Refer to Track
Changes on page 220 for more information and step-by-step instructions for showing the bar.
The following figure depicts the Track Changes bar and its functionalities:

Figure 8-67: Track Changes Bar

• Show/Hide Annotations Pane: This button (
•

) is used to show or hide the annotations

pane, where tracked changes are displayed. Refer to Showing/Hiding the Annotation Pane
on page 221 for step-by-step instructions.
Display mode: This popup menu is used to set the display mode for tracked changes (refer
to Setting The Track Changes Display Mode on page 222 for step-by-step instructions). The
following options are available:
• Original: The text is displayed in its original form, before any changes were made, as shown
in the following figure:
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Figure 8-68: Track Changes Original Display Mode
Changes such as deleted or replaced text are not displayed, only marked. Styling changes
are always displayed, even when in original mode.
Note: When you make any text changes in Original mode, the display mode automatically
switches to Show Changes.
Show Changes: The text is displayed with all the changes visible, as shown in the following
figure:

Figure 8-69: Track Changes Show Changes Display Mode.

• Final: The text is displayed in its final mode as if all the changes were accepted. Deletions,
additions or other changes are marked as shown in the following figure:

Figure 8-70: Track Changes Final Display Mode

• Final with Markup: The text is displayed with additions highlighted and deletions marked,
as shown in the following figure:
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Figure 8-71: Track Changes Final with Markup Display Mode

• Author: This popup menu is used to filter the tracked changes so that only changes made by
the selected author are displayed. Refer to Filtering Displayed Changes by Author on page
222 for step-by-step instructions.

• Pause

(

): This button is used to pause tracking changes without deactivating it

completely. Refer to Pausing Track Changes on page 222 for step-by-step instructions. When
the track changes feature is paused, the button is highlighted in red ( ).

• Navigation Buttons: These buttons are used to navigate to the next (

) or previous (

)

change. Refer to Navigating between Changes on page 223 for step-by-step instructions.

5. Outline Pane
The Outline pane is used to provide an overview of the document structure, to navigate it and
to change it as required. Refer to Outline on page 139 for more information.
The following figure depicts the Outline pane and its functionalities:

Figure 8-72: Outline Pane

• Outline/Story/Index Tabs: Navigates between the three panes that can be displayed in the
side pane: Outline, Story and Index. The active pane is displayed in Bold.
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• Document Outline: Displays all the Auto-titles and bookmarks in the document. Items that
•

are tagged are indicated by a corresponding icon. Items that are marked with a marker are
underlined with a corresponding colour.
Filter: This text box is used to filter the displayed outline items by text strings. Refer to
Filtering Outline Items on page 144 for more information.

• Filter Markers (

): This button is used to filter the outline items by their markers. Refer to

Filtering Outline Items on page 144 for more information.

• Filter Tags (
•
•

): This button is used to filter the outline items by their tags. Refer to Filtering

Outline Items on page 144 for more information.
Promote ( ): Promotes the selected outline item one level higher in the title flows
hierarchy. Refer to Promoting and Demoting Outline Items on page 141 for more
information.
Demote ( ): Demotes the selected outline item one level lower in the title flows hierarchy.
Refer to Promoting and Demoting Outline Items on page 141 for more information.

• Add Outline Element (

): Inserts a new outline item. Refer to Inserting Outline Items on
page 140 for more information.

• Toggle

Combined/Separate View (

): Determines whether Tag Flows are displayed

within the Structural Flows that include them, or in a separate outline section. Refer to
Changing the Outline Pane Layout on page 145 for more information. The button is
highlighted in blue when tag flows are displayed separately.

• Toggle

showing remarks (

): Determines whether remarks added to Auto-titles are

shown or hidden in the outline. Refer to Changing the Outline Pane Layout on page 145 for
more information. The button is highlighted in blue when remarks are shown.

• Resize side pane (

): Resizes the side pane. Refer to Changing the Outline Pane Layout on

page 145 for more information.

6. Story Pane
The Story pane is used to keep track of the progress of the plot in manuscripts and novels.
Refer to Story on page 147 for more information.
The following figure depicts the Story pane and its functionalities:
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Figure 8-73: Story Pane

• Outline/Story/Index Tabs: Navigates between the three panes that can be displayed in the
•
•

side panel: Outline, Story and Index. The active pane is displayed in Bold.
Points/Characters/Locations: Navigates between the three tabs that can be displayed in
the Story pane.
Story Points/Characters/Locations List: Displays all the story points/characters/locations
that exist in the document. Items that are tagged with tags are indicated by a corresponding
icon. Items that are marked with a marker are underlined with a corresponding colour. In the
Characters and Locations tabs, images can be added to items to assist in visually identifying
them (refer to Editing Characters and Locations on page 150 for more information).

• Sort Button (
•

): Sorts the displayed story points/characters/locations in a particular order.

Refer to Sorting Story Points, Characters and Locations on page 152 for more information.
Filter: This text box is used to filter the displayed items using text strings. Refer to Filtering
Story Points, Characters and Locations on page 151 for more information.

• Filter Markers (

): This button is used to filter the displayed items by their markers. Refer

to Filtering Story Points, Characters and Locations on page 151 for more information.

• Filter Tags (

): This button is used to filter the displayed items by their tags. Refer to

Filtering Story Points, Characters and Locations on page 151 for more information.

• Toggle

showing details (

): Determines whether story point details (importance,

locations, characters and time & date) are shown in the story pane. When the details are
shown, the button is highlighted in blue.

• Toggle expanding story points inline (

): Determines the appearance of story points in

the document area. Refer to Changing the Appearance of Story Points in the Document Area
on page 149 for more information.

• Resize side pane (

): Resizes the side pane. Refer to Changing the Story Pane Layout on

page 152 for more information.
335 | Appendix

7. Index Pane
The Index pane is used to create and manage indexes in the document. Refer to Indexing on
page 242 for more information.
The following figure depicts the Index pane and its functionalities:

Figure 8-74: Index Pane

• Outline/Story/Index Tabs: Navigates between the three panes that can be displayed in the
side panel: Outline, Story and Index. The active pane is displayed in Bold.
Indexes: This popup menu is used to choose the active index.

•
• Settings (
•
•

): This button is used to open the settings menu, which allows managing and

configuring indexes.
Index Records Outline: Displays a hierarchy of all created Index Records in the active index.
Items that are tagged are indicated by a corresponding icon. Items that are marked with a
marker are underlined with a corresponding colour.
Filter: This text box is used to filter the displayed index records by text strings. Refer to
Filtering Index Records on page 248 for more information.

• Filter

Markers (

): This button is used to filter the displayed index records by their

markers. Refer to Filtering Index Records on page 248 for more information.
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• Filter Tags (

): This button is used to filter the displayed index records by their tags. Refer

to Filtering Index Records on page 248 for more information.

• Add New Index Record (

): Adds a new Index Record. Refer to Adding Index Records on
page 244 for more information.

• Insert Index Mark (

): Marks the current document selection as a new Index Mark for the

selected Index Record. Refer to Adding Index Marks on page 249 for more information.

• Resize side pane (

): Resizes the side pane. Refer to Changing the Index Pane Layout on

page 260 for more information.

8. Palettes
There are ten (10) palettes in Mellel that include diﬀerent tools and functionalities grouped into
categories. You can configure your display layout to only show specific palettes, and to move
them around the screen as you wish. Refer to Configuring the Palette Layout on page 266 for
more information on changing the palette layout.
The following palettes are available:
• Character Palette: Used to edit character attributes and styles. Refer to Character Palette
Description below for a complete description.
• Paragraph Palette: Used to edit paragraph attributes and styles. Refer to Paragraph Palette
Description on page 342 for a complete description.
• List Palette: Used to edit list attributes and styles. Refer to List Palette Description on page
346 for a complete description.
• Section Palette: Used to edit section attributes and styles. Refer to Section Palette
Description on page 349 for a complete description.
• Page Palette: Used to edit page attributes and styles. Refer to Page Palette Description on
page 352 for a complete description.
• Table Palette: Used to edit tables structure and style. Refer to Table Palette Description on
page 357 for a complete description.
• Auto-Title Palette: Used to insert and manage Auto-titles. Refer to Auto-Title Palette
Description on page 362 for a complete description.
• Bibliography Palette: Used to manage bibliography in the document. Refer to Bibliography
Palette Description on page 363 for a complete description.
• Reference Palette: Used to enter and navigate references in the document. Refer to
Reference Palette Description on page 364 for a complete description.
• Markers Palette: Used to mark elements in the document and to browse marked elements.
Refer to Markers Palette Description on page 365 for a complete description.
• Statistics Palette: Used to display document statistics. Refer to Statistics Palette Description
on page 366 for a complete description.

1. Character Palette Description
The Character palette is used to style characters. You can either apply attributes directly to
selected characters, or use styles to apply several attributes at the same time. Refer to Styling
Essentials on page 155 for more information.
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The Character palette comprises two tabs:
• Attributes Tab: Used to manually apply attributes to selected characters.
• Styles Tab: Used to manage character styles.

A. Character Palette Attributes Tab
The following figure depicts the Character palette Attributes tab and its functionalities:

Figure 8-75: Character Palette Attributes Tab

• Font: This popup menu is used to set a font type (e.g. Arial, Times New Roman, Helvetica

etc.). Refer to Setting Character Font Family on page 157 for step-by-step instructions. The
availability of options in the list is determined by the fonts installed on your computer.
• Face: This popup menu is used to set a font face (Bold, Italic, etc.). Refer to Setting Character
Font Face on page 157 for step-by-step instructions. The availability of options in the list is
determined by the font selected in the Font popup menu. Some fonts have many faces, but
other fonts may have but a single, regular face.
• Size: This popup menu is used to set a font size (in points). Refer to Setting Character Font
Size on page 158 for step-by-step instructions. You can either choose a value from the list or
choose the Other option to manually enter a value.
• Line: This popup menu is used to add diﬀerent types of lines to the character. Refer to
Adding Lines to the Character on page 159 for step-by-step instructions.
Note: Once any line is added to the character, it can be styled using the various Stroke
functionalities. Refer to Setting Character Stroke on page 158 for step-by-step instructions.
• Stroke: This button is used to open the Stroke popover, which is used to style the stroke for
the character outline and/or any lines added to the character. Refer to Setting Character
Stroke on page 158 for step-by-step instructions.
• Stroke Type: This popup menu is used to determine the the stroke type.
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• Stroke Weight: This popup menu is used to determine the stroke size. You can set the size

either in absolute points or in percentages compared to the character font size. You can
either choose one of the value in the list, or choose the Other option and manually enter a
value. The popup menu is disabled when None is chosen in the Stroke popup menu.
• Stroke colour: This popup menu is used to open the Colour window to determine the
stroke colour. Refer to Setting Character Stroke on page 158 for step-by-step instructions,
and to Colour Window on page 281 for a complete description of how to use the Colour
window.
• Fill: This popup menu is used to determine the character filling pattern. Refer to Setting
Character Fill colour on page 158 for step-by-step instructions.
• Fill Colour: This button is used to open the Colour window to determine the character fill
colour. Refer to Setting Character Fill colour on page 158 for step-by-step instructions, and to
Colour Window on page 281 for a complete description of how to use the Colour window.
• Background: This popup menu is used to determine the character background filling
pattern. Refer to Setting Character Background Fill on page 158 for step-by-step instructions.
• Background Colour: This button is used to open the Colour window to determine the
character background fill colour. Refer to Setting Character Background Fill on page 158 for
step-by-step instructions, and to Colour Window on page 281 for a complete description of
how to use the Colour window.
• Position: This popup menu is used to determine the vertical position of the characters. Refer
to Setting Character Vertical Position on page 159 for step-by-step instructions. The
following options are available:
• Normal: Characters are placed on the baseline text level.
• Superscript: Characters are placed above the baseline text level. For example the digit 2 in
the following expression: X2.
• Subscript: Characters are placed below the baseline text level. For example the digit 2 in the
following expression H2O.
• Case: This popup menu is used to apply special capitalization attributes to the characters.
Refer to Setting Character Capitalization on page 160 for step-by-step instructions. The
following options are available:
• None: No special capitalization is applied.
• All Caps: All characters are displayed in regular caps. For example Mellel.
• Small Caps: The first character in a word is displayed in regular caps and all the following
characters are displayed in small caps (fake caps). For example Mellel.
• OpenType: This popup menu is used to determine which OpenType features are enabled for
the selected characters. Refer to Using OpenType Features on page 160 for step-by-step
instructions. Enabled features are marked by a black tick, and you can remove all features by
choosing Clear All. Refer to Advanced Typography on page 200 for a complete description
of available features.
Note: OpenType features only create a change when the font being used is an OpenType font
and the selected text includes the relevant options.
For example, if a font contains special ligatures that should be displayed only when writing in
Deutsch, then choosing Deutsch from the Language popup menu will cause Mellel to display
this special ligature when the text includes it.
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• Baseline shift: This text box is used to manually enter a value for the characters shift from

the text baseline level. Refer to Setting Character Vertical Position on page 159 for step-bystep instructions. Positive values would shift the characters above the baseline text level,
while negative values would shift the characters below it.
• Ligatures: This checkbox is used to enable ligatures for the selected characters. Refer to
Enabling Ligatures on page 160 for step-by-step instructions.
• Options: This button is used to open the Options popover, which includes the following
options:
• Script: This popup menu is used to set the script of the secondary font in bi-lingual texts.
The selection determines which font will be selected when switching between script
systems. For example, if you set the script to Arabic (and set the appropriate font, of
course), when you switch to an Arabic keyboard layout, Mellel will automatically select and
use the font, face, and size set for the secondary font. Refer to Setting the Secondary Font
Script on page 161 for step-by-step instructions.
Note: All the other Secondary font fields are disabled until a script is set.
• Font: This popup menu is used to set the font type (Arial, Times New Roman, Helvetica,
etc.) of the secondary font in bi-lingual texts. Refer to Setting the Secondary Font Type
on page 161 for step-by-step instructions. The availability of options in this list is
determined by the fonts installed on your computer.
Note: This feature is disabled until selecting a secondary font script. Refer to Setting the
Secondary Font Script on page 161 for step-by-step instructions.
• Face: This popup menu is used to set the font face (Bold, Italic, etc.) of the secondary font
in bi-lingual texts. Refer to Setting the Secondary Font Face on page 162 for step-by-step
instructions. The availability of options in the list is determined by the font selected in the
Font popup menu.
Note: This feature is disabled until selecting a secondary font script. Refer to Setting the
Secondary Font Script on page 161 for step-by-step instructions.
• Size Slider: Determines the secondary font size in bi-lingual texts. Refer to Setting the
Secondary Font Size on page 162 for step-by-step instructions. The size is determined in
percentages of the main font size. By default the secondary font is set to be the same size
as the main font (100%). Moving the slider right would make the secondary font bigger,
while moving it left would make its smaller.
Note: This feature is disabled until selecting a secondary font script. Refer to Setting the
Secondary Font Script on page 161 for step-by-step instructions.
• Font Size (Percentage): This read-only text box indicates the relative size of the secondary
font in relation to the main font. The value is updated based on the position of the Size
Slider and the main font size.
• Font Size (Absolute): This read-only field indicates the absolute size of the secondary font
(in points) in bi-lingual texts. The value is determined based on the position of the Size
Slider and the main font size.
• Tracking: This field allows you to set character tracking in 1/1000th of an EmSpace units,
typing a value or using the stepper.
• Direction: This option should not be used, it is only kept in the palette for backwards
compatibility purposes.
• Kashida: This checkbox is used to enable Kashida, used primarily in documents written in
Arabis script. Refer to Enabling Kashida on page 161 for step-by-step instructions.
Screen Descriptions | 340

B. Character Palette Styles Tab
The following figure depicts the Character palette Styles tab and its functionalities:

Figure 8-76: Character Palette Styles Tab

• Variation: This popup menu is used to choose a character style variation to apply or edit.
•

Refer to Character Style Variations on page 187 for more information and to Managing
Character Style Variations on page 191 for step-by-step instructions.
Styles List: Details all available character styles, with the following annotations:
• Blue tick: The style is applied in the currently selected text.

Figure 8-77: Current Style Indication

• Blue tick and black plus sign: the table contains overrides to the table style.
Figure 8-78: Changes to Current Style Indication

• Minus sign: The selected text includes more than one style. All included styles are marked.

Figure 8-79: Multiple Styles Indication

• Black diamond: The style is being used in the document but it is not part of the current
style set (refer to Style Sets on page 186 for more information). These styles are referred to
as Document Styles, and an example is shown in the following figure:
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Figure 8-80: Document Style Indication

• Create new style: Creates a new style. Refer to Creating a New Style on page 189 for stepby-step instructions.
• Delete style: Deletes the selected style. Refer to Deleting a Style on page 192 for step-bystep instructions.
• Edit style: Edits the selected style. Refer to Editing a Style on page 190 for step-by-step
instructions.
• Apply style: Applies the selected style to the selected text. Refer to Applying a Style on page
187 for step-by-step instructions.
• Save changes to style: Applies changes from the selected text to the selected style. Refer to
Editing a Style on page 190 for step-by-step instructions.
• Language: This popup menu is used to apply a language for the selected text (refer to
Multilingual Support on page 270 for more information.
Note: Applying a language is not considered a style attribute change and will not be
highlighted as an override in the style’s list.

2. Paragraph Palette Description
The Paragraph palette is used to style paragraphs. You can either apply attributes directly to
selected paragraphs, or use styles to apply several attributes at the same time. Refer to Styling
Essentials on page 155 for more information.
The Paragraph palette comprises two tabs:
• Attributes Tab: Used to manually apply attributes to selected paragraphs.
• Styles Tab: Used to manage paragraphs styles.

A. Paragraph Palette Attributes Tab
The following figure depicts the Paragraph palette Attributes tab and its functionalities:
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Figure 8-81: Paragraph Palette Attributes Tab

• Alignment Buttons: These buttons are used to set the paragraph text alignment (refer to
Aligning Paragraph Text on page 164 for step-by-step instructions). The following options
are available:

• Align to the left (
• Align to the centre (

): Text is aligned to the left side of the page.
): Text is aligned around the centre of the page.

• Align to the right (

): Text is aligned to the right side of the page.

• Block justification (

): Text is aligned to both sides of the page.

• Paragraph Spacing: These text boxes are used to set the spacing between paragraphs (refer
to Setting Paragraph Spacing on page 165 for step-by-step instructions).
• Above: This text box is used to set the spacing above the paragraph.
• Below: This text box is used to set the spacing below the paragraph.
• Also at top of pg/col: This checkbox is used to determine whether or not the spaces set
using the Above and Below text boxes are maintained when the paragraph is at the top of a
page/column. When the checkbox is not checked, no top spacing is applied, thus
preventing unnecessary white spaces at the top of a page.
Note: Paragraph spacing is calculated based on the larger value. For example, if paragraph A
has a set space below of 5 points, while paragraph B following it has a set space above of 8
points, the spacing between the two paragraphs will be 8 points (rather than 5 or 13 points).
• Line Spacing: Determines the spacing between lines within the paragraph (refer to Setting
Paragraph Line Spacing on page 165 for step-by-step instructions).
• Units: This popup menu is used to determine the units for the line spacing. Available
options include Lines or Points.
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• Amount: This text box is used to enter the value for the line spacing, based on the units set

in the Units popup menu.
• Minimum Word Spacing: sets the minimum spacing allowed, in per cent points, between
words in a paragraph that is block aligned. The default is 100% (no change in spacing).
• Margins: Sets diﬀerent margins for the paragraph in relation to page borders.
• Start: This text box is used to set the distance between the page margin and where the
paragraph lines begin (refer to Setting Paragraph Margins on page 165 for step-by-step
instructions).
• End: This text box is used to set the distance from the page margin where all the lines in
the paragraph break and flow to the next line (refer to Setting Paragraph Margins on page
165 for step-by-step instructions).
• Indent: This text box is used to set the distance between the page margin and the first line
in a paragraph (refer to Setting Paragraph Indention on page 166 for step-by-step
instructions).
• Tab: Manages tabs added to the paragraph.
• Lead: This popup menu is used to set a leading character for the selected tab (refer to
Adding a Lead to a Tab Stop on page 168 for step-by-step instructions). This character
will be repeated from the end of the text until the tab position.
• Position: This text box is used to set the selected tab position. Refer to Moving a Tab Stop
on page 168 for step-by-step instructions.
• Dec. align on: This text box is used to enter the character to align the selected decimal tab
on. Refer to Setting Decimal Alignment Character on page 168 for step-by-step
instructions.
Note: This option is only enabled when a decimal tab is selected.

B. Paragraph Palette Styles Tab
The following figure depicts the Paragraph palette Styles tab and its functionalities:
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Figure 8-82: Paragraph Palette Styles Tab

• Styles List: Details all available paragraph styles, with the following annotations:
• Blue tick: The style is applied in the currently selected text.
Figure 8-83: Current Style Indication

• Blue tick and black plus sign: Changes made to the current style.
Figure 8-84: Changes to Current Style Indication

• Minus sign: The selected text includes more than one style. All included styles are marked.

Figure 8-85: Multiple Styles Indication

• Black diamond: The style is being used in the document but it is not part of the current
style set (refer to Style Sets on page 186 for more information). These styles are referred to
as Document Styles, and an example is shown in the following figure:

Figure 8-86: Document Style Indication

• Create new style: Creates a new style. Refer to Creating a New Style on page 189 for stepby-step instructions.
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• Delete style: Deletes the selected style. Refer to Deleting a Style on page 192 for step-by•
•
•

step instructions.
Edit style: Edits the selected style. Refer to Editing a Style on page 190 for step-by-step
instructions.
Apply style: Applies the selected style to the selected text. Refer to Applying a Style on page
187 for step-by-step instructions.
Save changes to style: Applies changes from the selected text to the selected style. Refer to
Editing a Style on page 190 for step-by-step instructions.

3. List Palette Description
The List palette is used to create and style lists. You can either apply attributes directly to
selected lists, or use styles to apply several attributes at the same time. Refer to Styling
Essentials on page 155 for more information.
The List palette comprises two tabs:
• Attributes Tab: Used to manually apply attributes to selected lists.
• Styles Tab: Used to manage list styles.

A. List Palette Attributes Tab
The following figure depicts the List palette Attributes tab and its functionalities:

Figure 8-87: List Palette Attributes Tab

• Decrease (

): Moves a list item to the previous level. If the item is already at the top level,

the list is reset. Refer to Changing a List Item to the Previous Level on page 70 for step-bystep instructions.
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• Increase (

): Moves a list item to the next level. If the insertion point is not placed within a

list item, a new list is created. Refer to Changing a List Item to Next Level on page 70 for stepby-step instructions.
Note: The list control buttons (Decrease and Increase) icons will change when the paragraph
direction is changed to reflect the correct text direction.

• Reset (
•
•

): Resets the list and remove any list attributes from the selected elements. Refer

to Resetting a List on page 70 for step-by-step instructions.
Start at: Sets the initial value for a list. Refer to Changing the List Initial Number on page 71
for step-by-step instructions.
Symbol Format: This area is used for formatting the selected list (refer to Styling a List using
Attributes on page 71 for step-by-step instructions). The following formatting options are
available:
• Symbol Type: Chooses the symbol that is used in the currently selected level. Some
symbols are sequential (e.g. numbers, letters) while others are not (e.g. bullets, asterisks).
• Symbol format: Sets the format for displaying the selected symbol with or without any
appended punctuation marks.
• Symbol position: Determines the distance of the symbol from the previous margin (this
can be either the page margin or the margin of the previous level). The symbol position is
indicated by a small dot in the Ruler, as shown in the following figure:

Figure 8-88: Symbol Position Icon in Ruler

• Indent: Determines the distance of the first line in the list item from the previous margin.
The combination of the Symbol position and Indent values determines the distance
between the text and the symbol. For example, if you set the Symbol position to 3 points
and the Indent to 15 points, then the distance between the symbol and the text will be 12
points. The indent marker is indicated by a half-hexagon in the Ruler, as shown in the
following figure:

Figure 8-89: Indent Icon in Ruler
• Margin: Determines the distance of all non-first lines from the previous margin. This also
sets the margin for the next level.
• or example, if you set the Margin to zero, then the next level will start at the same level as
the current one. The margin is indicated by a small diamond in the Ruler, as shown in the
following figure:

Figure 8-90: Margin Icon in Ruler
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• Character Attributes Panel: Opens the character attributes popover, which enables you

to apply character attributes manually or to choose a character style and style variation
that will be applied to the list text.
Note: Any changes performed using the attributes tab will only aﬀect the current list and the
currently selected level.

B. List Palette Styles Tab Description
The following figure depicts the Lists palette Styles tab and its functionalities:

Figure 8-91: List Palette Styles Tab

• Decrease (

): Identical to the corresponding button in the Attributes tab. Refer to List

Palette Attributes Tab on page 346 for a complete description.

• Increase (

): Identical to the corresponding button in the Attributes tab. Refer to List

Palette Attributes Tab on page 346 for a complete description.

• Reset (
•
•

): Identical to the corresponding button in the Attributes tab. Refer to List Palette

Attributes Tab on page 346 for a complete description.
Start at: Identical to the corresponding text box in the Attributes tab. Refer to List Palette
Attributes Tab on page 346 for a complete description.
Styles List: Details all the list styles that are being used in the document, with the following
annotations:
• Blue tick: The style is applied in the currently selected text.

Figure 8-92: Current Style Indication

• Blue tick and black plus sign: Changes made to the current style.
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Figure 8-93: Changes to Current Style Indication

• Minus sign: The selected text includes more than one style. All used styles are marked.

Figure 8-94: Multiple Styles Indication

• Black diamond: The style is being used in the document but it is not part of the current
style set (refer to Style Sets on page 186 for more information). These styles are referred to
as Document Styles, and an example is shown in the following figure:

Figure 8-95: Document Style Indication

• Create new style: Creates a new list style. Refer to Creating a New Style on page 189 for
•
•
•
•

step-by-step instructions.
Delete style: Deletes the selected style. Refer to Deleting a Style on page 192 for step-bystep instructions.
Edit style: Edits the selected style. Refer to Editing a Style on page 190 for step-by-step
instructions.
Apply style: Applies the selected style to the selected text. Refer to Applying a Style on page
187 for step-by-step instructions.
Save changes to style: Applies changes from the selected text to the selected style. Refer to
Editing a Style on page 190 for step-by-step instructions.

4. Section Palette Description
The Section palette is used to style sections. You can either apply attributes directly to selected
characters, or use styles to apply several attributes at the same time. Refer to Styling Essentials
on page 155 for more information.
The Section palette comprises two tabs:
• Attributes Tab: Used to manually apply attributes to selected sections.
• Styles Tab: Used to manage section styles.

A. Section Palette Attributes Tab
The following figure depicts the Section palette Attributes tab and its functionalities:
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Figure 8-96: Section Palette Attributes Tab

• Section start: This popup menu is used to determine where would the selected section start
•

•

in relation to the previous section. Refer to Setting Section Start Preference on page 176 for
step-by-step instructions.
Columns: This area includes various options used to style the diﬀerent columns:
• Count: This text box is used to set the number of columns in the selected section. Refer to
Setting the Number of Columns on page 176 for step-by-step instructions. Maximal value
is 100.
• Order: This popup menu is used to set the direction of text flow between columns in the
selected section. Refer to Setting Columns Direction on page 176 for step-by-step
instructions. Available options include Left to right and Right to left.
• Background: This popup menu is used to set the selected section background colour
pattern. Refer to Setting Section Background Colour on page 176 for step-by-step
instructions. Available options include:
• None: No background colour is applied.
• Solid: The background is filled with a solid fill of the colour selected using the Colour
well.
• Colour: Clicking this button opens the Colour window which allows setting the selected
section background colour. Refer to Setting Section Background Colour on page 176 for
step-by-step instructions on setting the section background colour, and to Colour Window
on page 281 for more information on using the Colour window.
Note: The Colour well is disabled when None is chosen from the Background popup menu.
• Space above: This text box is used to determine the space above the selected section. Refer
to Setting Space above a Section on page 177 for step-by-step instructions.
• Balanced: This checkbox is used to enable balancing of text between columns, so that the
same number of lines is included in each column. Refer to Balancing Columns on page 177
for step-by-step instructions.
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• Gutter:

This area includes various options used to style the gutter, which is the line
separating diﬀerent columns. Refer to Styling the Gutter on page 177 for step-by-step
instructions.
• Width: This text box is used to set the gutter's width. This is essentially the distance
between columns.
• Line type: This popup menu is used to set the gutter line type.
Note: The line is always centered horizontally within the gutter.
• Line weight: This popup menu is used to set the gutter line weight. Available options
include 1-5 points, but you can manually enter any desired value.
• Line colour: This button is used to open the Colour window and set the gutter line colour.
Refer to Colour Window on page 281 for more information on using the Colour window.
• Space above: This text box is used to set the distance between the top of the column and
the top of the gutter line.
• Space below line: This text box is used to set the distance between the bottom of the
column and the bottom of the gutter line.
• Line Numbering: This popup menu is used to activate line numbering and to set the
numbering scheme for the selected section. Refer to Line Numbering on page 106 for more
information.

B. Section Palette Styles Tab
The following figure depicts the Section palette Styles tab and its functionalities:

Figure 8-97: Section Palette Styles Tab

• Styles List: Details all available section styles, with the following annotations:
• Blue tick: The style is applied in the currently selected text.
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Figure 8-98: Current Style Indication

• Blue tick and black plus sign: Changes made to the current style.
Figure 8-99: Changes to Current Style Indication

• Minus sign: The selected text includes more than one style. All included styles are marked.

Figure 8-100: Multiple Styles Indication

• Black diamond: The style is being used in the document but it is not part of the current
style set (refer to Style Sets on page 186 for more information). These styles are referred to
as Document Styles, and an example is shown in the following figure:

Figure 8-101: Document Style Indication

• Create new style: Creates a new style. Refer to Creating a New Style on page 189 for step•
•
•
•

by-step instructions.
Delete style: Deletes the selected style. Refer to Deleting a Style on page 192 for step-bystep instructions.
Edit style: Edits the selected style. Refer to Editing a Style on page 190 for step-by-step
instructions.
Apply style: Applies the selected style to the selected text. Refer to Applying a Style on page
187 for step-by-step instructions.
Save changes to style: Applies changes from the selected text to the selected style. Refer to
Editing a Style on page 190 for step-by-step instructions.

5. Page Palette Description
The Page palette is used to style pages and page ranges. You can either apply attributes
directly to selected pages, or use styles to apply several attributes at the same time. Refer to
Styling Essentials on page 155 for more information.
The Page palette comprises two tabs:
• Attributes Tab: Used to manually apply attributes to selected pages.
• Styles Tab: Used to manage pages styles.

A. Page Palette Attributes Tab
The following figure depicts the Page palette Attributes tab and its functionalities:
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Figure 8-102: Page Palette Attributes Tab

• Diﬀerent first page: This checkbox is used to enable applying diﬀerent attributes to the first
•
•

page in the selected page range. Refer to Enabling Diﬀerent Attributes for the First Page on
page 178 for step-by-step instructions.
Diﬀerent odd/even pages: This checkbox is used to enable applying diﬀerent attributes to
odd and even pages. Refer to Enabling Diﬀerent Attributes for Even and Odd Pages on page
179 for step-by-step instructions.
Page Type buttons: These buttons are used to choose the page type to edit the attributes
for (refer to Editing Diﬀerent Attributes for Diﬀerent Page Types on page 179 for step-by-step
instructions). The corresponding buttons only appear when the Diﬀerent first page and/or
Diﬀerent odd/even pages checkboxes are checked. The following buttons are available:

•
•
•
•

Edit the attributes of the all pages in the range.
Edit the attributes of the first page in the range.
Edit the attributes of all odd pages in the range.
Edit the attributes of all even pages in the range.

Note: The selected page type icon is highlighted in grey.
Changes made to the following options only aﬀect the selected page type:

• Editing: This read-only text area indicates the type of page currently being edited (refer to
•

Editing Diﬀerent Attributes for Diﬀerent Page Types on page 179 for more information): All
Pages, First Page, Odd Page or Even Page.
Header: This checkbox is used to add a header to the selected page type in the selected
page range. Refer to Creating Headers and Footers on page 181 for step-by-step
instructions.
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• Header Height: This text box is used to set the header's height (refer to Setting Header/
•
•

Footer Height on page 181 for step-by-step instructions). It is only available if the Header
checkbox is checked.
Footer: This checkbox is used to add a footer to the selected page type in the selected
page range. Refer to Creating Headers and Footers on page 181 for step-by-step
instructions.
Footer Height: This text box is used to set the footer's height (refer to Setting Header/
Footer Height on page 181 for step-by-step instructions). It is only available if the Footer
checkbox is checked.

• Background colour (

): This button is used to open the Colour and set the

background fill colour for the selected page type in the selected page range. Refer to
Setting Page Background on page 183 for step-by-step instructions).
• Image: This checkbox is used to enable using an image as a background for the selected
page type in the selected page range. Refer to Setting Page Background on page 183 for
step-by-step instructions).
• Select: This button is used to set the background image. Refer to Setting Page Background
on page 183 for step-by-step instructions). This button is only enabled if the Image
checkbox is checked.
• Image Name: This read-only area indicates the name of the background image file. If no
file is selected <no image selected> is displayed.
• Position: This popup menu is used to set the position of the background image (refer to
Setting Page Background on page 183 for step-by-step instructions). This list is only
enabled if the Image checkbox is checked.
• Opacity: This slider is used to set the background image opacity level (refer to Setting Page
Background on page 183 for step-by-step instructions). Default value is 100%, and opacity
level decreases as the slider is dragged to the left hand side. This slider is only enabled if
the Image checkbox is checked.
• Range Start: This popup menu is used to determine whether the selected page range can
start on any page, or only on odd or even pages (refer to Setting the Page Range Start
Preference on page 180 for step-by-step instructions). Available options include:
• Any Page: When this option is chosen, the page range can start at any page, odd or even.
• Odd Page: When this option is chosen, the page range can only start on an odd page. For
example, if the previous page range starts at page 1 and ends at page 15, Mellel will start
the current page range at page 17, leaving page 16 as a blank page.
• Even Page: When this option is chosen, the page range can only start on an even page. For
example, if the previous page range starts at page 1 and ends at page 16, Mellel will start
the current page range at page 18, leaving page 17 as a blank page.
• Numbering: This popup menu is used to choose the numbering scheme for page numbers.
(refer to Configuring Page Numbers on page 182 for step-by-step instructions).
• Start at: This checkbox and adjacent text box are used to set the initial number in the page
numbers sequence for the current page range (refer to Configuring Page Numbers on page
182 for step-by-step instructions).
Note: If no number is set, numbering will continue from the last page of the previous page
range.
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• Margins and Orientation: This button is used to open the Margins and Orientation window,
which is used to set the margins and orientation for the selected page range, as depicted in
the following figure:

Figure 8-103: Margins and Orientation Window

• Orientation Buttons: These buttons are used to set the selected page range orientation

(refer to Setting Page Orientations on page 184 for step-by-step instructions). Available
options include: Portrait (
) and Landscape (
).

Note: You may have both portrait and landscape pages in the same document, but a single
page range can only have one orientation.
• Facing Pages: This checkbox is used to set mirrored margins where even and odd pages
mirror each other to achieve symmetric margins. Refer to Setting Page Margins on page
185 for step-by-step instructions. When this checkbox is selected, the Left/Right text boxes
below are renamed Inside/Outside, enabling you to configure the symmetric margins.
• Top: This text box is used to set the top page margin. Refer to Setting Page Margins on
page 185 for step-by-step instructions.
• Bottom: This text box is used to set the bottom page margin. Refer to Setting Page
Margins on page 185 for step-by-step instructions.
• Left/Inside: This text box is used to set the left page margin. Refer to Setting Page Margins
on page 185 for step-by-step instructions. When the Facing Pages checkbox is checked, this
text box is renamed Inside and is used to determine the inside margin of two facing pages.
• Right/Outside: This text box is used to set the right page margin. Refer to Setting Page
Margins on page 185 for step-by-step instructions. When the Facing Pages checkbox is
checked, this text box is renamed Outside and is used to determine the outside margin of
two facing pages.

B. Page Palette Styles Tab
The following figure depicts the Page palette Styles tab and its functionalities:
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Figure 8-104: Section Palette Styles Tab

• Styles List: Details all available page styles, with the following annotations:
• Blue tick: The style is applied in the currently selected text.
Figure 8-105: Current Style Indication

• Blue tick and black plus sign: Changes made to the current style.
Figure 8-106: Changes to Current Style Indication

• Minus sign: The selected text includes more than one style. All included styles are marked.

Figure 8-107: Multiple Styles Indication

• Black diamond: The style is being used in the document but it is not part of the current
style set (refer to Style Sets on page 186 for more information). These styles are referred to
as Document Styles, and an example is shown in the following figure:

Figure 8-108: Document Style Indication

• Create new style: Creates a new style. Refer to Creating a New Style on page 189 for stepby-step instructions.
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• Delete style: Deletes the selected style. Refer to Deleting a Style on page 192 for step-by•
•
•

step instructions.
Edit style: Edits the selected style. Refer to Editing a Style on page 190 for step-by-step
instructions.
Apply style: Applies the selected style to the selected text. Refer to Applying a Style on page
187 for step-by-step instructions.
Save changes to style: Applies changes from the selected text to the selected style. Refer to
Editing a Style on page 190 for step-by-step instructions.

6. Table Palette Description
The following figure depicts the Table palette and its functionalities:

Figure 8-109: Table Palette
The Table palette is used to edit table attributes, and under the Styles tab, to also edit and
manage table styles. The options in this tables are identical to those oﬀered by the the Edit
Table Attributes popover. Refer to Styling Tables on page 82, Table Styles on page 85, Edit Table
Attributes popover on page 413, and to Table Style Window on page 409 for more information
about styling tables and table styles.

A. Table Palette Attributes Tab
Following are the attributes in the Table palette Attributes tab.
• Direction: Allows you to set the table’s direction (from Left-to-right or from Right-to-left).
• Table Size: Used to set the number of rows and columns in a table.
• Position: Used to set the table’s horizontal position. You can use the options set by default
(Left, 25%, centre, 75%, Right) or use the combo drop-menu to enter a value from 1% to 99%.
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• Width: Used to set the total width for any selection of cells. Values can be numeric (e.g., 10.5

•

cm) or relative (e.g., 45%). Relative values are contextual — if the selection does not span the
entire width of the table, the width set will be relative to the entire table width. If the
selection span the entire width of the table, the width will be relative to the section column
width (with 1 column, this means the entire page width sans margins on the left and the
right of the page.
Border Selector: Selects the borders to which you can apply attributes. The border selector
available selections change contextually depending on the range of cells selected. If you
selected just one cell (that is, you placed the insertion point within a cell), the border selector
will look something like this:

Figure 8-110: Border Selector with a single cell selected
Because only a single cell is selected, only its four borders (and diagonal lines) can be
changed using the border selector. However, when you select two cells vertically:

Figure 8-111: Vertical Cells Selection
The border selector will look like this:

Figure 8-112: Vertical Cells Border Selector
The added border indicates that there are horizontal lines between cells that can be manipulated. If you further extend the selection:
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Figure 8-113: Multiple Cells Selection
The border selector changes to fit the extended selection and shows a vertical line:

Figure 8-114: Multiple Cells Border Selector
Note: Clicking and selecting the inner lines when multiple cells are selected will apply any
changes to all the inner lines in the selected cells range, while clicking and selecting any
outer lines will only aﬀect a single corresponding external border in the selected cells range.

• Line Type: This popup menu is used to set the selected border line type.
• Weight: This popup menu is used to set the selected border line weight (width). The weight
•
•
•

•
•

can be set to Hairline, 0.1-0.5 points, 1-5 points, but you can manually enter any desired
value.
Colour: This button is used to open the Colour window and set the selected border line
colour.
Background: This popup and colour button allow you to determine if a selection of cells will
have a background (None or Solid) and set the colour of this background.
Colour Alternation: This field and colour button allow you you to determine the alternating
background colour that will be automatically applied in a table, and the line count for the
alternation (every other line, every 2 lines, etc.). Refer to Setting Colour Alternation on page
83 for a detailed description of colour alternation.
Header & Footer: Used to set the number of Header and Footer rows, and the number of
Leading and Trailing columns in a table.
Repeating Header: Used to set a repeating header. A repeating header is a table header that
appears again and again at the top of the page in a table spanning over multiple pages. You
can select to repeat any header row or all of them.
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1. Options popover
• Outer padding: The Outer Padding selector and field combo enables you to set the outer
padding for a cell. The padding is measured from the selected cell(s) boarder inwards. In
other words, a larger outer padding will not cause a padded cell (no pun intended) to
overstep its boundaries. For example:

Figure 8-115: Table with Outer Padding
With this table, where invisible table lines are visible for for clarity, you can see various cells
with diﬀerent outer padding settings. The outer padding is always applied from the cell’s
border inside.
Corner Radius: The Corner Radius selector and field combo enables you to set the outer
corner radius for a selection of cells. All corners are selected by default, but you can de-select
any of them. The higher the radius value set in the field, the rounder the corner will be. Some
examples of this:

Corner Radius: 0 for all
corners

Corner Radius top: 0.741
cm; bottom: 0

Corner Radius all
corners: 0.706 cm;
bottom: 0

Corner radius top-left
and bottom right: 0.635
cm; top -right, bottomleft: 0.106 cm

Table 8-1: Corner Radius examples

• Vertical

Alignment: This popup menu is used to determine the vertical alignment of
content within the selected cells. Options include Top, Middle, Bottom and Justify. The
following table exemplify the various options here:
Aligned to top
Aligned to top

Aligned to middle
Aligned to middle

Aligned to bottom
Aligned to bottom

Justified Justified
Justified Justified
Justified Justified
Justified Justified

Table 8-2: Table Vertical Alignment options

• Inner Padding: This popup menu is used to determine the distance between the selected
cells content and their borders. Options include None and 1-5 points. Refer to Configuring
Inner padding on page 84 for instructions on using this option.
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2. Table Commands menu
• Select Row: Selects an entire row.
• Select Column: Selects an entire column.
• Select All Cells: Selects all the cells in the table.
• Centre Table Horizontally: Centres the table horizontally.
• Add Row Before: Adds a new row to the table before the current (selected) row. Refer to
•
•
•
•
•
•
•
•
•
•

Adding and Subtracting Rows and Columns on page 78 for step-by-step instructions.
Add Row After: Adds a new row to the table after the current (selected) row. Refer to Adding
and Subtracting Rows and Columns on page 78 for step-by-step instructions.
Add Column Before: Adds a new column to the table before the current (selected) column.
Refer to Adding and Subtracting Rows and Columns on page 78 for step-by-step
instructions.
Add Row After: Adds a new column to the table after the current (selected) column. Refer to
Adding and Subtracting Rows and Columns on page 78 for step-by-step instructions.
Split Horizontally: Horizontally splits the selected cell into two equal parts. Refer to
Splitting Cells on page 81 for step-by-step instructions.
Split Vertically: Vertically splits the selected cell into two equal parts. Refer to Splitting Cells
on page 81 for step-by-step instructions.
Merge Cells: Merges the selected cells and their content into a single cell. Refer to Merging
Cells on page 81 for step-by-step instructions.
Equalise Columns Width: equalises the widths of all selected columns. Refer to Equalising
Row and Column size on page 81 for step-by-step instructions.
Equalise Row Heights: equalises the heights of all selected rows. Refer to Equalising Row
and Column size on page 81 for step-by-step instructions.
Delete Cells: Deletes the selected rows or columns. This option is enabled only when an
entire column (or columns) or an entire row (or rows) are selected. Refer to Deleting Cells on
page 81 for step-by-step instructions.
Remove Text Formatting: The text in a table cell is set by default using the style applied to
the table style and template. When you make changes to this style, you can always discard
those using Remove Text Formatting, and go back to the original styles applied by removing
the text formatting of a table or of a range of cells.

B. Table Palette Styles Tab
• Styles List: Details all available Table styles in the style set, with the following annotations:
• Blue tick: The style is applied in the currently selected table.
Figure 8-116: Current Style Indication

• Blue tick and black plus sign: the table contains overrides to the table style.
Figure 8-117: Changes to Current Style Indication
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• Black diamond: The style is being used in the document but it is not part of the current
style set (refer to Style Sets on page 186 for more information). These styles are referred to
as Document Styles; an example is shown in the following figure:

Figure 8-118: Document Style Indication

• Create new style: Creates a new style. Refer to Creating a New Style on page 189 for step•
•
•
•

by-step instructions.
Delete style: Deletes the selected style from the style set. Refer to Deleting a Style on page
192 for step-by-step instructions.
Edit style: Edits the selected style. Refer to Editing a Style on page 190 for step-by-step
instructions.
Apply style: Applies the selected style to the selected text. Refer to Applying a Style on page
187 for step-by-step instructions.
Save changes to style: Saves changes to a style that was changed; If there are no changes to
the style, this option will be inactive. Refer to Editing a Style on page 190 for step-by-step
instructions.

7. Auto-Title Palette Description
The Auto-Title palette allows you to enter Auto-titles into the document, and to configure the
Auto-titles flow setup. Refer to Auto-Titles on page 44 to learn more about Auto-titles.
The following figure depicts the Auto-Title palette and its functionalities:

Figure 8-119: Auto-Title Palette
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• Auto-Titles Flows List: Lists all the Auto-title flows available in the currently selected Autotitle Flows Setup. Structural flows appear on top in black, while tag flows are listed below in
blue. Refer to Flow Types on page 46 for more information on the diﬀerent flow types.
Note: When an Auto-title is selected in the text or in the Outline, a check-mark appears next to
the corresponding Auto-title level in the Auto-titles Flows list.

• Insert Auto-Title (

): Clicking this button inserts a new Auto-title of the selected flow into
the document. Refer to Inserting an Auto-Title on page 46 for a complete description of this
task.

• Edit title flows (
•

): Clicking this button opens the Auto-Titles Flow Setup window. Refer to
Auto-Titles Flows Setup Window on page 370 for a complete description of the window.
Setup: Allows changing the selected Auto-titles Flow Setup. Refer to Selecting an Auto-Titles
Flows Setup on page 51 for more information.

8. Bibliography Palette Description
The Bibliography palette is used to manage and style bibliography and citations in your
document. Refer to Bibliography on page 128 for more information.
The following figure depicts the Bibliography palette and its functionalities:

Figure 8-120: Bibliography Palette

• Citations List: Details all citations that were added to the current document.
• Refresh citation list ( ): Refreshes the list of citations. Refer to Refreshing the Citation List
on page 133 for more information.

• Enter citation manually (

): Used to manually enter a citation into the document. Refer

to Inserting Citations Manually on page 131 for step-by-step instructions.
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• Verify citations (

): Verifies citations in the document. Refer to Verifying Citations on

page 133 for more information. The button indicates verification status by either a black tick
(
) when all references in the document are verified or a red question mark (
) when
there are any unverified references (only applicable when Live Bibliography is enabled).

• Scan document (

): Scans the document, converts all citations to their final format and

creates a bibliography. Refer to Scanning the Document on page 136 for more information
(not available when Live Bibliography is enabled).

• Unscan

document (

): Unscans the document, converting all citations into their

temporary format. Refer to Unscanning the Document on page 137 for more information
(not available when Live Bibliography is enabled).

• Find in reference database (

): Opens the reference manager search window with the

currently selected text (if applicable) as the search string. Refer to Opening the Reference
Manager Search Window on page 133 for more information.

• Switch

to reference database (

): Switches to the selected reference manager

application.

• Edit style mapping for Bibliography & Citations (

): Used to configure applying styles

to bibliography and citations when scanning the document. Refer to Formatting Citations
Using Styles on page 133 and Formatting the Bibliography Using Styles on page 137 for
step-by-step instructions.

9. Reference Palette Description

The Reference palette allows you to add new references and
bookmarks into the document, and to navigate between
existing references and bookmarks. Refer to Cross References
on page 112 for more information.
The following figure depicts the Reference palette and its functionalities:
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Figure 8-121: Reference Palette

• Insert Bookmark (

): This button is used to insert a new bookmark into the document.

Refer to Inserting a Bookmark on page 112 for step-by-step instructions.

• Insert Reference (
•

): This button is used to insert a new reference into the document.

Refer to Inserting a Cross Reference on page 114 for step-by-step instructions.
Browse References: This radio button is used to choose the category of references to
browse. The following options are available:
• All: Browses all the references in the document. Refer to Navigating between References
on page 119 for step-by-step instructions.
• Virtual Targets: Browses all the references to virtual targets in the document. Refer to
Navigating between References to Virtual Targets on page 117 for step-by-step
instructions.
• Ambiguous: Browses all the ambiguous references in the document. Refer to Locating
Ambiguous References on page 120 for step-by-step instructions.

• Previous Reference (

): This button is used to navigate to the previous reference, based

on the Browse References radio button selection.

• Next Reference (

): This button is used to navigate to the next reference, based on the

Browse References radio button selection.

10. Markers Palette Description
The Markers palette is used to apply markers to document elements and to navigate between
marked elements in the document. Refer to Markers on page 235 for more information.
The following figure depicts the Markers palette and its functionalities:
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Figure 8-122: Markers Palette

• Markers list: Lists the colours and names of the eight available markers.
• Find previous marked text: Navigates to the previous marked text. Refer to Navigating
•
•

Marked Text on page 236 for step-by-step instructions.
Find next marked text: Navigates to the next marked text. Refer to Navigating Marked Text
on page 236 for step-by-step instructions.
Apply marker: Applies the selected marker to the selected text. Refer to Marking Text on
page 235 for step-by-step instructions.

11. Statistics Palette Description
The Statistics palette displays various read-only information regarding the number of diﬀerent
elements in the document. Refer to Document Statistics on page 238 for more information.
The following figure depicts the Statistics palette and the information it displays:
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Figure 8-123: Statistics Palette

• General:
•
•

Displays the total number of characters, words, lines and paragraphs in the
document. When selecting a part of the document in the document area, the total number
of characters, words and paragraphs in the selected text are displayed in parenthesis.
Notes: Displays the total number of notes in the document, and the total number of
characters and words in the notes text.
Other: Displays the total number of tables, images, citations, hyperlinks and Auto-titles in
the document.

9. Find and Replace Panel
The Find and Replace panel is used to search and replace certain patterns of characters and
words in the document. Refer to Find and Replace on page 209 for more information.
To open the Find and Replace panel, choose Edit > Find > Find from the menu bar, or press
Cmd + F.
The Find and Replace panel has a basic and an advanced layout, which are described in the
following sub-sections.

1. Basic Find Panel
The following figure depicts the Basic Find panel and its functionalities:

Figure 8-124: Basic Find Panel
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• Expand (

): This button is used to expand the Advanced Find and Replace panel. When the
Advanced Find and Replace panel is displayed, it is replaced by the Minimize button (
)
that is used to minimize the advanced panel and show the basic one. If there are certain
preferences used in the advanced panel that cannot be displayed in the basic panel (for
example, Ignore Diacritics is selected), the Expand button is highlighted in Red when the
advanced panel is minimized (
).

• Settings (
•
•
•
•
•

•

•

): This button is used to show the 10 most recent searches, enabling you to

repeat them by choosing the desired search from the list.
Previous: This button is used to navigate to the previous search match.
Next: This button is used to navigate to the next search match.
Done: This button is used to close the panel.
Find: This text box is used to insert the search string. Refer to Performing a Basic Find Action
on page 209 for step-by-step instructions.
Format Indication/Clear Button: This button is used to indicate that character attributes
were applied to the search string, so that only text that matches both the text and the
attributes is considered a match. Clicking the button removes all character attributes from
the search string.
Whole Words: This checkbox is used to determine whether only whole words that match
the search string are considered a match, rather than parts of words. For example, if you use
find as a search expression, Mellel will match find but not finder when the Whole words
checkbox is checked.
Ignore Case: This checkbox is used to determine whether the search is case sensitive or not.
For example, if you use Mellel as a search expression, both mellel and Mellel will be matched
when the Ignore Case checkbox is checked.

2. Advanced Find and Replace Panel
The following figure depicts the Advanced Find and Replace panel and its functionalities (only
functionalities that are unique to the advanced panel compared to the basic one are
described).

Figure 8-125: Advanced Find and Replace Panel

• Minimize (
• Settings (

): This button is used to minimize back to the Basic Find panel.
): The advanced panel settings menu includes the following options in

addition to those described for the basic panel above:
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• Load Find Action: Loads an existing Find Action. Refer to Running a Find Action on page 213

•
•
•
•
•
•
•
•

for step-by-step instructions.
• Save Find Action: Saves changes to a loaded Find Action. Refer to Running a Find Action on
page 213 for step-by-step instructions.
• Save Find Action As...: Saves the current search as a new Find Action. Refer to Creating a Find
Action on page 215 for step-by-step instructions.
Replace All: This button is used to replace all search matches with the replace expression.
Refer to Performing a Find and Replace Action on page 211 for step-by-step instructions.
Replace & Find: This button is used to replace the current search match with the replace
expression and navigate to the next match. Refer to Performing a Find and Replace Action
on page 211 for step-by-step instructions.
Replace: This button is used to replace the current match with the replace expression. Refer
to Performing a Find and Replace Action on page 211 for step-by-step instructions.
Search In: This popup menu is used to limit the search to certain document elements (refer
to Performing an Advanced Find Action on page 211 for step-by-step instructions).
Find: This text box is used to enter the search expression using regular text and/or the
adjacent Insert popup menu ( ). Refer to Performing an Advanced Find Action on page 211
for step-by-step instructions.
Replace: This text box is used to enter the replace expression using regular text and/or the
adjacent Insert popup menu ( ). Refer to Performing a Find and Replace Action on page 211
for step-by-step instructions.
From Beginning: This checkbox is used to set the search to begin from the top of the
document rather than the current position of the insertion point.
Ignore Diacritics: This checkbox is used to set the search to ignore accents and diacritical
marks when searching. For example, if you use fruit as the search expression fruit, fruït and
früit will all be matched. This feature also applies to vowel marks in Arabic, Hebrew, or any
other language that uses them.

10. Bottom Bar
1. Zoom Menu
Refer to Changing the Document Zoom Level on page 264 for a complete description of the
zoom menu and its functionalities.

2. Page Status Bar
The following figure depicts the Page Status bar and its functionalities:

Figure 8-126: Page Status Bar
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• Current page style: Indicates the page style used for the current page. Refer to Inspecting

•
•

the Applied Style on page 188 for more information. If there are any ad hoc changes applied
to the text compared to the current style, they are indicated by a black plus sign, as shown in
the figure above.
Current page number: Indicates the current page number in the current page range. The
number is shown in the numbering unit selected for the current page range. Refer to
Configuring Page Numbers on page 182 for more information.
Absolute page number: Indicates the current page absolute number out of the absolute
total number of pages in the document.

3. Navigation Panel
Refer to Navigation Panel on page 37 for a complete description of the navigation panel and
its functionalities.

11. Various Windows
1. Auto-Titles Flows Setup Window
The Auto-Titles Flows Setup window allows you to edit the Auto-title flows setup. Refer to
Editing Auto-Title Flows Setup on page 53 for more information.
To open the Auto-Titles Flows Setup window Do one of the following:

• In the Auto-Title palette, click the Edit title flows button (

).

Or
• In the menu bar, choose Insert > Auto-Title > Edit title flows.
The Auto-Title Flows Setup window is divided into four main areas, as shown in the following
figure:
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Figure 8-127: Auto-Titles Flows Setup Window

• Setup Management Area: In this area you can create, load, save or delete Auto-title flows
•
•
•

setups. Refer to Setup Management Area below for a complete description of this area.
Title Flows List Area: Lists all the diﬀerent Auto-title flows in the selected setup, and allows
changing flow names, as well as adding, moving and deleting tag flows. Refer to Title Flows
List Area on page 372 for a complete description of this area.
Title Flow Attributes Area: Allows you to set and change general title flow preferences such
as numbering units, inclusion in table of contents, separation from previous content, and
more. Refer to Title Flow Attributes Area on page 373 for a complete description of this area.
Format Area: Allows editing the Auto-title flow format, including applying diﬀerent style
and format for Auto-titles in diﬀerent document areas. Refer to Format Area on page 374 for
a complete description of this area.

A. Setup Management Area
The following figure depicts the Setup Management area and its functionalities:

Figure 8-128: Setup Management Area

• Selected setup: This popup menu is used to choose a diﬀerent Auto-title flow setup. Refer
•

to Selecting an Auto-Titles Flows Setup on page 51 for step-by-step instructions.
Save setup: This button is used to save the current Auto-title flow setup. Refer to Saving
Changes to an Auto-Titles Flows Setup on page 59 for step-by-step instructions.
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• Delete setup: This button is used to delete the currently selected setup. Refer to Deleting an
•

Auto-Titles Flow Setup on page 52 for step-by-step instructions.
Left to Right/Right to Left: This popup menu is used to determine whether the Title flows
list is displayed in a left to right or right to left orientation. The selection has no eﬀect on the
actual Auto-title setup, only their display in the setup window.

B. Title Flows List Area
The following figure depicts the Title flows list area and its diﬀerent functionalities:

Figure 8-129: Title Flows List Area

• Flows List: Displays the hierarchy of all the flows in the current setup. Structural flows are

•
•
•

listed in black while tag flows are listed in blue. Refer to Flow Types on page 46 for more
information on diﬀerent flow types. You can use the list to move tag flows around, as
described in Moving a Tag Flow on page 53.
Delete: Deletes the selected tag flow, as described in Deleting a Tag Flow on page 53.
Add: Adds a new untitled tag flow, as detailed in Adding a Tag Flow on page 53.
Auto Indent: This checkbox is used to enable auto indent in the document. Refer to Using
Auto-Indent on page 50 for more information.
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C. Title Flow Attributes Area
The following figure depicts the Title Flow Attributes area and its diﬀerent functionalities:

Figure 8-130: Title Flow Attributes Area

• Numbering Unit: Sets the numbering unit for the selected flow, as detailed in Setting the

Numbering Unit on page 54.
Note: Every flow has a numbering unit, even if it is not actually used in its format.
• Start at: Sets the initial number for the selected flow, as detailed in Setting the Initial Number
on page 54. The default value is one (1) and usually meets most use cases.
Note: The selected initial number can be a negative number or zero, but you must bear in
mind that some numbering schemes do not allow for negative values or zero. Therefore, if you
set the Numbering Unit to Greek and the Start value to -2, for example, the result would be that
the first three Auto-titles in the flow will contain the first available value, rather than a nonexistent negative value.
• Increment: Sets the selected flow numbering increment, as detailed in Setting the
Numbering Increment on page 54. The default value is one (1) and usually meets most use
cases.
• Insert Before: Inserts a structural separation between an Auto-title from the selected flow
and the content above it in the document (refer to Separate the Auto-Title from Previous
Content on page 58 for step-by-step instructions). The following options are available for
selection (refer to Breaks on page 111 for more information regarding the diﬀerent
separating objects):
• None: Inserts nothing before the Auto-title. This is useful if you want the Auto-title to
appear in-line with surrounding text.
• Return: Inserts a Return break before the Auto-title. This is the default option.
• Column break: Inserts a Column break before the Auto-title. If the section has just one
column, the Auto-title will be placed at the top of the next page.
• Page break: Inserts a Page break before the Auto-title.
• Page style break: Inserts a Page Style break before the Auto-title.
• Select Title after inserting: Determines whether the title is automatically selected for
editing when an Auto-title from the selected flow is inserted into the document, as detailed
in Selecting the Title When Inserting Auto-Titles on page 58.
• Include in TOC: Determines whether Auto-titles from the selected flow are included in the
table of contents, as detailed in Include/Exclude a Flow from the Table of Contents on page 58.
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• List as separate section in TOC: Determines whether the selected tag flow will be listed as a

•

separate section in the Table of Contents (TOC), as detailed in Include/Exclude a Flow from the
Table of Contents on page 58. This option is only applicable to tag flows that are included in
the TOC. When this option is checked, Auto-titles from the selected tag flow are listed
separately in the TOC.
Reset numbering with higher level flow: Determines whether the current flow is reset
when any of its higher flows are reset, as detailed in Configuring Flow Numbering Reset on
page 59. The following figure shows the diﬀerence between the two states:

Figure 8-131: Diﬀerent Reset Options

D. Format Area
The following figure depicts the Format area and its functionalities:

Figure 8-132: Format Area

• Format Tabs: These tabs are used to select the Auto-title format to edit, as detailed in Use a
Diﬀerent Format for Diﬀerent Auto-Titles Usages on page 57. The following tabs are available:
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• Format: Determines how the Auto-title is displayed at its insertion point in the document

•

area.
• TOC format: Determines how the Auto-title is displayed in the table of contents. Refer to
Table of Contents on page 121 for more information.
• Mention format: Determines how the Auto-title is displayed in a mention. Refer to
Inserting Mentions on page 183 for more information.
• Outline format: Determines how the Auto-title is displayed in the Outline. Refer to Outline
on page 139 for more information.
• Ref format: Determines how the Auto-title is displayed in a cross-reference. Refer to Cross
References on page 112 for more information.
• Use a diﬀerent format for: When any format tab other than Format is selected, this
checkbox becomes available and you must check it to enable changing the format and
style for the selected tab.
Elements: This popup menu is used to enter dynamic elements into the format area. The
following options are available:
• Title: Inserts a dynamic element that will be displayed as the current Auto-title's title.
• Current Level #: Inserts a dynamic element that displays the number of the current Autotitle in its flow (Displayed as Curr# in the format area). For example, if an Auto-title is
numbered 2.3.1, its current level number is 1.
• Previous Level #: Inserts a dynamic element that displays the number of the current Autotitle in flows higher in the hierarchy. After entering this element, click it and use the popup
menu to set the level that will be displayed in the Auto-title (Displayed as Prev#1 in the
format area, where 1 is the selected level). For example, if an Auto-title is numbered 2.3.1,
its previous level 1 number is 3 and its previous level 2 number is 2. The following figure
shows an example for selecting the previous level to be displayed:

Figure 8-133: Configuring the Prev# Element
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• Tab: Inserts a tab.
Note: If there is no tab in the Ruler (or if you’ve selected a paragraph style that contains no
tabs), any part of the Auto-title following that tab will flow to the next line. If you want to flow
an element to the next line, use the Line break element.
• Line break: Inserts a line break.
• Variable: Inserts a document variable (Refer to Variables on page 124 for more
information). After entering this element, click it and use the popup menu to choose the
specific variable you wish to enter (Displayed as Var in the format area).
• Page #: Inserts a dynamic element which is displayed as the page number in which the
Auto-title is located. This element is only available in the Mention and TOC format tabs.
• Ruler and Tab Well: Used to manage the tabs in the Auto-title format area. These tools are
identical to those in the Document Area. Refer to Ruler on page 330 and Tab Well on page
328 for more information on using them.
• Format Area: Allows editing the Auto-title format by entering text and elements, as well as
applying styles and attributes from the Character and Paragraph palettes. Refer to
Formatting the Flow Auto-Titles on page 55 for step-by-step instructions.
• Preview: Displays a preview of how the Auto-title would look like.

2. Edit Note Attributes Window
The Edit Note Attributes window is used to manage note streams in your document. It enables
you to add new note streams, to edit or delete existing ones, and to configure general notes
preferences. Refer to Managing Note Streams on page 62 for a complete list of tasks that are
associated with this window.
To open the Edit Note Attributes window, choose Insert > Note > Edit note attributes from the
menu bar.
The Edit Note Attributes window and its diﬀerent areas are shown in the following figure:
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Figure 8-134: Edit Notes Attributes Window Description
The window comprises the following areas:
• Note Streams: Used to manage note streams. Refer to Streams List below for a complete
description.
• General Options: Used to configure various preferences, both global and specific to a
selected note stream. Refer to General Options on page 378 for a complete description.
• Note Style: Used to manage note stream styles. Refer to Note Style on page 379 for a
complete description.
• Placement: Used to configure the placement of notes from the selected stream. Refer to
Placement on page 379 for a complete description.
• Separator: Used to configure the separator for notes from the selected stream. Refer to
Separator Area on page 381 for a complete description.
• Reference Symbol: Used to configure the reference symbol format for notes from the
selected stream. Refer to Reference Symbol Area on page 382 for a complete description.
• Note Symbol: Used to configure the note symbol format for notes from the selected stream.
Refer to Note Symbol on page 382 for a complete description.
• Note Text Style: Used to style the note text for notes from the selected stream. Refer to Note
Text Style Area on page 382 for a complete description of this area.

A. Streams List
The following figure depicts the Streams List area and its functionalities:
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Figure 8-135: Streams List Area

• Streams List: Lists all the existing note streams in your document, with their keyboard

shortcut (if applicable) to their right. You may use the list to choose note streams for editing,
to change their order, to rename them and to assign them with shortcuts. Refer to Editing a
Stream on page 63, Repositioning a Stream in the Streams List on page 64, Renaming a
Stream on page 63, and Assigning a Shortcut to a Stream on page 67, respectively.

• Add (
• Delete (

): Adds a new note stream, as detailed in Creating a New Stream on page 62.
): Deletes the selected note stream, as detailed in Deleting a Stream on page 62.

B. General Options
The following figure depicts the General Options area and its functionalities:

Figure 8-136: General Options Area

• Height limit: Sets the percentage of the page height that the notes may occupy. Refer to
•
•
•

Setting Notes Height Limit on page 65 for step-by-step instructions.
Highlight notes on screen: Highlights notes in the document area. Refer to Highlighting
Notes on page 62 for step-by-step instructions.
Highlight notes in print: Highlights notes when the document is printed. Refer to
Highlighting Notes on page 62 for step-by-step instructions.
Start at number: Sets the initial number for the selected note stream. Refer to Setting the
Stream Start Number on page 64 for step-by-step instructions.
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C. Note Style
The following figure depicts the Style area and its functionalities:

Figure 8-137: Style Area

• Note: This popup menu is used to apply an existing style to the currently selected note
stream. Refer to Applying a Note Stream Style on page 68 for step-by-step instructions. The list
includes all the note stream styles available in the document, with the currently selected one
displayed. You can also use it to rename the current style by clicking on it and typing in the
new name.

• New Style (

): This button is used to create a new style. Refer to Creating a Note Stream

Style on page 67 for step-by-step instructions.

• Delete Style (

): This button is used to delete the selected style. Refer to Deleting a Note

Stream Style on page 68 for step-by-step instructions.

• Save Style (

): This button is used to save changes made to the currently selected style.

Refer to Editing a Note Stream Style on page 67 for step-by-step instructions. This button is
disabled until you make any changes to the selected style.

D. Placement
The following figure depicts the Placement area and its functionalities:

Figure 8-138: Placement Area

• Position:

•

Sets the position for notes from the selected stream (refer to Setting Notes
Position on page 66 for step-by-step instructions). The following options are available:
• Bottom of page: Places the note on the bottom of the page where it is referenced from. This
option is used for footnotes.
• Below text: Places the note directly beneath the referencing text.
• End of document: Places all of the document notes together at the end of the document.
This option is used for Endnotes.
Numbering: Sets the numbering logic for the selected stream (refer to Setting Reseting
Option on page 66 for step-by-step instructions). The following options are available:
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• Continuous: Numbering will never restart.
• Restart every page: Numbering will restart with every new page.
• Restart every section: Numbering will restart with every new section.
• Restart every page range: Numbering will restart with every new page range.

• May separate from reference: Determines whether the note and the reference can be on
diﬀerent pages (refer to Configuring Note and Reference Same Page Limitation on page
66 for step-by-step instructions). When the checkbox is selected, a note and its
corresponding reference can appear on diﬀerent pages.
When May split from reference is selected, with a long paragraph and a long note, Mellel
moves the note to the next page, separating it from the note reference. When the option is
not checked, Mellel moves the note and the note reference together to the next page. This
results in the creation of a wider block of white space at the bottom of the previous page, as
shown in the following figure:

Figure 8-139: Note and Reference Separation Options
Note: This option is only available when the Continuous option is selected for Numbering.
• May Split: Determines where can the note text be split (refer to Configuring Splitting
Rules on page 66 for step-by-step instructions). The following options are available:
• Nowhere: Note text can never be split, and will always be kept as a single unit.
• Between Paragraphs: Note text can only be split between paragraphs, so that paragraphs
are not split across diﬀerent pages, at the expanse of optimal text layout.
• Anywhere: Note text can split anywhere to allow optimal document layout.
The following figure illustrates the diﬀerent splitting options:
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Figure 8-140: Note Text Splitting Options

E. Separator Area
The following figure depicts the Separator area and its functionalities (refer to Styling the
Separator on page 65 for step-by-step instructions):

Figure 8-141: Separator Area

• Alignment: Sets the separator line alignment: No line, Left, Centre, or Right.
• Weight: Sets the separator line weight (thickness). The list includes options for 1-5 points,
but you may manually enter any value.
Note: Any line weight below one (1) point may look grey on screen rather than black.
However, it will print in black.
• Line: Sets the separator line style.
• Width: Sets the separator line width, in percentages relative to the page size.
• Colour: Opens the Colour window (refer to Colour Window on page 281 for more
information) and determine the separator line colour.
• Space Above: Sets the space between the separator line and the document text.
• Space Below: Sets the space between the separator line and the notes text.
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F. Reference Symbol Area
The following figure depicts the Reference Symbol area and its functionalities (refer to Setting
Reference Symbol Attributes on page 64 for step-by-step instructions for configuring the
Reference Symbol):

Figure 8-142: Reference Symbol Area

• Type: Sets the numbering scheme for the selected stream reference symbol. The default
•
•

•

options is Arabic (1,2,3...).
Format: Sets the format for displaying the number with or without surrounding punctuation
marks. The default option is none which just displays the number itself.
Character Style: Opens the Character Attributes popover, which allows applying character
attributes or style to notes of the selected stream. The default style is use surrounding, which
results in the reference symbol adopting its surrounding text character attributes. However,
all of the document character styles are available for selection as well.
Superscript: Displays the reference symbol in superscript letters.

G. Note Symbol
The functionalities in the Note Symbol area is identical to those in the Reference Symbol area.
Refer to Reference Symbol Area above for a detailed description and to Setting Note Symbol
Attributes on page 64 for step-by-step instructions for setting the Note Symbol attributes.

H. Note Text Style Area
The following figure depicts the Note Text Style area and its functionalities (refer to Changing
Note Text Styles on page 64 for step-by-step instructions):

Figure 8-143: Note Text Style Area

• Paragraph:

Opens the Paragraph Attributes popover, which allows applying paragraph
attributes or style to notes of the selected stream.
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• Character:

Opens the Character Attributes popover, which allows applying character
attributes or style to notes of the selected stream.

3. Font Matching Panel
The Font Matching panel may be displayed when RTF documents are imported, depending on
your preferences. Refer to Importing RTF Documents on page 29 for more information.
The following image depicts the Font Matching panel and its functionalities:

Figure 8-144: Font Matching Panel

• Font Pairs Table: Each row in the table includes two font names: The value in the RTF Font

•
•
•

Name column includes the name of an original font from the imported RTF document, while
the value in the Replacement Font column indicates the matched font that will be used
instead of he original font in the Mellel document. You can choose any row from the list to
change its replacement font. The following colour code is used in the table:
• Bold Face: Matches you configured as default. Mellel will not attempt to resolve these
matches.
• Regular Face: Matches resolved automatically by Mellel. These matches are usually correct
and require no input.
• Red: Matches that Mellel was not able to resolve automatically, and thus used a more
general font family. These matches should be carefully reviewed.
Font: This popup menu is used to change the replacement font for the selected pair.
Face: This popup menu is used to change the face of the replacement font for the selected
pair.
Make Default: This checkbox is used to save the current match as the default matching for
the original font. This match will be used in the next import for the same RTF Font Name.
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• OK: Pressing this button will import the document with the configured font matching.
• Cancel: Pressing this button will cancel the import process.

4. Edit Image Popover
The Edit Image popover is used to change image attributes. Refer to Images on page 92 for
more information. To display it, double-click any image.
The following figure depicts the Edit Image popover and its functionalities:

Figure 8-145: Edit Image Popover

• Image Area:
• Fitting method: This popup menu is used to determine how is the image fitted within its
frame. Available options include:
• Scale to fit (default): The image is resized to fit the frame size.
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• Float in frame: The image is not resized, and only the portion that fits within the frame is
displayed. This option enables you to move the image within its frame, as described in
Moving an Image Within its Frame on page 93.

Figure 8-146: Same Image Scaled to Fit (Left) and Float in Frame (Right)

• Lock (default): Determines whether the height/width ratio of the image is locked and
automatically maintained when you change one of the parameters. The ratio is maintained
when the icon is locked (
) and ignored when it is open (
).

• Resize (Percentages): Resizes the image height or width to a percentage value relative to
•

the original image.
• Resize (Dimensions): Resizes the image height or width to an absolute value.
Fill Area: Formats the image fill. Refer to Setting Image Fill on page 95 for step-by-step
instructions.
• Type: This popup menu is used to determine the fill pattern. Options include:
• None (default): No fill.
• Solid: Solid fill.

• Colour (

•

): This button is used to open the colour window and determine the fill
colour. Refer to Colour Window on page 281 for step-by-step instructions for using the
Colour window.
• Alpha: Sets the image transparency level. You can either manually input a value in the
adjacent text-box or click and drag the slider. Refer to Setting Image Transparency on page
95 for step-by-step instructions.
Frame Area: Formats the image frame. Refer to Setting Image Frame on page 95 for step-bystep instructions. The default setup is no frame.
• Type: This popup menu is used to choose the type of frame line.

• Colour (

): This button is used to open the Colour window and determine the frame
colour. Refer to Colour Window on page 281 for step-by-step instructions for using the
Colour window.
• Weight: Sets the frame weight (width). You can either use the popup menu to choose a
value of 1-5 points, or manually enter any desired value.
Note: The Weight function is disabled if None is selected as a Frame Type.
385 | Appendix

• Radius: This text-box is used to apply a rounded corners eﬀect to the image by determining
•

•

•

the corner radius. Refer to Setting Image Corner Radius on page 95 for step-by-step
instructions.
Vertical Position Area: When images are set to be inline with the text, this area is used to
determine their positioning:
• Vertical Position: Determines the image vertical positioning relative to the text baseline.
Positive values indicate the image is above the text baseline, while negative values
indicate it is below it. Refer to Setting Image Vertical Position on page 95 for step-by-step
instructions. The default value is 0 (at text level).
• Adjust fixed line spacing: This checkbox is used to determine whether or not Mellel
automatically pads the image size to multiplications of the surrounding text line spacing,
so that the layout remains consistent. Refer to Adjusting Fixed Line Spacing for Images on
page 95 for more information.
Image Management Area:
• Image title: Used to enter a title for the image, which can later be used to easily locate the
image and to use it as part of the automatic text in a reference pointing to the image. Refer
to Setting Image Title on page 96 for step-by-step instructions.
• Cross Reference Target ID: Used to enter a Reference Target ID for the image, so that you
can cross-reference it from other parts of the document. Refer to Setting Image CrossReference Target ID on page 96 for step-by-step instructions.
• Assign Virtual Target: Used to assign an existing virtual target as the reference ID for the
image. Refer to Setting Image Cross-Reference Target ID on page 96 for step-by-step
instructions.
Wrapping Area:
• Placement: Determines whether the image will be positioned inline with the text or float
above it. Options include Inline (default) and Floating. Refer to Setting the Image as Inline
or Floating on page 96 for step-by-step instructions.
• Image Causes Wrap: This checkbox is used to determine whether or not text will wrap
around the image. Refer to Setting Image Text Wrapping on page 96 for step-by-step
instructions.
• Wrapping Buttons: When the Image Causes Wrap checkbox is checked, these buttons can
be used to determine how text wraps around the image. Available options change based
on whether the image is set as inline or floating::
• Inline Images:

•

Align image to the left, and wrap text around it:

Figure 8-147: Inline Image - Align Left and Wrap

•

Center image, and wrap text around it:
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Figure 8-148: Inline Image - Centre and Wrap

•

Align image to the right, and wrap text around it:

Figure 8-149: Inline Image - Align Right and Wrap

•

Align image to the left, and wrap text above and below it:

Figure 8-150: Inline Image - Align Left and Wrap Above and Below

•

Center image, and wrap text above and below it:

Figure 8-151: Inline Image - Align Centre and Wrap Above and Below

•

Align image to the right, and wrap text above and below it:
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Figure 8-152: Inline Image - Align Right and Wrap Above and Below

•

Floating Images:

•

Wrap text to the right of the image (leaving a blank space to the left):

Figure 8-153: Floating Image - Wrap Text to the Right

•

Wrap text around the image:

Figure 8-154: Floating Image - Wrap Text Around

•

Wrap text to the left of the image (leaving a blank space to the right):

Figure 8-155: Floating Image - Wrap Text to the Left

•

Wrap text to the right or to the left of the image, depending on the horizontal
width of the area available for the text on either side:
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Figure 8-156: Floating Image - Wrap to Bigger Area

•

Skip: Wrap the text above and below the image:

Figure 8-157: Floating Image - Wrap Above and Below

• Extra

Space: This text-box is used to create extra space between the image and the
wrapping text. This option is only enabled when Image Causes Wrap is checked.

5. Edit Text Box Popover
The Edit Text Box popover is used to change text box attributes. Refer to Text Boxes on page 98
for more information. To display it, double-click any text box.
The following figure depicts the Edit Text Box popover and its functionalities:
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Figure 8-158: Edit Text Box Popover

• Text Box Area:
• Width: Sets the text box width. Refer to Setting Text Box Dimensions on page 100 for step-

•

by-step instructions.
• Height: Sets the text box height. Refer to Setting Text Box Dimensions on page 100 for
step-by-step instructions.
• Padding: Sets the text box padding. Refer to Setting Text Box Padding on page 100 for
step-by-step instructions.
Fill Area: Formats the text box fill. Refer to Setting Text Box Fill on page 100 for step-by-step
instructions:
• Type: This popup menu is used to set the fill pattern. Options include:
• None (default): No fill.
• Solid: Solid fill.

• Colour well

•

(
): Opens the Colour window and set the fill colour. Refer to Colour
Window on page 281 for step-by-step instructions for using the Colour window.
• Alpha: Determines the image transparency level. You can either manually input a value in
the text-box or drag the slider. Refer to Setting Text Box Transparency on page 101 for stepby-step instructions.
Frame Area: Formats the text box frame. Refer to Setting Text Box Frame on page 101 for
step-by-step instructions.
• Type: This popup menu is used to choose the type of frame line.

• Colour well (

): Open the Colour window and set the frame colour. Refer to Colour
Window on page 281 for step-by-step instructions for using the Colour window.
Screen Descriptions | 390

• Weight: Determines the frame weight (width). You can either use the popup menu to

choose a value of 1-5 points, or manually enter any other value.
Note: The Weight function is disabled if None is chosen as a Frame Type.
• Radius: This text-box is used to apply a rounded corners eﬀect to the text box by
determining the corner radius. Refer to Setting Text Box Corner Radius on page 101 for
step-by-step instructions.
• Vertical Position Area: When text boxes are set to be inline with the text, this area is used to
determine their positioning.
• Vertical Position: Determines the text box vertical positioning relative to the surrounding
text baseline level. Positive values indicate the text box is above the text level, while
negative values indicate it is below it. Refer to Setting Text Box Vertical Position on page
101 for step-by-step instructions. The default value is 0 (at text level).
• Adjust fixed line spacing: This checkbox is used to determine whether or not Mellel
automatically fits a text box as multiplications of the surrounding text line spacing, so that
the layout remains consistent. Refer to Adjusting Fixed Line Spacing for Text Box on page
101 for step-by-step instructions.
• Text Wrap Area:
• Placement: Determines whether the text box is positioned inline with the text or float
around it. Options include Inline (default) and Floating. Refer to Setting Text Box as Inline
or Floating on page 101 for step-by-step instructions.
• Text Box Causes Wrap: This checkbox is used to determine whether or not surrounding
text wraps around the text box. Refer to Setting Text Box Text Wrapping on page 102 for
step-by-step instructions.
• Wrapping Buttons: When the Text Box Causes Wrap checkbox is checked, these buttons
can be used to determine how text will wrap around the text box. Available options
change based on whether the text box is set as inline or floating (these options are
identical to those described for text wrapping images. Refer to Edit Image Popover on
page 384 for example figures:
• Inline Text Boxes:

•
•
•
•
•
•
•

Align text box to the left, and wrap text around it.
Center text box, and wrap text around it.
Align text box to the right, and wrap text around it.
Align text box to the left, and wrap text above and below it.
Center text box, and wrap text above and below it.
Align text box to the right, and wrap text above and below it.

Floating Text Boxes:

•
•
•

Wrap text to the right of the text box (leaving a blank space to the left).
Wrap text around the text box.
Wrap text to the left of the text box (leaving a blank space to the right).
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•

Wrap text to the right or to the left, depending on the horizontal width of the area
available for the text on both sides of the text box.

•

Wrap the text above and below the text box.

• Extra

Space: This text-box is used to add extra space between the text box and the
wrapping text. This option is only enabled when Text Box Causes Wrap is checked.

6. Edit Hyperlink Window
The Edit Hyperlink window is used to insert and edit hyperlinks in the document. Refer to
Inserting a Hyperlink on page 103 for more information.
The Edit Hyperlink window has three possible layouts, depending on the selection made using
the Hyperlink Type popup menu: Web, E-Mail and File. The following sub-sections describe the
diﬀerent layouts and their functionalities.

A. Edit Hyperlink Window - Web Layout
The following figure depicts the web layout of the Edit Hyperlink window and its
functionalities:

Figure 8-159: Edit Hyperlink Window - Web Layout

• Hyperlink Type: This popup menu is used to set the type of hyperlink. The selection made
here aﬀects the availability of other elements in the window.
• Display Text: This text box is used to enter the text that is displayed in the document as the
actual hyperlink. Clicking the display text will navigate to the link target.
Note: By default, the display text is dynamically and automatically copied from the URL. Only if
you manually change the display text would the two diﬀer.
• Display as link: This checkbox is used to determine whether the current hyperlink is
displayed as a hyperlink (e.g. in a diﬀerent colour with an underline) or as plain text.
Screen Descriptions | 392

• URL: This text box is used to enter the target web address.
• Anchor: This text box is used to determine a specific anchor within the URL that you are
directed to when clicking the hyperlink.

B. Edit Hyperlink Window - E-Mail Layout
The following figure depicts the e-mail layout of the Edit Hyperlink window and its
functionalities (only functionalities that are unique to this layout and were not described as
part of the web layout above are described):

Figure 8-160: Edit Hyperlink Window - Web Layout

• Display Text: This text box is used to enter the text that is displayed in the document as the
actual hyperlink. Clicking this display text will generate a new e-mail to the set address.
Note: By default, the display text is dynamically and automatically copied from the e-mail
address. Only if you manually change the display text would the two diﬀer.
• Address: This text box is used to enter the target e-mail address.
• Subject: This text box can be used to determine a specific subject that will be used for the
generated e-mail.

C. Edit Hyperlink Window - File Layout
The following figure depicts the file layout of the Edit Hyperlink window and its functionalities
(only functionalities that are unique to this layout and were not described as part of the web
layout above are described):
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Figure 8-161: Edit Hyperlink Window - Web Layout

• Display Text: This text box is used to enter the text that will be displayed in the document as
the actual hyperlink. Clicking this display text will open the linked file.
Note: By default, the display text is automatically changed to the file path. Only if you
manually change the display text would the two diﬀer.
• Path: Sets the target file path by pressing the Browse button, locating and choosing the
desired file.

7. Line Numbers Window
The Line Numbers window is used to configure line numbers that can be added to document
sections. Refer to Line Numbering on page 106 for more information.
The following figure depicts the Line Numbers window and its functionalities:
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Figure 8-162: Line Numbers Window

• Line Numbers: This popup menu is used to activate line numbering and determine the

•

numbering reset behavior (refer to Activating Line Numbering on page 106 for step-by-step
instructions). The following options are available:
• Restart with Page: Line numbers would restart with every new page.
• Restart with Section: Line numbers would restart with every new section.
• Continuous: Line numbers would never restart throughout the document.
Numbering Method:
• Start at: This text box is used to set the initial value for numbering lines. Refer to
Configuring Numbering Options on page 107 for step-by-step instructions.
• Increment: This text box is used to set the increment between two ensuing numbered lines.
Refer to Configuring Numbering Options on page 107 for step-by-step instructions.
• Type: This popup menu is used to set the numbering scheme (refer to Configuring
Numbering Options on page 107 for step-by-step instructions).
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• Character attributes: Clicking this area opens the Character Attributes popover that allows
•
•

applying diﬀerent character attributes to the line numbers (refer to Setting Character
Attributes on page 107 for available options) or applying a character style.
Count: This popup menu is used to determine whether to count lines or paragraphs. Refer to
Selecting What to Count on page 108 for step-by-step instructions.
Display every: This text box is used to determine the frequency of displaying the numbered
element (refer to Changing Display Frequency on page 108 for step-by-step instructions).
The following figure depicts a numbered text with Display every set to 5:

Figure 8-163: Line Numbering Display Frequency Example

• Always display for first line: This checkbox is used to set Mellel to always display the first line
number, regardless of the Display every setting. Refer to Numbering First and Last Lines on
page 108 for step-by-step instructions.
Note: This checkbox is only enabled when a value diﬀerent than one (1) is entered in the
Display every text box.
• Always display for last line: This checkbox is used to set Mellel to always display the last line
number, regardless of the Display every setting. Refer to Numbering First and Last Lines on
page 108 for step-by-step instructions.
Note: This checkbox is only enabled when a value diﬀerent than one (1) is entered in the
Display every text box.
• Only count numbered lines: This checkbox is used to set Mellel to only count numbered
lines based on the value in the Display every text box (refer to Only Counting Numbered
Lines on page 108 for step-by-step instructions). The following figure depicts a text with
Display every set to 5 and Only count numbered lines enabled:
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Figure 8-164: Line Numbering Only Count Numbered Lines Enabled

• Ignore empty lines: This checkbox is used to ignore empty lines when numbering lines.
•

Refer to Ignoring Empty Lines on page 109 for step-by-step instructions.
Relative to text: This popup menu is used to position line numbers relative to the text (refer
to Setting Numbers Position on page 109 for step-by-step instructions). The following
options are available:
• Before: Numbers are entered before the text, as depicted in the following figure:

Figure 8-165: Line Numbers Before Text

• After: Numbers are entered after the text, as depicted in the following figure:

Figure 8-166: Line Numbers After Text

• Before and After: Numbers are entered both before and after the text, as depicted in the
following figure:
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Figure 8-167: Line Numbers Before and After Text

• Alternate Before and After: Alternating between entering numbers before or after the text,
as depicted in the following figure:

Figure 8-168: Line Numbers Alternating Before and After Text

• Before, After with Last Column: Numbers are entered before the text, except for the last
column where they are entered after the text. This option is depicted in the following
figure:

Figure 8-169: Line Numbers Before Text and After Last Column

• Distance from text: This text box is used to set the distance between the line numbers and
•

the text. Refer to Setting Numbers Position on page 109 for step-by-step instructions.
Alignment: This popup menu is used to set the alignment of the line numbers within the
page margin (refer to Setting Numbers Position on page 109 for step-by-step instructions).
The following options are available:
• Natural: Numbers are aligned to the page border, as depicted in the following figure:
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Figure 8-170: Line Numbers Natural Alignment

• Center: Numbers are centered, as depicted in the following figure:

Figure 8-171: Line Numbers Centre Alignment

• Next to Text: Numbers are aligned to the text, as depicted in the following figure:

Figure 8-172: Line Numbers Next to Text Alignment

• Line type: This popup menu is used to choose the separating line type (refer to Formatting
•
•
•

the Separating Line on page 109 for step-by-step instructions).
Weight: This popup menu is used to set the separator line weight (refer to Formatting the
Separating Line on page 109 for step-by-step instructions). While the list includes 1-5 points
as options, you can manually enter any desired value.
Colour: This button is used to open the Colour window and set the separator line colour.
Refer to Formatting the Separating Line on page 109 for step-by-step instructions.
Distance from line: This text box is used to set the distance between the separator line and
the document text. Refer to Formatting the Separating Line on page 109 for step-by-step
instructions.
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• Numbering channel: This popup menu is used to assign the line numbers sequence to a

specific numbering channel (refer to Setting the Numbering Channel on page 110 for stepby-step instructions). The following figure depicts an example including two diﬀerent line
numbering streams with a diﬀerent format on the same page:

Figure 8-173: Two Diﬀerent Line Numbering Streams

8. Edit Reference Window
The Edit Reference window is used to insert new references into the document or to edit
existing ones. It enables you to set the reference target, and to change its format and style.
To open the Edit Reference window, either insert a new reference (refer to Inserting a Cross
Reference on page 114 for step-by-step instructions) or edit an existing one by doubleclicking it.
The following figure depicts the Edit Reference window and its functionalities:
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Figure 8-174: Edit Reference Window

• Reference type: This area lists the diﬀerent types of references that can be added to the
document. The option selected from this list determines the content of the adjacent targets
list. The following options are available:
• Existing Targets: When this option is chosen, the targets list is titled Existing targets and lists
the targets of all existing references in the document, sorted alphabetically. This may
include Auto-titles ( ), images ( ), bookmarks ( ) and virtual targets (
).

• Auto-titles: When this option is chosen, the targets list is titled Auto-titles and lists all the

•

•

Auto-titles in the document, sorted by order of appearance. The Target ID area indicates
the suggested target ID for the selected target. For Auto-titles, this would be the same as
the element's title, unless a reference ID was already defined for the Auto-title. Refer to
Inserting an Auto-Title on page 46 for more information.
Images: When this option is chosen, the targets list is titled Images and lists all the images
in the document, sorted by order of appearance. The images appear in the list by their
image title, and the Target ID area indicates the suggested target ID for the selected image.
If no target ID was set for the image, the title is used. If no title was entered, a generic
image title followed by a serial number is assigned to the image. Refer to Setting Image
Title on page 96 and Setting Image Cross-Reference Target ID on page 96 for more
information.
Virtual Target: When this option is chosen, the targets list is replaced by the Virtual target ID
text box, which is used to enter an ID for a new virtual target. Refer to Creating a Reference
to a New Virtual Target on page 116 for step-by-step instructions.
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Note: For Auto-titles and Images, if no target ID is set for the element, you can use the Target
ID text box to enter one. If there is already an existing target ID, the text box is not editable.
• Filter: This text box is used to filter the displayed targets by text strings. This text box is not
available when Virtual Target is chosen.

• Filter Markers (

): This button is used to filter the displayed auto-titles based on the

markers applied to them. Refer to Filtering Outline Items on page 144 for more information.
This button is not displayed when Images or Virtual Target is chosen.

• Filter Tags (
•
•

): This button is used to filter the displayed auto-titles by the tags assigned to

them. Refer to Filtering Outline Items on page 144 for more information. This button is not
displayed when Images or Virtual Target is chosen.
Preview: This area is used to preview the targeted element.
Reference format: This area is used to format the reference. Refer to Formatting a Reference
on page 118 for step-by-step instructions.
• Elements: This popup menu is used to insert a dynamic context sensitive element to the
reference format area. The following options are available:
• Page number: Inserts the page number where the target element begins. Double-clicking
the Page element in the Format Edit area opens the Conditional Page Number Format
window, which enables you to change the appearance of the page element based on the
target location:

Figure 8-175: Conditional Page Number Format

• Default number format: Sets the default format for displaying the page number.
• Above: Sets the format to use when the target is anywhere in the document above the
•
•

reference.
Below: Sets the format to use when the target is anywhere in the document below the
reference.
Above (same page): Sets the format to use when the target is on the same page as the
reference and above it.
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• Below (same page): Sets the format to use when the target is on the same page as the

reference and below it.
• On the next page: Sets the format to use when the target is on the page following the
reference.
• On the previous page: Sets the format to use when the target is on the page preceding
the reference.
• Opposite page: Sets the format to use when the target is on the page opposing the
reference.
• Note symbol: When the reference targets a note, inserts the note's symbol.
• Auto-title format: When the reference targets an Auto-title, choosing this option enters
the format determined for that Auto-title level for usage in references. Refer to Use a
Diﬀerent Format for Diﬀerent Auto-Titles Usages on page 57 for step-by-step instructions
on adjusting this format.
• Auto-title title: When the reference targets an Auto-title, choosing this option enters the
Auto-title title text. For example, if an Auto-title appears in the text as 1.5. Mellel: Why it’s
Great, referencing the Auto-title title element the reference would appear in the text as
Mellel: Why it’s great.
• Auto-title current level number: When the reference targets an Auto-title, choosing this
option enters the current level number of the targeted Auto-title. For example, if an
Auto-title appears in the text as 1.5. Mellel: Why it’s Great, referencing the Auto-title
current level number element the reference would appear in the text as 5 (the current
level number).
• Auto-title previous level number: When the reference targets an Auto-title, choosing this
option allows entering the number of any level above the targeted Auto-title. For
example, if an Auto-title appears in the text as 1.5. Mellel: Why it’s Great, referencing the
Auto-title previous level number element the reference would appear in the text as 1
(the previous level number).
• Auto-title range start: When the reference targets an Auto-title, choosing this option
enters the page number where the Auto-title range begins (where the actual Auto-title is
located).
• Auto-title range end: When the reference targets an Auto-title, choosing this option
enters the page number where the Auto-title range ends (where the next Auto-title of
the same level is entered).
Note: Using the Auto-title range start/end is a very convenient means to refer to a page range,
but only if that page range is defined by an Auto-title. When this is not the case, you’ll need to
create two references: one for a bookmark on the first page in the range, and another for a
bookmark on the last page in the range.
• Image title: When the reference targets an image, enters the image title.
• Reference formats: This popup menu is used to choose an existing reference format. Refer
to Using an Existing Reference Format on page 118 for step-by-step instructions.

• Direction (
•

): Clicking this button changes the direction of the format edit area. It does

not aﬀect the appearance of the actual reference in the document.
Format Edit Area: This area is used to edit the reference format, using one of the following
methods:
• To add a dynamic element, use the Elements popup menu.
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• To add text, place the insertion point within the edit area and type the desired text.
• To apply character attributes, select the desired text and use the Character palette.
Note: In addition to the regular document styles, you can choose the <use surrounding>
option from the Character palette Styles tab to automatically match the reference character
style to its surrounding text.

9. Edit Character Style Window
The Edit Character Style window is used to create new character styles and to edit existing
ones. It includes similar functionalities to the Character palette Attributes tab.
Refer to Creating a New Style on page 189 and Editing a Style on page 190 for step-by-step
instructions to open this window.
Most of the options in the Edit Character Style window are similar to those in the Character
palette Attributes tab. Refer to Styling Characters Using Attributes on page 157 for step-bystep instructions for applying diﬀerent attributes to the character style and to Character
Palette Description on page 337 for a complete description of the diﬀerent options.
The following figure depicts the Edit Character Style window and its unique functionalities that
are not part of the Character palette Attributes tab:

Figure 8-176: Edit Character Style Window
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• Style name: Used to rename the edited style. Refer to Renaming a Style on page 191 for
•

step-by-step instructions.
Style variations: Used to choose a specific style variation to edit. Refer to Editing a
Character Style Variation on page 191 for step-by-step instructions. Variations that are
diﬀerent then the base variation are displayed in bold. Otherwise they are displayed as plain
text.

• Reset variation (

): Resets the attributes of the currently selected variation to those of

the base variation. Editing a Character Style Variation on page 191 for step-by-step
instructions.

• Reset
•
•
•

all variations (

): Resets the attributes of all variations to those of the base

variation. Editing a Character Style Variation on page 191 for step-by-step instructions.
Preview Area: Displays a preview of how text would look like using the currently set
attributes. You can manually change the text in the preview area to check how a specific
string would look like.
Cancel: Clicking this button discards all changes and closes the window.
Create/Save: Clicking this button applies all changes and closes the window.

10. Edit Paragraph Style Window
The Edit Paragraph Style window is used to create new paragraph styles and to edit existing
ones. It includes similar functionalities to the Paragraph palette Attributes tab.
Refer to Creating a New Style on page 189 and Editing a Style on page 190 for step-by-step
instructions to open this window.
Most of the options in the Edit Paragraph Style window are similar to those in the Paragraph
palette Attributes tab. Refer to Styling Paragraphs Using Attributes on page 164 for step-bystep instructions for applying diﬀerent attributes to the paragraph style and to Paragraph
Palette Description on page 342 for a complete description of the diﬀerent options.
The following figure depicts the Edit Paragraph Style window and its unique functionalities
that are not part of the Paragraph palette Attributes tab:
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Figure 8-177: Edit Paragraph Style Window

• Style name: Used to rename the edited style. Refer to Renaming a Style on page 191 for
•

step-by-step instructions.
Hyphenation Area: Used to set hyphenation preferences for the selected style. Refer to
Managing Paragraph Hyphenation on page 169 for more information.
• Enable: This checkbox is used to enable hyphenation. Refer to Activating Hyphenation on
page 170 for step-by-step instructions.
• Dictionary: This popup menu is used to choose a hyphenation dictionary (refer to
Activating Hyphenation on page 170 for step-by-step instructions). This option is only
available if the Enable checkbox is checked.
• Customise minimum: This checkbox is used to enable you to customize the default
dictionary settings for minimum word length and number of characters before and after
the hyphen (refer to Customizing Minimum Hyphenation Length on page 171 for step-bystep instructions). This option is only available if the Enable checkbox is checked.
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• Word length: This text box is used to set the minimum word length that can be hyphened.

For example, with a minimum length to 6 letters, a word such as hippodrome, which is
longer than the minimum, can be hyphenated, but a word such as apron cannot. The
default is the value set in the chosen hyphenation dictionary (normally 5).
Note: This option is only available if both the Enable and Customise minimum checkboxes are
checked.
• Before hyphen: This text box is used to set the minimum number of characters before the
hyphen. For example, setting the value to 3 will allow the word Semaphore to be
hyphenated as Sem-aphore but not as Se-maphore. The default is the value set in the
chosen hyphenation dictionary (usually, 2).
Note: This option is only available if both the Enable and Customise minimum checkboxes are
checked.
• After hyphen: This text box is used to set the minimum number of characters after the
hyphen. For example, setting the value to 3 will allow the word Semaphore to be
hyphenated as Semaph-ore but not as Semapho-re. The default is the value set in the
chosen hyphenation dictionary (usually, 2).
Note: This option is only available if both the Enable and Customise minimum checkboxes are
checked.
• Hyphenation limit: This text box is used to set the maximal number of consecutive lines
that can end with a hyphen (refer to Setting Hyphenation Lines Limit on page 170 for stepby-step instructions).
Note: This option is only available if the Enable checkbox is checked.
• Hyphenation zone: This text box is used to set the maximal size of the hyphenation zone
(refer to Setting the Hyphenation Zone on page 171 for more information).
Note: This option is only available if the Enable checkbox is checked.
• Tabs Well: This panel is used to add tabs to the paragraph style. It is identical to the tabs well
in the toolbar. Refer to Tab Well on page 328 for a complete description.
• Keep options Area: Includes diﬀerent options that are aimed at assuring paragraphs are
kept together without scattering individual lines across diﬀerent pages (commonly referred
to as widows and orphans). Refer to Keeping Lines Together on page 172 for step-by-step
instructions.
• Keep lines together: This checkbox is used to enable keeping paragraph lines together.
When it is not checked, lines will flow to the next page regardless of the paragraph they are
associated with.
• Options: When the Keep lines together checkbox is checked, this popup menu is enabled
and used to configure this functionality. Available options include:
• All lines in a paragraph: When this option is chosen, paragraphs are kept as a single unit,
and are not split across pages.
• At start/end of paragraph: When this option is chosen, you can set set how many lines will
be kept together at the beginning or the end of a paragraph. This option is useful to
prevent widows and orphans, where only the first or last lines in a paragraph are
displayed at the top or at the bottom of a page
• Lines at start: When At start/end of paragraph is chosen, this text box becomes enabled and
is used to set the number of lines that will be kept together at the start of a paragraph
without being split across diﬀerent pages.
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• Lines at end: When At start/end of paragraph is chosen, this text box becomes enabled and

is used to set the number of lines that will be kept together at the end of a paragraph
without being split across diﬀerent pages.
• Keep with next: This text box enables you to keep the current paragraph tied to the next
paragraph. The text box is used to enter the number of lines from the next paragraph that
will be kept together with the current one.
• This option is especially useful to keep headings tied to sub-headings and to body text at
the bottom of the page, and is usually activated only with headings. Setting the value to 2
or 3 lines will yield an optimal result. A value of 1 will have no eﬀect and a value of 4 or
more lines will usually force Mellel to move headings near the bottom of the page to the
top of the next page.
Tip: It is highly recommended to only use this feature for headings.
• Associated character style: This popup menu is used to set a character style that is
associated with the edited paragraph style. Whenever the paragraph style is applied to a
text, the selected character style is set as well. Refer to Setting an Associated Character Style
on page 173 for step-by-step instructions.
Note: You can only associate a character style, not a character style variation.
• Next paragraph style: This popup menu is used to set a paragraph style that is
automatically applied to the next paragraph after pressing the Return key at the end of the
current paragraph. This option is useful when you want a heading or a special style to be
followed by a body style. Refer to Setting the Next Paragraph Style on page 173 for step-bystep instructions.
Tip: If you don’t want the current paragraph style to change when you press the Return key,
choose the option Same style.
• Ruler: Visually indicates the position of tabs. It is identical to the ruler at the top of the
document area. Refer to Ruler on page 330 for a complete description.
• Preview Area: Displays a preview of how text would look like using the currently set
attributes. You can manually change the text in the preview area to check how a specific
string would look like.
• Cancel: Clicking this button discards all changes and closes the window.
• Create/Save: Clicking this button applies all changes and closes the window.

11. Edit List Style Window
The Edit List Style window is used to create new styles and to edit existing ones. It includes
similar functionalities to the List palette Attributes tab.
Refer to Creating a New Style on page 189 and Editing a Style on page 190 for step-by-step
instructions to open this window.
Most of the options in the Edit List Style window are similar to those in the List palette Attributes
tab. Refer to Styling a List using Attributes on page 71 for step-by-step instructions for
applying diﬀerent attributes to the character style and to List Palette Description on page 346
for a complete description of the diﬀerent options.
The following figure depicts the Edit List Style window and its unique functionalities that are
not part of the List palette Attributes tab:
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Figure 8-178: Edit List Style Window

• Style name: Used to rename the edited style. Refer to Renaming a Style on page 191 for
•
•
•

•
•

step-by-step instructions.
Selected: Indicates the selected list level. All changes are applied only to the selected list
level, unless the Replicate to all button is used.
Replicate to all: Replicates the margin, indent and symbol positions, as well as the character
attributes from the currently selected level to all the levels in the list.
Preview Area: Previews all ten levels of the list and how would they look like based on the
current settings. The preview area includes a formatted display area and a ruler. The preview
area enables you to edit each level separately while viewing the impact of a change over the
look of the list as a whole.
Cancel: Discards all changes.
Save/Create: Applies changes to the edited style.

12. Table Style Window
The Table Style is the central hub for editing Table styles. Most of the options here are identical
to those oﬀered with the Table palette (See page 357) and the Edit Table Attributes popover
(See page 413). Some of the options, however, are only available here. A full description of all
the option follows.
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Figure 8-179: The Table Style Window

• Style Name: Text field allowing you to name or rename the table style.
• Attributes for: This popup menu, combined with Attributes selection widget, allows you to
select to which type of table cells your editing will be applied. The options here are:
• All Cells: Changes will be applied to all types of table cells.
• Normal Cells: Any table cell that is not a header, footer, leading to trailing cell.
• Header Cells: Any header cell.
• Footer Cell: Any Footer.
• Leading Column Cell: Any Leading Column cell
• Trailing Column Cell: Any Trailing Column Cell
• Leading Column Header Cells: Cells at the intersection of a header cell and a leading
column.
• Trailing Column Header Cells: Cells at the intersection of a header cell and a trailing
column.
• Leading Column Footer Cells: Cells at the intersection of a footer cell and a leading
column.
• Trailing Column Footer Cells: Cells at the intersection of a footer cell and a trailing
column.
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• Note: If you’ve selected cells of a type that do not exist in your template, you’ll be oﬀered the
•
•
•

•
•
•
•
•

option to add those type of cells to the template.
Note: All the options available here are also available from the Template area and the
Preview area in the Table Style window.
Direction: Allows you to set the table’s direction (from Left-to-right or from Right-to-left).
Border: Used to select to which borders of the selected cell type changes will be applied. All
options here are selected by default, except Ascending Diagonal and Descending Diagonal,
but you can combine any or all of the options here. The options here are:
• Horizontal outer Border: applies to the horizontal external borders of the selected cell
type.
• Vertical Outer Border: applies to the vertical external borders of the selected cell type.
• Horizontal Border Between Cells: applies to the horizontal border between cells of the
selected type.
• Vertical Border Between Cells: applies to the vertical border between cells of the
selected type.
• Horizontal Border with cells of a diﬀerent type: applies to the horizontal border
between cells of the selected type and cells of a diﬀerent type. For example, between
Header cells and Regular cells.
• Vertical Border with cells of a diﬀerent type: applies to the vertical border between cells
of the selected type and cells of a diﬀerent type. For example, between Leading Column
cells and Regular Cells.
• Ascending Diagonal: applies to the ascending diagonal line in the selected type of cells.
This option is mainly used with Leading Column Header Cells; This option is unselected by
default.
• Descending Diagonal: applies to the descending diagonal line in the selected type of
cells. This option is mainly used with Leading Column Header Cells; This option is
unselected by default.
Line Type: This popup menu is used to set the selected border line type.
Weight: This popup menu is used to set the selected border line weight (width). The weight
can be set to Hairline, 0.1-0.5 points, 1-5 points, but you can manually enter any desired
value.
Colour: This button is used to open the Colour window and set the selected border line
colour.
Background: This popup and colour button allow you to determine if a selection of cells will
have a background (None or Solid) and set the colour of this background.
Vertical Alignment: This popup menu is used to determine the vertical alignment of
content within the selected cells. Options include Top, Middle, Bottom and Justify. The
following table exemplify the various options here:
Aligned to top
Aligned to top

Aligned to middle
Aligned to middle

Aligned to bottom
Aligned to bottom

Table 8-3: Table Vertical Alignment options
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Justified Justified
Justified Justified
Justified Justified
Justified Justified

• Inner Padding: This popup menu is used to determine the distance between the selected
•
•

cells content and their borders. Options include None and 1-5 points. Refer to Configuring
Inner padding on page 84 for instructions on using this option.
Alternating Rows: This field and colour button allow you you to determine the alternating
background colour that will be automatically applied in a table. Refer to Setting Colour
Alternation on page 83 for a detailed description of colour alternation.
Corner Radius: The Corner Radius selector enables you to set the corner radius for a
selection of files. All corners are selected by default, but you can de-select any of them. The
higher the radius value set in the field, the rounder the corner will be. Some examples of this:

Corner Radius: 0 for all
corners

Corner Radius top: 0.741
cm; bottom: 0

Corner Radius all
corners: 0.706 cm;
bottom: 0

Corner radius top-left
and bottom right: 0.635
cm; top -right, bottomleft: 0.106 cm

Table 8-4: Corner Radius examples

• Outer padding: The Outer Padding selector and field combo enables you to set the outer
padding for a cell. The padding is measured from the selected cell(s) boarder inwards. In
other words, a larger outer padding will not cause a padded cell (no pun intended) to
overstep its boundaries. For example:

Figure 8-180: Table with Outer Padding

• Character Style button: Use this option to open the Character Style popover, and apply any
•

character attribute to the selected cell type.
Paragraph Style button: Use this option to open the Paragraph Style popover, and apply
any paragraph attribute to the selected cell type.

A. Template Configuration section
This section of the Table Style window will allow you to set Template specific options.
• Template: The popup and the adjoining Add and Delete buttons will allow you to switch
between templates while editing, Add templates and Delete templates.
• Table Size: Used to set the number of rows and columns in a table.
• Position: Used to set the table’s horizontal position. You can use the options set by default
(Left, 25%, centre, 75%, Right) or use the combo drop-menu to enter a value from 1% to 99%.
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• Width: Used to set the total width for any selection of cells. Values can be numeric (e.g., 10.5

cm) or relative (e.g., 45%). Relative values are contextual — if the selection does not span the
entire width of the table, the width set will be relative to the entire table width. If the
selection span the entire width of the table, the width will be relative to the section column
width (with 1 column, this means the entire page width sans margins on the left and the
right of the page.
Tip: Setting the width relatively will allow your table flexibility with changing conditions (e.g.,
changing from one column section to a two column section).
• Header & Footer: Used to set the number of Header and Footer rows, and the number of
Leading and Trailing columns in a table.
• Repeating Header: Used to set a repeating header. A repeating header is a table header that
appears again and again at the top of the page in a table spanning over multiple pages. You
can select any header row or all of them.

B. Preview
The preview area allows you to preview the table as a whole, and select certain cell type
quickly to manipulate them. It’s functionality is identical to that of the Attributes popup and
other options (see page 410).

C. Save and Cancel
Pressing the Save button will save your changes. Pressing the Cancel button will discard them.

13. Edit Table Attributes popover
The Edit Table Attributes popover is used to edit table attributes, and to edit and manage table
styles. The options in this popover are identical to those oﬀered by the the Table palette. Refer
to Styling Tables on page 82, Table Styles on page 85, Table Palette Description on page 357,
and to Table Style Window on page 409 for more information about styling tables and table
styles.
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Figure 8-181: The Edit Table Attributes popover

• Style: A combo drop down menu used to select and apply table styles and to rename the
•
•
•
•
•
•
•
•

•

edited style,.
Create new style: Used to add a New table style to the style set, based on the style currently
applied to a table.
Delete style: Used to remove the currently selected style from the style set.
Save changes to style: Saves changes to the table to the current table style. A + sign next to
the style’s name will indicate if it there are overrides to the style); If there are no changes to
the style, this option will be inactive.
Direction: Allows you to set the table’s direction (from Left-to-right or from Right-to-left).
Table Size: Used to set the number of rows and columns in a table.
Header & Footer: Used to set the number of Header and Footer rows, and the number of
Leading and Trailing columns in a table.
Position: Used to set the table’s horizontal position. You can use the options set by default
(Left, 25%, centre, 75%, Right) or use the combo drop-menu to enter a value from 1% to 99%.
Width: Used to set the total width for any selection of cells. Values can be numeric (e.g., 10.5
cm) or relative (e.g., 45%). Relative values are contextual — if the selection does not span the
entire width of the table, the width set will be relative to the entire table width. If the
selection span the entire width of the table, the width will be relative to the section column
width (with 1 column, this means the entire page width sans margins on the left and the
right of the page.
Repeating Header: Used to set a repeating header. A repeating header is a table header that
appears again and again at the top of the page in a table spanning over multiple pages. You
can select to repeat any header row or all of them.
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• Border Selector: Selects the borders to which you can apply attributes. The border selector
available selections change contextually depending on the range of cells selected. If you
selected just one cell (that is, you placed the insertion point within a cell), the border selector
will look something like this:

Figure 8-182: Border Selector with a single cell selected
Because only a single cell is selected, only its four borders (and diagonal lines) can be
changed using the border selector. However, when you select two cells vertically:

Figure 8-183: Vertical Cells Selection
The border selector will look like this:

Figure 8-184: Vertical Cells Border Selector
The added border indicates that there are horizontal lines between cells that can be manipulated. If you further extend the selection:
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Figure 8-185: Multiple Cells Selection
The border selector changes to fit the extended selection and shows a vertical line:

Figure 8-186: Multiple Cells Border Selector
Note: Clicking and selecting the inner lines when multiple cells are selected will apply any
changes to all the inner lines in the selected cells range, while clicking and selecting any
outer lines will only aﬀect a single corresponding external border in the selected cells range.

• Line Type: This popup menu is used to set the selected border line type.
• Weight: This popup menu is used to set the selected border line weight (width). The weight
•
•

can be set to Hairline, 0.1-0.5 points, 1-5 points, but you can manually enter any desired
value.
Colour: This button is used to open the Colour window and set the selected border line
colour.
Corner Radius: The Corner Radius selector and field combo enables you to set the outer
corner radius for a selection of cells. All corners are selected by default, but you can de-select
any of them. The higher the radius value set, the rounder the corner will be. Some examples
of this:

Corner Radius: 0 for all
corners

Corner Radius top: 0.741
cm; bottom: 0

Corner Radius all
corners: 0.706 cm;
bottom: 0

Corner radius top-left
and bottom right: 0.635
cm; top -right, bottomleft: 0.106 cm

Table 8-5: Corner Radius examples

• Outer padding: The Outer Padding selector and field combo enables you to set the outer
padding for a cell. The padding is measured from the selected cell(s) boarder inwards. In
other words, a larger outer padding will not cause a padded cell (no pun intended) to
overstep its boundaries. For example:
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Figure 8-187: Table with Outer Padding
With this table, where invisible table lines are visible for for clarity, you can see various cells
with diﬀerent outer padding settings. The outer padding is always applied from the cell’s
border inside.
Background: This popup and colour button allow you to determine if a selection of cells will
have a background (None or Solid) and set the colour of this background.
Colour Alternation: This field and colour button allow you you to determine the alternating
background colour that will be automatically applied in a table. Refer to Setting Colour
Alternation on page 83 for a detailed description of colour alternation.
Inner Padding: This popup menu is used to determine the distance between the selected
cells content and their borders. Options include None and 1-5 points. Refer to Configuring
Inner padding on page 84 for instructions on using this option.
Vertical Alignment: This popup menu is used to determine the vertical alignment of
content within the selected cells. Options include Top, Middle, Bottom and Justify. The
following table exemplify the various options here:
Aligned to top
Aligned to top

Aligned to middle
Aligned to middle

Aligned to bottom
Aligned to bottom

Justified Justified
Justified Justified
Justified Justified
Justified Justified

Table 8-6: Table Vertical Alignment options

14. Contextual Table Commands Menu
The Table Commands context menu contains the following options:
• Select Row: Selects an entire row.
• Select Column: Selects an entire column.
• Select All Cells: Selects all the cells in the table.
• Centre Table Horizontally: Centres the table horizontally.
• Add Row Before: Adds a new row to the table before the current (selected) row. Refer to
Adding and Subtracting Rows and Columns on page 78 for step-by-step instructions.
• Add Row After: Adds a new row to the table after the current (selected) row. Refer to Adding
and Subtracting Rows and Columns on page 78 for step-by-step instructions.
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• Add Column Before: Adds a new column to the table before the current (selected) column.
•
•
•
•
•
•
•
•

Refer to Adding and Subtracting Rows and Columns on page 78 for step-by-step
instructions.
Add Row After: Adds a new column to the table after the current (selected) column. Refer to
Adding and Subtracting Rows and Columns on page 78 for step-by-step instructions.
Split Horizontally: Horizontally splits the selected cell into two equal parts. Refer to
Splitting Cells on page 81 for step-by-step instructions.
Split Vertically: Vertically splits the selected cell into two equal parts. Refer to Splitting Cells
on page 81 for step-by-step instructions.
Merge Cells: Merges the selected cells and their content into a single cell. Refer to Merging
Cells on page 81 for step-by-step instructions.
Equalise Columns Width: equalises the widths of all selected columns. Refer to Equalising
Row and Column size on page 81 for step-by-step instructions.
Equalise Row Heights: equalises the heights of all selected rows. Refer to Equalising Row
and Column size on page 81 for step-by-step instructions.
Delete Cells: Deletes the selected rows or columns. This option is enabled only when an
entire column (or columns) or an entire row (or rows) are selected. Refer to Deleting Cells on
page 81 for step-by-step instructions.
Remove Text Formatting: The text in a table cell is set by default using the style applied to
the table style and template. When you make changes to this style, you can always discard
those using Remove Text Formatting, and go back to the original styles applied by removing
the text formatting of a table or of a range of cells.

15. Edit Section Style Window
The Edit Section Style window is used to create new section styles and to edit existing ones. It
includes similar functionalities to the Section palette Attributes tab.
Refer to Creating a New Style on page 189 and Editing a Style on page 190 for step-by-step
instructions to open this window.
Most of the options in the Edit Section Style window are similar to those in the Section palette
Attributes tab. Refer to Styling Sections Using Attributes on page 175 for step-by-step
instructions for applying diﬀerent attributes to the section style and to Section Palette
Description on page 349 for a complete description of the diﬀerent options.
The following figure depicts the Edit Section Style window and its unique functionalities that
are not part of the Section palette Attributes tab:
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Figure 8-188: Edit Section Style Window

• Style name: Used to rename the edited style. Refer to Renaming a Style on page 191 for
•
•

step-by-step instructions.
Cancel: Clicking this button discards all changes and closes the window.
Create/Save: Clicking this button applies all changes and closes the window.

16. Edit Page Style Window
The Edit Page Style window is used to create new page styles and to edit existing ones. It
includes similar functionalities to the Page palette Attributes tab, but their layout is diﬀerent,
allowing for a more friendly user experience and an immediate preview of the results.
Refer to Creating a New Style on page 189 and Editing a Style on page 190 for step-by-step
instructions to open this window.
Some of the options in the Edit Page Style window are similar to those in the Page palette
Attributes tab. Refer to Styling Pages Using Attributes on page 178 for step-by-step
instructions for applying diﬀerent attributes to the page style and to Page Palette Attributes
Tab on page 352 for a complete description of the diﬀerent options.
The following figure depicts the Edit Page Style window and its unique functionalities that are
not part of the Page palette Attributes tab:
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Figure 8-189: Edit Page Style Window

• Style name: Used to rename the edited style. Refer to Renaming a Style on page 191 for
•
•

•

•

step-by-step instructions.
Direction: Sets the direction of pages in the preview area when Odd/Even pages are edited
(i.e. whether the first page appears on the left or on the right hand side). This setting has no
eﬀect on the actual page style in the document, it is only applied to the preview area.
Horizontal Margins: Indicates and adjusts the horizontal margins of the edited pages. You
can change the horizontal margins by clicking the number and manually entering the
desired value, or by clicking the number and dragging the cursor upwards or downwards to
increase or decrease the margin, respectively.
Purple Bar: Indicates and adjusts the area available for editing in the page. The purple area
indicates the total area available for editing in the page (i.e. the page size minus the top and
bottom margins). You can adjust this area by clicking the number in the middle of the bar
and manually entering the desired value, or by clicking the number and dragging the cursor
upwards or downwards to increase or decrease the edit area, respectively. Increasing the
purple edit area would decrease the vertical margins, and vice versa.
Green Bar: Indicates and adjusts the area available for editing text in the page. The green
area indicates the total area available for inserting text in the document (i.e. the page size
minus the top and bottom margins minus the header and footer height). You can adjust this
area by clicking the number in the middle of the bar and manually entering the desired
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•

value, or by clicking the number and dragging the cursor upwards or downwards to increase
or decrease the area, respectively. Increasing the green edit area would decrease the header/
footer area, and vice versa.
Create Header/Footer: Clicking on this area opens the Create Header/Footer window, which
includes functionalities similar to those described in Editing Headers and Footers on page
181. The Create Header/Footer window is shown in the following figure:

Figure 8-190: Create Header/Footer Window

• Insert Image: This button is similar to the Select button in the Page palette Attributes tab.

Refer to Page Palette Attributes Tab on page 352 for more information. The button is shown
in the following figure:

Figure 8-191: Insert Image Button
After an image is added, you can click it and then click the pencil shaped edit icon to open
the Background Image popover, which includes options similar to the Page palette Attributes
tab. The Background Image popover is depicted in the following figure:
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Figure 8-192: Background image Popover

• Background Colour (
•

•
•

): This button is similar to the Colour well in the Page palette

Attributes tab. Refer to Page Palette Attributes Tab on page 352 for more information.
Page Type Buttons: These buttons are similar in appearance and function to the page type
buttons in the Page palette Attributes tab (refer to Page Palette Attributes Tab on page 352
for more information). The only diﬀerence is that the Odd/Even icons are united, as the Edit
Page Style window allows displaying and editing both simultaneously.
Cancel: Clicking this button discards all changes and closes the window.
Create/Save: Clicking this button applies all changes and closes the window.

17. Add Tab Stops Window
The Add Tab Stops window allows adding several tabs to the ruler in a single action (refer to
Adding a Tab Stop on page 166 for step-by-step instructions).
The following figure depicts the Add Tab Stops window and its functionalities:

Figure 8-193: Add Tab Stops Window

• Tab type: This popup menu is used to choose the type of tab to insert. Refer to Tab Well on
page 328 for a complete description of the diﬀerent tab types.
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• First tab at: This text box is used to enter the distance of the first tab from the page margin.
•
•
•
•
•

If the start margin is bigger than the First tab at value, a first tab will not be added, as not tabs
can be added before the start margin.
Between tabs: This text box is used to enter the distance between each pair of adjacent
tabs.
Combo tab indent: If Combo Tab is chosen from the Tab type popup menu, this text box is
used to enter the indent position for the combo tab. Refer to Tab Well on page 328 for a
complete description of the combo tab.
Decimal tab align on: If Decimal Tab is chosen from the Tab type popup menu, this text box
is used to enter the character to align on as a decimal separator. Refer to Tab Well on page
328 for a complete description of the decimal tab.
Tab lead: This popup menu is used to set a leading character for the added tabs.
Clear tabs of this type: This checkbox is used to clear all existing tabs of the selected type
from the ruler before adding the new ones.

18. Style Sets Window
The Style Sets window is used to manage style sets. Refer to Managing Style Sets on page 194
for step-by-step instructions.
To open the window, choose Styles > Edit style sets from the menu bar or use the Cmd +
Shift + A keyboard shortcut.
The following figure depicts the Style Sets window and its functionalities:
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Figure 8-194: Style Sets Window

• Style set: This list details all available style sets. It can be used to choose a style set (refer to
Selecting a Style Set on page 194 for step-by-step instructions), to rename it (refer to
Renaming a Style Set on page 197 for step-by-step instructions) and to lock/unlock it for
editing (Locking a Style Set on page 196).

• Create New Style Set (

): This button is used to add a new style set. Refer to Creating a

Style Set on page 196 for step-by-step instructions.

• Duplicate style set (

): This button is used to duplicate the selected style set. Refer to

Creating a Style Set on page 196 for step-by-step instructions.

• Delete style set (

): This button is used to delete the selected style set. Refer to Deleting a

Style Set on page 197 for step-by-step instructions.

• Make style set global (
•

): This button is used to convert a document style set into a

global style set that is available in other documents as well. Refer to Making a Document
Style Set Global on page 197 for step-by-step instructions.
Styles Tabs: Switch between editing the diﬀerent categories that comprise a style set:
Character, Paragraph, Page, Section, List, Note and Index. Each area includes similar
functionalities:
• Styles List: Lists all available styles and their keyboard shortcut (if applicable).
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• Create New Style (

): This button is used to add a new style. Refer to Creating a New Style

on page 189 for step-by-step instructions.

• Duplicate style (

): This button is used to duplicate the selected style. Refer to Creating a

New Style on page 189 for step-by-step instructions.

• Edit style (

): This button is used to edit the selected style. Refer to Editing a Style on

page 190 for step-by-step instructions.

• Delete style (
•
•

): This button is used to delete the selected style. Refer to Deleting a Style

on page 192 for step-by-step instructions.
Cancel: Clicking this button discards all changes and closes the window.
Save: Clicking this button saves all changes and closes the window.

19. Replace Styles Window
The Replace Styles window is used to replace used character and paragraph styles in a
document with other styles you select. Refer to Replacing Styles on page 193 for step-by-step
instructions on opening the window and replacing styles.
To open the Replace Styles window choose File > Replace Styles from the menu bar.
The following figure depicts the Replace Styles window and its functionalities:

Figure 8-195: Replace Styles Window

• Character/Paragraph: Sets the category of styles to be replaced. The selected category is
highlighted in blue.
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• Used

•
•
•
•
•
•
•

Styles: Lists all styles used in the document for the selected category, with the
following annotations:
• Styles in bold indicate that no replacing style has been configured yet. Once a replacing
style is set using the Style popup menu, the bold face is removed.
• Ad hoc changes to text that global styles were applied to (styles that are part of a style set)
are indicated by a black plus sign followed by the number of changes.
• Document styles (styles that are used in the document but are not part of the style set) are
indicated by a black diamond.
Style attributes: Lists the attributes of the selected style.
Overrides: If there are any ad hoc changes to text that global styles were applied to, this
area lists all the attributes that were changed.
Style: This popup menu is used to choose the replacing style.
Variation: This popup menu is used to choose the replacing character style variation. It is
only displayed when the Character tab is selected.
Direction: This popup menu is used to set the direction of the replacing paragraph style. It is
only displayed when the Paragraph tab is selected.
Cancel: Closes the window without replacing any styles.
OK: Performs all the selected style replacements and closes the window.

20. Spelling and Grammar Window
The Spelling and Grammar window is used to spell check the document and handle any
spelling errors. Refer to Spell Checking on page 231 for more information.
To open the Spelling and Grammar window, choose Edit > Spelling > Spelling from the menu
bar, or press Cmd + Shift + ;.
The following figure depicts the Spelling and Grammar window and its functionalities:

Figure 8-196: Spelling and Grammar Window

• Highlighted Word: Displays the highlighted word that is not part of the current spelling
dictionary.
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• Suggestions List: Lists possible suggestions for replacing the highlighted word with a word
•
•
•
•
•
•

from the spelling dictionary.
Language: This is a generic macOS option that is overwritten by Mellel. Refer to Selecting
Spelling Dictionary on page 234 for more information.
Change: This button is used to replace the highlighted word with the selected suggestion,
and move to the next highlighted word. Refer to Correcting Spelling Errors on page 232 for
step-by-step instructions.
Find Next: This button is used to move to the next highlighted word without applying any
changes to the current one. Refer to Navigating Spelling Errors on page 232 for step-by-step
instructions.
Ignore: This button is used to ignore the highlighted word. Refer to Ignoring Spelling Errors
on page 233 for step-by-step instructions.
Learn: This button is used to add the highlighted word to the dictionary. Refer to Adding
Words to the Dictionary on page 233 for step-by-step instructions.
Define: This button is used to look up the highlighted word in the default macOS dictionary.
Refer to Defining Words on page 233 for step-by-step instructions.

21. Sort Window
The Sort window is used to apply advanced sorting to selected document elements. Refer to
Sorting on page 228 for more information.
To open the Sort window, choose Edit > Sort > Advanced Sort from the menu bar.
The following figure depicts the Sort window and its functionalities:
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Figure 8-197: Sort Window

• Sort
•

order: These buttons are used to determine whether to sort in ascending or
descending order. Refer to Advanced Sorting on page 228 for step-by-step instructions.
Sort By: This popup menu is used to choose what will the selected elements be sorted by
(refer to Advanced Sorting on page 228 for step-by-step instructions). The following options
are available:
• Words: When chosen, all the words in the current selection will be sorted.
• Paragraphs: When chosen, all the paragraphs in the current selection will be sorted.
• Section: When chosen, all the sections in the current selection will be sorted.
• Tab delimited items: When chosen, all the elements that are separated by a tab in the
current selection will be sorted.
• Comma delimited items: When chosen, all the elements that are separated by a comma in
the current selection are sorted by the set method.
• Custom: When chosen, a text box is displayed to allow the you to determine a custom
character as a delimiter. This will sort all the elements that are separated by the custom
character.
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• Sort Method: This radio button is used to determine whether to sort the selected elements

•
•

•

alphabetically or numerically (refer to Advanced Sorting on page 228 for step-by-step
instructions). When Sort Alphabetically is chosen, you can use the adjacent popup menu to
choose the sorting language.
Secondary sort: This checkbox is used to enable secondary sorting. Refer to Secondary
Sorting on page 229 for step-by-step instructions.
Secondary item prefix: When the Secondary sort checkbox is checked, this popup menu is
used to determine the prefix that distinguishes the diﬀerent sorting levels (refer to
Secondary Sorting on page 229 for step-by-step instructions). The following options are
available:
• Tab: When chosen, items preceded by the same number of tabs are considered on the
same level and will be sorted together.
• Space: When chosen, items preceded by the same number of spaces are considered on the
same level and will be sorted together.
• #: When chosen, items preceded by the same number of hashes are considered on the
same level and will be sorted together.
• Custom: When chosen, you can use the adjacent text box to enter a custom prefix. Mellel
will then consider items that are preceded by the same number of custom prefix
characters on the same level and sort them together.
Sort ignoring: This checkbox is used to enable ignoring words from the Ignored Words list
when sorting. Refer to Ignoring Words when Sorting on page 230 for step-by-step
instructions.

• Add (

): This button is used to add a new word to the Ignored Words list. Refer to Ignoring

Words when Sorting on page 230 for step-by-step instructions.

• Delete (
•
•

•

): This button is used to remove the selected word from the Ignored Words list.

Refer to Ignoring Words when Sorting on page 230 for step-by-step instructions.
Ignored Words List: This list details the words that will be ignored during sorting when the
Sort ignoring checkbox is checked. Refer to Ignoring Words when Sorting on page 230 for
more information.
Ignore text enclosed by: This checkbox is used to enable ignoring text that is enclosed by
certain characters (refer to Ignoring Enclosed Text on page 230 for step-by-step instructions).
When this checkbox is checked, you can use the adjacent popup menu to choose the
enclosing characters.
Remove enclosing after sort: When the Ignore text enclosed by checkbox is checked, this
checkbox is used to remove the enclosing characters after sorting is completed, so that they
do not appear in the sorted text. Refer to Ignoring Words when Sorting on page 230 for more
information.

22. Find Set Window
The Find Set window is used to manage and run Find Sets. Refer to Managing Find Sets on page
216 for more information.
To open the Find Set window, choose Edit > Find > FindSet from the menu bar, or press Cmd
+ Shift + F.
The following figure depicts the Find Set window and its functionalities:
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Figure 8-198: Find Set Window

• Run: This
•

•

•
•

button is used to run the currently selected Find Set or Find Action. Refer to
Running a Find Action on page 213 for step-by-step instructions. The active selection is
highlighted in Blue.
Status Bar: Indicates what will happen when pressing the Run button - which Find Set/Find
Action will be run (based on the current selection) and what document will it be run on
(based on the active document). When the Run button is clicked, the status bar displays a
visual progress indication.
Action Library: Details all available Find Sets, as well as the All Actions library. When choosing
any of the Find Sets, all the Find Actions that are included in that set are displayed in the Find
Actions list. The selected Find Set is highlighted in Blue (if no Find Action is selected) or Grey (if
a Find Action is selected).
Find Actions List: Details all Find Actions that are included in the selected Find Set. The
selected Find Action is highlighted in Blue.
Find Action Details: This area is used to show and edit the details of the selected Find Action.
It includes similar functionalities to the Advanced Find and Replace panel (refer to Advanced
Find and Replace Panel on page 368 for a complete description) as well as the following
additional functionalities:

• Open in Panel (

): This button is used to load the selected Find Action into the Advanced

Find and Replace panel.

• Reset (

): When any changes are performed to the selected Find Action, clicking this

button discards them and reverts back to the original version.
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• Save (

•

): When any changes are performed to the selected Find Action, clicking this

button saves them.
• Comment: This text box is used to enter comments regarding the Find Action, such as its
purpose and any recommendations for using it.
Find Set Log: This read only area logs the progress of running Find Actions/Find Sets. Each
Find Action is indicated by its name, the time when it started to run and the number of
changes it resulted in the document. Completed Find Actions are indicated by a green tick.

• Settings (

): This button is used to open the Settings menu, which includes the following

options:
• Delete Find Set: Deletes the selected Find Set. Refer to Deleting a Find Set on page 218 for
step-by-step instructions.
• Delete Find Set and Actions: Deletes the selected Find Set and the Find Actions included in it.
Refer to Deleting a Find Set on page 218 for step-by-step instructions.
• Duplicate Find Set: Creates a copy of the selected Find Set. Refer to Creating a Find Set on
page 217 for step-by-step instructions.
• Export File Set to file: Exports the selected Find Set into a file that can be shared with other
users and computers. Refer to Exporting a Find Set on page 218 for step-by-step
instructions.
• Import File Set from file: Imports a File Set from an external file. Refer to Importing a Find Set
on page 219 for step-by-step instructions.

• Add Find Set (

): Creates a new Find Set. Refer to Creating a Find Set on page 217 for stepby-step instructions.

• Add Find Action (

): Creates a new Find Action. Refer to Creating a Find Action on page
215 for step-by-step instructions.

• Duplicate Find Action (
•
•

): Duplicates an existing Find Action. Refer to Creating a Find

Action on page 215 for step-by-step instructions.
Search Find Action: This search box is used to search for a Find Action in the Find Actions list.
The list is filtered in real time as you type text into the search box.
Clear Log: This button is used to clear the Find Set Log.

23. Edit Citation Window
The Edit Citation window is used to edit an existing citation. Refer to Editing a Citation on page
133 for step-by-step instructions for opening the window.
To open the Edit Citation window, double-click any existing citation in the document.
The following figure depicts the Edit Citation window and its functionalities:
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Figure 8-199: Edit Citation Window

• Citation: This text box is used to display and edit the temporary citation text.
• Formatted Citation: This text box is used to display and edit the final citation, as it would
•
•
•
•

appear in the final manuscript.
Display: This popup menu is used to choose whether to display the Temporary Citation or
the Final Citation in the document.
Exclude from final document: This checkbox is used to exclude the current citation from
the final document. Refer to Excluding a Citation form the Final Bibliography on page 134 for
step-by-step instructions.
Don't enclose formatted citation: This checkbox is used to remove the enclosing
characters from the final format of the current citation. Refer to Removing Enclosing
Characters from Citations on page 134 for step-by-step instructions.
Suppress superscript: This checkbox is used to prevent any superscript character style to be
applied to the current citation in the text. Refer to Suppressing Superscript in Citations on
page 135 for step-by-step instructions.

24. Bibliography and Citations Style Mapping Window
The Bibliography and Citations Styles window is used to format the appearance of bibliography
and citations in your document using styles. Refer to Formatting Citations Using Styles on
page 133 and Formatting the Bibliography Using Styles on page 137 for step-by-step
instructions.
The window comprises two tabs, which are detailed in the following sub-sections.
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A. Bibliography and Citations Styles Window - Bibliography Tab
The following figure depicts the Bibliography and Citations Styles window Bibliography tab and
its functionalities:

Figure 8-200: Bibliography and Citations Styles Window - Bibliography Tab

• Bibliography:
•
•
•
•

This tab is used to switch to the Bibliography tab of the window. It is
highlighted in blue when the Bibliography tab is selected and active.
Citations: This tab is used to switch to the Citations tab of the window. It is highlighted in
blue when the Citations tab is selected and active.
Paragraph Style: This popup menu is used to choose the paragraph style to apply to the
bibliography.
Character Style: This popup menu is used to choose the character style to apply to the
bibliography.
Mapping bibliography styles: This table is used to set specific mappings for styles from the
reference manager into the document bibliography:
• Text in: Sets the text style to map.
• Use Style: Sets the character style that will be applied to the selected Text in element when
they are inserted from the reference manager into the document.
• And Variation: Sets the character style variation that will be applied to the selected Text in
element when they are imported from the reference manager into the document.
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• No Mapping: This preview area is used to show how the bibliography entry would look like
•

with no mapping.
With Mapping: This preview area is used to show how the bibliography entry would look
like with the selected mapping configuration.

B. Bibliography and Citations Styles Window - Citations Tab
The following figure depicts the Bibliography and Citations Styles window Citations tab and its
functionalities:

Figure 8-201: Bibliography and Citations Styles Window - Citations Tab

• Bibliography:
•
•
•

This tab is used to switch to the Bibliography tab of the window. It is
highlighted in blue when the Bibliography tab is selected and active.
Citations: This tab is used to switch to the Citations tab of the window. It is highlighted in
blue when the Citations tab is selected and active.
Map Citation Styles: This checkbox is used to enable mapping citation styles. When it is not
selected, citations will be applied with their surrounding text styling attributes.
Mapping citation styles: This table is used to set specific mappings from styles in the
reference manager into the document citations.
• Text in: sets the text style to map.
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• Use Style: Sets the character style that will be applied to the selected Text in element when

•
•

it is inserted from the reference manager into the document.
• And Variation: Sets the character style variation that will be applied to the selected Text in
element when it is inserted from the reference manager into the document.
No Mapping: This preview area is used to show how citations would look like with no
mapping.
With Mapping: This preview area is used to show how citations would look like with the
selected mapping configuration.
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